Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Errordocument für verschiedene Sprachen in TYPO3-Umgebung?

Frage Internet CMS

Mitglied: jhinrichs

jhinrichs (Level 2) - Jetzt verbinden

06.11.2009 um 08:14 Uhr, 3208 Aufrufe

Hallo zusammen,
ich erstelle eine mehrsprachige Website unter TYPO3 (LAMPP-Basis), das Grundgerüst steht fast vollständig (Inhalte bislang nur rudimentär), auch das Rewriting mit real_url funktioniert bestens.
(Bin ein bisschen stolz auf mich, da ich kein Webprogrammierer/designer o.ä. bin... )
Nun wird unter TYPO3 ja die Sprache per URL-Parameter weitergegeben ("&L=x"), fehlt dieser Parameter, wird L=0 angenommen, somit die Standardsprache eingestellt.
In der .htaccess steht ein Errordocument für die gängigen Fehlermeldungen, welches auf eine TYPO3-Content-Seite verweist. Das funktioniert auch, nur kann ich in der .htaccess natürlich nicht den "letzten L-Wert" abfragen, der Verweis zeigt immer auf eine fest eingestellte Sprache. Da dann aber in der angezeigten Fehlerseite auch die Menüeinträge und internen Links auf diese fest eingestellte Sprache zeigen, ist sozusagen ein "Sprachwechsel" erfolgt.
Gibt es eine Möglichkeit (entweder über .htaccess oder Typo3-intern), das anders zu lösen?
Viele Grüße
Neuester Wissensbeitrag
Router & Routing

192.168er Adresse im öffentlichen Netz

(2)

Erfahrungsbericht von visco-c zum Thema Router & Routing ...

Ähnliche Inhalte
C und C++
C-sharp List verschiedene Bedingungen (5)

Frage von Yanmai zum Thema C und C ...

Router & Routing
VLANs über verschiedene MPLS-Leitungen routen (3)

Frage von Tomschaf91 zum Thema Router & Routing ...

Microsoft Office
gelöst Bedingte Formatierung in Excel für verschiedene Dezimalstellen (6)

Frage von winget zum Thema Microsoft Office ...

Netzwerkmanagement
gelöst Anregungen, kleiner Betrieb, IT-Umgebung (18)

Frage von Unwichtig zum Thema Netzwerkmanagement ...

Heiß diskutierte Inhalte
Zusammenarbeit
Als Administrator im Großraumbüro (29)

Frage von Dopamin85 zum Thema Zusammenarbeit ...

Exchange Server
Test-ActiveSyncConnectivity Error nach neuem Zertifikat (22)

Frage von Driphex zum Thema Exchange Server ...

Hyper-V
HYPER V und USB (16)

Frage von Hendrik2586 zum Thema Hyper-V ...

SAN, NAS, DAS
Backupserver für KMU (14)

Frage von Leo-le zum Thema SAN, NAS, DAS ...