Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

ESXi 4.1 - Nach Neustart haben alle VMs den Status Unknown (ungültig)

Frage Virtualisierung

Mitglied: anaxagoras83

anaxagoras83 (Level 1) - Jetzt verbinden

08.10.2011 um 13:12 Uhr, 13613 Aufrufe, 7 Kommentare

Nach dem Ausfall einer Festplatte im RAID5 auf einem IBM-Server und dem Einbinden der getauschten Festplatte in das RAID-System (RAID5-4HDDs), werden nach dem Start des ESXi Servers die VMs als "Unknown (ungültig)" angezeigt.

Hallo zusammen.

Ich kämpfe gerade mit einem Problem bei dem ich einfach nicht weiter weiß. Ich habe versucht die Informationen so strukturiert und umfrangreich wie möglich zu halten.

Vorgeschichte:

Eine meiner letzten Fragen bezog sich auf das Thema RAID-Konfiguration bei einem IBM-Server mit installiertem ESXi-Server. Es war mir nicht möglich, die Konfiguration der getauschten Festplatte aus dem laufenden System heraus vorzunehmen. Automatisch wurde die Rekonfigurationd es RAIDs auch nicht durchgeführt. Also fragte ich zunächste IBM per Hotline und Chat wie ich diese administrative Aufgabe erledigen könne. Diese sagten mit das bei einem ESX(i) System keine Möglichkeit bestünde, im laufenden Betrieb Änderungen an der RAIDkonfiguration vorzunehmen.

Nachdem ich die Frage in diesem Forum stelle, bekam ich jedoch eine Antwort mit einem Link zu einem Knowledgebaseartikel in dem ein Workaround beschrieben wurde, diese Aufgabe doch durchführen zu können:

http://www.administrator.de/index.php?content=173780

Nachdem ich diese Punkte durchführen wollte und zu keinem positiven Ergebnis kam, startete ich den Server nun doch neu und griff auf die embedded RAID-Konsole zu um die Änderungen am RAID durchzuführen.

Die neue Festplatte wurde erkannt (jedoch als JBOD) änderung des States in "Conf-Free" und zuweisen der Festplatte zu dem bestehenden RAID, danach wurde der Status der Festplatte von "offline" auf "online" gesetzt und der Server neu gebootet.

Schon wurde der Health-Status des RAID als "optimal" erkannt. (vorher stand das RAID auf degrated) dies wurde jeweils im IMM-Health Check angezeigt als auch im VSphere Client.

Fehlerbeschreibung:

Nach dem Boot der Maschine werdem die virtuellen Maschinen in der Bestandsliste nur als "Unknown (ungültig)" angezeigt. Ein Neustart des Virtualisierungshost brachte leider keine Verbesserung.

Eine Recherche im Internet brachte nur einige Beiträge in denen Nutzer eine ähnliche Situation beschrieben. Einen Lösungsansatz hatten jedoch alle gemein:

- Entfernen der VMs mittels Rechtsklick und "Aus Bestandsliste entfernen"
- Durchsuchen des Datastores und hinzufügen der VMX-Datei zur Bestandsliste unter Angabe des Maschinennamens.

Leider bringt dieses keine positive Veränderung des Problems.

Da ich in der VMWARE-Welt recht neu bin, habe ich erst wenig Erfahrung mit Troubleshooting.
Also denke ich nun einfach mal laut:

- Kann durch die RAID-Problematik das Dateisystem beschäfigt worden sein und dadurch der Fehler auftreten?
- An welchem Punkt habe ich in diesem Setup einen Fehler gemacht, was hätte ich anders machen können um den Fehler zu umgehen?
- Was sind die nächsten Schritte um dieses Problem zu beheben?
- Ist es möglich auf Grundlage der noch vorhandenen VMDKs eine neue VMX Datei zu erstellen mit Aussicht auf eine funktionierende, startende Maschine?

Detailinformation:

- Server IBM x3400
- RAID5 (4xHDDs-SAS)
- Raidcontroller LSI-MegaRAID
- ESXi 4.1 Installation auf USB-Stick
- RAID als VM-Storage
- Installierte Maschinen: 4
- Gastbetriebssysteme: Windows 2008 R2 - Enterprise

Ich danke vielmals und verbleibe

mit freundlichem Gruß

Anaxagoras83
Mitglied: tonabnehmer
08.10.2011 um 13:36 Uhr
Hi,

Zitat von anaxagoras83:
- Ist es möglich auf Grundlage der noch vorhandenen VMDKs eine neue VMX Datei zu erstellen mit Aussicht auf eine
funktionierende, startende Maschine?

wenn Du aktuell an die VMDKs ran kommst, solltest Du diese sofort an einen sicheren Ort sichern, um Verluste zu vermeiden. Wenn Du an die VMDKs ran kommst, kommst Du doch auch an die Konfigurationsdateien der VMs (*.vmx) bzw. an die Verzeichnisse mit den VMs. Sichere zunächst alles weg.
Um Deine Frage zu beantworten: Ja, Du kannst wenn Dein ESXi wieder läuft, neue VMs erstellen und die vorhandenen VMDK Dateien als virtuelle Festplatte eingeben. Dabei ändern sich aber die UUID der VMs und auch die MAC Adressen der virtuellen NICs. Da muss dann ggf. ein Windows neu aktiviert oder bei einem RedHat die Netzwerkeinstellungen neu konfiguriert werden.

Wenn Du also an die Verzeichnisse der VMs ran kommst, sichere diese vollständig weg, repariere dann Dein RAID oder wenn das nicht geht, lege es eben neu an. Die vorher gesicherten VMs kannst Du zurückspielen und so wie Du oben beschrieben hast, der Bestandsliste neu hinzufügen. Die VMs sind dann so wie vorher.

Zu der RAID Geschichte selbst kann ich nur Vermutungen anstellen. Ich hatte etwas Ähnliches mal vor Jahren. Da hatte ich unseren iSCSI geupdatet und anschließend wollte ESX nicht mehr die VMs von dort starten. Status war wohl wie bei Dir Unknown und die Namen der VMs waren grau und in kursiver Schrift. Das Problem war wohl, dass der iSCSI Storage, auf dem die VMs lagen, eine neue ID hatte und ESX der Meinung war, es wäre ein Snapshot des iSCSI. Da musste ich dann in der erweiterten Konfiguration erst irgendwelche Parameter von True auf False und umgekehrt setzen, damit ESX den iSCSI akzeptiert hatte.

Viel Erfolg!

Grüße,
tonabnehmer
Bitte warten ..
Mitglied: anaxagoras83
08.10.2011 um 13:44 Uhr
Hallo Tonabnehmer,

vielen Dank für die wirklich schnelle Antwort:

wenn Du aktuell an die VMDKs ran kommst, solltest Du diese sofort an einen sicheren Ort sichern, um Verluste zu vermeiden. Wenn Du
an die VMDKs ran kommst, kommst Du doch auch an die Konfigurationsdateien der VMs (*.vmx) bzw. an die Verzeichnisse mit den VMs.
Sichere zunächst alles weg.
Um Deine Frage zu beantworten: Ja, Du kannst wenn Dein ESXi wieder läuft, neue VMs erstellen und die vorhandenen VMDK Dateien
als virtuelle Festplatte eingeben. Dabei ändern sich aber die UUID der VMs und auch die MAC Adressen der virtuellen NICs. Da
muss dann ggf. ein Windows neu aktiviert oder bei einem RedHat die Netzwerkeinstellungen neu konfiguriert werden.

Wenn Du also an die Verzeichnisse der VMs ran kommst, sichere diese vollständig weg, repariere dann Dein RAID oder wenn das
nicht geht, lege es eben neu an. Die vorher gesicherten VMs kannst Du zurückspielen und so wie Du oben beschrieben hast, der
Bestandsliste neu hinzufügen. Die VMs sind dann so wie vorher.

Ich komme an alle Daten ran. Der Datastore wird mir ohne Probleme angezeigt und ich kann in der Verzeichnisstruktur stöbern.

Zu der RAID Geschichte selbst kann ich nur Vermutungen anstellen. Ich hatte etwas Ähnliches mal vor Jahren. Da hatte ich
unseren iSCSI geupdatet und anschließend wollte ESX nicht mehr die VMs von dort starten. Status war wohl wie bei Dir Unknown
und die Namen der VMs waren grau und in kursiver Schrift. Das Problem war wohl, dass der iSCSI Storage, auf dem die VMs lagen,
eine neue ID hatte und ESX der Meinung war, es wäre ein Snapshot des iSCSI. Da musste ich dann in der erweiterten
Konfiguration erst irgendwelche Parameter von True auf False und umgekehrt setzen, damit ESX den iSCSI akzeptiert hatte.

Okay - wenn ich von einem Problem ausgehe welches durch das RAID-System verursacht wurde. Gibt es so etwas wie Checkdisk für VMFS? Vielleicht ist dadurch das Problem ja schon behoben und die VMX Dateien sind wieder lesbar oder interpretierbar für den ESXi.

Beste Grüße

Anaxagoras83
Bitte warten ..
Mitglied: tonabnehmer
08.10.2011 um 13:53 Uhr
Zitat von anaxagoras83:
Ich komme an alle Daten ran. Der Datastore wird mir ohne Probleme angezeigt und ich kann in der Verzeichnisstruktur stöbern.

Sehr gut, dann kannst Du die VMs komplett sichern und dann die Reparaturversuche fortsetzen.

Okay - wenn ich von einem Problem ausgehe welches durch das RAID-System verursacht wurde. Gibt es so etwas wie Checkdisk für
VMFS? Vielleicht ist dadurch das Problem ja schon behoben und die VMX Dateien sind wieder lesbar oder interpretierbar für den
ESXi.

Von einem "Checkdisk" ist mir nichts bekannt. Da Du ja den Datastore durchforsten kannst, scheint Dein VMFS ja auch in Ordnung zu sein. Du solltest eher in den Logs schauen, was der ESXi zu dem RAID bzw. dem VMFS sagt. Dann kannst Du gezielt reparieren. Oder Du gehst den pragmatischen Weg und legst das RAID neu an, spielst die VMs zurück und inventarisierst diese neu.

Mehr wüsste ich jetzt auch nicht. Vielleicht melden sich ja noch VM/RAID Experten zu Wort.

Viele Grüße,
tonabnehmer
Bitte warten ..
Mitglied: anaxagoras83
09.10.2011 um 11:51 Uhr
> Ich komme an alle Daten ran. Der Datastore wird mir ohne Probleme angezeigt und ich kann in der Verzeichnisstruktur
stöbern.

Sehr gut, dann kannst Du die VMs komplett sichern und dann die Reparaturversuche fortsetzen.

Ja. Aber genau darin liegt mein Problem, da ich nicht weiß wie ich diese Dateien reparieren kann.

> Okay - wenn ich von einem Problem ausgehe welches durch das RAID-System verursacht wurde. Gibt es so etwas wie Checkdisk
für
> VMFS? Vielleicht ist dadurch das Problem ja schon behoben und die VMX Dateien sind wieder lesbar oder interpretierbar
für den
> ESXi.

Von einem "Checkdisk" ist mir nichts bekannt. Da Du ja den Datastore durchforsten kannst, scheint Dein VMFS ja auch in
Ordnung zu sein. Du solltest eher in den Logs schauen, was der ESXi zu dem RAID bzw. dem VMFS sagt. Dann kannst Du gezielt
reparieren. Oder Du gehst den pragmatischen Weg und legst das RAID neu an, spielst die VMs zurück und inventarisierst diese
neu.

Das wäre auf jeden Fall ein Versuch wert. Ich schaue es mir einmal an. Vielen Dank.

Mehr wüsste ich jetzt auch nicht. Vielleicht melden sich ja noch VM/RAID Experten zu Wort.

Das wäre prima. Vielleicht hatte ja schon jemand dieses Problem und kennt eine Lösung oder ein Workaround?

Viele Grüße,
tonabnehmer

Dankesehr - Gruß

Anaxagoras83
Bitte warten ..
Mitglied: tonabnehmer
09.10.2011 um 14:14 Uhr
Hi,

wieviele VMs hast Du denn im Datastore und wieviel GByte sind es? Geh doch einfach den Weg, die VMs komplett zu sichern und anschließend Dein RAID und das VMFS neu aufzusetzen. Dann kopierst Du die VMs wieder zurück, nimmst sie in die Bestandsliste auf und fertig. Der Zeitaufwand ist hier lediglich das Kopieren der VMs und ggf. das Initialisieren des RAID. Bei beiden musst Du nicht zugucken und kannst sinnvollere Dinge nebenbei tun. Im Gegensatz dazu kannst Du aber auch warten, bis weitere Ratschläge kommen und diese dann probieren. Da sieht aber ein bischen nach Stochern im Nebel aus.

Viele Grüße und viel Erfolg,
tonabnehmer
Bitte warten ..
Mitglied: anaxagoras83
09.10.2011 um 15:43 Uhr
wieviele VMs hast Du denn im Datastore und wieviel GByte sind es? Geh doch einfach den Weg, die VMs komplett zu sichern und
anschließend Dein RAID und das VMFS neu aufzusetzen. Dann kopierst Du die VMs wieder zurück, nimmst sie in die
Bestandsliste auf und fertig. Der Zeitaufwand ist hier lediglich das Kopieren der VMs und ggf. das Initialisieren des RAID. Bei
beiden musst Du nicht zugucken und kannst sinnvollere Dinge nebenbei tun. Im Gegensatz dazu kannst Du aber auch warten, bis
weitere Ratschläge kommen und diese dann probieren. Da sieht aber ein bischen nach Stochern im Nebel aus.

Da hast du allerdings recht. Werde diesen Weg jetzt auch gehen, da mir keine anderen Optionen mehr einfallen. Schaue noch einmal
für eine halbe Stunde im Netz ob ich etwas passendes finde, dann werden die Maschinen kopiert und das RAID erneut augesetzt.

Beste Grüße

Anaxagoras83
Bitte warten ..
Mitglied: anaxagoras83
11.10.2011 um 13:51 Uhr
> wieviele VMs hast Du denn im Datastore und wieviel GByte sind es? Geh doch einfach den Weg, die VMs komplett zu sichern und
> anschließend Dein RAID und das VMFS neu aufzusetzen. Dann kopierst Du die VMs wieder zurück, nimmst sie in die
> Bestandsliste auf und fertig. Der Zeitaufwand ist hier lediglich das Kopieren der VMs und ggf. das Initialisieren des RAID.
Bei
> beiden musst Du nicht zugucken und kannst sinnvollere Dinge nebenbei tun. Im Gegensatz dazu kannst Du aber auch warten, bis
> weitere Ratschläge kommen und diese dann probieren. Da sieht aber ein bischen nach Stochern im Nebel aus.

Da hast du allerdings recht. Werde diesen Weg jetzt auch gehen, da mir keine anderen Optionen mehr einfallen. Schaue noch einmal
für eine halbe Stunde im Netz ob ich etwas passendes finde, dann werden die Maschinen kopiert und das RAID erneut augesetzt.

So .. nachdem ich eine ganze Nacht an der Rücksicherung hing, jetzt noch einmal die Rückmeldung:

- Ich habe die Holzhammermethode gewählt.
- Reboot und RAID neu-erstellt.
- In VMWARE den Datastore neu erstellt
- Maschinen aus der letzten Sicherung wieder hergestellt
- Gestartet (mehrfach)
- Alles wieder ok.

Beste Grüße

Anaxagoras83
Bitte warten ..
Ähnliche Inhalte
Vmware
ESXi 4.1 VM korrupt nach Neustart des Servers
gelöst Frage von LARSOMATVmware1 Kommentar

Hallo, nachdem wir unseren ESXi-Server wegen arbeiten am Stromnetz herunterfahren mussten, erscheinen 2 VMs ín der Übersicht als "unknown". ...

Vmware
Probleme mit Snapshot unter ESXi 4.1
gelöst Frage von gmeurbVmware7 Kommentare

Hallo, folgendes Problem. ich mußte eine Systemplatte eines virtuellen Windows 2008 R2 Servers von 40GB auf 50GB erweitren. Ich ...

Vmware
ESX 4.1 auf 6.5 - VMs migrieren
gelöst Frage von Xaero1982Vmware15 Kommentare

Moin Zusammen, ich hab hier sowohl nen Esx 4.1, als auch nun einen neuen 6.5 laufen. Ich muss die ...

Vmware
Backup ESXi und VMs
Frage von BurgunderVmware3 Kommentare

Hi Zusammen, kurze Frage: Ich habe 5 600GB SAS Platten in einem Dell R610 Server. Konfig: Raid 5 (4 ...

Neue Wissensbeiträge
Internet

USA: Die FCC schaff die Netzneutralität ab

Information von Frank vor 12 StundenInternet2 Kommentare

Jetzt beschädigt US-Präsident Donald Trump auch noch das Internet. Der neu eingesetzte FCC-Chef Ajit Pai ist bekannter Gegner einer ...

DSL, VDSL

ALL-BM200VDSL2V - Neues VDSL-Modem mit Vectoring von Allnet

Information von Lochkartenstanzer vor 15 StundenDSL, VDSL1 Kommentar

Moin, Falls jemand eine Alternative zu dem draytek sucht: Gruß lks

Windows 10

Microsoft bestätigt DMA-Policy-Problem in Win10 v1709

Information von DerWoWusste vor 16 StundenWindows 10

Wer sein Gerät mit der DMA-Policy absichert, bekommt evtl. Hardwareprobleme in v1709 von Win10. Warum? Weil v1709 endlich "richtig" ...

Verschlüsselung & Zertifikate

Die Hölle friert ein weiteres Stück zu: Microsoft integriert OpenSSH in Windows

Information von ticuta1 vor 19 StundenVerschlüsselung & Zertifikate

Interessant Die Hölle friert ein weiteres Stück zu: Microsoft integriert OpenSSH in Windows SSH-Kommando in CMD.exe und PowerShell

Heiß diskutierte Inhalte
Netzwerkmanagement
Mehrere Netzwerkadapter in einem PC zu einem Switch zusammenfügen
Frage von prodriveNetzwerkmanagement21 Kommentare

Hallo zusammen Vorweg, ich konnte schon einige IT-Probleme mit Hilfe dieses Forums lösen. Wirklich klasse hier! Doch für das ...

Hardware
Links klick bei Maus funktioniert nicht
gelöst Frage von Pablu23Hardware16 Kommentare

Hallo erstmal. Ich habe ein Problem mit meiner relativ alten maus jedoch denke ich nicht das es an der ...

Windows Server
Anmeldung direkt am DC nicht möglich
Frage von ThomasGrWindows Server16 Kommentare

Hallo, ich habe bei unserem Server 2016 Standard ein Problem. Keine Ahnung wie das auf einmal passiert ist. Ich ...

TK-Netze & Geräte
VPN-fähige IP-Telefone
Frage von the-buccaneerTK-Netze & Geräte14 Kommentare

Hi! Weiss noch jemand ein VPN-fähiges IP-Telefon mit dem man z.B. einen Heimarbeitsplatz gesichert anbinden könnte? Habe nur einen ...