Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Excel 2013: Inhalt von Zeilen auf Basis eines Kriteriums auslesen

Frage Microsoft Microsoft Office

Mitglied: muetzer123

muetzer123 (Level 1) - Jetzt verbinden

07.04.2014 um 09:23 Uhr, 1108 Aufrufe, 4 Kommentare

Ich habe ein Thema, das erscheint so einfach, aber ich finde auch durch googeln nichts wirklich richtiges und SVERWEIS funktioniert dafür nicht. Vielleicht könnt ihr mir helfen:

Also, habe in einem Tabellenblatt eine Liste mit 2 Spalten, so zum Beispiel:

Art Produkt
Print Flyer
Print Plakat
Internet Facebook
Internet Website

Im nächsten Tabellenblatt möchte ich nur die Print Produkte aus dem 1. Tabellenblatt stehen haben - also Flyer und Plakat, denn hier werden weitere Spalten hinzu gefügt.

- SVERWEIS funktioniert nicht, gibt nur ein Kriterium zurück
- Autofilter bezieht sich nur auf das aktuelle Tabellenblatt

Habt ihr ne Idee?

Vielen herzlichen Dank.
Mitglied: Crofex
07.04.2014, aktualisiert um 10:02 Uhr
=SVERWEIS("Print";Tabelle1!A2:B5;2;0) gibt mir Flyer und Plakat aus. EIgentlich genau das was du möchtest.

Ansonsten
01.
=WENN(A2="Print";B2;"")
Bitte warten ..
Mitglied: muetzer123
07.04.2014 um 11:48 Uhr
Hi Crofex,

ich füge mal eine Beispieldatei bei, vielleicht wird das Thema dadurch klarer. SVERWEIS gibt nur den ersten Wert - hier Flyer - wieder.
Mit =WENN funktioniert das zwar grundsätzlich, ABER in der Praxis mit großen Nachteilen, denn wenn die Liste 100 Zeilen hat, müssen im 2. Tabellenblatt auch 100 Zeilen abgefragt werden. Und wenn die Bedingung für Zeile 20 bis 50 nicht zutrifft, entsteht hier eine Lücke von 30 Zeilen.


Link zur Beispieldatei:
https://dl.dropboxusercontent.com/u/43264955/Excel_test.xlsx
Bitte warten ..
Mitglied: Crofex
07.04.2014 um 13:36 Uhr
Die Frage ist, was soll statt dessen da raus kommen? Ich hätte es noch so im Angebot.

https://www.dropbox.com/s/cdbumjn2c1e8aeq/Excel_test.xlsx
Bitte warten ..
Mitglied: muetzer123
07.04.2014 um 14:17 Uhr
Ja, das ist schon gut, aber auch hier ist das "Problem" mit den Leerzeilen, denn Sinn und Zweck ist die Verdichtung der Datensammeltabelle der Seite 1 auf den Folgetabellen. Auf den Folgetabellen wird praktisch ein Extrakt der ersten Tabellenseite gemacht und diese Daten dann weiter verarbeitet.

Kriegt man die Leerzeilen nicht irgendwie raus?
Bitte warten ..
Ähnliche Inhalte
Microsoft Office
gelöst Inhalte vieler excel dateien auslesen und als Liste wiedergeben (13)

Frage von tw3aker zum Thema Microsoft Office ...

Batch & Shell
gelöst Komplette Zeile aus Textdatei auslesen (3)

Frage von tegwert zum Thema Batch & Shell ...

Microsoft Office
gelöst Excel: Einzelne Zeilen einer mehrzeiligen Zelle auslesen (3)

Frage von Booster07 zum Thema Microsoft Office ...

Microsoft Office
gelöst Excel Zeilen einblenden wenn (9)

Frage von misau70 zum Thema Microsoft Office ...

Neue Wissensbeiträge
Multimedia

Raspberry Pi als Digital-Signage-Computer

(1)

Information von BassFishFox zum Thema Multimedia ...

Windows Update

Novemberpatches und Nadeldrucker bereiten Kopfschmerzen

(15)

Tipp von MettGurke zum Thema Windows Update ...

Windows 10

Abhilfe für Abstürze von CDPUsersvc auf Win10 1607 und 2016 1607

(7)

Tipp von DerWoWusste zum Thema Windows 10 ...

Heiß diskutierte Inhalte
Router & Routing
Freigabe aus anderem Netz nicht erreichbar (21)

Frage von McLion zum Thema Router & Routing ...

Windows Server
Kennwort vergessen bei Hyper vserver 2012r (21)

Frage von jensgebken zum Thema Windows Server ...

Batch & Shell
Batch Programm verhalten bei shoutdown -p (19)

Frage von Michael-ITler zum Thema Batch & Shell ...

Festplatten, SSD, Raid
gelöst Raidcontroller funktioniert nur, wenn unter Legacy-Boot gestartet wird (14)

Frage von DerWoWusste zum Thema Festplatten, SSD, Raid ...