Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

EXCEL 97 auf WIN 7 64bit Fehler beim Zugriff auf die Registrierung

Frage Microsoft Microsoft Office

Mitglied: FISIStew

FISIStew (Level 1) - Jetzt verbinden

04.12.2011, aktualisiert 07.12.2011, 5348 Aufrufe, 4 Kommentare

Hallo liebe Gemeinde,
vielleicht könnt Ihr mir mit einem Problem weiterhelfen, das ich dringend gelöst brauche.

Ich hoffe das mein Beitrag ausführlich genug ist und mir geholfen werden kann.

Gegebenheiten:

2 Rechner mit Windows 7 64bit (Ultimate und Professional) und ein Programm was unter EXCEL 97 geschrieben wurde.

Auf dem Ultimate Rechner läuft etwa seit 8 Monaten Office 97 einwandfrei, nachdem ich die deutsche Setup Datei in die Englische Installation gepackt hatte und installierte.
Es wurde bis gestern noch ein XP Rechner verwendet der auf das Netzlaufwerk des Ultimate Rechners zugegriffen hat und auch mit Office 97 arbeitete und an einer geschriebenen Excel -(Software) gearbeitet wurde. Dies lief auch einwandfrei.
Nun wurde es Zeit für einen neuen Rechner, den besagten Win7 Pro.

Hintergrund

Das "Programm" wurde vor etwa 18 Jahren für Windows 3.x geschrieben und beinhaltet Makros die ein paar Tabellen mit eingegebenen Daten füllen und seinen Sinn und Zweck erfüllen.
Es wurde noch Upgegradet auf eine XP Umgebung allerdings auch unter Office 97, dies war 2003.
Eine Umprogrammierung kann von meiner Seite nicht durchgeführt werden und würde sich nicht mehr rentieren, da dieses Programm vorraussichtlich nur noch 2 - 3 Jahre zum Einsatz kommen wird und es ja bis dato noch funktioniert.

EXCEL Programm

Es ist mit einer Maske versehen das verschiedene Tabellen öffnet und Daten zusammenfasst oder selbstgeschrieben Vorlagen öffnet und diese dann mit bestimmten Werten ausgibt und ausdruckt oder abspeichert.
Die Makros erledigen in diesem Falle dieses Zusammenspiel und es ist etwa 1000 Zeilen lang.


1. Problem

Ein Update auf eine neuere Office Version funktionierte bisher nicht, da die geschriebenen Makros in Exel nicht mehr richtig funktionieren und Fehler auftreten. Versucht habe ich Office 2000, Office XP und Office 2003 sowie Office 2007.
Die eingegebenen Daten verschwinden sporadisch und tauchen entweder gar nicht mehr oder ab und zu wieder auf.

Vielleicht gibt es ja auch hier eine schnelle Umprogrammierung bzw. einen Befehl der mir ein Upgrade auf eine neue Excel Version zulässt.

2. Problem (Eigentlich mein größtes)

Nach der Installation von Office 97 auf dem Professional Rechner kann ich zwar alle Excel Tabellen einzeln öffnen, aber bei der Benutzermaske des geschriebenen Programms kommt nach der Frage ob Makros aktiviert werden sollen der Fehler "Fehler beim Zugriff auf die Registrierung".

Die Maske besteht aus 4 Excel Tabellen und wird durch eine "Start" Exceltabelle geöffnet wo dann Makros beginnen die Tabellen einzubinden.

Lösung

Was kann ich tun das dieses selbstgeschriebene Programm wieder läuft oder wie komme ich auf die Eingabemaske?



So sieht ein Teil der Makros aus

0,19 MwSt Wert
Makros f. Excel V4.0 Version : 2.21 vom 10.10.1993
update auf XP vom 29.10.2003
Kundenstamm bearbeiten Bemerkung
=ECHO()
=AKTIVIEREN("kunden.xls")
=AUSWÄHLEN("Z3s1")
=ENDE.AUSWÄHLEN(4)
=FORMEL("=Z(-1)S+1";) formel kdnr. +1 eintragen
=MASKE()
=FORMEL.GEHEZU(!Datenbank)
=ENDE.AUSWÄHLEN(4)
=FORMEL(AKTIVE.ZELLE();!B2) letzte kn in z2s2 eintragen
=AUSWÄHLEN("zs1:z(-100)s1") die letzten 100 kundennr
=KOPIEREN() in werte umwandeln
=INHALTE.EINFÜGEN(3;1;FALSCH;FALSCH)
=ABBRECHEN.KOPIEREN()
=AKTIVIEREN("bedienO.xls")
=RÜCKSPRUNG()
Vorabrechng dr suchen
=ECHO(FALSCH)
=AKTIVIEREN("Kunden.xls")
=AUSWÄHLEN("Z3S1:Z3S29") alle kunden mit
=KOPIEREN() vorab rechng
=AUSWÄHLEN("Z68S32") suchen
=EINFÜGEN()
=AUSWÄHLEN("Z69S52")
=ABBRECHEN.KOPIEREN()
=FORMEL(">1")
=AUSWÄHLEN("Z68S32:Z69S60")
=SUCHKRITERIEN.FESTLEGEN()
=AUSWÄHLEN("Z68S32:Z68S37;Z68S52;z68s56:z68s60")
=KOPIEREN()
=AUSWÄHLEN("Z73S32")
=EINFÜGEN()
=ZIELBEREICH.FESTLEGEN()
=SUCHEN.KOPIEREN(FALSCH) ende
..........
..........
..........
Mitglied: clSchak
04.12.2011 um 12:02 Uhr
Guten Morgen!

eine Möglichkeit wäre, es unter dem WinXP Mode in Win7 laufen zu lassen oder einmal Excel 97 per Rechtsklick "Als Administrator ausführen" - dann sollte zum. die Zugriffsberechtigung klappen - wobei ich nicht weis ob Excel 97 überhaupt mit x64 OS klar kommt.

Und nach 18 Jahren - kann man es ruhig mal auf eine neue Version portieren - das amotosiert sich auch noch nach 3 Jahren und erspart einem dem Stress mit zukünftigen OS Versionen. Das ist dann mal eine Woche arbeit die VB Sachen anzupassen und alles läuft wieder rund.

Bedenke aber auch beo Office 2007/2010 das du die Excel-Tabellen in XLM speichern musst und nicht in XLSX oder XLS
Bitte warten ..
Mitglied: FISIStew
04.12.2011 um 12:15 Uhr
Mahlzeit,

vielen Dank für Deine Antwort, allerdings habe ich das Problem, das im XP Modus zwar das ganze laufen würde, aber die Netzlaufwerk freigabe nicht mehr stimmt.

Diese würde im Normalfall heißen: O:\OPV\.......

Im XP Mode würde es heißen: \\tsclient\o auf .....

Wenn ich aber die Pfade im Debugger ändere kann der Rechner wo die Geschichte läuft nicht mehr den Pfad finden, da es ja auf seinem Rechner lokal zu finden ist....

Wie gesagt die Windows 7 Ultimate 64 bit hat komischerweiße seit 8 Monaten keine Probleme mit der Geschichte, nur der neue Rechner auf einmal.


Und leider kann ich die Makros nicht anpassen, weil ich nicht weiß welche ich anpassen müsste damit es wieder auf einer neueren Version läuft.


Wie meinst Du das mit XLM ? XLM ist doch die Makro Datei Endung oder? Liegt vielleicht auch da der Fehler bei einer neueren Version?
Bitte warten ..
Mitglied: bastla
04.12.2011 um 18:49 Uhr
Hallo FISIStew!
Im XP Mode würde es heißen: \\tsclient\o auf .....
Ein
net use O: \\tsclient\o
sollte zumindest dieses Problem erledigen ...

Grüße
bastla

P.S.: "Linux & Unix" hätte sich mir für diese Fragestellung nicht unbedingt aufgedrängt - und wenn Du dann schon dabei bist, das Eröffnungsposting zu editieren, könntest Du auch das durchgängig fehlende "c" in "Excel" noch ergänzen ...
Bitte warten ..
Mitglied: FISIStew
07.12.2011 um 07:52 Uhr
ups... danke für den Tip

also das wollte ich nicht mit Linux/Unix...

muss wohl mein "c" kaputt sein

hmm... Ich soll also ne batch schreiben, die mein Netzlaufwerk, obwohl es schon verbunden ist, beim Start neuverbinden???
Ich wollte das Laufwerk ja neu verbinden, allerdings tauchen die Freigaben unter Netzwerkumgebung unter XP Modus nicht auf.

Aber ich werde es versuchen...


Auch Dir vielen Dank für Deinen Kommentar
Bitte warten ..
Neuester Wissensbeitrag
Humor (lol)

Linkliste für Adventskalender

(3)

Information von nikoatit zum Thema Humor (lol) ...

Ähnliche Inhalte
Windows 10
Win 10 Msconfig Fehler seit Selective startup

Frage von stormwind81 zum Thema Windows 10 ...

Windows 7
gelöst DISM Fehlermeldung: Fehler: 5 Zugriff verweigert! (3)

Frage von Bobby.S zum Thema Windows 7 ...

Heiß diskutierte Inhalte
Windows Server
DHCP Server switchen (25)

Frage von M.Marz zum Thema Windows Server ...

SAN, NAS, DAS
gelöst HP-Proliant Microserver Betriebssystem (14)

Frage von Yannosch zum Thema SAN, NAS, DAS ...

Grafikkarten & Monitore
Win 10 Grafikkarte Crash von Software? (13)

Frage von Marabunta zum Thema Grafikkarten & Monitore ...

Windows 7
Verteillösung für IT-Raum benötigt (12)

Frage von TheM-Man zum Thema Windows 7 ...