Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
Kommentar vom Moderator Biber am 03.12.2009 um 12:34:32 Uhr
In einem Excel-Tabellenblatt wird ein Stundennachweiß geführt.
Lässt sich eigentlich auch Schwarzarbeit nachweißen?

Excel, brauche if zelle 1 gleich zelle 2 then, else bedingung

Frage Microsoft Microsoft Office

Mitglied: TokenRing

TokenRing (Level 1) - Jetzt verbinden

03.12.2009, aktualisiert 12:34 Uhr, 15672 Aufrufe, 7 Kommentare

Hallo und guten Tag.

Habe folgende Thematik.

In einem Excel-Tabellenblatt wird ein Stundennachweiß geführt.
(siehe Anhang)

Solange das Datum vorne gleich bleibt soll die Tagessumme hinten addiert werden.
Wenn sich das Datum vorne ändert soll auch wieder angefangen werden einen neuen Tagesstundensumme erstellt zu werden.

Vielleicht einfach mal den Anhang öffnen, ich denke der ist dann selbsterklärend.

Und dann natürlich die Frage wie mach ich das. Reichen Excel Bordmittel oder muss ich was mit Visual Basic erstellen ?

Danke schön und viele Grüße

bild:

http://www.ippoek.de/picture/excel.jpg
Mitglied: TheEternalPhenom
03.12.2009 um 10:51 Uhr
Hallo

es wäre sehr hilfreich, wenn du die genau Formel mal posten würdest um dort schonmal nach Fehlern zu suchen.
Generell dürfte es aber mit einer Hilfssplte nicht unmöglich sein ohne VBA aus zukommen.
Ich schau mir das ganze vllt später mal an. Im moment kann ich nur sagen, dass ich schon mal ein ähnliches System aufgebaut haben. Falls in der Zwischenzeit kein Lösungsvorschlage kommen sollte wirst du morgen mittag spätestens noch mal von mir hören.

mfg duffman521
Bitte warten ..
Mitglied: Xolger
03.12.2009 um 11:33 Uhr
Hallo TokenRing,

hier mal ein Vorschlag:
Spalte G wird zu für Zwischenwerte verwendet und ist später auszublenden.

Zelle G8: =WENN(A8=A7,F8+G7,F8)
Zelle H8: =WENN(A8=A9,"",G8)

Die Formeln in den Spalten nach unten kopieren und es klappt.

Gruß
Xolger
Bitte warten ..
Mitglied: TheEternalPhenom
03.12.2009 um 12:59 Uhr
Hallo

da wäre ich nochmal .

Ich hab mir jetzt ein paar Gedanken darüber gemacht. Mir ist die Möglichkeit gekommen, dass es vllt mehr als nur zwei Einsätze am Tag gibt also bin ich auffolgende Formel gekommen.

In G8 steht:

=WENN(UND(A8<>A9;A8<>A7);F8;WENN(UND(A8=A9;A9=A10);WENN((A11=A12);H8;"1");WENN(UND(A8=A9;A8=A7);"";H8)))

und in H8 steht:

=WENN(UND(A8=A9;A9=A10);F8+F9+F10;WENN(A9=A8;F9+F8;""))

Die Spalte H8 kann Ausgblendet werden.

Ich habe es zwar nicht getestet aber ich vermute mal das man die Formel mit etwas geschick auch auf mehr als 3 gleiche Daten um änderen kann. Ebenfalls habe ich die dumpfe Vermutung, dass man die Formel in Spalte H8 in die Formel von Spalte G8 integrieren kann.

Falls ich heute noch Lust und Zeit habe werd ich, dass auch noch Testen.

@Biber ich glaub so gut ist Excel jetzt auch noch net
Bitte warten ..
Mitglied: TheEternalPhenom
03.12.2009 um 14:54 Uhr
So ich hatte gerade noch etwas Zeit und hab mir das ganze nochmals angesehen.

Mit folgender Formel kannst du dir sogar die Hilfszeile sparen.

=WENN(UND(A8<>A9;A8<>A7);F8;WENN(UND(A8=A9;A9=A10);WENN((A11=A12);F8+F9+F10;"1");WENN(UND(A8=A9;A8=A7);"";WENN(A9=A8;F9+F8;""))))

Du kannst die Formel einfach in Zeile F8 einfügen und nach unten kopieren. Es ist sogar möglich die Formel auf 4 Einsätze pro Tag zu erweitern, jedoch ist dazu etwas geschick nötig.
Bitte warten ..
Mitglied: Fraenk
03.12.2009 um 15:03 Uhr
Hallo,

unter der Vorraussetzung, dass die Eingabe nach Datum sortiert erfolgt würde auch folgende Formel helfen:

WENN(A9=A8;"";SUMMEWENN($A$8:$A$20;A8;$F$8:$F$20))


MFG
Fraenk
Bitte warten ..
Mitglied: TokenRing
04.12.2009 um 15:25 Uhr
So, erstmal vielen vielen Dank für die zahlreichen und schnellen Lösungsvorschlägen. Werds das Wochenende, wenn ich Zeit dazu hab mal testen. Ich geb dann bescheid wenns funktioniert hat.

Vielen dank und viele Grüße
Bitte warten ..
Mitglied: 76109
05.12.2009 um 09:54 Uhr
Hallo TokenRing!

Die Ideale Formel, ist die von Fraenk und sie liefert das Ergebnis genauso, wie Du es anhand Deines Beispiels haben möchtest. Und wenn Du schon beim testen bist und eventuell die Gesamtstunden beim letzten Eintrag eines gleichen Datums stehen soll, so braucht es nur eine geringfügige Änderung der Formel von Fraenk:
Formel G8: WENN(A8<>A9;SUMMEWENN($A$8:$A$20;A8;$F$8:$F$20);"")

Falls sinnvollerweise in der Spalte F auch eine Formel steht, die nur ein Ergebnis anzeigt, wenn in Spalte C und D eine Zeitwert steht, dann könnte das Ganze so aussehen:
Formel F8: =WENN(ODER(C8="";D8="");"";D8-C8)
Formel G8: =WENN(UND(A8<>A9;F8<>"");SUMMEWENN($A$8:$A$20;A8;$F$8:$F$20);"")

Gruß Dieter
Bitte warten ..
Ähnliche Inhalte
Microsoft Office
Excel - Zelle einfärben (mehrere Bedingungen)
Frage von fire036Microsoft Office1 Kommentar

Hallo zusammen, zur Zeit stehe ich vor folgendem Problem: Die Zelle soll dann eingefärbt werden, wenn Ihr Zellwert in ...

Batch & Shell
Get-Aduser - If then else???
gelöst Frage von MuHMuHBatch & Shell2 Kommentare

Hallo Zusammen, ich exportiere mit nachfolgendem Code (nachfolgende ein kleiner Auszug) Daten aus dem ADS in eine CSV-Datei, die ...

Microsoft Office
Excel: wenn Zelle in Tabellenblatt 1 leer, dann gleiche Zelle in Tabellenblatt 2 löschen
gelöst Frage von IGEL.DanielMicrosoft Office7 Kommentare

Hallo alle miteinander, Dank meines Chefs ich "darf" mich an Excel versuchen. Trotz nicht vorhandener VBA - Kenntnisse klappt ...

Datenbanken
SQL Trigger über 2 Tabellen mit 1 Bedingung
gelöst Frage von holiboliDatenbanken1 Kommentar

Hallo ich versuche einen Trigger zu erstellen der mir die Werte von: LAG_Statistik.MengeEin in LAG_Artikel.Z_MengeEin LAG_Statistik.MengeAUS in LAG_Artikel.Z_MengeAUS LAG_Statistik.Datum ...

Neue Wissensbeiträge
Microsoft

Update KB4073578 für AMD CPU (Spectre und Meltdown Lücke)

Information von sabines vor 1 StundeMicrosoft

Wegen Problemen (BOSD, nicht startende PCs) wurde das Update KB4056897 und KB4056894 für AMD CPUs zurückgezogen. Dieses Update KB4073578 ...

Mac OS X

MacOS wo ist die Tilde ?

Tipp von Alchimedes vor 14 StundenMac OS X1 Kommentar

Hallo, ich hab eine MacOS qwertz Keyboard auf US Layout umgestellt da die Sonderzeichen besser erreichbar sind. Leider fehlt ...

Datenschutz

Weitere Informationen zum Sicherheitsproblem BeA

Information von Penny.Cilin vor 21 StundenDatenschutz

Im folgenden ein weiterer Bericht über die Sicherheitsprobleme von Bea. Fataler Konstruktionsfehler im besonderen elektronischen Anwaltspostfach Gruss Penny

Windows 10

Systemdienste behalten nach Win10 inplace-Upgrade nicht die ggf. modifizierte Startart bei

Tipp von DerWoWusste vor 22 StundenWindows 103 Kommentare

Stellt Euch vor, Ihr habt ein Win10 System und modifiziert dort die Startart von Systemdiensten. Zum Beispiel wollt Ihr ...

Heiß diskutierte Inhalte
Netzwerke
NTFS-Berechtigung
Frage von Daoudi1973Netzwerke23 Kommentare

Hallo zusammen und frohes neues Jahr (Sorry, ich bin spät dran) Meine Frage: 1- Ich habe einen Ordner im ...

Batch & Shell
AD-Abfrage in Batchdatei und Ergebnis als Variable verarbeiten
gelöst Frage von Winfried-HHBatch & Shell19 Kommentare

Hallo in die Runde! Ich habe eine Ergänzungsfrage zu einem alten Thread von mir. Ausgangslage ist die Batchdatei, die ...

Windows 10
Netbook erkennt Soundkarte nicht - keinerlei Info zum Hersteller und Modell vom Netbook und Hardware bekannt
Frage von fyrb38Windows 1018 Kommentare

Guten Tag, meine Schwester reist in einigen Wochen für ein paar Monate ins Ausland und hat sich dafür ein ...

Microsoft Office
Deaktivieren von Startbildschirm und Backstage-Ansicht in Office 2016 per Batch-Datei
Anleitung von SarekHLMicrosoft Office17 Kommentare

Guten Morgen zusammen! Ich habe mir gestern (auch mit Hilfe dieses Boards) ein Script gebastelt, um in Office 2016 ...