Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Excel, Index umkehren

Frage Microsoft Microsoft Office

Mitglied: AS-N00

AS-N00 (Level 1) - Jetzt verbinden

06.11.2012, aktualisiert 21:44 Uhr, 3694 Aufrufe, 7 Kommentare

Hallo,

ich habe hier ein kleines Problem mit Excel, bei dem ich nicht weiter komme.
Es sind zwei Arbeitsblätter.

In einem stehen folgende Daten:

ABCD
100200ROTDAS IST EIN TEST2
100201GELBDAS IST EIN TEST2
100202GRÜNDAS IST KEIN TEST, GANZ BESTIMMT NICHT1
100203BLAUIST KEIN TEST1
100300BLAUEIN TEST IST DAS2

das zweite Arbeitsblatt so:

AB
1KEIN TEST
2EIN TEST

In Spalte D der ersten Tabelle muss jetzt entweder 1 oder 2 aus der Spalte A der zweiten Tabelle ausgegeben werden, so wie jetzt oben stehend.
Das Problem ist, dass ich eigentlich jedes einzelne Wort oder Wortphrasen aus der Spalte C der ersten Tabelle in der Spalte B der zweiten Tabelle suchen muss, oder besser gesagt umgekehrt, prüfen muss, ob die Wortphrase der Spalte B der zweiten Tabelle in der Spalte C der ersten Tabelle steht.

Bisher habe ich das so gemacht:
01.
WENN(ISTZAHL(FINDEN(Kalkulationen!$A$1;C1));"1";WENN(ISTZAHL(FINDEN(Kalkulationen!$A$2;C1));"2"...........
Das ist aber begrenzt, da ich nur eine gewisse Menge der Formeln verschachteln kann und das ganze auch so unübersichtlich wird.
Gibt es da irgend eine Möglichkeit, das ganze über Index eleganter zu lösen?

[Edit Biber] Codeformatierung. [/Edit]
Mitglied: DschinN
06.11.2012 um 19:24 Uhr
also du willst in spalte D die zahl 1 oder 2 stehen haben, abhängig von dem was in spalte C drin steht ??
lieg ich da richtig ??
Bitte warten ..
Mitglied: AS-N00
06.11.2012 um 20:01 Uhr
Ja, genau.
Und zwar muss es die Wortphrase aus Spalte B der zweiten Tabelle sein.
Bitte warten ..
Mitglied: DschinN
06.11.2012 um 20:09 Uhr
ok ich werd mir das gleich mal genauer anschaun!
Bitte warten ..
Mitglied: DschinN
06.11.2012 um 23:26 Uhr
100200 ROT DAS IST EIN TEST =WENN(ISTZAHL(SUCHEN("* ein test*";C1));"2";WENN(ISTZAHL(SUCHEN("*kein test*";C1));"1";""))
100201 GELB DAS IST EIN TEST =WENN(ISTZAHL(SUCHEN("* ein test*";C2));"2";WENN(ISTZAHL(SUCHEN("*kein test*";C2));"1";""))
100202 GRÜN DAS IST KEIN TEST, GANZ BESTIMMT NICHT =WENN(ISTZAHL(SUCHEN("* ein test*";C3));"2";WENN(ISTZAHL(SUCHEN("*kein test*";C3));"1";""))
100203 BLAU IST KEIN TEST =WENN(ISTZAHL(SUCHEN("* ein test*";C4));"2";WENN(ISTZAHL(SUCHEN("*kein test*";C4));"1";""))
100300 BLAU EIN TEST IST DAS =WENN(ISTZAHL(SUCHEN("* ein test*";C5));"2";WENN(ISTZAHL(SUCHEN("*kein test*";C5));"1";""))


also habs mal so probiert is ne schwere nuss er hat probleme mit der 5ten zeile da "EIN TEST" am anfang steht somit kein Leerzeichen davor steht sonst würds wunderbar klappen hab jez leider nichmehr zeit hoffe ich konnte dir paar anregungen geben
Bitte warten ..
Mitglied: AS-N00
07.11.2012 um 08:21 Uhr
Naja, so ähnlich hab ichs ja, aber die Tabelle 2 hat ca 200 Einträge uaf die geprüft werden soll. So lang kann ich keine Formel mit obigen Muster machen.
Bitte warten ..
Mitglied: AS-N00
07.11.2012, aktualisiert um 08:25 Uhr
So gehts leider auch nicht:

=INDEX(zweitetabelle!A:A;VERGLEICH("*"&C1&"*";zweitetabelle!B:B;0);1)

denn hier reicht ein Wort das übereinstimmt, es muss aber die ganze Wortkombination aus Spalte B der zweiten Tabelle sein.
Aber irgend wie so in die Richtung muss es doch gehen.
Bitte warten ..
Mitglied: AS-N00
07.11.2012 um 11:53 Uhr
=VERWEIS(9^9;FINDEN(Kalkulationen!$B$1:$B$200;D12287;1);Kalkulationen!$A$1:$A$200)

ist die Lösung!
Bitte warten ..
Neuester Wissensbeitrag
Windows 10

Powershell 5 BSOD

(2)

Tipp von agowa338 zum Thema Windows 10 ...

Ähnliche Inhalte
Microsoft Office
gelöst Excel: Text in Zellbereich prüfen mit Vergleichstext ggf. mit Exact-Funktion (5)

Frage von Michi1 zum Thema Microsoft Office ...

VB for Applications
Excel VBA Sortierung von Daten (5)

Frage von easy4breezy zum Thema VB for Applications ...

Microsoft Office
gelöst Excel-Formel oder VBA (7)

Frage von nicki01 zum Thema Microsoft Office ...

Heiß diskutierte Inhalte
LAN, WAN, Wireless
gelöst Server erkennt Client nicht wenn er ausserhalb des DHCP Pools liegt (28)

Frage von Mar-west zum Thema LAN, WAN, Wireless ...

Windows Server
Server 2008R2 startet nicht mehr (Bad Patch 0xa) (18)

Frage von Haures zum Thema Windows Server ...

Outlook & Mail
Outlook 2010 findet ost datei nicht (18)

Frage von Floh21 zum Thema Outlook & Mail ...