Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Excel - Summe abhänig von Kriterien?

Frage Microsoft Microsoft Office

Mitglied: DerParte

DerParte (Level 1) - Jetzt verbinden

09.04.2008, aktualisiert 10.04.2008, 10718 Aufrufe, 3 Kommentare

Hallo zusammen,

möchte gerne eine Summe haben wenn etwas im januar liegt und die Bezeichnung ANNU hat.

Derfür habe ich folgende Formel erstellt:

{=SUMME(WENN((MONAT(A1:A100)=1)*(A1:A100>0);WENN(B1:B100="y;B1:B100))}

Kann das so funktionieren? Habe gerade kein Excel zurhand vielleicht kann das ja mal jemand ausprobieren.
Mitglied: bastla
09.04.2008 um 18:07 Uhr
Hallo DerParte!

Etwas schwer nachzuvollziehen, woher etwa die zu summierenden Beträge kommen sollen ...

Unter der Annahme, dass in Spalte A das Datum, in Spalte B der Text und in Spalte C der Betrag steht, sollte
01.
{=SUMME((MONAT(A1:A100)=1)*(B1:B100="ANNU")*C1:C100)}
eigentlich schon genügen.

Voraussetzung ist allerdings, dass der Text tatsächlich exakt nur "ANNU" lautet, ansonsten etwa so:
01.
{=SUMME((MONAT(A1:A100)=1)*NICHT(ISTFEHLER(SUCHEN("ANNU";B1:B100)))*C1:C100)}
Hier muss der Text den Begriff "ANNU" (in beliebiger Kombination von Klein- und Großschreibung der einzelnen Buchstaben) nur enthalten.

Grüße
bastla
Bitte warten ..
Mitglied: Biber
09.04.2008 um 18:27 Uhr
... oder, wem Arrayformeln zu suspekt sind:
= SUMMENPRODUKT((Monat(A1:A100)=1)*(B1:B100="ANNU"))

...wobei mir außer der Frage, WTF denn irgendjemand die 4 Buchstaben "ANNU" reingeklöppelt haben sollte noch schleierhafter ist, wie jemand diese Formel mit "keinem Excel zur Hand" testen will...

Grüße
Biber
Bitte warten ..
Mitglied: DerParte
10.04.2008 um 06:27 Uhr
Jo habe zuhause schon getestet. Notebook unterwegs habe ich kein Excel drauf. ABer im Internet gegoogle und nach einer Lösung gesucht. Und dann halt einfach nur gedanklich mal zusammengesetzt.
Bitte warten ..
Ähnliche Inhalte
VB for Applications
gelöst DB-Abfrage in Excel mit Kriterien aus Excel (11)

Frage von JensDND zum Thema VB for Applications ...

Linux
gelöst Vergleich zwischen Distributionen. Mögliche Kriterien? (18)

Frage von hansleitner zum Thema Linux ...

Microsoft Office
Brauche bitte Denkanstoss bei Excel (2)

Frage von Data61 zum Thema Microsoft Office ...

Neue Wissensbeiträge
Entwicklung

Exploit Development

Anleitung von burhanudinn123 zum Thema Entwicklung ...

Windows Update

Microsoft Update KB4034664 verursacht Probleme mit Multimonitor-Systemen

(1)

Tipp von beidermachtvongreyscull zum Thema Windows Update ...

Viren und Trojaner

CNC-Fräsen von MECANUMERIC werden (ggf.) mit Viren, Trojanern, Würmern ausgeliefert

(4)

Erfahrungsbericht von anteNope zum Thema Viren und Trojaner ...

Heiß diskutierte Inhalte
Netzwerkprotokolle
Leiten "dumme" Switches VLAN-Tags mit durch? (17)

Frage von coltseavers zum Thema Netzwerkprotokolle ...

E-Business
Wo tragt ihr eure privaten Termine ein? (13)

Frage von honeybee zum Thema E-Business ...

Batch & Shell
Batch zum suchen und verschieben von Verknüpfungen (12)

Frage von zeroblue2005 zum Thema Batch & Shell ...

Windows Server
Terminalserver starten willkürlich neu (12)

Frage von thaefliger zum Thema Windows Server ...