Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Excel Summe nach Wenn Formel

Frage Microsoft Microsoft Office

Mitglied: StephanAmount

StephanAmount (Level 1) - Jetzt verbinden

04.04.2012 um 14:48 Uhr, 3016 Aufrufe, 9 Kommentare

Hallo,
erstmal Danke im Voraus an alle die sich die Zeit nehmen die Frage durchzulesen und mir zu helfen.

Mein Problem ist folgendes:
In Spalte A steht ein Datum mit Angabe des Wochentages (Bsp. Donnerstag), in Spalte B steht hier zu ein Wert,
nun möchte ich die Werte, welche in der gleichen Zeile stehen wie der Tag Donnerstag zusammenzählen und die Werte mit der Angabe Freitag usw.
Mir ist klar das ich mit einer Wenn Formel beginne aber wie geht´s dann weiter bzw was muss ich da verschachteln, hier noch ein kleines Beispiel:


Do,1.4 12000
Fr., 2.4 16000
Do, 8.4 12000
Fr.,9.4 16000


dann ein Ergebnisblatt mit:

Do.: 24000
Fr.: 36000


Vielen Dank für jede Hilfe und Grüße aus dem sonnigen München

Stephan
Mitglied: dog
04.04.2012 um 14:56 Uhr
Jetzt drückst du in Excel mal F1 und gibts in die Suche die Wörter Summe und Wenn ein...
Bitte warten ..
Mitglied: Skyemugen
04.04.2012 um 15:10 Uhr
Meinst du Excel schafft es, 16000+16000=36000? Will er noch eine Fehlerquote in der Berechnung haben? Wann sind die Ferien wieder vorbei?
Bitte warten ..
Mitglied: StephanAmount
04.04.2012 um 15:11 Uhr
Hallo,

Danke für die schnelle Antwort, leider bekomme ich es mit SUMMEWENN nicht hin, ich bekomme zwar keinen Formelfehler, aber es wird 0 als Summe angezeigt, kann das daran liegen, das ja der Tag als Wort von Excel generiert wird und eigentlich in der Zelle beispielsweise 15.03.12 steht und nicht Donnerstag,15.03.2012?

Danke Grüße Stephan
Bitte warten ..
Mitglied: d4shoerncheN
04.04.2012 um 15:11 Uhr
Hallo,
versuch es einmal hier mit:
=WENN(A:A="Do";SUMMEWENN(A:A;"Do";C:C);SUMMEWENN(A:A;"Fr";C:C))

Mein Beispiel:
Spalte A - Spalte B - Spalte C - Spalte D
Do - 05.04.12 - 12000 - 24000
Fr - 06.04.12 - 10000 - 20000
Do - 12.04.12 - 12000
Fr - 13.04.12 - 10000


Struktur sollte dir klar sein, deine Tabelle dann bitte anpassen oder Formel ändern.
Bitte warten ..
Mitglied: bastla
04.04.2012 um 15:13 Uhr
@dog
... was aber auch bestenfalls dann zum Erfolg führt, wenn es sich in der Spalte A nicht um "echte" Datumsangaben (sondern um Text) handelt - ansonsten wird's auf eine Array-Formel hinauslaufen ...

Grüße
bastla
Bitte warten ..
Mitglied: StephanAmount
04.04.2012 um 15:14 Uhr
Das war das Problem

Danke Grüße Stephan
Bitte warten ..
Mitglied: StephanAmount
04.04.2012 um 15:15 Uhr
Danke dir,

hat geklappt!

Grüße
Bitte warten ..
Mitglied: bastla
04.04.2012 um 15:22 Uhr
Hallo StephanAmount!
kann das daran liegen, das ja der Tag als Wort von Excel generiert wird und eigentlich in der Zelle beispielsweise 15.03.12 steht und nicht Donnerstag,15.03.2012?
Jepp - die unten angedeutete Array-Formel (in der von Biber bevorzugten "SUMMENPRODUKT()"-Version) würde dann etwa so aussehen:
=SUMMENPRODUKT((TEXT(A:A;"TTT")="Do")*B:B)
Schneller wird's, wenn Du nicht die gesamte Spalte vorgibst, sondern den Bereicht zB auf $A$1:$A$1000 (und analog für B) beschränken kannst. Natürlich bietet es sich noch an, "Do" durch einen Zellbezug zu ersetzen (damit lässt sich die Formel dann auch für alle Wochentage kopieren) ...

Grüße
bastla
Bitte warten ..
Mitglied: Skyemugen
04.04.2012 um 15:26 Uhr
Aloha,

wenn das geklappt hat, war dein Eingangsbeispiel aber an der Realität vorbei, denn ohne
=SUMMEWENN(A:A;"Do*";B:B)
(man beachte den Platzhalter), würde bei Do, 5.4 nicht viel passieren ... (auch bei 05.04.2012 würde ohne Platzhalter ...) oder habe ich hier eben eine spontane Evolution verpasst? (gab es nicht mal nur zwei Spalten?)

aber gut, wieder ein schweres Thema beendet ...

greetz André
Bitte warten ..
Ähnliche Inhalte
Microsoft Office
Excel - Summe einer Formel mit einer enthaltenen Reihe mit Dezimalzahl
Frage von TraxtormerMicrosoft Office10 Kommentare

Hallo zusammen, es geht um eine Berechnung im Excel, bei der eine Rolle ein Band mit einer gewissen Anzahl ...

Microsoft Office
Excel - Summe aus Zahlen finden
gelöst Frage von Questionmark93Microsoft Office11 Kommentare

Hey Leute, Eine Frage; wie kann ich in Excel eine Summe herausfinden? Sprich ich habe : Summe 1: 6.081,45 ...

Microsoft Office
Excel Formel mit Raute
gelöst Frage von Florian86Microsoft Office2 Kommentare

Hallo, ich habe folgende Formel im Netz gefunden =HYPERLINK("#A"&VERGLEICH(B1;A:A;);"Gehe zu: "&B1) Die Formel an sich ist mir Klar aber ...

VB for Applications
Excel VBA Formel "WENN" einfügen
gelöst Frage von chef1568VB for Applications2 Kommentare

Hallo zusammen, ich möchte per Excel-Makro folgende Formel eintragen: EXCEL: VBA: Leider bekomme ich hier immer einen anwendungsrelevanten Fehler ...

Neue Wissensbeiträge
Microsoft

Update KB4073578 für AMD CPU (Spectre und Meltdown Lücke)

Information von sabines vor 3 StundenMicrosoft

Wegen Problemen (BOSD, nicht startende PCs) wurde das Update KB4056897 und KB4056894 für AMD CPUs zurückgezogen. Dieses Update KB4073578 ...

Mac OS X

MacOS wo ist die Tilde ?

Tipp von Alchimedes vor 16 StundenMac OS X1 Kommentar

Hallo, ich hab eine MacOS qwertz Keyboard auf US Layout umgestellt da die Sonderzeichen besser erreichbar sind. Leider fehlt ...

Datenschutz

Weitere Informationen zum Sicherheitsproblem BeA

Information von Penny.Cilin vor 23 StundenDatenschutz

Im folgenden ein weiterer Bericht über die Sicherheitsprobleme von Bea. Fataler Konstruktionsfehler im besonderen elektronischen Anwaltspostfach Gruss Penny

Windows 10

Systemdienste behalten nach Win10 inplace-Upgrade nicht die ggf. modifizierte Startart bei

Tipp von DerWoWusste vor 1 TagWindows 103 Kommentare

Stellt Euch vor, Ihr habt ein Win10 System und modifiziert dort die Startart von Systemdiensten. Zum Beispiel wollt Ihr ...

Heiß diskutierte Inhalte
Batch & Shell
Anmeldevorgang für Informatikraum (Schule) unter Windows
Frage von IngenieursBatch & Shell24 Kommentare

Hey zusammen, ich werde in naher Zukunft den Informatik Raum meiner jetzigen Schule von dem aktuellen Betreiber übernehmen (Vertrag ...

Windows 10
Netbook erkennt Soundkarte nicht - keinerlei Info zum Hersteller und Modell vom Netbook und Hardware bekannt
Frage von fyrb38Windows 1019 Kommentare

Guten Tag, meine Schwester reist in einigen Wochen für ein paar Monate ins Ausland und hat sich dafür ein ...

Batch & Shell
AD-Abfrage in Batchdatei und Ergebnis als Variable verarbeiten
gelöst Frage von Winfried-HHBatch & Shell19 Kommentare

Hallo in die Runde! Ich habe eine Ergänzungsfrage zu einem alten Thread von mir. Ausgangslage ist die Batchdatei, die ...

Microsoft Office
Deaktivieren von Startbildschirm und Backstage-Ansicht in Office 2016 per Batch-Datei
Anleitung von SarekHLMicrosoft Office17 Kommentare

Guten Morgen zusammen! Ich habe mir gestern (auch mit Hilfe dieses Boards) ein Script gebastelt, um in Office 2016 ...