Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Excel-SUMMEWENN mit bedingter Multiplikation

Frage Microsoft Microsoft Office

Mitglied: immobrauch

immobrauch (Level 1) - Jetzt verbinden

10.01.2010 um 11:11 Uhr, 17796 Aufrufe, 4 Kommentare

Excel 2003 SP3

Hallo zusammen,

ich möchte den aktuellen Warenbestandswert EK-Netto auf einem separaten
Sheet auslesen.

In der Tabelle gibt es u. a. 2 Blätter "Hardware" und "Auswertung". Die
gesuchte Formel soll in "Auswertung" stehen und Berechnungen aus "Hardware"
durchführen.

X:X in "Hardware" zeigt den aktuellen Warenbestand (Stückzahl)
AB:AB in "Hardware" zeigt den EK-Netto/Stück

Formel A

=SUMMEWENN(Hardware!X:X;">0";Hardware!AB:AB)

summiert mir richtig die Spalte AB:AB in "Hardware", ohne allerdings den
EK-Netto/Stück mit dem Warenbestand in X:X zu multiplizieren.

Formel B

=WENN(Hardware!X:X>0; Hardware!X:X*Hardware!AB:AB) multipliziert zwar,
allerdings immer nur Zeile für Zeile.

In Formel B taucht der Artikel XYZ nur 1x auf. Wenn der Warenwert/EK € 20,00
ist, werden auch nur die € 20,00 berechnet. Habe ich den Artikel 3x im Laden,
muss hier aber mit € 60,00 gerechnet werden, also mit 3 multipliziert werden.

Ich möchte nun Formel A so anpassen, dass mir mehrfach vorhandene Waren in
der Gesamtsumme wie in Formel B berücksichtigt.


Wer weiß hierzu Rat?

--
Immo Brauch
Mitglied: bastla
10.01.2010 um 13:56 Uhr
Hallo immobrauch!

Dazu benötigst Du die folgende Array-Formel:
{=SUMME(WENN(Hardware!X:X>0; Hardware!X:X*Hardware!AB:AB;0))}
Die geschwungenen Klammern "{" und "}" an Beginn und Ende der Formel sind dabei nicht einzugeben, sondern werden von Excel zur Kennzeichnung der Formel als "Array-Formel" gesetzt. Die Eingabe muss (auch nach jeder Bearbeitung / Änderung der Formel) mit der Tastenkombination "Strg + Umsch + Eingabe" abgeschlossen werden.

Anmerkung: Soferne es keine negativen Mengen zu berücksichtigen gibt, könnte das "WENN" auch entfallen (die Multiplikation mit der Menge 0 führt automatisch auch zu einem Wert 0):
{=SUMME(Hardware!X:X*Hardware!AB:AB)}
Grüße
bastla
Bitte warten ..
Mitglied: immobrauch
10.01.2010 um 18:48 Uhr
Hallo Bastla,

das Ergebnis = #ZAHL!

Ich habs mittlerweile gelöst mit SUMMENPRODUKT, wobei ich in XL 2003 keine ganzen Spalten AB:AB, sondern nur Bereiche AB2:AB5000 eingeben kann.

Deine Lösung wäre komfortabler, da sie nicht mehr angepasst werden muss, funktioniert bei mir aber leider nicht.

Mit der Tastenkombination "Strg + Umsch + Eingabe" habe ich abgeschlossen und die geschweiften Klammern auch weggelassen.

Immo Brauch
Bitte warten ..
Mitglied: bastla
10.01.2010 um 20:09 Uhr
Hallo immobrauch!

Sorry - hatte mal wieder vergessen, dass auch für die Array-Formel die Angabe der gesamten Spalten nicht funktioniert (womit auch der vermeintliche Vorteil sich schon wieder erledigt hätte) ...

Mit
{=SUMME(Hardware!X2:X500*Hardware!AB2:AB5000)}
sollte es geklappt haben, wobei allerdings für die Version ohne "WENN()" tatsächlich "SUMMENPRODUKT()" die bessere Alternative darstellt. Für den Fall, dass tatsächlich einmal eine Bedingung erforderlich wäre, könntest Du aber die erste "Array"-Version von oben verwenden.

Grüße
bastla
Bitte warten ..
Mitglied: immobrauch
10.01.2010 um 20:18 Uhr
Hallo Bastla,

funktioniert! *freu* Merci vielmals.

Immo Brauch
Bitte warten ..
Ähnliche Inhalte
Microsoft Office
Bedingte Formatierung in Excel 2010
gelöst Frage von killtecMicrosoft Office10 Kommentare

Hallo, ich möchte in Excel 2010 eine Bedingte Formatierung anlegen, die etwas komplexer ist. Ich habe einen Wert z.B. ...

Microsoft Office
Excel bedingte Formatierung
Frage von 103148Microsoft Office3 Kommentare

Hallo, ich berechne das Alter von Computern aus dem Liefer Datum ( K181 ) K181 L181 M181 28.02.2013 3 Alter: 1 ...

Microsoft Office
Excel 2013 Formel zum Filtern und SummeWenn Funktion
gelöst Frage von LordXearoMicrosoft Office5 Kommentare

Hallo zusammen, ich könnte etwas Unterstützung beim lösen einer Excel Angelegenheit gebrauchen. Ich habe dazu bereits eine Makro gestützte ...

Microsoft Office
Bedingte Formatierung in Excel für verschiedene Dezimalstellen
gelöst Frage von wingetMicrosoft Office6 Kommentare

Hallo zusammen, ich suche die Möglichkeit durch "Bedingte Formatierung" in Excel verschiedene Dezimalstellen durch verschiedene Farben (die Zelle soll ...

Neue Wissensbeiträge
Humor (lol)

"gimme gimme gimme": Automatischer Test stolpert über Easter Egg im man-Tool

Information von Penny.Cilin vor 1 StundeHumor (lol)2 Kommentare

Interessant, was man so alles als Easter Egg implementiert. Ist schon wieder Ostern? "gimme gimme gimme": Automatischer Test stolpert ...

MikroTik RouterOS

Mikrotik - Lets Encrypt Zertifikate mit MetaROUTER Instanz auf dem Router erzeugen

Anleitung von colinardo vor 17 StundenMikroTik RouterOS8 Kommentare

Einleitung Folgende Anleitung ist aus der Lage heraus entstanden das ein Kunde auf seinem Mikrotik sein Hotspot Captive Portal ...

Sicherheit

Sicherheitslücke in HP-Druckern - Firmware-Updates stehen bereit

Information von BassFishFox vor 17 StundenSicherheit1 Kommentar

Ein weiterer Grund, dass Drucker keinerlei Verbindung nach "auswaerts" haben sollen. Unter Verwendung spezieller Malware können Angreifer aus der ...

Administrator.de Feedback

Entwicklertagebuch: Die Startseite wurde überarbeitet

Information von admtech vor 19 StundenAdministrator.de Feedback10 Kommentare

Hallo Administrator User, mit dem Release 5.7 haben wir unsere Startseite überarbeitet und die Beiträge und Fragen voneinander getrennt. ...

Heiß diskutierte Inhalte
Windows Server
RDP macht Server schneller???
Frage von JaniDJWindows Server17 Kommentare

Hallo Community, wir betrieben seit geraumer Zeit diverse virtuelle Maschinen und Server mit Windows Server 2012. Leider haben wir ...

Windows Netzwerk
Netzwerk Neustrukturierung
Frage von IT-DreamerWindows Netzwerk16 Kommentare

Hallo verehrte Community und Admins, bei uns im Haus steht eine Neustrukturierung an. Dafür benötige ich von euch ein ...

Windows 10
Windows 10 dunkler Bildschirm nach Umfallen
Frage von AkcentWindows 1015 Kommentare

Hallo, habe hier einen Windows 10 Rechner der von einem User umgefallen wurde (Beine übers Knie, an den PC ...

Linux
OpenSource Groupware
Frage von FA-jkaLinux13 Kommentare

Hallo, ich suche eine Groupware als Alternative zum Exchange. Wesentliche Aufgaben sind die Handhabung von E-Mails (persönliche und gemeinsam ...