Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Excel-SUMMEWENN mit bedingter Multiplikation

Frage Microsoft Microsoft Office

Mitglied: immobrauch

immobrauch (Level 1) - Jetzt verbinden

10.01.2010 um 11:11 Uhr, 17551 Aufrufe, 4 Kommentare

Excel 2003 SP3

Hallo zusammen,

ich möchte den aktuellen Warenbestandswert EK-Netto auf einem separaten
Sheet auslesen.

In der Tabelle gibt es u. a. 2 Blätter "Hardware" und "Auswertung". Die
gesuchte Formel soll in "Auswertung" stehen und Berechnungen aus "Hardware"
durchführen.

X:X in "Hardware" zeigt den aktuellen Warenbestand (Stückzahl)
AB:AB in "Hardware" zeigt den EK-Netto/Stück

Formel A

=SUMMEWENN(Hardware!X:X;">0";Hardware!AB:AB)

summiert mir richtig die Spalte AB:AB in "Hardware", ohne allerdings den
EK-Netto/Stück mit dem Warenbestand in X:X zu multiplizieren.

Formel B

=WENN(Hardware!X:X>0; Hardware!X:X*Hardware!AB:AB) multipliziert zwar,
allerdings immer nur Zeile für Zeile.

In Formel B taucht der Artikel XYZ nur 1x auf. Wenn der Warenwert/EK € 20,00
ist, werden auch nur die € 20,00 berechnet. Habe ich den Artikel 3x im Laden,
muss hier aber mit € 60,00 gerechnet werden, also mit 3 multipliziert werden.

Ich möchte nun Formel A so anpassen, dass mir mehrfach vorhandene Waren in
der Gesamtsumme wie in Formel B berücksichtigt.


Wer weiß hierzu Rat?

--
Immo Brauch
Mitglied: bastla
10.01.2010 um 13:56 Uhr
Hallo immobrauch!

Dazu benötigst Du die folgende Array-Formel:
{=SUMME(WENN(Hardware!X:X>0; Hardware!X:X*Hardware!AB:AB;0))}
Die geschwungenen Klammern "{" und "}" an Beginn und Ende der Formel sind dabei nicht einzugeben, sondern werden von Excel zur Kennzeichnung der Formel als "Array-Formel" gesetzt. Die Eingabe muss (auch nach jeder Bearbeitung / Änderung der Formel) mit der Tastenkombination "Strg + Umsch + Eingabe" abgeschlossen werden.

Anmerkung: Soferne es keine negativen Mengen zu berücksichtigen gibt, könnte das "WENN" auch entfallen (die Multiplikation mit der Menge 0 führt automatisch auch zu einem Wert 0):
{=SUMME(Hardware!X:X*Hardware!AB:AB)}
Grüße
bastla
Bitte warten ..
Mitglied: immobrauch
10.01.2010 um 18:48 Uhr
Hallo Bastla,

das Ergebnis = #ZAHL!

Ich habs mittlerweile gelöst mit SUMMENPRODUKT, wobei ich in XL 2003 keine ganzen Spalten AB:AB, sondern nur Bereiche AB2:AB5000 eingeben kann.

Deine Lösung wäre komfortabler, da sie nicht mehr angepasst werden muss, funktioniert bei mir aber leider nicht.

Mit der Tastenkombination "Strg + Umsch + Eingabe" habe ich abgeschlossen und die geschweiften Klammern auch weggelassen.

Immo Brauch
Bitte warten ..
Mitglied: bastla
10.01.2010 um 20:09 Uhr
Hallo immobrauch!

Sorry - hatte mal wieder vergessen, dass auch für die Array-Formel die Angabe der gesamten Spalten nicht funktioniert (womit auch der vermeintliche Vorteil sich schon wieder erledigt hätte) ...

Mit
{=SUMME(Hardware!X2:X500*Hardware!AB2:AB5000)}
sollte es geklappt haben, wobei allerdings für die Version ohne "WENN()" tatsächlich "SUMMENPRODUKT()" die bessere Alternative darstellt. Für den Fall, dass tatsächlich einmal eine Bedingung erforderlich wäre, könntest Du aber die erste "Array"-Version von oben verwenden.

Grüße
bastla
Bitte warten ..
Mitglied: immobrauch
10.01.2010 um 20:18 Uhr
Hallo Bastla,

funktioniert! *freu* Merci vielmals.

Immo Brauch
Bitte warten ..
Ähnliche Inhalte
Microsoft Office
gelöst Bedingte Formatierung in Excel für verschiedene Dezimalstellen (6)

Frage von winget zum Thema Microsoft Office ...

Microsoft Office
gelöst Bedingte Formatierung in Excel, wenn zweite Dezimalstelelle nicht eine Null ist (11)

Frage von winget zum Thema Microsoft Office ...

Microsoft Office
gelöst Microsoft Excel tabelen sotierung (7)

Frage von lauri2223 zum Thema Microsoft Office ...

Neue Wissensbeiträge
Sicherheit

Millionen Euro in den Sand gesetzt?

(1)

Information von transocean zum Thema Sicherheit ...

Sicherheit

How I hacked hundreds of companies through their helpdesk

Information von SeaStorm zum Thema Sicherheit ...

Erkennung und -Abwehr

Ccleaner-Angriff war nur auf große Unternehmen gemünzt

(10)

Information von Lochkartenstanzer zum Thema Erkennung und -Abwehr ...

Heiß diskutierte Inhalte
Humor (lol)
gelöst Freidach Beitrag (40)

Frage von Penny.Cilin zum Thema Humor (lol) ...

Windows 7
gelöst SSD - Win7 Lags (20)

Frage von ph5555 zum Thema Windows 7 ...

Firewall
gelöst Firewall Firmeneimsatz (19)

Frage von wiesi200 zum Thema Firewall ...