Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

EXCEL - Tabellenabfrage mit Rückgabe eines Wertes

Frage Microsoft Microsoft Office

Mitglied: DJSchwollkopp

DJSchwollkopp (Level 1) - Jetzt verbinden

07.10.2014, aktualisiert 16:47 Uhr, 1405 Aufrufe, 7 Kommentare

Hallo zusammen,

ich habe eine Excel-Tabelle, in der ich 3 Kriterien abfragen muss, um einen Wert zurückzubekommen:
So sieht meine Tabelle aus:

f4bf1cc16225ca1233bd9cbe19e92b36 - Klicke auf das Bild, um es zu vergrößern

Die Spalten sind wie folgt: A1,A2,B1 und B2 und werden über ein Eingabefeld abgefragt.
Dabei ist jede Spalte ein weiteres Mal unterteilt in 2 oder 3, wird ebenfalls über ein Eingabefeld abgefragt.
Das 3. Kriterium ist der Querschnitt (1,5mm²-120mm²), wir auch abgefragt.

Wie erhalte ich nun für die 3 Eingaben z.B. B1-3-70mm², den Wert 160 zurück???

Thx im voraus!

DJSchwollkopp
Mitglied: colinardo
07.10.2014, aktualisiert um 16:31 Uhr
Moin DJSchwollkopp,
benutze bitte die Formatierungsmöglichkeiten, damit wir hier besser verstehen wie deine Tabelle aussieht ...Danke.

-edit- p.s. Etwas ähnliches nach dem gleichen Schema hatte ich bereits hier gepostet:
Wertabfrage aus mehr dimensionaler Matrix

Grüße @colinardo
Bitte warten ..
Mitglied: DJSchwollkopp
07.10.2014 um 16:50 Uhr
Habe Bild eingefügt...
Bitte warten ..
Mitglied: colinardo
07.10.2014, aktualisiert 08.10.2014
Alles klar
Hier das Demo-Sheet: abfrage_matrix_251189.xlsx

e6915a073f82a8fa03992b047cb59a23 - Klicke auf das Bild, um es zu vergrößern

Geht natürlich auch mit einer SVERWEIS Variante für das Demo-Sheet sähe diese dann so aus:
=SVERWEIS($C$21;$B$4:$J$15;VERGLEICH($C$19;$C$2:$J$2;0)+WENN($C$20=2;0;1)+1;0)
Grüße Uwe
Bitte warten ..
Mitglied: Biber
08.10.2014, aktualisiert um 11:09 Uhr
Moin colinardo,

Kleine Anmerkung zu der SVERWEIS-Variante:
- du hast da einen Tippfehler drin.. das 6.te $-Zeichen ist einen mm zu weit nach rechts gerutscht.
- da die Werte in Spalte B nicht aufsteigend sortiert vorliegen, braucht SVERWEIS als 4ten Parameter ein FALSCH/0. Sonst kommen u.U. falsche Ergebnisse


=SVERWEIS($C$21;$B$4:$J$15;VERGLEICH($C$19;$C$2:$J$2;0)+WENN($C$20=2;0;1)+1;0 )
Grüße
Biber
Bitte warten ..
Mitglied: colinardo
08.10.2014, aktualisiert um 09:57 Uhr
Hi Biber,
Danke für die Korrektur, ist oben korrigiert - das iPad trifft manchmal nicht da hin wo ich will, da fehlen einfach die Pfeiltasten

Grüße Uwe
Bitte warten ..
Mitglied: DJSchwollkopp
08.10.2014 um 10:35 Uhr
Hi Uwe,

danke für die Hilfe! Problem gelöst!

DJ
Bitte warten ..
Mitglied: colinardo
08.10.2014, aktualisiert um 13:20 Uhr
Zitat von DJSchwollkopp:
danke für die Hilfe! Problem gelöst!
den Beitrag dann bitte noch auf gelöst setzen. Merci.
Bitte warten ..
Ähnliche Inhalte
Microsoft Office
Excel (2016): Enthaltenen Text suchen (2)

Frage von ralfkausk zum Thema Microsoft Office ...

VB for Applications
gelöst EXCEL VBA Zellen verbinden. MERGE (6)

Frage von Aximand zum Thema VB for Applications ...

VB for Applications
gelöst VBA Excel Skript - Hilfe! (1)

Frage von Compu2017 zum Thema VB for Applications ...

Microsoft Office
VBA Code zum Kopieren von einzelnen Zellen in Excel (3)

Frage von SebastianL zum Thema Microsoft Office ...

Neue Wissensbeiträge
Tipps & Tricks

Wie Hackt man sich am besten in ein Computernetzwerk ein

(29)

Erfahrungsbericht von Herbrich19 zum Thema Tipps & Tricks ...

Humor (lol)

Bester Vorschlag eines Supporttechnikers ever: APC

(15)

Erfahrungsbericht von DerWoWusste zum Thema Humor (lol) ...

Windows Server

Exchange 2010 Active Directory und Windows Server 2016

(4)

Erfahrungsbericht von Herbrich19 zum Thema Windows Server ...

Heiß diskutierte Inhalte
Internet
gelöst Mitarbeiter surft auf unerwünschter Seite - Wie damit umgehen? (52)

Frage von sabines zum Thema Internet ...

Netzwerke
LAN2LAN Verbindung sehr langsam flaschenhals gesucht (27)

Frage von PixL86 zum Thema Netzwerke ...

Router & Routing
PFsense - Netzverbindung steht, aber kein Internet vorhanden (24)

Frage von aschmid zum Thema Router & Routing ...

Windows Server
gelöst Windows 2016 Hyper-V und VHDS (19)

Frage von emeriks zum Thema Windows Server ...