Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Excel - verweis auf Arbeitsblatt über Zellinhalt

Frage Microsoft Microsoft Office

Mitglied: leknilk0815

leknilk0815 (Level 3) - Jetzt verbinden

10.05.2006, aktualisiert 23:45 Uhr, 35751 Aufrufe, 7 Kommentare

Wie läßt sich über einen Zellinhalt ein Verweis auf ein Arbeitsblatt erstellen??

Hallo zusammen!

Ich habe folgendes Problem:

In einem Excel- Sheet befinden sich mehrere Arbeitsblätter, benannt z.B. AAA, BBB, CCC.
Man kann nun einen Verweis in einer Zelle auf eine Zelle in einem anderen Arbeitsblatt mit:
='BBB'!A1 erstellen.
Gibt es eine Möglichkeit, diesen Verweis mittels eines Zellinhaltes zu machen, also z.B.:

In Zelle B2 (Arbeitsblatt AAA) steht "BBB".
Dieses "BBB" möchte ich in die Formel "='BBB'!A1" einbauen.

Geht das und wenn, wie?????
(Würde mir vieles extrem erleichtern, da ich dann nicht in jede Formel den Verweis manuell eintragen müsste, sondern auf Zellinhalt referenzieren könnte)

Danke mal vorab

Gruß - Toni
Mitglied: Biber
10.05.2006 um 14:28 Uhr
Moin Toni.

nimm dazu die Funktion INDIREKT()

=INDIREKT(B2 &"!A1")

...oder mit Vornamen =INDIREKT(AAA!B2 &"!A1")
liefert dann einen Verweis auf das Feld BBB!A1..
.. oder besser ausgedrückt, den Feldinhalt von BBB!A1

Gruß
Biber
Bitte warten ..
Mitglied: leknilk0815
10.05.2006 um 15:12 Uhr
Hallo Biber,

da hab ich mich wohl etwas zu einfach ausgedrückt.
Ich muß diesen Bezug in Formeln einbauen, z.B.:
=SVERWEIS("serial";'31583'!C:D;2;FALSCH)
Das Arbeitsblatt heißt in dem Fall 31583, und dieser Wert (Seriennummer) steht in Zelle D4.
Das heißt, im SVERWEIS müsste statt '31583'! irgendwas mit D4 stehen

Gruß - Toni
Bitte warten ..
Mitglied: leknilk0815
10.05.2006 um 22:34 Uhr
Hallo Biber,
ich hab jetzt die Lösung:
es geht mit "indirekt" und "verketten".

Danke für Deine Mühe

Gruß - Toni
Bitte warten ..
Mitglied: Biber
10.05.2006 um 22:43 Uhr
Na dann poste doch bitte die ganze Zeile.. *gg

..ich lerne ja auch gern dazu..

Grüße
Biber
Bitte warten ..
Mitglied: leknilk0815
10.05.2006 um 23:00 Uhr
gerne, hier die Zeile (grins...)

{=WENN($D4=SVERWEIS("serial";INDIREKT(VERKETTEN("'"&D4&"'!C:D"));2;FALSCH);LINKS(INDIREKT(VERKETTEN("'"&D4&"'!$F$3"));SUMME(1*(ISTZAHL(LINKS(INDIREKT(VERKETTEN("'"&D4&"'!$F$3"));SPALTE(1:1))*1))))*1;"SN# stimmt nicht überein!")}

Ich benutze das Ding, um die Wartungskosten von HDS- Türmen zu ermitteln. Hierbei sind auf einem Sheet u.a. die SN# hinterlegt, auf mehreren anderen Arbeitsblättern, welche mit den jeweiligen Seriennummern benannt sind, die Daten aus dem autom. Storage Report. Mit dieser Formel brauche ich nun die Verweise nicht mehr von Hand einzutragen und kann die Formel einfach runterziehen. Nachdem mittlerweile knapp 500TB rumstehen, muß man "automatisieren".

Gruß - Toni (und danke nochmal)

Edit: damit mir keine lange Nase wächst: der Tipp mit indirekt verketten kam aus nem Excelforum, der Rest ist von meinem Mist
Bitte warten ..
Mitglied: Biber
10.05.2006 um 23:31 Uhr
Danke Dir auch, Toni,
aber das probier ich morgen mal aus..
IMHO ist dieses geschraubte
.....INDIREKT(VERKETTEN("'"&D4&"'!C:D"));....
gleichbedeutend mit meinem
...INDIREKT(D4&"'!C:D");
(aber schlechter lesbar *gg)
Hab grad kein Excel on board... ich teste es morgen mal.

Gruß
Biber
Bitte warten ..
Mitglied: leknilk0815
10.05.2006 um 23:45 Uhr
Hab ich ausprobiert, geht aber irgendwie nicht. Wäre natürlich einfacher...
Bitte warten ..
Ähnliche Inhalte
Microsoft Office
gelöst Zellinhalt in Excel-Kopfzeile übernehmen (2)

Frage von Kyrinja zum Thema Microsoft Office ...

Microsoft Office
gelöst Excel 2010 Makro Ausgabe in bestimmter Tabelle ausgeben (6)

Frage von dressa zum Thema Microsoft Office ...

Microsoft Office
gelöst Dynamische tabellen erstellen und in einanderes arbeitsblatt kopieren (18)

Frage von hugothemagpie zum Thema Microsoft Office ...

Neue Wissensbeiträge
Linux Netzwerk

Ping und das einstellbare Bytepattern

(1)

Erfahrungsbericht von LordGurke zum Thema Linux Netzwerk ...

Windows Update

Microsoft Update KB4034664 verursacht Probleme mit Multimonitor-Systemen

(3)

Tipp von beidermachtvongreyscull zum Thema Windows Update ...

Viren und Trojaner

CNC-Fräsen von MECANUMERIC werden (ggf.) mit Viren, Trojanern, Würmern ausgeliefert

(4)

Erfahrungsbericht von anteNope zum Thema Viren und Trojaner ...

Heiß diskutierte Inhalte
SAN, NAS, DAS
MSA 2050 RAID Konfig (27)

Frage von Leo-le zum Thema SAN, NAS, DAS ...

Microsoft Office
Office Druck fehler (12)

Frage von DaistwasimBusch zum Thema Microsoft Office ...

Festplatten, SSD, Raid
Uninitialisierte Festplatte - Daten retten (11)

Frage von peterla zum Thema Festplatten, SSD, Raid ...

Netzwerkmanagement
Windows Server 2008 R2: "netsh reset" nicht verfügbar? (11)

Frage von RickTucker zum Thema Netzwerkmanagement ...