Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Excel - verweis auf Arbeitsblatt über Zellinhalt

Frage Microsoft Microsoft Office

Mitglied: leknilk0815

leknilk0815 (Level 3) - Jetzt verbinden

10.05.2006, aktualisiert 23:45 Uhr, 36718 Aufrufe, 7 Kommentare

Wie läßt sich über einen Zellinhalt ein Verweis auf ein Arbeitsblatt erstellen??

Hallo zusammen!

Ich habe folgendes Problem:

In einem Excel- Sheet befinden sich mehrere Arbeitsblätter, benannt z.B. AAA, BBB, CCC.
Man kann nun einen Verweis in einer Zelle auf eine Zelle in einem anderen Arbeitsblatt mit:
='BBB'!A1 erstellen.
Gibt es eine Möglichkeit, diesen Verweis mittels eines Zellinhaltes zu machen, also z.B.:

In Zelle B2 (Arbeitsblatt AAA) steht "BBB".
Dieses "BBB" möchte ich in die Formel "='BBB'!A1" einbauen.

Geht das und wenn, wie?????
(Würde mir vieles extrem erleichtern, da ich dann nicht in jede Formel den Verweis manuell eintragen müsste, sondern auf Zellinhalt referenzieren könnte)

Danke mal vorab

Gruß - Toni
Mitglied: Biber
10.05.2006 um 14:28 Uhr
Moin Toni.

nimm dazu die Funktion INDIREKT()

=INDIREKT(B2 &"!A1")

...oder mit Vornamen =INDIREKT(AAA!B2 &"!A1")
liefert dann einen Verweis auf das Feld BBB!A1..
.. oder besser ausgedrückt, den Feldinhalt von BBB!A1

Gruß
Biber
Bitte warten ..
Mitglied: leknilk0815
10.05.2006 um 15:12 Uhr
Hallo Biber,

da hab ich mich wohl etwas zu einfach ausgedrückt.
Ich muß diesen Bezug in Formeln einbauen, z.B.:
=SVERWEIS("serial";'31583'!C:D;2;FALSCH)
Das Arbeitsblatt heißt in dem Fall 31583, und dieser Wert (Seriennummer) steht in Zelle D4.
Das heißt, im SVERWEIS müsste statt '31583'! irgendwas mit D4 stehen

Gruß - Toni
Bitte warten ..
Mitglied: leknilk0815
10.05.2006 um 22:34 Uhr
Hallo Biber,
ich hab jetzt die Lösung:
es geht mit "indirekt" und "verketten".

Danke für Deine Mühe

Gruß - Toni
Bitte warten ..
Mitglied: Biber
10.05.2006 um 22:43 Uhr
Na dann poste doch bitte die ganze Zeile.. *gg

..ich lerne ja auch gern dazu..

Grüße
Biber
Bitte warten ..
Mitglied: leknilk0815
10.05.2006 um 23:00 Uhr
gerne, hier die Zeile (grins...)

{=WENN($D4=SVERWEIS("serial";INDIREKT(VERKETTEN("'"&D4&"'!C:D"));2;FALSCH);LINKS(INDIREKT(VERKETTEN("'"&D4&"'!$F$3"));SUMME(1*(ISTZAHL(LINKS(INDIREKT(VERKETTEN("'"&D4&"'!$F$3"));SPALTE(1:1))*1))))*1;"SN# stimmt nicht überein!")}

Ich benutze das Ding, um die Wartungskosten von HDS- Türmen zu ermitteln. Hierbei sind auf einem Sheet u.a. die SN# hinterlegt, auf mehreren anderen Arbeitsblättern, welche mit den jeweiligen Seriennummern benannt sind, die Daten aus dem autom. Storage Report. Mit dieser Formel brauche ich nun die Verweise nicht mehr von Hand einzutragen und kann die Formel einfach runterziehen. Nachdem mittlerweile knapp 500TB rumstehen, muß man "automatisieren".

Gruß - Toni (und danke nochmal)

Edit: damit mir keine lange Nase wächst: der Tipp mit indirekt verketten kam aus nem Excelforum, der Rest ist von meinem Mist
Bitte warten ..
Mitglied: Biber
10.05.2006 um 23:31 Uhr
Danke Dir auch, Toni,
aber das probier ich morgen mal aus..
IMHO ist dieses geschraubte
.....INDIREKT(VERKETTEN("'"&D4&"'!C:D"));....
gleichbedeutend mit meinem
...INDIREKT(D4&"'!C:D");
(aber schlechter lesbar *gg)
Hab grad kein Excel on board... ich teste es morgen mal.

Gruß
Biber
Bitte warten ..
Mitglied: leknilk0815
10.05.2006 um 23:45 Uhr
Hab ich ausprobiert, geht aber irgendwie nicht. Wäre natürlich einfacher...
Bitte warten ..
Ähnliche Inhalte
Microsoft Office
Zellinhalt in Excel-Kopfzeile übernehmen
gelöst Frage von KyrinjaMicrosoft Office2 Kommentare

Guten Tag, stehe vor dem Problem, das ich Excellisten drucken Soll Welche folgendermaßen aufgebaut sind: Seite Lager von bis ...

Microsoft Office
Excel Arbeitsblätter kopieren sich selbstständig
gelöst Frage von KMP1988Microsoft Office7 Kommentare

Servus, ich habe ein Problem mit Excel 2013. Ein Kunde hat bei sich am PC eine Excel-Datei mit mehreren ...

Microsoft Office
Excel Zellinhalte aus einer Datei in eine andere Excel Datei kopieren und auch aktualisieren
gelöst Frage von Rene1976Microsoft Office4 Kommentare

Hallo, bis jetzt habe ich immer eine Referenz von einer Excelzelle aus einer Datei in eine andere Excelzelle einer ...

Microsoft Office
Excel Arbeitsblatt automatisch um Zelle erweitern
gelöst Frage von tom1987Microsoft Office2 Kommentare

Hallo VBA-Profis ;) Ich habe folgendes Problem Bin gerade dabei ein Protokoll zu erstellen, über die %-Auslastung der LKW´s ...

Neue Wissensbeiträge
Microsoft Office

Office 2010 Starter erneut auf einer frischen Windows-Version installieren

Tipp von Lochkartenstanzer vor 14 StundenMicrosoft Office2 Kommentare

Moin, vor ein paar Tagen schlug bei mir ein Kunde auf, der sein Widnows 7 geschrottet und es inklusive ...

Datenbanken

Upgrade MongoDB 3.4 auf 3.6

Erfahrungsbericht von Frank vor 16 StundenDatenbanken

Seit kurzem gibt es das 3.6 Update für die MongoDB: Sicherheit, das Sortieren, Aggregation und auch die Performance wurde ...

SAN, NAS, DAS

Backdoor Zugang und Upload-Bug in vielen Western Digital MyCloud Geräten

Information von Frank vor 17 StundenSAN, NAS, DAS2 Kommentare

James Bercegay von der Firma Gulftech hat die Fehler an Western Digital gemeldet und das Unternehmen stellt bereits ein ...

Microsoft Office

Outlook 2016 - Beim Weiterleiten keine PDF Anhänge mehr - KB4011626 entfernen

Erfahrungsbericht von Deepsys vor 20 StundenMicrosoft Office1 Kommentar

Wenn ihr feststellt das ihr beim Weiterleiten von E-Mails keine PDF Anhänge mehr versendent, dann dankt Microsoft. Diese tolle ...

Heiß diskutierte Inhalte
Windows Netzwerk
Drucker isolieren in Windows Domäne
gelöst Frage von lcer00Windows Netzwerk14 Kommentare

Hallo zusammen, habe eine Windows-AD (2012R2) in der es einen Druckerserver gibt. Mittlerweile verliere ich das Vertrauen in die ...

Server-Hardware
Veeam Backup Server stürzt alle paar Tage ab
Frage von Leo-leServer-Hardware12 Kommentare

Hallo Forum, ich habe momentan folgendes Problem. Veeam Backup and Replication 9.5 u2 auf voll gepatchten DL 380 G7 ...

Windows 10
Win10 Laptop findet keine Netzwerkgeräte und Freigaben mehr
Frage von CoolzeroWindows 1010 Kommentare

Hi, seit ein paar Tagen habe ich das Problem das mein Windows 10 Laptop keine Geräte mehr in der ...

Batch & Shell
Dateien verschieben mit batch
gelöst Frage von michi-ffmBatch & Shell10 Kommentare

Hallo Zusammen hat jemand evtl eine Idee? Zunächst hier das Skript: Leider werden keine UNC-Pfade unterstüzt, kann mir jemand ...