Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Excel nach Worten oder Text in Zelle suchen

Frage Microsoft Microsoft Office

Mitglied: Albafotos

Albafotos (Level 1) - Jetzt verbinden

14.10.2012, aktualisiert 23:25 Uhr, 13165 Aufrufe, 13 Kommentare

Hallo, ich suche Lösung für folgendes Problem.

Ich möchte in Tabelle 1 Spalte D1 bis D(n) einen Wort eintippen und in Spalte I1 -I(n) soll dann ein Zahl erscheinen.

Tabelle 1

Dazu habe ich in Tabelle 2 eine Matrix erstellt.

Tabelle 2


Gegoogelt, Beispiele angepasst, aber wenn ich noch dazu ein Wort oder Text in D1 einschreibe, Exel zeigt Fehler oder NV.

Hier sind paar Versuche:


=WENN(ISTTEXT(SVERWEIS($I1;$D$10:$E$11;2;FALSCH)) = WAHR; "Fehler"; SVERWEIS($I1;$D$10:$E$11;2;FALSCH)) 
 
=SVERWEIS("*" &I1&"*";Tabelle2!A:B;2;)
Ich hoffe, dass mir jemand helfen kann. Vielen Dank!
Mitglied: DschinN
15.10.2012, aktualisiert um 13:31 Uhr
also fang mal wie folgt an: mach dir ne matrix von a 26 bis b 35
dann trägst du bei I folgendes ein und ziehst es nach unten =WENN(D1="";"";SVERWEIS(D1;$A$26:$B$41;2;))
wenn du jetzt bei D einen ort eingibst den es in der matrix gibt wird er dir die zahl anzeigen.

Falls du natürlich ein Wort eingibst welches es nicht gibt zeigt er dir nen Fehler an.

Wenn du als Suchkriterium z.b. "*"&D1&"*" eingiebst sucht er dir alles durch kann aber natürlich zu falschen Werten führen.

mfg Neuhäusler Korbinian
Professioneller EDV Anwender(HWK)
Bitte warten ..
Mitglied: bastla
15.10.2012 um 14:08 Uhr
@ DschinN
Damit der (an sich richtige Ansatz) auch wirklich funktioniert, solltest Du noch ein "FALSCH" oder, einfacher, eine Null spendieren:
=WENN(D1="";"";SVERWEIS(D1;$A$26:$B$41;2;0))
Soferne übrigens Albafotos Deiner Empfehlung
mach dir ne matrix von a 26 bis b 35
gefolgt sein sollte, würde sich die Bereichsangabe eher mit $A$26:$B$35 anbieten ...

BTW:
Wenn du als Suchkriterium z.b. "*"&D1&"*" eingiebst sucht er dir alles durch
Seit welcher Excel-Version kann denn SVERWEIS() mit "*" umgehen?

Grüße
bastla
Bitte warten ..
Mitglied: DschinN
15.10.2012, aktualisiert um 17:15 Uhr
also ich habs mit 2010 gemacht geht einwandfrei das problem is halt wenn du z.b. 2 mal die werte hast nimmt er nur den ersten

und es ist egal ob du 0 oder falsch oder einfach nur nen ; machst. sobald der ; da ist ist es automatisch 0 es sei denn es steht was andres da .



ich würde nur gerne den sinn von der formel verstehen wieso da isttext drin is. was erwartest du denn als ergebnis ?? die zahl hinter der stadt ?? oder nur 0 oder 1 ?


mfg
Bitte warten ..
Mitglied: bastla
15.10.2012 um 17:21 Uhr
@ DschiN
Dass "SVERWEIS()" Suchbegriffe mit Wildcards erlaubt, war mir neu, und den ";" am Ende muss ich dann wohl übersehen haben ...

Grüße
bastla
Bitte warten ..
Mitglied: DschinN
15.10.2012 um 17:25 Uhr
aber für was ist der isttext ??
Bitte warten ..
Mitglied: bastla
15.10.2012 um 17:29 Uhr
... weil nur Zahlen als Ergebnis gewünscht sind? Näheres weiß aber vermutlich nur der TE ...

Grüße
bastla
Bitte warten ..
Mitglied: Albafotos
15.10.2012 um 22:38 Uhr
Hallo DschinN und bastla! Vielen Dank für Eure Zeit und Hilfe.
Beide Lösungen funktionieren, aber ich denke, dass ich mich falsch ausgedrückt habe.
Ich will, dass Ergebnis/Wert immer gleich bleibt, wenn ich noch in die Zelle zusätsliche Text eintippe.
Z.b. Das Wort "München" aus Tabelle_2 soll immer Zahl 4471 bringen, ob da "München Negative" oder "Schönste Stadt ist München".

"München Negative" = 4471
"Schönste Stadt ist München" = 4471

Ist so was mit Exel möglich? Nochmal Vielen Dank.
Bitte warten ..
Mitglied: bastla
15.10.2012, aktualisiert 17.10.2012
Hallo Albafotos!

Wenn Du die Schreibweise der Orte in Deiner Matrix auf zB "*München*" änderst - oder in einer Hilfsspalte, zB Spalte C, die entsprechende Schreibweise erzeugst:
="*"&A1&"*"
- kannst Du das mit einer Arrayformel bzw einem "missbrauchten" "SUMMENPRODUKT()", etwa
=SUMMENPRODUKT((ZÄHLENWENN(D1;$A$1:$A$20)>0)*$B$1:$B$20)
oder, für die "Hilfsspalten"-Variante, mit
=SUMMENPRODUKT((ZÄHLENWENN(D1;$C$1:$C$20)>0)*$B$1:$B$20)
versuchen - vorausgesetzt, die gesuchten Begriffe (Städte) kommen jeweils nur einmal in den durchsuchten Begriffen der Spalte D vor (da Du ansonsten die Summe der Werte erhältst - so wäre etwa für "Bilder aus München und Prag" das Ergebnis 9858) ...

Grüße
bastla
Bitte warten ..
Mitglied: DschinN
15.10.2012 um 23:37 Uhr
Was machste damit eigentlich? Vielleicht gibts ja ne bessere Lösung für das Problem z.b. Access
Bitte warten ..
Mitglied: Albafotos
17.10.2012 um 00:00 Uhr
Hallo DschinN und bastla!

Bastla, ich habe versucht Excel zu "missbrauchen", aber kommte Fehlermeldungen oder führten zu falschen Ergebnissen, oder ich kann mit Excel nicht gut umgehen.

Die Musterformel habe ich bei Google gefunden.
Formel für Wortsuche im Text.
=VERWEIS(2;1/FINDEN(A$2:A$4;D2);A$2:A$4)
Ein wenig "misbraucht"und Formel im Exel_2010._xlsx jetzt sieht so aus:
=VERWEIS(2;1/FINDEN(A$20:A$24;D2);B$20:B$24)
Wortsuche funktioniert, aber Exakt und Groß- und Kleinschreibung muss man beachten.
Es kann man in Zelle zusätsliche Text und Sondernzeichen eintippen.
Meine Fragen:
- Ist möglich Groß- und Kleinschreibung umgehen? Mit Exel Optionen?

- Ist möglich Matrix In Tabelle1 veschieben.

Versucht, aber funktioniert nicht
=VERWEIS(2;1/FINDEN(Tabelle1!A$20:A$24;Mappe1!D2);Tabelle1!B$20:B$24)
- Interpretiere ich die Formel richtig?

Zahl 2 - Spalte mit Zahlen im Matrix
Zahl 1 - Fehlermeldung
Matrix - A$20:A$24 ; B$20:B$24

Vielen Dank für Hilfe!
Bitte warten ..
Mitglied: DschinN
17.10.2012 um 06:27 Uhr
ich würd ma access anschmeissen ganz ehrlich
Bitte warten ..
Mitglied: bastla
17.10.2012 um 12:16 Uhr
Hallo Albafotos!

Mein Vorschlag von oben sollte mit beiden zusätzlichen Wünschen zurechtkommen - in der "Hilfsspalten"-Version dann einfach:
=SUMMENPRODUKT((ZÄHLENWENN(D1;Tabelle1!$C$1:$C$20)>0)*Tabelle1!$B$1:$B$20)
Grüße
bastla
Bitte warten ..
Mitglied: Albafotos
24.10.2012, aktualisiert 26.10.2012
Hallo bastla und DschinN,

bastla, ich benutze gerne Deine batch-s und -.vbs aus dem Forum und =SUMMENPRODUKT natürlich ausprobiert, aber irgendwie klappt es nicht.

Trotzdem die Lösung gefunden!

=VERWEIS(2;0/SUCHEN(Tabelle1!A$1:A$20;D2);Tabelle1!B$1:B$20)
Laut Google, bei FINDEN muss man Groß- und Kleinschreibung beachten,

beim SUCHEN nicht.

NOCH EINE BEDIENUNG: im Tabelle1 Matrix muss genau A1:A20 und B1:B20 sein, sonst Formel liefert 0 (null).
Aber mit etwas Genauigkeit kann man leben.

Vielen Dank für ihre Hilfe!
Bitte warten ..
Neuester Wissensbeitrag
Windows 10

Powershell 5 BSOD

(8)

Tipp von agowa338 zum Thema Windows 10 ...

Ähnliche Inhalte
Heiß diskutierte Inhalte
Microsoft
Ordner mit LW-Buchstaben versehen und benennen (20)

Frage von Xaero1982 zum Thema Microsoft ...

Outlook & Mail
gelöst Outlook 2010 findet ost datei nicht (19)

Frage von Floh21 zum Thema Outlook & Mail ...

Netzwerkmanagement
gelöst Anregungen, kleiner Betrieb, IT-Umgebung (18)

Frage von Unwichtig zum Thema Netzwerkmanagement ...

Festplatten, SSD, Raid
M.2 SSD wird nicht erkannt (14)

Frage von uridium69 zum Thema Festplatten, SSD, Raid ...