Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Exceldatei als Testversion, die nach 10 Tagen nicht mehr zu öffnen ist

Frage Microsoft Microsoft Office

Mitglied: shadoweyeotto

shadoweyeotto (Level 1) - Jetzt verbinden

28.03.2013 um 09:51 Uhr, 2594 Aufrufe, 5 Kommentare

Hallo zusammen,

hoffentlich könnt Ihr mir helfen.
Ich habe folgende Anforderung ...


Mit viel Mühe habe ich eine Datei erstellt, die ich meinen Kunden für Testzwecke zur Verfügung stellen möchte um Sie auf Herz und Nieren zu testen. Diese soll dann aber nach einer gewissen Zeit, (verschiedene Intervalle) nicht mehr zu öffnen sein. Im besten Fall mit der Meldung Testzeit Abgelaufen bitte wenden Sie sich an bliblablubb.

Ich kenne mich mit Excel für eure Verhältnisse sicher nicht so gut aus.
Daher ist es toll, wenn Ihr eine sehr detaillierte Beschreibung formulieren.
Auch mein Wissen mit Makros ist gegen Null!

Ich nutze das Office 2010, Mit Windows 7
Mitglied: Barthinator
28.03.2013 um 10:05 Uhr
Moin Moin,

das ganze lässt sich über VBS realisieren.

Ist leider nicht so mein Gebiet, habe hier aber ein paar nette Ansätze gefunden:

http://www.office-loesung.de/ftopic392731_0_0_asc.php

und

http://www.herber.de/forum/archiv/136to140/137721_Excel_nach_bestimmter ...


LG
Barthinator
Bitte warten ..
Mitglied: 106543
28.03.2013 um 10:35 Uhr
Hi,

wenn du vorgeschriebene Zeiten nimmst, wirst du aber Probleme haben, weil die Leute einfach die Systemuhr zurückstellen und damit noch weiter arbeiten können

Nur als kleine Anregung sehn ;)

Grüße
Exze
Bitte warten ..
Mitglied: leknilk0815
28.03.2013, aktualisiert um 11:24 Uhr
Servus,

In Arbeitsblatt "Tabelle2" bei A1 das Verfalldatum eintragen
Die Zelle evt. schützen und die Schriftfarbe auf weiß ändern
In Arbeitsblatt "Tabelle1" in A1 folgende Formel eingeben:
01.
=WENN(Tabelle2!A1+6>HEUTE();"OK";"abgelaufen")
Arbeitsblatt "Tabelle2" umbenennen in "A3" (Grund: "A3" könnte auch ein Zellbezug in einer Formel sein und fällt nicht so ins Auge wie "Tabelle2" - reine Verwirrungstaktik)
Arbeitsblatt "A3" verstecken (ausblenden):
Auf Arbeitsblatt "A3" gehen, in der Menüleiste "Format - Blatt - Ausblenden" anklicken.
Somit ist das Arbeitsblatt nicht mehr sichtbar.
Das Verfalldatum ist über die Formel auf 6 Tage gesetzt, den Wert bei längerer Laufzeit
dementsprechend erhöhen.
Die Zellen A1 würde ich dafür aber nicht verwenden, die sind zu "naheliegend".
Besser irgendwo ans Ende verfrachten und den Zellbezug in der Formel anpassen.
Über das Ergebnis in Tabelle1 Zelle A1 kannst Du dann mit unauffälligen Abfragen, z.B.:
01.
=WENN(A1="abgelaufen";"mach nix";"mach weiter")
irgendeinen Unsinn programmieren, so daß das Programm nichts Vernünftiges mehr produziert.

Einen vernünftigen Schutz kenne ich nicht, ein Excel- Profi braucht nur Sekunden, um praktisch
jeden Schutz auszuhebeln.
Da die Funktion "Ausblenden" aber nicht so bekannt sein dürfte, sollte das für Deine Kunden reichen
(sonst müsstest Du ihnen keine Excel- Mappe stricken..., die könnten sie dann auch selber erstellen)
Gruß - Toni
Bitte warten ..
Mitglied: DockMaster-de
28.03.2013 um 14:20 Uhr
Hallo,

wie mein Vorredner schon geschrieben hat, ist es für ein Excel-Profi eine Kleinigkeit diesen Schutz zu umgehen.
Schau dir mal das Programm "LockXLS" an.

have a nice day...
DockM@ster
Bitte warten ..
Mitglied: DerWoWusste
29.03.2013 um 15:50 Uhr
Hi.

Darf ich mal hinterfragen, was das bringen soll? Wenn der Kunde sieht, dass er das Ding nur eine bestimmte Zeit nutzen kann, dann kopiert er sich alles raus - was also kannst Du auf diesem Wege schützen?
Alle sicheren Wege beruhen auf Verschlüsselung (auch LockXLS), Makros kannst du vergessen, da manipulierbar. Und Verschlüsselung hat das selbe Problem mit dem Rauskopieren.

Dein Problem kann man als das "Selbstzerstören-von-Dokumenten-Problem" bezeichnen und das ist nur begrenz lösbar und erfordert einigen Aufwand.

Ich schlage vor, ob Du Deinen Kunden nicht anderen Testinhalt geben kannst, den Sie ruhig behalten können.
Bitte warten ..
Neuester Wissensbeitrag
Humor (lol)

Linkliste für Adventskalender

(3)

Information von nikoatit zum Thema Humor (lol) ...

Ähnliche Inhalte
Heiß diskutierte Inhalte
Windows Server
DHCP Server switchen (25)

Frage von M.Marz zum Thema Windows Server ...

SAN, NAS, DAS
gelöst HP-Proliant Microserver Betriebssystem (14)

Frage von Yannosch zum Thema SAN, NAS, DAS ...

Grafikkarten & Monitore
Win 10 Grafikkarte Crash von Software? (13)

Frage von Marabunta zum Thema Grafikkarten & Monitore ...

Windows 7
Verteillösung für IT-Raum benötigt (12)

Frage von TheM-Man zum Thema Windows 7 ...