Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Exchaneg 2010 Upgrade SP3 abgebrochen und Fehler beim erneuten Installationsversuch

Frage Microsoft Exchange Server

Mitglied: SilentGreen

SilentGreen (Level 1) - Jetzt verbinden

26.07.2013 um 09:43 Uhr, 3059 Aufrufe, 1 Kommentar

Hallo zusammen

Ich habe hier eine etwas kniffligere Aufgabe (zumindest für mich).

Bei einem Kunden habe ich einen Exchange 2010 SP2 (gehabt) und wollte diesen auf SP3 upgraden.
So weit, so gut. Setup gestartet Prüfungen alle erfolgreich und Setup loslaufen lassen.

Nach einer Weile ist das Setup bei Installation der Postfachrolle abgebrochen (ExSetupUI.exe hat einen Fehler verursacht und wurde beendet).

Ich habe dann feststellen können, dass der Speicherplatz auf C: (vorher 14,9 GB frei) während der Installation vollgelaufen war. Meine Vermutung ist, dass deshalb das Setup abgebrochen ist, aber kann ich nicht mit Gewissheit sagen. Nachdem ich zuerst versucht hatte das Setup einfach erneut zu starten (komischerweise wieder 21.9 GB frei), hat das Setup wieder bei der Postfachrolle abgebrochen (Fehlermeldung kommt später).

Daraufhin habe ich den Server neu gestartet und das Ganze noch einmal versucht. Zuerst das Problem (Aufgrund einer vorhergehenden Installation ist ein Neustart erforderlich), was ich aber beheben konnte, und danach wieder das gleiche Spiel (Abbruch bei Installation der Postfachrolle).

Nach mehreren erfolglosen Versuchen das SP sauber installieren kam ich nicht weiter und habe versucht den Exchange wenigstens so weit wieder zum Laufen zu bekommen, dass der Kunde möglichst keine Einschränkungen hat. Die Auswirkungen waren dann, dass einige Dienste des Exchange-Servers nicht gelaufen sind. Diese konnte ich aber manuell neu starten und habe sowohl den Versand als auch den Empfang der Mails getestet und funktioniert. Beim daraufhin (vorerst) letzten Versuch das Setup noch einmal zu starten ist aber dennoch der gleiche Effekt und folgende Fehlermeldung aufgetreten:

EVENTLOG:
Protokollname: Anwendung
Ereignis-ID: 1002
Ebene: Fehler
Quelle: MSExchangeSetup
Aufgabenkategorie: Micrsoft Exchange Setup
Benutzer: Nicht zutreffend
Computer: XXXX
Beschreibung:
Fehler bei Exchange Server-Komponente 'Postfachrolle'.
Fehler: Fehler:
Der folgende Fehler wurde generiert, als "$error.Clear();
$file = 'microsoft.exchange.search.exsearch.exe.config';
$fullPath = [System.IO.Path]::Combine([System.IO.Path]::Combine($RoleInstallPath, "bin"), $file);
$inMemTracingConfigFilePath = [System.IO.Path]::Combine($RoleInstallPath, "bin\EnabledInMemoryTraces.config");
set-appconfigvalue -ConfigFileFullPath:$fullPath -Element:configuration/runtime/generatePublisherEvidence -Attribute:enabled -NewValue:false;
set-appconfigvalue -ConfigFileFullPath:$fullPath -Element:configuration/appSettings -AppSettingKey:ExInMemoryTraceConfiguration -NewValue:"$inMemTracingConfigFilePath";
" ausgeführt wurde: "Set-AppConfigValue: Das Stammelement im angegebenen XML-Pfad configuration entspricht nicht dem Dokumentstammelement in C:\Program Files\Microsoft\Exchange Server\V14\bin\microsoft.exchange.search.exsearch.exe.config.".

Set-AppConfigValue: Das Stammelement im angegebenen XML-Pfad configuration entspricht nicht dem Dokumentstammelement in C:\Program Files\Microsoft\Exchange Server\V14\bin\microsoft.exchange.search.exsearch.exe.config.


Fehler:
Der folgende Fehler wurde generiert, als "$error.Clear();
$file = 'microsoft.exchange.search.exsearch.exe.config';
$fullPath = [System.IO.Path]::Combine([System.IO.Path]::Combine($RoleInstallPath, "bin"), $file);
$inMemTracingConfigFilePath = [System.IO.Path]::Combine($RoleInstallPath, "bin\EnabledInMemoryTraces.config");
set-appconfigvalue -ConfigFileFullPath:$fullPath -Element:configuration/runtime/generatePublisherEvidence -Attribute:enabled -NewValue:false;
set-appconfigvalue -ConfigFileFullPath:$fullPath -Element:configuration/appSettings -AppSettingKey:ExInMemoryTraceConfiguration -NewValue:"$inMemTracingConfigFilePath";
" ausgeführt wurde: "Set-AppConfigValue: Das Stammelement im angegebenen XML-Pfad configuration entspricht nicht dem Dokumentstammelement in C:\Program Files\Microsoft\Exchange Server\V14\bin\microsoft.exchange.search.exsearch.exe.config.".

Set-AppConfigValue: Das Stammelement im angegebenen XML-Pfad configuration entspricht nicht dem Dokumentstammelement in C:\Program Files\Microsoft\Exchange Server\V14\bin\microsoft.exchange.search.exsearch.exe.config.

Zu diesem Fehler habe ich bisher überhaupt nichts gefunden, daher hoffe ich, dass mir hier jemand weiter helfen kann.

Momentan läuft der Exchange zwar aber meiner Meinung nach ist das eben einfach nicht sauber. Ausserdem lassen sich mache Dienste nicht starten (wie z.B. Unified Messaging, was zwar für den Kunden aktuell nicht wirklich relevant ist, aber funktionieren muss).

Das seltsame ist, dass er mir aber sagt, dass die Exchange-Version 14.03.0123.003 sei, also SP3 (ohne Update Rollup 1, welches ich eigentlich auch och installieren wollte, mich nun aber nicht traue).

Für jegliche Infos und/oder Hinweise bin ich sehr dankbar.

Greetz
Holger
Mitglied: 16568
26.07.2013 um 17:01 Uhr
Backup einspielen, Temp-Verzeichnis reinigen, für genügend Platz sorgen, nochmals machen.


Lonesome Walker
Bitte warten ..
Ähnliche Inhalte
Exchange Server
Exchange 2010 SP3 Installation schlägt fehl. Jetzt kann ich das Upgrade nicht mehr starten :-(
gelöst Frage von niko.muensterExchange Server4 Kommentare

Hallo, ich wollte ServicePack 3 bei einem SBS2011 installieren Jedoch bekam ich folgende Fehlermeldung: Jetzt ist es mir nicht ...

Windows Installation
Windows Upgrade schlägt fehl
Frage von ratzekahlxWindows Installation11 Kommentare

Hallo zusammen, ich habe ein Problem, welches schon seit Tagen ungelöst ist. Simples Upgrade von Windows 7 auf Windows ...

Exchange Server
Exchange 2010 auf Exchange 2010 SP3 aktualisieren
gelöst Frage von Leo-leExchange Server7 Kommentare

Hallo Forum, wie ist Eure Erfahrung mit der Aktualisierung zweier Exchange Servern in einer DAG auf SP3? Der momentane ...

Exchange Server
Exchange 2010 SP3 Default Limits
Frage von ExcaliburxExchange Server3 Kommentare

Hallo Zusammen, im Einsatz ist ein Exchange 2010 SP3. 1. Im Netzwerk wird ein Dienst (Druckoutput) betrieben, der E-Mails ...

Neue Wissensbeiträge
Linux

Limux-Ende in München: Wie ein Linux Projekt unter Ausschluss der Öffentlichkeit zerstört wurde

Information von Frank vor 4 StundenLinux12 Kommentare

Mein persönlicher Kommentar zum Thema "Limux-Ende". Die SPD-Politikerin Anne Hübner hat die Richtung von München ganz klar definiert: "Wir ...

Batch & Shell

Open Object Rexx: Eine mittlerweile fast vergessene Skriptsprache aus dem Mainframebereich

Information von Penny.Cilin vor 1 TagBatch & Shell9 Kommentare

Ich kann mich noch sehr gut an diese Skriptsprache erinnern und nutze diese auch heute ab und an noch. ...

Humor (lol)

"gimme gimme gimme": Automatischer Test stolpert über Easter Egg im man-Tool

Information von Penny.Cilin vor 1 TagHumor (lol)6 Kommentare

Interessant, was man so alles als Easter Egg implementiert. Ist schon wieder Ostern? "gimme gimme gimme": Automatischer Test stolpert ...

MikroTik RouterOS

Mikrotik - Lets Encrypt Zertifikate mit MetaROUTER Instanz auf dem Router erzeugen

Anleitung von colinardo vor 2 TagenMikroTik RouterOS8 Kommentare

Einleitung Folgende Anleitung ist aus der Lage heraus entstanden das ein Kunde auf seinem Mikrotik sein Hotspot Captive Portal ...

Heiß diskutierte Inhalte
Router & Routing
Zwei Netzwerke erstellen
Frage von bunteblumeRouter & Routing14 Kommentare

Hallo Zusammen, Ich möchte gerne ein backup von einem bestimmten Folder welcher auf dem Server regelmässig synchronisiert wird auf ...

Off Topic
Fachkräftemangel in Deutschland? - Talentschmiede schreibt alle 2 Tage die gleichen Stellen aus
Frage von Penny.CilinOff Topic12 Kommentare

Hallo, haben wir in Deutschland Fachkräftemangel? Die Talentschmiede schreibt gefühlt alle zwei Tage dieselben Stellen aus. Und das schon ...

Linux
Limux-Ende in München: Wie ein Linux Projekt unter Ausschluss der Öffentlichkeit zerstört wurde
Information von FrankLinux12 Kommentare

Mein persönlicher Kommentar zum Thema "Limux-Ende". Die SPD-Politikerin Anne Hübner hat die Richtung von München ganz klar definiert: "Wir ...

Windows 10
Alle Programme mit bestimmtem Namen automatisch (per GPO) deinstallieren
gelöst Frage von lordofremixesWindows 1012 Kommentare

Hallo zusammen, gibt es eine Möglichkeit, alle Programme beginnend mit z.B. "Dell" im Namen per Script und somit per ...