Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Exchange 2003, kein Front-End, nur Back-End, Zugriff per RPC over HTTPs, Syncronisation Mobile Device funktioniert nicht

Frage Microsoft Exchange Server

Mitglied: iamnils

iamnils (Level 1) - Jetzt verbinden

25.08.2008, aktualisiert 27.08.2008, 6219 Aufrufe, 10 Kommentare

Hallo zusammen,

ich habe leider ein kleines Problem mit einem Exchange-Server beim Kunden.

Ein User möchte ein Mobile-Device (IPhone) syncronisieren, dies funktioniert nicht. Folgende Wege funktionieren: RPC over HTTPs (Outlook Client), OWA.

Zunächst mal die Einstellungen und Besonderheiten:
- Windows 2003 Netzwerk mit Domäne (w2k.firma.mg) (ich weiß, ist nicht richtig, sind Altlasten vom Kunden, habe ich nicht verbockt )
- Prä-Windows-2000: w2k-firma-mg
- Exchange-Name: Firma
- Exchange Server 2003 (V6.5, Build 7638.2: ServicePack 2)
- IIS ist installiert, RPC über HTTP-Proxy ist installiert
- Formularbasierte Authentifierung ist aktiviert (Komprimierung hoch)
- als RPC-HTTP-Back-End konfiguriert
- kein Front-End-Server im Netz vorhanden, daher Registry editiert:
[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Rpc\RpcProxy]
"ValidPorts"="servername:100-5000;servername:6001-6002;servername:6004;servername.domainname:6001-6002;servername.domainname:6004;externer.domainname.de:6001-6002;externer.domainname.de:6004;"

Die gleichen Einstellungen habe ich bei mir im Netz (ist allerdings ein SBS 2003 Std.)
Und bei mir funktionierte die Syncronisation auf Anhieb. Das iPhone vom Kunden hat bei mir auch funktioniert.

Hat jemand von Euch eine Idee und kann mir weiterhelfen?

Mit freundlichen Grüßen

Nils Rochholl
Mitglied: 68955
25.08.2008 um 12:17 Uhr
Mit was für einer Software Synchronisiert das iPhone genau?

Hast du irgendwelche Outputs in der Ereignisanzeige?
Bitte warten ..
Mitglied: iamnils
25.08.2008 um 12:23 Uhr
Hallo Christoph,

IPhone hat 2.0.2 drauf, Ereignisanzeige ist leer (bzgl. dieses Problems). Andere Probleme, Warnungen etc existieren auch nicht.
Bitte warten ..
Mitglied: Dani
25.08.2008 um 12:25 Uhr
Hi Rochholl,
vergleiche mal bitte deinen Konfiguration mit dieser Anleitung: Configure RPC over HTTP/S on a Single Server.
Denn z.B. die VaildPorts habe ich zuerst auch manuell gemacht -> klappte nicht, danach mit einem Tool. Steht aber alles in dem Link...


Gruss,
Dani
Bitte warten ..
Mitglied: iamnils
25.08.2008 um 12:43 Uhr
Hallo Dani,

vielen Dank für die Anleitung.

Ich habe die Konfiguration soweit überprüft (stimmt auch) bis auf wenige Unterschiede:

- HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\NTDS\Parameters
Ordner NTDS existiert nicht, auf dem DC gibt es den Eintrag: "NSPI interface protocol sequences"="ncacn_http:6004" nicht.

- Server hat folgende Rollen:
Windows Server 2003 SP2 + Exchange 2003 SP2 + RPC Proxy (kein DC!!!)

NetBIOS name: w2k-firma-mg06
FQDN - Internal: w2k-firma-mg06.w2k.firma.mg
FQDN - External: intranet.firma.de


- [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Rpc\RpcProxy]
"ValidPorts"="servername:100-5000;
Dieser Part ist in deiner Anleitung nicht vorhanden, steht beim Exchange aber drinne.



Mit freundlichen Grüßen

Nils
Bitte warten ..
Mitglied: Dani
25.08.2008 um 12:52 Uhr
Hi Nils,
aso..du hast kein Single Exchange/DC server - dann ist es natürlich klar. Dann schau dir bitte das hier an. Daran habe ich mich orientiert...
Dort siehst du auch die Port-Konfiguration. Interessant wird es im mittleren Abschnitt...


Gruss,
Dani
Bitte warten ..
Mitglied: iamnils
25.08.2008 um 13:05 Uhr
Hallo Dani,

naja, bei der Konfiguration hatte ich am Anfang schon meine Probleme, da es normalerweise für RPC ja eine Front-End/Back-End Konstelation sein muss.

In diesem Falle ist das ja nicht der Fall.

IIS usw läuft alles auf dem Exchange, aber der Exchange ist nicht gleichzeitig DC. Die Anleitung von msxfaq zeigt aber auch mehrere Server. Ist das aber trotzdem korrekt?
Bitte warten ..
Mitglied: Dani
25.08.2008 um 13:26 Uhr
Hi,
uhhhh....ok, in deinem Fall würde ich theoretisch sagen dass du die Anleitungen kombinieren musst. Konfiguriere deinen Server zuerst nach der Single...Anleitung und danach änderst du die Ports nach MSFAQ ab. Siehe hier:
http://www.msxfaq.de/clients/rpchttp07.gif

In diesem Bild einfach den RPC/IIS aus den Exchange verlagern. Der Rest passt dann genau auf dein Szenario, oder?


Gruss,
Dani
Bitte warten ..
Mitglied: iamnils
25.08.2008 um 14:15 Uhr
Hi,

bis auf dass der IIS mit auf dem EX installiert ist ja....

heißt also konkret:

DC= w2k-firma-mg01
EX/IIS= w2k-firma-mg06

- den Eintrag 100-5000 in den ValidPorts brauche ich nicht?
- Port 6001-6002 muss auf w2k-firma-mg06 geroutet werden
- Port 6004 muss auf w2k-firma-mg01 geroutet werden
- NSPI interface protocol sequences muss auf w2k-firma-mg01 eingetragen werden

restlichen Sachen hatte ich ja schon vorher konfiguriert (IIS/RPC auf dem Exchange eingestellt etc)
Bitte warten ..
Mitglied: Dani
25.08.2008 um 14:35 Uhr
Also wo du die 100-500 her hast, würde mich interessieren. Habe ich noch nie davon gehört bzw. gelesen!

Genauso hätte ich das Bild gedeutet. Aber ich habe Frank noch angeschrieben. Das Bild kann man auf den 2. Blick auch anders deuten. Daher bin ich mir grad nicht mehr sicher. Habe es zwar schon gemacht, aber das war in meiner Ausbildung.

Edit:
Hier die Antwort von Frank Carius:
01.
Ja das ist unglücklich. 
02.
Ich werden folgenden Text unter dem Bild ergänzen 
03.
„ In den Beispielen ist der DC und Exchange Server der gleiche Server namens SRV01. Wenn Sie die Funktion auf mehrere Server verteilen, dann müssen Sie natürlich die Namen entsprechend anpassen.“ 
04.
Ich hoffe so ist es dann verständlicher
Gruss,
Dani
Bitte warten ..
Mitglied: iamnils
27.08.2008 um 20:13 Uhr
Hallo zusammen,

ich bin nun einen Schritt weitergekommen, aber die Funktion des Mobile-Zugriffs ist immer noch nicht vorhanden.

Nach Pflege des Vorschlags aus KB817379 (Methode 2) und Vergleichs mit meinem SBS (und natürlich Anpassung der Einstellungen im IIS) kann ich zumindest mittels Browser (IE7) auf das oma-Verzeichnis zugreifen und mich einloggen.

Ein einloggen mit einem WM6 oder Iphone ist nur immer noch nicht möglich.

Derzeit kann ich mir nicht erklären wieso und ich bin irgendwie ratlos.

Mit freundlichen Grüßen Nils
Bitte warten ..
Neuester Wissensbeitrag
Ähnliche Inhalte
Exchange Server
Exchange 2003 auf 2007 Implace Migration (18)

Frage von Herbrich19 zum Thema Exchange Server ...

Exchange Server
gelöst Exchange 2003 von Windows 2003 Server lösen bzw. entfernen (3)

Frage von plexxus zum Thema Exchange Server ...

Exchange Server
Office 2013 oder 2016 mit Exchange 2003 (2)

Frage von uridium69 zum Thema Exchange Server ...

Exchange Server
Exchange 2003 für Experimente noch nutzbar? (14)

Frage von pelzfrucht zum Thema Exchange Server ...

Heiß diskutierte Inhalte
Windows Userverwaltung
Ausgeschiedene Mitarbeiter im Unternehmen - was tun mit den AD Konten? (33)

Frage von patz223 zum Thema Windows Userverwaltung ...

LAN, WAN, Wireless
Server erkennt Client nicht wenn er ausserhalb des DHCP Pools liegt (22)

Frage von Mar-west zum Thema LAN, WAN, Wireless ...

LAN, WAN, Wireless
FritzBox, zwei Server, verschiedene Netze (21)

Frage von DavidGl zum Thema LAN, WAN, Wireless ...

Viren und Trojaner
Aufgepasst: Neue Ransomware Goldeneye verbreitet sich rasant (20)

Link von Penny.Cilin zum Thema Viren und Trojaner ...