Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Exchange 2003 Gesendet Zeit stimmt nicht

Frage Microsoft Exchange Server

Mitglied: markh

markh (Level 1) - Jetzt verbinden

14.09.2010 um 09:16 Uhr, 5566 Aufrufe, 7 Kommentare

Die Gesendet-Zeit ist um zwei Stunden verschoben.

Hallo,

wir haben einen Exchange-Server 2003 SP2 mit Outlook als Client. Jetzt haben wir das Problem, dass bei Mails, die von einem nicht Microsoft e-Mail-Client (hier Alarmmeldungen von einem Maschinenhersteller) die Gesendet-Zeit um 2 Std. verschoben ist.
Ich habe im Header der Mails den folg. Eintrag gefunden:

Date: 14 SEP 10 08:11:28

Bei den Mails, bei denen die Gesendet-Zeit richtig ist steht folg.:

Date: Tue, 14 Sep 2010 08:09:40 +0200


Da wird wohl der Fehler sein. Die Frage ist jetzt nur, warum haut der Exchange-Server zwei Stunden auf die Gesendet-Zeit drauf, wenn der Eintrag +0200 nicht vorhanden ist.


Ich habe die Mails mal zum testen über einen externen SMTP-Server weitergeleitet und dann mit OE und Outlook über Pop3 abgerufen. OE und Outlook zeigen die richtige Gesendet-Zeit an. Es ist also definitiv der Exchange-Server, der die Zeit ändert.
Ich weiß nur nicht, wo und was ich jetzt einstellen kann.

Kennt vielleicht jemand das Problem?
Mitglied: GuentherH
14.09.2010 um 10:41 Uhr
Hallo.

Zeitprobleme mit dem Exchange Server gibt es eigentlich nur dann, wenn bei einem der beteiligten Rechner (Server oder Client) die Umschaltung Sommer-/Winterzeit nicht automatisch erfolgt.

LG Günther
Bitte warten ..
Mitglied: markh
14.09.2010 um 11:22 Uhr
Hallo Günther,

die automatische Zeitumstellung ist auf Client und Server aktiviert.
Bitte warten ..
Mitglied: GuentherH
14.09.2010 um 12:16 Uhr
Hallo.

Überprüfe doch einmal im SMTP Logging, welche Zeit hier eingetragen ist. Im SMTP Log ist die Zeit als UTC aufgeführt. Also MESZ - 2 Stunden.

Bei den Mails, bei denen die Gesendet-Zeit richtig ist steht folg.:
Date: Tue, 14 Sep 2010 08:09:40 +0200

Dieser Eintrag ist ja auch korrekt, als UTC oder ehemals GMT +2 ergibt MESZ

Wenn es daher bei einer Meldung um 1 Stunde differiert, dann ist die Sommer-/Winterzeit nicht korrekt eingestellt.

LG Günther
Bitte warten ..
Mitglied: markh
14.09.2010 um 14:18 Uhr
Hallo,

die SMTP-Log-Datei fängt mir diesen Zeilen an:

#Software: Microsoft Internet Information Services 6.0
#Version: 1.0
#Date: 2010-09-14 12:12:54
#Fields: date time c-ip s-sitename s-ip s-port cs-method time-taken

Das Datum hier ist tatsächlich schon falsch. Ist um 2 Stunden zurück. Müsste eigentlich 14:12:54 sein und nicht 12:12:54

Aber wo kann das jetzt am SMTP-Server einstellen? Die Uhrzeit am Server ist korrekt und die automatische Umstellung ist auch aktiviert.
Bitte warten ..
Mitglied: GuentherH
14.09.2010 um 14:32 Uhr
Hallo.

Das Datum hier ist tatsächlich schon falsch

Ich habe doch geschrieben, dass hier die Zeit in UTC also MESZ - 2 Stunden angefürt wird. Also ist diese Zeit richtig.

Überprüfe den Client, bei dem die Zeitdifferenz nur eine Stunde beträgt.

LG Günther
Bitte warten ..
Mitglied: markh
14.09.2010 um 14:54 Uhr
Ähm, wie soll ich das denn jetzt verstehen?

In den ganzen Log-Dateien ist die Uhrzeit um zwei Stunden zurück z.B. beginnen die Einträge mit

2010-09-14 12:44:34

Die Uhrzeit ist aber eigentlich 14:44:34. Wie soll das denn richtig sein? Woher holt der Server diese Zeit? In Ereignissen etc. steht ja auch die richtige Zeit.
Was nutzen mir denn Log-Dateien die eine falsche Zeitangabe enthalten?

Das die Zeit in UTC angeführt wird, kann ja sein, aber dann muss er die Zeit doch entsprechend umrechen, anhand der Zeiteinstellung am Server, also GMT +1.

Die Zeitdifferenz beträgt ja auch immer genau 2 Stunden und nie nur eine Stunde. Ich habe keinen Client, bei dem die Zeitdiff nur eine Stunde beträgt.
Bitte warten ..
Mitglied: markh
14.09.2010 um 15:21 Uhr
Hallo Günther,

sorry, aber ich habs jetzt geschnallt. Ich habe zum Test mal die automatische Umstellung deaktiviert. Dann war die Zeitverschiebung nur noch eine Stunde, das passt dann zu unserer Zeitzone GMT+1.

Das Gesendet-Datum wird wohl deshalb "falsch" angezeigt, weil der Mail-Header nicht RFC-822 konform ist. Die Angabe der Zeitzone fehlt einfach, also wie soll dann der Exchange-Server wissen, dass er bei diesen Mails ne Ausnahme machen soll.
Der Exchange-Server macht also alles richtig. Ich kann also wohl keine Einstellung machen, da ja der Mail-Client im Header einen Fehler macht und somit die Mail einfach schon falsch ankommt.

Danke Günther.
Bitte warten ..
Neuester Wissensbeitrag
Windows 10

Powershell 5 BSOD

(8)

Tipp von agowa338 zum Thema Windows 10 ...

Ähnliche Inhalte
Exchange Server
Exchange 2003 auf 2007 Implace Migration (18)

Frage von Herbrich19 zum Thema Exchange Server ...

Exchange Server
gelöst Exchange 2003 von Windows 2003 Server lösen bzw. entfernen (3)

Frage von plexxus zum Thema Exchange Server ...

Exchange Server
Office 2013 oder 2016 mit Exchange 2003 (2)

Frage von uridium69 zum Thema Exchange Server ...

Exchange Server
Exchange 2003 für Experimente noch nutzbar? (14)

Frage von pelzfrucht zum Thema Exchange Server ...

Heiß diskutierte Inhalte
Microsoft
Ordner mit LW-Buchstaben versehen und benennen (21)

Frage von Xaero1982 zum Thema Microsoft ...

Netzwerkmanagement
gelöst Anregungen, kleiner Betrieb, IT-Umgebung (18)

Frage von Unwichtig zum Thema Netzwerkmanagement ...

Windows Update
Treiberinstallation durch Windows Update läßt sich nicht verhindern (17)

Frage von liquidbase zum Thema Windows Update ...