Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Exchange 2003 senden empfangen über VPN

Frage Microsoft Exchange Server

Mitglied: sycom08

sycom08 (Level 1) - Jetzt verbinden

30.04.2008, aktualisiert 06.05.2008, 4291 Aufrufe, 9 Kommentare

Hallo,

erstmal muss ich los werden, das mir administrator.de schon sehr viel geholfen hat. Nun habe ich aber ein Problem was ich hier in der Art noch nicht gefunden habe.

Folgendes Szenario:

Ich habe einen Win 2K3 SBS der als DC und Exchange-Server dient

Es sind 2 Netzwerkkarten eingebaut, eine die für interne Verbindung zuständig ist (Bsp. 192.168.20.1) und die andere ist direkt an meine Fritzbox gestöppselt für den internetzugang (Bsp. 192.168.1.2)

Soweit funktioniert es auch das der Server sowie die Clients (per NAT über Server) ins internet gehen können. Weiterhin wurde der Exchange so eingerichtet, er per smarthost die Mails versendet und der Empfang wurde bis jetzt per DynDNS Domain, die im Router eingetragen ist und der Empfang per Port-Weiterleitung vom Router zum Server. Das klappt klappt auch alles super.

Seit Montag habe ich einen Zugang bei vtunnel.de, wo mir eine feste IP mittels openVPN zur verfügung gestellt wird. Nun ist das Problem wenn ich jetzt die feste IP beim virtuellen Internetserver für SMTP eintrage (Reiter Allgemein -> IP-Adresse) dann kann ich weder Mails versenden noch empfangen.

DNS Einträge habe ich bei meinem Provider, wo die Internet domain auch gehostet ist, geändert.

Der HTTP-Zugriff funktioniert allerdings. Das wundert mich etwas.
Mitglied: alexanderschuhmann
02.05.2008 um 15:02 Uhr
Hallo,

Ich weiß zwar nicht ob ich das alles so richtig verstehe, aber ich werde einmal mein Glück versuchen.
Also du baust mit dem Server mit dem Programm Openvpn eine Verbindung auf. Ich kenne VPN Verbindungen immer nur, mit dem privaten Adressraum. Weiterhin verstehe ich nicht, warum du die IP Adresse des VPN Tunnels eingibst, dieser baut doch nur einen Verbindung zu dem Internet auf, wobei die eingehenden SMTP Verbindungen wieder einen ganz andere IP Adresse haben. Der VPN Betreiber müsste ja nach meinem Verständnis, damit deine Konfiguration funktionieren sollte ja von sämtliche TCP Pakete den IP Header ändern und dann an den lokalen Server weiterschicken, wobei er das dann auch wieder, mit den Herausgehenden Paketen machen müsste. (SMTP Pakete werden über TCP übertragen) Dieses Verfahren, stell ich mir sehr schwierig vor wobei es mögliche ist, soweit ich weiß (Es gibt Angriffe mit veränderten TCP Headern)

Bitte verbessere mich falls ich mich irren sollte.


Mit freundlichen Grüßen,
Alexander Schuhmann
Bitte warten ..
Mitglied: sycom08
02.05.2008 um 18:15 Uhr
Hallo,

danke für die Antwort. Wenn ich es mir jetzt nochmal so richtig durch den kopf gehen lasse baut openvpn ja nur über den udp port eine Verbindung zum Server auf. Da wird es wirklich schwierig, TCP Pakete durchzu schleusen. Muss ich woll nochmal mit meinem Anbieter reden, weil da stand ausdrücklich drin das man mittels dieser vpn-verbindung auch mailserver betreiben kann.

Werd mich da nochmal schlau machen.
Bitte warten ..
Mitglied: alexanderschuhmann
02.05.2008 um 18:33 Uhr
Hallo,

das sollte vollkommend egal sein, ein VPN ist ein Netzwerk also ein virtuelles aber ein Netzwerk. Das heißt das man vollkommend Protokollungebunden argieren kann. Dieses VPN sollte eigentlich auch TCP Ports benutzen, weil der Nachteil der UPD- Packete ist das sie keinen Hash wert haben
--> es wird nicht überprüft ob die Pakete kaputt sind

Mit freundlichen GRüßen,
ALexander Schuhmann
Bitte warten ..
Mitglied: sycom08
02.05.2008 um 19:51 Uhr
ich habe nochmals nachgeschaut welchen adressbereich ich nutze ist definitiv keine private ip, denn sie liegt im 080.244.250.xxx bereich. Ich werde es nochmal auf einen anderen server mit nur einer Netzwerkkarte probieren. Ich habe die vermutung das der sbs mit den 3 Netzwerkverbindungen nicht zurecht kommt.
Bitte warten ..
Mitglied: sycom08
06.05.2008 um 07:42 Uhr
So ich bin schonmal einen Schritt weiter. Es liegt am "Routing & RAS" Dienst, wenn ich diesen deaktiviere, funktioniert die Verbindung mit dem OpenVPN-Client auf anhieb. Ich bekomme es aber einfach nicht gebacken, den speziellen Port so durch zuschleifen, dass die Verbindung auf der WAN-NIC funktioniert. Habt ihr eventuell noch einen Tip für mich. Habe schon versucht den Port explizit auf die WAN-NIC (192.168.0.*) zu leiten. Dies funktioniert aber nicht.
Bitte warten ..
Mitglied: alexanderschuhmann
06.05.2008 um 08:29 Uhr
Hallo,

Man kann die Einstellungen doch in Systemsteuerung/Verwaltung/Routing und RAS verändern

Mit freundlichen Grüßen,

Alexander Schuhmann
Bitte warten ..
Mitglied: sycom08
06.05.2008 um 09:35 Uhr
Hallo,

hab ich schon versucht. Über die Eigenschaften der WAN-NIC habe ich bei Dienste und Ports den Port angelegt und die WAN-NIC IP angegeben aber irgendwie will es nicht funktionieren.
Bitte warten ..
Mitglied: alexanderschuhmann
06.05.2008 um 10:03 Uhr
Hallo,

Also, damit ich das richtig verstehe, nochmal ganz von Anfang
Es wird einen Internetverbindung über einen Router aufgebaut der mit dem Server verbunden ist.
Auf diesem Server Läuft eine VPN Verbindung, die eine feste Ip Addresse im Internet hat.
Nun ist die Frage, man könnte ja auch einfach den Routing und RAS Dienst auf der VPN Verbindung deaktivieren, dann könnten die User des Intranets aber nur über die schon bestehende Internetverbindung, ins Internet gehen. (Meiner Meinung nach die bessere Möglichkeit, das diese VPN Verbindungen ja Traffic Begrenzt sind) Für die User ensteht dadurch eigentlich kein mir spontan einfallender Nachteil.

MFg,

ALexander Schuhmann
Bitte warten ..
Mitglied: sycom08
06.05.2008 um 10:30 Uhr
Hallo,

Also, damit ich das richtig verstehe,
nochmal ganz von Anfang
Es wird einen Internetverbindung über
einen Router aufgebaut der mit dem Server
verbunden ist.


das ist soweit richtig, ich habe aber noch eine LAN-NIC die den internen Traffic regeln soll bzw. das Intranet vom Internet abschotten soll. Aber wenn ich mir es so recht überlege ist das eigentlich schwachsinn, da ich ja zwischen dem WAN und Server einen Router habe.

Ich denke mal ich werde den Server mit nur einem NIC betreiben und und den Routing & RAS dienst deaktivieren.
Bitte warten ..
Ähnliche Inhalte
Exchange Server
Email in Exchange an 2ten Empfänger senden
gelöst Frage von MultiStormExchange Server18 Kommentare

Hallo ich habe mal eine Grundsätzliche Frage, wir haben aktuell einen Excahnge 2016 im einsatz, nun möchte mein Chef, ...

Exchange Server
Konfiguration von Exchange 2013 zum direkten Senden und Empfangen von Mails
gelöst Frage von TxerriExchange Server2 Kommentare

Hallo zusammen, ich versuche gerade einen Exchange 2013 so umzukonfigurieren, dass er für Mailverkehr direkt im Internet zur Verfügung ...

Exchange Server
Senden und Empfangen zwischen Exchange 2010 und Exchange 2013 Koexistenz nicht möglich
Frage von BelneaHPExchange Server3 Kommentare

Moin, ich komme bei diesem Problem nicht weiter und erbitte eure Unterstützung. Wenn ich versuche eine E-Mail von dem ...

Outlook & Mail
Thunderbird Senden an E-Mail-Empfänger
gelöst Frage von DasWombat1993Outlook & Mail3 Kommentare

Liebe Administratoren, Ich habe folgendes Problem mit Thunderbird 52.1.1 unter Windows 7 64 bit: Wenn ich auf einer Datei ...

Neue Wissensbeiträge
Apple

IOS 11.2.1 stopft HomeKit-Remote-Lücke

Tipp von BassFishFox vor 17 StundenApple

Das Update für iPhone, iPad und Apple TV soll die Fernsteuerung von Smart-Home-Geräten wieder in vollem Umfang ermöglichen. Apple ...

Windows 10

Windows 10 v1709 EN murkst bei den Regionseinstellungen

Tipp von DerWoWusste vor 22 StundenWindows 10

Dieser kurze Tipp richtet sich an den kleinen Personenkreis, der Win10 v1709 EN-US frisch installiert und dabei die englische ...

Webbrowser

Kein Ton bei Firefox Quantum über RDP

Tipp von Moddry vor 22 StundenWebbrowser

Hallo Kollegen! Hatte das Problem, dass der neue Firefox bei mir auf der Kiste keinen Ton hat, wenn ich ...

Internet

EU-DSGVO: WHOIS soll weniger Informationen liefern

Information von sabines vor 1 TagInternet4 Kommentare

Wegen der europäische Datenschutzgrundverordnung stehen die Prozesse um die Registrierung von Domains auf dem Prüfstand. Sollte die Forderungen umgesetzt ...

Heiß diskutierte Inhalte
Windows Server
RODC kann nicht aus Domäne entfernt werden
Frage von NilsvLehnWindows Server18 Kommentare

HAllo, ich arbeite in einem Universitätsnetzwerk mit 3 Standorten. Die Standorte haben alle ein ESXi Cluster und auf diesen ...

Hardware
Links klick bei Maus funktioniert nicht
gelöst Frage von Pablu23Hardware16 Kommentare

Hallo erstmal. Ich habe ein Problem mit meiner relativ alten maus jedoch denke ich nicht das es an der ...

Windows XP
Windows XP Aktivieren geht nicht
Frage von tetikmiroWindows XP13 Kommentare

Hallo Ich habe einen Windows XP mit einen vCenter Converter umgezogen auf eine ESXI. Soweit funktioniert dies auch ohne ...

Netzwerkmanagement
Mehrere Netzwerkadapter in einem PC zu einem Switch zusammenfügen
gelöst Frage von prodriveNetzwerkmanagement12 Kommentare

Hallo zusammen Vorweg, ich konnte schon einige IT-Probleme mit Hilfe dieses Forums lösen. Wirklich klasse hier! Doch für das ...