Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Exchange 2003 zeigt -Keinen Specherplatz mehr- an - Platte hat aber noch viel Platz

Frage Microsoft Exchange Server

Mitglied: ALT-F4

ALT-F4 (Level 1) - Jetzt verbinden

28.07.2008, aktualisiert 17:38 Uhr, 4816 Aufrufe, 17 Kommentare

Hallo,

HILFE: Ich weiss echt nicht mehr weiter.
Exchange startet nicht mehr - angeblich kein Speicherplatz für die Protokolldatei mehr.

Hier die Konfiguration:

MS Windows 2003 SBS mit Exchange - aktuelle Patches
Alles liegt auf einer Platte (ist halt nun mal so)
Freier Plattenplatz 110 GB
C:\exchsvr\MDBDATA\priv.ebd ist ca 7,5 GB groß
Kontigente sind eingeschaltet, aber nur für die User aktiv. Alle Admins und Admin-Gruppen haben unlimitiertes Kontingent.

Beim Starten bekommen ich folgendes Ereignis:

Quelle: ESE
Ereigniskennung: 428
Information Store (3672) Erste Speichergruppe: Das Datenbankmodul kann keine Aktualisierungen akzeptieren, weil die Festplatte, auf der sich die Protokolldatei der Datenbank befindet, über zu wenig freien Speicherplatz verfügt.

In der Folge startet auch der Informationsspeicher nicht:
Quelle: MSExchangeIS
Ereigniskennung: 9518
Fehler Protokolldatenträger ist voll. beim Starten von Speichergruppe /DC=local/DC=MyFirma/CN=Configuration/CN=Services/CN=Microsoft Exchange/CN=MyFirma/CN=Administrative Groups/CN=erste administrative gruppe/CN=Servers/CN=FILESERVER/CN=InformationStore/CN=Erste Speichergruppe im Microsoft Exchange Server-Informationsspeicher.
Storage Group - Initialization of Jet failed.

Dann der gleiche Fehler noch einmal mit:
Fehler Protokolldatenträger ist voll. beim Starten von Speichergruppe /DC=local/DC=SPP/CN=Configuration/CN=Services/CN=Microsoft Exchange/CN=SPP/CN=Administrative Groups/CN=erste administrative gruppe/CN=Servers/CN=FILESERVER/CN=InformationStore/CN=Erste Speichergruppe im Microsoft Exchange Server-Informationsspeicher.
<NULL>.

Auch wenn ich den Exchange Server anhalte, kann ich die Datei priv1.edb nicht wegkopieren. Komisch oder?

Bitte, wenn jemand eine Idee hat - her damit! Danke.
Falls noch Infos gebraucht werden, schicke ich gerne nach

Grüße Manuel
Mitglied: DerParte
28.07.2008 um 09:33 Uhr
Probiers es doch mal im abgesicherten Modus.
Bitte warten ..
Mitglied: ALT-F4
28.07.2008 um 09:36 Uhr
Ja, mache ich mal, danke. feedback kommt gleich.

Das löst aber noch nicht ganz mein Problem, oder?
Ich müsste dann die *.edb und *.stm neu einspielen, oder?
Bitte warten ..
Mitglied: Heysel
28.07.2008 um 09:44 Uhr
Wenn du die Datenbank im laufenden Betrieb nicht löschen oder verschieben kannst würde ich mit einem PE starten das Raid Systeme unterstützt und dann die Datei Verschieben. Beim nächsten neustart sollte das system dann eine neue leere Datenbank anlegen.

Gruß
Floh
Bitte warten ..
Mitglied: kugman
28.07.2008 um 09:45 Uhr
bitte unbedingt vorher die Datenbank sichern. Z.Bsp mit NTBackup. Erst beim erfolgreichen Backup werden die Transaktionen in die Datenbank comitted. Dein Exchange schreibt sämtliche Ereignisse, die passieren (mail bekommen, mail senden, etc...) in sogenannte Transaktionsprotokolle - die sind in der Regel 5MB groß.
Erst beim erfolgreichen Backup werden diese transaktionsprotokolle in die Datenbank geschrieben. Wenn Du die Datenbank jetzt wegkopierst, und dann irgendwo ohne die Transaktionsprotokolle wieder herstellst, dann ist Deine Exchangedatenbank auf exakt dem status, den sie zum Zeitpunkt der letzten erfolgreichen Vollsicherung hatte.

Also Obacht und unbedingt vorher sicherstellen, dass die Transaktionsprotokolle committed sind
Bitte warten ..
Mitglied: ALT-F4
28.07.2008 um 09:49 Uhr
Hallo kugman

danke für die INfo.
Aber ich kann doch mit ntbackup nur die datenbank richtig sichern, solange sie läuft. Der Informationsspeicher ist aber nicht online.

Oder langt es das Verzeichnis der edb's inkl. der Logs zu sichern?


Im abgesicherten Modus lässt sich die DB jetzt wegkopieren.
Das ist schonmal etwas.
Nun mache ich mal ein Backup vom ganzen Verzeichnis, oder?
Bitte warten ..
Mitglied: Heysel
28.07.2008 um 09:51 Uhr
Liegt dein System auf einem Raid oder einer einfachen Patition?
Bitte warten ..
Mitglied: kugman
28.07.2008 um 09:53 Uhr
du solltest auf jeden Fall mal deinen momentanen "Ist-Status" sichern. Wenn Du Acronis im Haus hast, würd ich vielleicht auch einfach mal ein Image von der Kiste ziehen.

Man kann das alles mit Eseutil wieder reparieren, aber man sollte schon genau wissen, was man da tut.

ich hatte sowas mal bei einem Kunden, dessen Datenbank zwar lief, aber fehlerhaft war. Auf grund dessen konnten die TK-Protokolle nicht mehr committed werden (seit 3 jahren!)
Hier hab ich dann MS-Support in Anspruch genommen, die sind ziemlcih fit

Möglicherweise solltest Du einfach einen Call aufmachen - kostet im Zweifel 500 Öcken, aber das sollte doch drin sein.
Bitte warten ..
Mitglied: Heysel
28.07.2008 um 09:55 Uhr
Jo das Mit dem Acronis kann ich nur unterstreichen!!!!!!


Dann kannste auch rumtesten.
Bitte warten ..
Mitglied: ALT-F4
28.07.2008 um 09:55 Uhr
Das System liegt auf einem RAID5.
Ganz langsam im abgesicherten Modus wird die priv1.edb nun kopiert.

Ich erfahre gerade, dass womöglich am Wochenende hier jemand eine Plattendefragmentierung hat druchlaufen lassen (bei laufendem Exchangeserver übrigens). Könnte die Datei einfach super fragmentiert sein, wenn das womöglich abgebrochen wurde?)
Bitte warten ..
Mitglied: ALT-F4
28.07.2008 um 12:02 Uhr
Ok,
acronis lässt sich so weiteres installieren - ich habe auch keine Lust auf 2 Probleme

Ich habe nun die Dateien wegkopiert + mit ntbackup ein Backup des Verzeichnisses MDBDATA gezogen.
Leider geht es nicht, dass ich die Options ExchangeServer sichern benutze.

Nun versuche ich mal die Datenbankdateien zu ersetzen, um auszuschliessen, dass es an der Fragmentierung des Platte liegt. (im abgesicherten Modus).

Wie prüfe ich die Datenbanken am besten?
Ich habe schon mal ein ESEUTIL.EXE /MH gemacht und die priv1.edb ist soweit ok. Das ist je das merkwürdige. Unter State: steht "clean shutdown".
Bitte warten ..
Mitglied: Heysel
28.07.2008 um 12:09 Uhr
Wenn du mit Acronis ein Image vom Server gezogen hast dann brauchst du ja nix mehr seperat zu speichern in die Images kann man nachher einfach rein schauen.

Hast du mal getestet was passiert wenn du im abgesicherten Modus oder mit einer Win PE CD die Datenbank verschiebst oder löschst?

Ich würd garnciht versuchen die datenbank zu reparieren mach eine neue und importier die alte das ist sauberer. Wenn du die DB jetzt reparierst dann kann es sein das dennoch inkonsistente daten in das DB bleiben aufgrund der warscheinlich defekten oder nicht mehr vorhandenen Transaktion Logs
Bitte warten ..
Mitglied: ALT-F4
28.07.2008 um 12:16 Uhr
nene, acronis lässt sich NICHT installieren, aber ich habe die priv1.edb und priv1.stm kopieren können. ein ntbackup ist auch durchgelaufen.



Ok, sorry, aber bitte kleine Hilfe - mir brummt eh der Schädel.
Wie setze ich das neu auf? Einfach mal die *.edb löschen und neu erstellen lassen?

Wie importiere ich aus vorhandener priv1.edb in die neue?

Danke.
Bitte warten ..
Mitglied: Heysel
28.07.2008 um 12:23 Uhr
Also als aller erstes gehst du jetzt hin und installierst das acronis auf irgend einem xp rechenr und erstellst mit dem Acronis Bootmedium Builder eine Boot CD. Mit dieser Bootest du dann. Anschliessend kannste dann ohne das acronis installieren zu müssen ein komplettes image aller daten der Platte machen so das du es 1:1 wieder zurück spielen kannst wenn es Probleme geben solltest.
Das passt jetzt auch dann kanste nämlich während der das image macht Mittag essen

Dann startest du den Server im abgesicherten Modus und verschiebst die Daten bank wenn das nicht gehen sollte weil ein dienst den zugriff verhindert musst du dir eine Windows PE CD Downloaden mit der startest du dann. dann greift auch kein dienst mehr auf die DB zu.
Wenn du die DB gelöscht hast startest du den server erneut dann werden warscheinlich ganz viele dienste mekern das die DB nicht mehr da ist. Das ignorierst du dann erst mal und gehst in die Exchange Verwaltungskonsole dort erstellst du dann eine neue DB und Importierst die alten daten der verschobenen DB.
Das sollte eigentlich gehen. Hab ich auch shconmal aus nem anderen grund gemacht.
Bitte warten ..
Mitglied: ALT-F4
28.07.2008 um 13:20 Uhr
Das ignorierst du dann erst mal und gehst in die Exchange Verwaltungskonsole dort erstellst du dann eine neue DB und Importierst die alten daten der verschobenen DB.

Prima,
denk dran - es ist ein Small Business Server mit Exchange.
Nur eine Speichergruppe ist möglich, oder?

Also, Daten sind verschoben, Server startet und meckert irgendwie anders. In der Verwaltungskonsole ist die "erste Speichergruppe" noch zu sehen - die lösche ich nun??? Und lege eine Neue an?

Oder reicht es in den Eigentschaften unter Datenbank eine neue Anzugeben?
Bitte warten ..
Mitglied: Heysel
28.07.2008 um 13:52 Uhr
Ja stimmt probier einfach mal ob du einfach die verschobene angeben kannst dann guckt der auch rein und repariert die.
Bitte warten ..
Mitglied: ALT-F4
28.07.2008 um 16:10 Uhr
Das klappt alles nicht...

Ich habe jetzt bei MS ein Ticket aufgemacht.
Prompt habe ich ein Hotfix zugemailt bekommen.
Mal schauen, woran es nun liegt.

Ich werde hier noch schreiben, ob und wie es gelöst wurde.
Bitte warten ..
Mitglied: ALT-F4
28.07.2008 um 17:38 Uhr
Ok,

Problem ist gelöst:
Die Ursache, warum die komische Fehlermeldung 428 mit dem mangelnden Plattenplatz kam, ist ungelöst. Mich hat aber auch inzwischen nur noch interessiert, dass die DB überhaupt wieder läuft.


Folgendes wurde mit den original Dateien gemacht:

eseutil /MH priv1.edb
und dann noch über die priv1.stm, pub1.edb und pub1.stm.

Alle Datenbanken waren "clean shutdown" und keine "log required" waren 0. Damit konnten schon mal die *.log gelöscht werden.

Anschließend sind die Datenbanken mit
eseutil /d priv1.edb / eseutil /d pub1.edb defragmentiert worden.

Da beide DBs offline waren, folgte noch ein
isinteg -s fileserver -fix -test alltests
(max 5mal machen) - nach 2 Durchläufen waren die DBs in Ordnung.

Danach klappte auch das einhängen der Datenbanken mit
"Bereitstellen des Informationspeichers" im Exchange System Manager wieder. - sowohl mit dem öffentlichen als auch dem Postfächern.

Das war's, danke trotzdem für die Unterstützung.
Bitte warten ..
Neuester Wissensbeitrag
Ähnliche Inhalte
Exchange Server
Exchange 2003 auf 2007 Implace Migration (18)

Frage von Herbrich19 zum Thema Exchange Server ...

Exchange Server
gelöst Exchange 2003 von Windows 2003 Server lösen bzw. entfernen (3)

Frage von plexxus zum Thema Exchange Server ...

Exchange Server
Office 2013 oder 2016 mit Exchange 2003 (2)

Frage von uridium69 zum Thema Exchange Server ...

Heiß diskutierte Inhalte
Windows Userverwaltung
Ausgeschiedene Mitarbeiter im Unternehmen - was tun mit den AD Konten? (32)

Frage von patz223 zum Thema Windows Userverwaltung ...

LAN, WAN, Wireless
FritzBox, zwei Server, verschiedene Netze (21)

Frage von DavidGl zum Thema LAN, WAN, Wireless ...

Viren und Trojaner
Aufgepasst: Neue Ransomware Goldeneye verbreitet sich rasant (20)

Link von Penny.Cilin zum Thema Viren und Trojaner ...

Windows Netzwerk
Windows 10 RDP geht nicht (18)

Frage von Fiasko zum Thema Windows Netzwerk ...