Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Exchange 2007 - Fallback bei Sendeconnectoren

Frage Microsoft Exchange Server

Mitglied: dd-mbecker

dd-mbecker (Level 1) - Jetzt verbinden

11.09.2012 um 16:07 Uhr, 2443 Aufrufe, 4 Kommentare

Hallo alle zusammen,

wir haben in unserem Netzwerk einen Exchange-Server 2007, der nicht direkt im Internet steht, sondern über ein Mailrelay (Debian mit Postfix) die E-Mails versendet und auch empfängt. Ein zweites Mailrelay ist als Backup im Netz aktiv. Im Exchange habe ich jetzt zwei identische Sendeconnectoren angelegt, der erste Connector verweist auf die IP des ersten Mailgateways und hat als Kosten eine 1 eingetragen. Der zweite Sendeconnector enthält die IP des 2. Mailgateways, die Kosten für diesen Connector sind 10.

Wir sind davon ausgegangen, dass bei einem Ausfall des ersten Mailgateways der Exchange automatisch umschwenkt auf die teurere Route. Dies tut er leider nicht. Auch das Deaktivieren des Sendeconnectors zum ersten Mailgateway hat leider keinen Erfolg gebracht, trotz Neustart des Exchange 2007.

Gibt es hier eventuell Anregungen, wie ein Fallback zu bewerkstelligen ist? Gerne auch Anleitungen, Manuals im Internet. Wie o.a. habe ich bei meinen Recherchen nur die Beschreibungen zu den Sendeconnectoren (Technet) gefunden.

Vielen Dank und mit freundlichen Grüßen,

Marc Becker
Mitglied: filippg
11.09.2012, aktualisiert um 19:00 Uhr
Hallo,

mit Exchange 2007 hat MS das "Link State Routing" gestrichen, und routet nur noch nach Kosten. Will heißen: Dein Exchange wird den Konnektor 1 (den mit den geringeren Kosten) _immer_ dem Konnektor 2 vorziehen, auch wenn 1 down ist.
"Exchange 2007 never load balances across different routing paths, where a routing path consists of IP site links, connectors, and routing group connectors."
http://technet.microsoft.com/en-us/library/bb267003%28v=exchg.80%29


Das von dir gewünschte Verhalten lässt sich m.W. gar nicht mehr automatisch erzielen, sondern nur durch manuelles deaktivieren des 1. Konnektors (und selbst dann wäre ich mir nicht ganz sicher, ob und wann die Queue über den zweiten Abgebaut wird, siehe http://technet.microsoft.com/en-us/library/bb232161%28EXCHG.80%29.aspx )

Gruß

Filipp

Edit: Gerade noch einen Trick gefunden, wie man das über DNS abbilden kann: http://henrikzawischa.wordpress.com/2010/02/18/exchange-2007-send-conne ...
Bitte warten ..
Mitglied: dd-mbecker
11.09.2012 um 19:10 Uhr
Hi Filipp,

danke für die Antwort und den Technet Artikel, den habe ich irgendwie überlesen.

Leider hat selbst das Deaktivieren des Sendeconnectors (inkl. anschließendem Neustart des Exchange) keinen Erfolg gebracht.

Also wird dieses Feature so nicht funktionieren, werde mal den Trick mit dem DNS ausprobieren.

Gruß,

Marc
Bitte warten ..
Mitglied: dd-mbecker
02.10.2012 um 09:54 Uhr
Für alle Interessierten:
Ich habe beim Sendeconnector zwei Smarthosts eingetragen. Bisher scheint es zu funktionieren.
Bitte warten ..
Mitglied: dd-mbecker
04.11.2012 um 11:49 Uhr
Also kurz mal ein Nachtrag:

Wir haben jetzt einen Ausfalltest gemacht und wie o.a. funktioniert es. Wenn man beim Sendeconnector zwei Relay-Gateways einträgt, schaltet der Exchange automatisch um, auch wenn bereits der Versand an eines der Gateways ein- oder zweimal versucht wurde.

Der Empfang und die Weiterleitung erfolgt ja auf den Gateways direkt, also sind hier keine Anpassungen nötig.
Bitte warten ..
Neuester Wissensbeitrag
Windows 10

Sticky Notes - Autostart unterbinden

(1)

Tipp von Pedant zum Thema Windows 10 ...

Ähnliche Inhalte
Exchange Server
Outlook 2010 i. V. m. Exchange 2007, "Senden als" funktioniert nicht (1)

Frage von departure69 zum Thema Exchange Server ...

Exchange Server
WSUS bietet CU22 für Exchange 2007 SP3 nicht an. EOL Exchange 2007

Tipp von DerWoWusste zum Thema Exchange Server ...

Exchange Server
Exchange 2007 Datenbank restore ohne Exchange zu verändern - SBS2008

Frage von pitamerica zum Thema Exchange Server ...

Heiß diskutierte Inhalte
Router & Routing
Tipps für Router (ca. 100 clients, VPN) (18)

Frage von oel-auge zum Thema Router & Routing ...

TK-Netze & Geräte
Convert von TAPI auf CAPI gesucht (12)

Frage von StefanKittel zum Thema TK-Netze & Geräte ...