Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Exchange 2007 mit fester ip über mobile Endgeräte erreichen

Frage Microsoft Exchange Server

Mitglied: mike-snow

mike-snow (Level 1) - Jetzt verbinden

16.11.2012 um 11:14 Uhr, 3677 Aufrufe, 15 Kommentare

Hallo Zusammen,

bin neu hier und freu mich auf euch.


Hier das Problem:

Haben eine SBS 2008 mit Exchange 2007 SP2 im Einsatz. Die User greifen lokal sowie extern auf Ihre Konten zu. Intern über Lan/WLan extern über eine fest IP. Soweit funktioniert alles nur bei mobilen Geräten wie Smartphones funktioniert der Zugriff nur von Extern. dh. in der Gerätekonfiguration habe ich die feste IP eingetragen. Sobald sich die Geräte über das interne LAN/WLAN einloggen funktioniert es nicht mehr.

Mein Lösungsansatz war:
1. Bei unserem Internetprovider (1und1) eine Sub-Domain anlegen und A-DNS Eintrag unsere IP-Adresse eintragen.
2. Intern mit dem gleichen Sub-Domain Namen eine DNS Forward eintragen.
3. Die Sub-Domain wir jetzt anstatt der festen IP in den Smartphones als Server eingetragen.

Von Intern funktioniert der Zugriff auf den Exchange aber von extern leider nicht. Was ist hier bei den DNS Eintrag bei 1und1 zu beachten? Oder gibt es auch eine alternative Problemlösung?
Ich hoffe die Ausführung war soweit verständlich.

Herzliche Grüße
Mike
Mitglied: Hitman4021
16.11.2012 um 11:42 Uhr
Hallo,

meine Lösung war eine etwas andere.
Was hast du für eine Firewall?
Machne unterstützen es wenn ich aus dem Internen Netz auf die externe IP zugreife und ich werde normal weitergeleitet.

Aber ansonsten kannst du es so versuchen:
-Interner DNS Record -> owa.meinefirma.at -> interne IP
-Externer DNS Record -> owa.meinefirma.at -> externe IP
Wenn die Geräte im WLAN sind sollten sie theoretisch (solange sie den Record nicht cachen) zugreifen können, da sie den lokalen NS benutzen.

Gruß
Bitte warten ..
Mitglied: mike-snow
16.11.2012 um 12:30 Uhr
Hallo,

Firewall im Netgear Router. DG834B. Kann die von Dir beschriebene Einstellung nicht vornehmen.

Den Zweiten Vorschlag habe ich eigentlich soweit realisiert.
- intern funktionier
- nur extern eben nicht

Hier der DNS Check von 1und1:

Domainname :xyz.firmendomain.de
IP-Adresse (A-Record) : "unser feste IP"
IPv6-Adr. (AAAA-Record) :
Nameserver 1: ns65.1und1.de
Nameserver 2: ns66.1und1.de
Mailserver 1: mx00.kundenserver.de, 10
Mailserver 2: mx01.kundenserver.de, 10

Viele Grüße
Bitte warten ..
Mitglied: Hitman4021
16.11.2012 um 12:34 Uhr
Hallo,

du greifst aufs OWA zu oder?
Welche Ports sind freigegeben? bzw weitergeleitet?
Hmm wenn die Auflösung richtig ist sollte das funktionieren...

Gruß
Bitte warten ..
Mitglied: mike-snow
16.11.2012 um 12:45 Uhr
Hi,

ich weiß nicht genau ob ich auf owa zugreife.
wenn ich die feste ip im Smartphone eintrage wird diese im Router auf unseren internen Exchange-Server via https:// weitergeleitet. Alle Mails/Kontakte/Kalender werden mit dem S-Phone synchronisiert.
Ich dacht immer owa ist der Zugriff über den WEB-Browser.

Gruß
Bitte warten ..
Mitglied: Hitman4021
16.11.2012 um 12:48 Uhr
Hallo,

Ich dacht immer owa ist der Zugriff über den WEB-Browser.
nein nicht nur. Ich kann jetzt nur sagen wie es IOS macht. Hier verbindet sich der MailClient via RPC over HTTPS auf den Exchange Server und greift somit auf das OWA zu. Das gleiche kann man auch mit Outlook konfiguriere. Aber das ist eigentlich etwas OT.

Kannst du per Browser von extern zugreifen?
Portweiterleitungen sind gesetzt?
Kannst du per IP von extern zureifen?

Gruß
Bitte warten ..
Mitglied: mike-snow
16.11.2012 um 12:52 Uhr
Hi,

ja ich kann per Browser von extern zugreifen.
Portweiterleitungen sind gesetzt.
ja ich kann per IP von extern zugreifen.

Gruß
Bitte warten ..
Mitglied: Hitman4021
16.11.2012 um 12:56 Uhr
Hallo,

okay.
01.
nslookup 
02.
server $INTERNER_NAMESERVER 
03.
xyz.meinefirma.at 
04.
#Antwort sollte interne IP sein 
05.
server $EXTERNER_NAMESERVER 
06.
xyz.meinefirma.at 
07.
#Antwort sollte externe IP sein
Kommen hier die richtigen Antworten?

Erhältst du deine Nameserver per DHCP?

Gruß
Bitte warten ..
Mitglied: mike-snow
16.11.2012, aktualisiert um 13:07 Uhr
Hi,

nslookup
Standardserver: externe-IP
Address: Interne-IP

exc.fimrendomain.de
Server: externe-IP
Address: interne-IP

Name: exc.fimrendomain.de
Address: interne-IP

Der Domainserver ist der DHCP-Server.

Gruß
Bitte warten ..
Mitglied: Hitman4021
16.11.2012 um 13:14 Uhr
Hallo,

wenn ich das richtig lese stimmt da gewaltig etwas nicht.
das ganze sollte in etwas so aussehen:
01.
nslookup 
02.
Standardserver: dc.firma.de 
03.
Adress: $IP_DES_DCs 
04.
 
05.
#Dann gibst du deine Domain ein also exc.firmendomain.de 
06.
> exc.firmendomain.de 
07.
Server: dc.firma.de 
08.
Address: $IP_DES_DCs 
09.
 
10.
#Und nach einer Leerzeile die Antwort 
11.
Name: exc.firmendomain.de 
12.
Address: $INTERNE_IP_DES_EXCHANGE_SERVERS 
13.
 
14.
#Nun wechselst du den Server auf den Externen 
15.
> server $DEIN_EXTERNER_NAMESERVER 
16.
 
17.
#Und fragst diesen auf die GENAU gleiche Domain ab exc.firmendomain.de 
18.
> exc.firmendomain.de 
19.
Server: $DEIN_EXTERNER_NAMESERVER 
20.
Address: $DEIN_EXTERNER_NAMESERVER_IP 
21.
 
22.
#Und nach einer Leerzeile die Antwort 
23.
Name: exc.firmendomain.de 
24.
Address: $EXTERNE_IP_DES_EXCHANGE_SERVERS
Oder ich habe das was du geschrieben hast nicht richtig verstanden.
Aber der externe NS liefert dir die Interne IP zurück?
Dann liegt bei diesen Record der Fehler.

Gruß
Bitte warten ..
Mitglied: mike-snow
16.11.2012 um 13:28 Uhr
Hi,
ich Blicks gerade selbst nicht mehr.

Wenn ich auf meinem Client unter ausführen cmd eintrage und dann den nslookup ausführe erhalte ich die vorher beschriebenen Antworten.
Wenn ich unter Ausführen direkt nslooup eintage erhalte ich:

Standardserver: Domainserver.locla
Adresse: interne-IP

exc.firmendomain.de
Domainserver
Adresse: interne-IP

Name: exc.firmendomain.de
Adresse: interne-IP

Bin etwas verwirrt.

Gruß
Bitte warten ..
Mitglied: Hitman4021
16.11.2012 um 13:35 Uhr
Hallo,

Okay sowas ist per Remote auch relativ schwer zu lesen. Aber welche IP-Adresse gibt dir der externe Nameserver zurück?

Gruß
Bitte warten ..
Mitglied: mike-snow
16.11.2012 um 13:45 Uhr
Hi,

ich habe jetzt mal die Abfrage über den externen Nameserver gemacht.
Die Antwort ist:
***exc.firmendomain.de wurde von externer Nameserver nicht gefunden.

Gruß
Bitte warten ..
Mitglied: Hitman4021
16.11.2012 um 13:48 Uhr
Hallo,

dann stimmt etwas mit deinem A-Record am externen Server nicht.
im Prinzip musst du bei 1und1 einen A-Record anlegen der auf deine externet IP verweisst.
Und der funktioniert anscheinend nicht

Gruß
Bitte warten ..
Mitglied: mike-snow
16.11.2012 um 13:57 Uhr
Herzlichen Dank für Deine Unterstützung.
Werde mich jetzt mit 1und1 in Verbindung setzen.

Gruß
Bitte warten ..
Mitglied: mike-snow
19.11.2012 um 10:12 Uhr
So,

abschließend gibt es zu berichten.
Das Problem war ein Stück weit meine Ungeduld. d.h. die Name-Server der Provider waren noch nicht upgedatet. Daher wurde die Sub-Domain mit dem A-Record noch nicht richtig oder gar nicht aufgelöst. Jetzt funktioniert alles korrekt.

Besten Dank für die Unterstützung

mike
Bitte warten ..
Neuester Wissensbeitrag
CPU, RAM, Mainboards

Angetestet: PC Engines APU 3a2 im Rack-Gehäuse

(1)

Erfahrungsbericht von ashnod zum Thema CPU, RAM, Mainboards ...

Ähnliche Inhalte
Exchange Server
Exchange 2007 Datenbank restore ohne Exchange zu verändern - SBS2008

Frage von pitamerica zum Thema Exchange Server ...

DSL, VDSL
Fritzbox Exchange 2007 UM Gateway mit Freetz (2)

Frage von Herbrich19 zum Thema DSL, VDSL ...

Exchange Server
gelöst Zertifikatsfehler nach Migration von Exchange 2007 zu Exchange 2013 (2)

Frage von Tommy1983 zum Thema Exchange Server ...

Exchange Server
gelöst Exchange 2007 Migration auf Exchange 2016 (3)

Frage von Tommy1983 zum Thema Exchange Server ...

Heiß diskutierte Inhalte
DSL, VDSL
DSL-Signal bewerten (13)

Frage von SarekHL zum Thema DSL, VDSL ...

Switche und Hubs
Trunk für 2xCisco Switch. Wo liegt der Fehler? (9)

Frage von JayyyH zum Thema Switche und Hubs ...

Backup
Clients als Server missbrauchen? (9)

Frage von 1410640014 zum Thema Backup ...

Windows Server
Mailserver auf Windows Server 2012 (9)

Frage von StefanT81 zum Thema Windows Server ...