Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Exchange 2007 - IMAP-Ausfälle

Frage Microsoft Exchange Server

Mitglied: Newton

Newton (Level 1) - Jetzt verbinden

22.10.2008, aktualisiert 12.11.2008, 5048 Aufrufe, 4 Kommentare

Trotz Services --> Microsoft.Exchange.IMAP4(service) "running": kein Postfachabruf mehr möglich !

Hallo liebe Admingemeinde,

Unser Exchange2007-SP1 (auf Win Server 2003) bockt mal wieder:
Mehrere User in unterschiedlichen Netzen beklagten sich kürzlich, dass sie per Thunderbird und IMAP/ssl keine Mail erhielten und nicht senden konnten, sprich, über das Protokoll kein Ordner-Sync mehr möglich war.

Habe daraufhin die Dienstekonsole geöffnet : Microsoft.Exchange.IMAP4 (und .IMAPservice) waren beide up & "running",
genauso kamen sie in der Ausgabe von Get-Process als laufende Prozesse vor. ("IMAP4" übrigens mit vergleichbar hoher CPU- und Speicherlast, CPU(s) = 4000, WS(k) = 165000 )

Jedenfalls lief der IMAP-service noch und war anscheinend nicht mehr in der Lage, hereinkommende Requests zu beantworten.
Ein Neustart des Dienstes behob dann das Problem erstmal.
Es ist dann ein paar Stunden später nochmal aufgetreten, gegen Abend hin, wieder half ein Neustart in der Dienstekonsole.

Insgesamt ist unser ganzer Server recht langsam, nun muss man dazu sagen, dass er gleichzeitig AD-Domänencontroller, CAS und Hub Transport macht und beide Storage Groups mit auf der Sys-Partition liegen (500GB Scsi-Stripeset), dafür aber ein Pentium D 3.4GHz und 4 GB RAM vorhanden sind. Es sind ca. 125 Mailboxen / AD-User in unsere Domäne angelegt.

Kann man den IMAP-Ausfall nun mit Sicherheit als Performance-Problem abhaken, wenn MAPI (also Outlook-/OWA-Zugriff) bislang immer geklappt hat ?
Gibt es evtl. noch eine wichtige Stellschraube a la "max_connection_requests" serverseitig ?

Weiß nicht, von welcher Seite ich das Problem angehen soll; seit ein paar Tagen ist es auch nicht mehr aufgetreten, aber wir wissen ja alle, dass sowas genau im ungünstigsten Moment wieder zuschlagen kann....

Über Hilfe, Anregungen und Tipps freut sich der

== Newton ==

Danke!
Mitglied: schiffmeister
22.10.2008 um 20:51 Uhr
Hi,

also von der Hardwareleistung her ist das voll OK. 4GB RAM ist vielleicht nicht gerade viel, aber ausreichend für Anzahl von Postfächer.
Gibt es in der Ereignisanzeige keine Meldungen?
Bitte warten ..
Mitglied: Newton
11.11.2008 um 17:33 Uhr
Bin schon oft den Eventviewer daraufhin durchgegangen, aber sowohl Application, System als auch Security zeigen nichts signifikantes...

Was ich bei wiederholtem Prozess-Listing in der Powershell erkenne, ist, wie sich der Dienst Microsoft.Exchange.IMAP4 kontinuierlich immer mehr CPU-Leistung und Speicher heranholt:

[PS] C:\Documents and Settings\.... > Get-Process Microsoft.Exchange.*
Handles NPM(K) PM(K) WS(K) VM(M) CPU(s) Id ProcessName
------ ----- ----- ----- ------ -- -----------
447 30 33848 7516 531 1,22 2492 Microsoft.Exchange.AntispamUpdateSvc
475 44 53880 16000 575 276,34 4060 Microsoft.Exchange.Cluster.ReplayService
660 34 57832 56136 139 14,98 4360 Microsoft.Exchange.ContentFilter.Wrapper
439 30 58580 15444 -1360 7,73 1368 Microsoft.Exchange.EdgeSyncSvc
1046 46 281696 246560 -1278 2.428,38 3704 Microsoft.Exchange.Imap4
409 105 70652 14348 -1364 17,59 3460 Microsoft.Exchange.Imap4Service
582 27 72196 18964 592 47,70 2852 Microsoft.Exchange.Search.ExSearch
652 34 97628 29956 -1253 40,05 3292 Microsoft.Exchange.ServiceHost

Im Vergleich zu den anderen Exchange services ziemlich unverhältnismäßig, oder ?

Es könnte also ein kumulativer Effekt sein, vielleicht das Ausbleiben einer Garbage Collection / Speicherfreigabe nach jedem Logoff eines IMAP-Nutzers... Anscheinend ist das aber noch kein den Entwicklern bekanntes Problem. Bliebe abzuwarten, ob ein kommendes Update oder künftiger ServicePack2 das Problem beheben wird...

Schöne Grüße,
== Newton ==
Bitte warten ..
Mitglied: Newton
11.11.2008 um 17:43 Uhr
Ohje, ich habe hier in Blockschrift editiert und dabei ganz vergessen, dass es der Browser bei euch nachher in Arial o.ä. darstellt und die Lesbarkeit damit zum Teufel geht...
- großes SORRY !!! -

IMAP4 sticht also durch 2.428,38 "CPU(s)" heraus, im Gegensatz zu z.B. Cluster.ReplayService mit 276,34 CPU(s) - die andern liegen im Bereich ~40 oder weit darunter, einstellig.
In Minutenabständen "Get-Process *IMAP*" aufgerufen, kann man zusehen, wie dieser Wert steigt, monoton. Weniger wird es nie, bis ich unter Dienste die Notbremse ziehe und IMAP restarte. Dann selbes Verhalten, der jetzige Wert über 2.400 ist nach Restart vor 5 Tagen erreicht worden, ab 6.000 kann es kritisch werden.
Der Memorywert ist relativ hoch, schwankt aber ohne Tendenz zwischen 160000 - 280000 kB.
(PM(k) bzw WS(k) )

Genug Technobabble, gibt es jemanden, der zumindest erstmal Licht ins Dunkel der hier verwendeten Abkürzungen bringen und erklären kann, was mir Get-Processes da eigtl. genau anzeigt ?

Die Hilfeseite dazu kann man nämlich vergessen, die ist was für Captain Obvious...

Nochmals Grüße + Dank,
Cpt. Newton
Bitte warten ..
Mitglied: schiffmeister
12.11.2008 um 08:28 Uhr
Morgen,

hast du es schon mal in einer Microsoft Newsgroup versucht?
http://www.microsoft.com/communities/newsgroups/en-us/default.aspx?& ...

da schwirren jede Menge MVPs rum und solche die wirklich Ahnung haben.
Bitte warten ..
Neuester Wissensbeitrag
CPU, RAM, Mainboards

Angetestet: PC Engines APU 3a2 im Rack-Gehäuse

(1)

Erfahrungsbericht von ashnod zum Thema CPU, RAM, Mainboards ...

Ähnliche Inhalte
Exchange Server
Exchange 2007 Datenbank restore ohne Exchange zu verändern - SBS2008

Frage von pitamerica zum Thema Exchange Server ...

DSL, VDSL
Fritzbox Exchange 2007 UM Gateway mit Freetz (2)

Frage von Herbrich19 zum Thema DSL, VDSL ...

Exchange Server
gelöst Zertifikatsfehler nach Migration von Exchange 2007 zu Exchange 2013 (2)

Frage von Tommy1983 zum Thema Exchange Server ...

Exchange Server
gelöst Exchange 2007 Migration auf Exchange 2016 (3)

Frage von Tommy1983 zum Thema Exchange Server ...

Heiß diskutierte Inhalte
Grafikkarten & Monitore
Win 10 Grafikkarte Crash von Software? (13)

Frage von Marabunta zum Thema Grafikkarten & Monitore ...

DSL, VDSL
DSL-Signal bewerten (13)

Frage von SarekHL zum Thema DSL, VDSL ...

Switche und Hubs
Trunk für 2xCisco Switch. Wo liegt der Fehler? (9)

Frage von JayyyH zum Thema Switche und Hubs ...

Backup
Clients als Server missbrauchen? (8)

Frage von 1410640014 zum Thema Backup ...