Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Exchange 2007: Shared Namespace geht nicht

Frage Microsoft Exchange Server

Mitglied: lasseboo

lasseboo (Level 1) - Jetzt verbinden

20.01.2015 um 09:57 Uhr, 839 Aufrufe, 1 Kommentar

Hallo, Forum,

an einem Exchange 2007 auf SBS 2008 hatten wir bisher die Domain unser-exchange.de lokal im LAN betrieben. Smarthost / MXer im Internet (Postfix) nimmt die Mails aus dem WAN für unser-exchange.de an, von dort ruft der Exchange / SBS mit dem integrierten POP-Connector ab.

So weit, so gut. Nun ist aber ein Standort mit einem Teil der Benutzer aus dem AD DS (respektive der SBS-Console) abgetrennt worden.

user.hier@unser-exchange.de bleibt also bei uns.
user.dort@unser-exchange.de wird auf dem neuen MTA am anderen Standort betrieben.

Dummerweise unter derselben Domain, was ja dank Shared Namespace kein Problem sein sollte.

Also habe ich:

a) zuerst die vorhandene Domain unser-exchange.de auf dem lokalen Exchange von Authoritative auf InternalRelay gesetzt:

Set-AcceptedDomain unser-exchange.de -DomainType InternalRelay

b) den Sendeconnector für die Domain gesetzt:

New-SendConnector -Name "Internal Relay" -Internet -AddressSpace unser-exchange.de -SmartHosts mx.extern.de

c) den AddressBook-Lookup deaktiviert:

Set-AcceptedDomain unser-exchange.de -AddressBookEnabled $false

d) Schliesslich noch über die Exchange Verwaltungskonsole = Anti-Spam das Recipient filtering abgeschaltet.

e) user.dort@unser-exchange.de auf unserem Exchange gelöscht


Schicke ich jetzt über unseren Exchange eine Mail von user.hier@unser-exchange.de an user.dort@unser-exchange.de, sollten diese an den SendConnector zugestellt werden, weil ich user.dort@unser-exchange.de ja bei un. Klappt nur leider nicht ... d.h. es klappt, aber nur für Adressen, die es vorher nicht im lokalen SBS / Exchange gab.

a) Schreibe ich also an eine alte (gelöschte) Emailadresse, bekomme ich einen NDR vom lokalen Exchange.
b) Schreibe ich an eine Phantasie-Adresse (gibts.nicht@unser-exchange.de), bekomme ich einen NDR vom MX/Smarthost (Postfix) - also funktioniert der Sende-Connector.
c) Erstelle ich auf dem Postfix-MXer/Smarthost eine neue Emailadresse neuer.user@unser-exchange.de, wird diese Mail zugestellt.

Ich habe alle Adressen gecheckt, in der Exchange-Verwaltungskonsole und im ADDS nachgesehen - aber es gibt user.dort@unser-exchange.de nirgends mehr auf unserem Exchange. trotzdem erhalte ich beim Versuch, eine Mail an user.dort@unser-exchange.de zusenden, einen NDR von unserem lokalen Exchange.

Ich habe den SendConnector gelöscht und neu angelegt mit etwas anderer Syntax:

New-SendConnector -Name "Internal Relay" -Custom -AddressSpaces unser-exchange.de -SmartHosts mx.extern.de -SourceTransportServers exchange-local

- aber meines Erachtens ist das nicht das Problem, das Relayen an (neu) unbekannte Adressen funktioniert ja.

Ich habe gestern abend den Exchange neugestartet in der Hoffnung, dass es das behebt, aber das war es auch nicht

Habe ich etwas übersehen? Einen Verständnisfehler gemacht?

Vielleicht hat ja jemand eine gute Idee ...

Vielen Dank im Voraus!


Mit freundlichen Grüßen

lasseboo
Mitglied: lasseboo
30.01.2015 um 09:20 Uhr
Hallo zusammen,

ich antworte mir jetzt mal selber ;)

Hier die Schritte, wie es dann letztlich ablief:

1) Domain von Authoritative auf InternalRelay gesetzt:

Set-AcceptedDomain unser-exchange.de -DomainType InternalRelay

bzw (laut Microsoft)

New-AcceptedDomain -Name "unser-exchange.de" -DomainName unser-exchange.de -DomainType InternalRelay

2) externen Sendeconnector erstellt bzw. zugewiesen:

New-SendConnector -Name "Internal Relay" -Internet -AddressSpace unser-exchange.de -DNSRoutingEnabled $false -SmartHosts mx.extern.de-SmartHostAuthMechanism ExternalAuthoritative -MaxMessageSize 20MB

bzw (laut Microsoft)

New-SendConnector -Name "Internal Relay" -Custom -AddressSpaces unser-exchange.de -SmartHosts mx.extern.de -SourceTransportServers ex2007.mycompany.local

3) Da die Domain am Hauptstandort bereits angelegt war, ist die Adressbuch-Abfrage standardmässig aktiviert. Deswegen diese Abfrage für die entsprechende Domain abschalten:

Get-AcceptedDomain | select name,domaintype,addressbookenabled

Set-AcceptedDomain unser-exchange.de -AddressBookEnabled $false

4) Schliesslich noch Recipient filtering abschalten:

= Exchange Verwaltungskonsole = Anti-Spam

5) Dann diese Schritte in der Exchange-Shell ausgeführt:

Get-EmailAddressPolicy | Update-EmailAddressPolicy
Get-AddressList | Update-AddressList
Get-GlobalAddressList | Update-GlobalAddressList

get-mailbox | set-mailbox -applymandantoryproperties

6) Jetzt funktionierte der Versand von einem NEU angelegten Outlook-Konto aus (bzw. einem PC mit neuem Profil, der nicht durch eine "alte" Autovervollständigung per NK2 bzw. vorgeschlagener Kontakte "belastet" war:

a) Mail an user.hier wurde am alten Standort zugestellt
b) Mail an user.dort ging problemlos an den User am neuen Standort (mit neuem Exchange) raus

7) An den "alten" PCs bzw. deren Konten muss man nun entweder

a) die "falschen" Adressen aus den Vorschlägen manuell entfernen - das hat nur manchmal geholfen, bei ca. 20 PCs, es lebe die Berechenbarkeit von IT-Systemen ;)

b) die alte Autovervollständigung komplett zu löschen hätte vermutlich auch geholfen

c) wenn ein neuer User user.dort vom neuen Exchange am abgetrennten Standort übrigens eine Mail an die "alten" User am lokalen Standort hier schickt und beantwortet wird, geht diese auch zum abgetrennten Exchange.

Letztlich muss man wohl entweder diesen berüchtigten X.500-Proxy anlegen (den ich aber bisher noch nicht begriffen habe - macht man das für die verschobenen User oder global für einen Bereich?), oder die alten Outlook-Konten manuell abklappern.

So hat es bei uns geklappt, alle Aussagen ohne Gewähr, alles war sehr mühselig - aber wer eine bessere (funktionierende und nachvollziehbare!) Lösung hat, soll sie hier posten, ich lerne gerne dazu!


Schöne Grüße

Lasseboo
Bitte warten ..
Neuester Wissensbeitrag
Ähnliche Inhalte
Exchange Server
Exchange 2007 Datenbank restore ohne Exchange zu verändern - SBS2008

Frage von pitamerica zum Thema Exchange Server ...

DSL, VDSL
Fritzbox Exchange 2007 UM Gateway mit Freetz (2)

Frage von Herbrich19 zum Thema DSL, VDSL ...

Exchange Server
gelöst Zertifikatsfehler nach Migration von Exchange 2007 zu Exchange 2013 (2)

Frage von Tommy1983 zum Thema Exchange Server ...

Exchange Server
gelöst Exchange 2007 Migration auf Exchange 2016 (3)

Frage von Tommy1983 zum Thema Exchange Server ...

Heiß diskutierte Inhalte
Windows Userverwaltung
Ausgeschiedene Mitarbeiter im Unternehmen - was tun mit den AD Konten? (33)

Frage von patz223 zum Thema Windows Userverwaltung ...

LAN, WAN, Wireless
FritzBox, zwei Server, verschiedene Netze (21)

Frage von DavidGl zum Thema LAN, WAN, Wireless ...

Viren und Trojaner
Aufgepasst: Neue Ransomware Goldeneye verbreitet sich rasant (20)

Link von Penny.Cilin zum Thema Viren und Trojaner ...

Windows Netzwerk
Windows 10 RDP geht nicht (18)

Frage von Fiasko zum Thema Windows Netzwerk ...