Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Exchange 2010 Cmdlets verschwunden?

Frage Microsoft Exchange Server

Mitglied: frickenet

frickenet (Level 1) - Jetzt verbinden

02.05.2012, aktualisiert 17:15 Uhr, 13621 Aufrufe, 2 Kommentare

Nach Installation von SP2: Probleme mit IIS-Zugriff, der Exchangeverwaltungskonsole und Exchange Management Shell

Nach der Installation von Sp2 funktionieren verschiedene Dinge nicht mehr. Update Rollup 1 und Update Rollup 2 halfen nicht.

Problem 1
Beim Aufrufen von OWA, ECP fehlte die Grafiken in den Webseiten. Das Problem könnte ich lösen durch Kopieren der fehlenden Bilder und Scripte von C:\Program Files\Microsoft\Exchange Server\V14\ClientAccess\Owa\14.2.247.5\themes nach C:\Program Files\Microsoft\Exchange Server\V14\ClientAccess\Owa\14.2.298.4\themes

Problem 2
Die Exchangeverwaltungskonsole startet nur noch unvollständig. Es fehlt der Bereich "Serverkonfiguration". Versuche ich von dieser Konsole einen anderen Exchangeserver zu verwalten findet er keine Exchangeserver. Auch nicht den Eigenen. Die Suche wird abgebrochen mit der folgenden Fehlermeldung: Die Benennung "Get-ExchangeServer" wurde nicht als Name eines Cmdlet, einer Funktion oder eines ausführbaren Programms erkannt...." Damit kommen wir zum Problem 3

Problem 3
Bestimmte Cmdlets wie "Get-ExchangeServer" funktionieren in der Exchange Management Shell nicht mehr. Get-Mailbox -Identity “Username” funktioniert noch.

Nun meine Frage. Wie kann ich die Exchange Management Shell reparieren?


P.S. Ich habe die Exchangeverwaltungskonsole auf einem anderen Server installiert und sehe von dort aus alle drei Bereiche.

P.S. "get-pssnapin -Registered | fl name" in der Windows Powershell ergab nur den folgenden Eintrag:

Name : Microsoft.Exchange.Management.PowerShell.Setup

Nach dieser Anleitung: http://joetrombley.wordpress.com/2011/03/12/the-windows-powershell-snap ... habe ich die fehlenden Einträge von Hand hinzugefügt und erhalte nun mit "get-pssnapin -Registered | fl name" alle erforderlichen snapins:

Name : Microsoft.Exchange.Management.PowerShell.Setup
Name : Microsoft.Exchange.Management.PowerShell.E2010
Name : Microsoft.Exchange.Management.Powershell.Support

Anschließend habe ich noch in der Windows Powershell: add-pssnapin Microsoft.Exchange.Management.PowerShell.E2010 eingeben. Das lief fehlerfrei durch, aber trotzdem kein "Get-ExchangeServer" in der Exchange Management Shell
Mitglied: frickenet
03.05.2012 um 08:48 Uhr
Problem gelöst Habe in der Anmeldeinformationsverwaltung eine WIndows-Anmeldeinformation eines Benutzers ohne Adminrechte gelöscht. Anscheinend hat die Exchange Management Shell dieses Konto verwendet! Draufgekommen bin ich von dieser Quelle: http://social.technet.microsoft.com/Forums/en-US/exchange2010/thread/ec ...
Bitte warten ..
Mitglied: x-scips
16.04.2013 um 14:28 Uhr
Hallo frickenet,
vielen Dank für die Lösung des Problems.
Bin über das gleiche "Problem 3" gestolpert.
Have a nice day
Bitte warten ..
Ähnliche Inhalte
Exchange Server
Exchange 2010 standard quotas greifen nicht (3)

Frage von jocologne zum Thema Exchange Server ...

Exchange Server
gelöst Exchange 2010 aufgesetzt - Mailempfang von extern nicht möglich! (7)

Frage von crossh4ir zum Thema Exchange Server ...

Exchange Server
Exchange 2010 SMART Host SMTP Relay Probleme (6)

Frage von dawdad zum Thema Exchange Server ...

Exchange Server
gelöst Exchange 2010 Standard auf neuen Server 2016 installieren? (9)

Frage von zeroblue2005 zum Thema Exchange Server ...

Heiß diskutierte Inhalte
Windows Installation
Eine etwas (wirklich) speziellere Frage: Windows 10-Installation über (16)

Frage von DerFurrer zum Thema Windows Installation ...

Multimedia & Zubehör
gelöst Iphone 6 prob (10)

Frage von jensgebken zum Thema Multimedia & Zubehör ...

Netzwerkgrundlagen
gelöst Cisco SG500 Series LAG hat sich von selbst umgestellt (10)

Frage von Ex0r2k16 zum Thema Netzwerkgrundlagen ...

Linux
gelöst Boot failed: not a bootable disk (10)

Frage von Fleckmen zum Thema Linux ...