Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Exchange 2010 DAG - Failover Probleme trotz CAS Array und NLB

Frage Microsoft Exchange Server

Mitglied: Dr.Jay

Dr.Jay (Level 1) - Jetzt verbinden

26.08.2013 um 14:34 Uhr, 2343 Aufrufe, 2 Kommentare, 1 Danke

Ein herzliches Hallo miteinander,

ich habe ein Kundenprojekt übernommen, bei dem ein Exchange Server welcher zu einer DAG gehört aus dem
Verbund genommen und einer anderen Aufgabe zugeführt werden soll. Sobald dieser Server auch nur heruntergefahren wird,
kann keiner der ca. 30 Clients vor Ort mehr auf den Exchange Cluster zugreifen. Die Konfiguration vor Ort ist zwar recht
sonderbar, sollte jedoch in diesem Falle korrekt funktionieren.

Folgendermaßen ist der Exchange Cluster aufgebaut:

Es existieren zwei Exchange Server in einer DAG. Auf beiden ist das Failovermanagement aktiviert.
Beide Server haben einen VMware Server 2.0 am laufen auf welchem jeweils ein CAS Server mit NLB läuft.
Vermutlich wurde die Installation so gewählt, da der vorherige Administrator bei Setup nicht wusste, dass DAG + NLB
auf einem Host nicht möglich sind...
Beim 2. Exchange Server wurde aufgrund von Verbindungsproblemen der CAS Server in der VM nicht mehr gestartet.

Heißt: 2x Exchange, auf dem einen ist der CAS Server. Schalte ich den Exchange ohne den CAS Server ab, hat
kein Client mehr Zugriff auf den Exchange. Sieht also so aus, als ob der CAS Server, den 2. Exchange, welcher
nur eine Passive Kopie der Datenbank hat, ansteuert. Wie kann das aber gehen, wenn die Kopie nicht "aktiv"
geschaltet wurde?

Irgendetwas übersehe ich hier, aber was? Hat jemand eine Idee?

lg. der René
Mitglied: filippg
26.08.2013 um 19:46 Uhr
Hallo,

Vermutlich wurde die Installation so gewählt, da der vorherige Administrator bei Setup nicht wusste, dass DAG + NLB
auf einem Host nicht möglich sind...
Afaik kann man das nicht "nicht wissen": Die Installer der Cluster Services und vom NLB-Feature prüfen wechselseitig, ob der jeweils andere schon installiert ist und verweigern die Installation. Sprich: Es kann einem (nach meinem Wissen) nicht passieren, dass man versehentlich beides installiert. Man muss dazu schon echt hart tricksen.
Daher auch mein Rat: Wenn an den Servern irgendjemand schon gebastelt hat, der (so verstehe ich den Post) auch nicht mehr erreichbar ist, würde ich dir raten, parallel einen neuen Exchange aufzusetzen, und alles auf diesen zu übertragen.

Ansonsten solltest du halt mal schauen, ob die Dinge wirklich so sind, wie sie scheinen. Laufen sie wirklich im NLB? Wie heißt das CAS-Array? Welche IP ist bei dem DNS-Name hinterlegt? Ist der Name auf den DBs gesetzt? Welchen Namen sprechen die Clients an?

Natürlich kann auch ein Blick in die Eventlogs nichts schaden, davon schreibst du gar nichts...

Daneben finden sich auch zahlreiche Anleitungen, wie man einen Knoten korrekt aus einer DAG entfernt. Die könntest du dir mal anschauen. Du musst allerdings damit rechnen, dass du irgendeinen normalerweise völlig korrekten Schritt machst, und auf einmal gar nichts mehr geht -auch kein Zurück. Vielleicht solltest du versuchen, als allererstes das NLB aufzulösen.

Grüße

Filipp
Bitte warten ..
Mitglied: Dr.Jay
26.08.2013 um 20:07 Uhr
Hallo Filipp,

vielen Dank für dein Feedback. Bezüglich des NLG und der DAG stützt sich meine Vermutung quasi auf deine Antwort. Während der Installation
wurde wohl festgestellt, dass DAG + NLB auf einem System nicht funktionieren. Anders kann ich mir nicht erklären, warum man auf dieses System
noch zusätzlich einen VMware Server installiert, welcher die bereits dürftige Performance des Systems noch weiter verschlechtert. Aber nun gut,
dass sind ja nur Mutmaßungen.

Die Outlook Clients lösen das quasi das CAS Array auf. So wie es eigentlich sein sollte. Das Array Heißt einfach nur EXCAS. Hier ist die IP des NLB
hinterlegt (192.168.5.115) Der NLB verweißt auf nur einen CAS Server (der 2. wurde wie gesagt aufgrund von Fehlern abgestellt). In den Eventlogs
sieht alles prächtig aus. Keine Fehlermeldungen.

Bevor ich den Knoten aus der DAG entferne, wollte ich auf dieser Plattform nochmal sicherstellen, ob dies die einzig vernünftige Möglichkeit
ist. Ich werde wohl so vorgehen, dass ich die gesamte Umgebung via vCenter Converter abziehe, virtualisiere und dann auf den alten Systemen
eine Neuinstallation durchführen werden. Sicher ist sicher

lg. der René
Bitte warten ..
Ähnliche Inhalte
Exchange Server
Exchange 2010 DAG funktioniert nur teilweise (1)

Frage von apex.predator24 zum Thema Exchange Server ...

Exchange Server
Exchange 2010 DAG DB Limit erhöhen (5)

Frage von Corrben zum Thema Exchange Server ...

Exchange Server
Exchange 2010 SMART Host SMTP Relay Probleme (6)

Frage von dawdad zum Thema Exchange Server ...

Exchange Server
Office 2013 - Exchange 2010 - Probleme mit Anhängen (3)

Frage von Coscos zum Thema Exchange Server ...

Heiß diskutierte Inhalte
Router & Routing
Tipps für Router (ca. 100 clients, VPN) (18)

Frage von oel-auge zum Thema Router & Routing ...

TK-Netze & Geräte
gelöst Convert von TAPI auf CAPI gesucht (13)

Frage von StefanKittel zum Thema TK-Netze & Geräte ...