Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Exchange 2010 Datenbank bei Prüfung inkonsistent (Logs fehlen)

Frage Microsoft Exchange Server

Mitglied: Flashy

Flashy (Level 1) - Jetzt verbinden

18.07.2011 um 15:40 Uhr, 8126 Aufrufe, 5 Kommentare

Konsistenz-Check der MSX2010 DB schlägt fehlt, weil einige Transaktionsprotokolle fehlen

Hallo zusammen,

ich habe ein Server von einem Admin mit Halbwissen übernommen. Leider läuft das Backup des Exchange-Servers nicht so wie es sollte.
Daher brauche ich mal einen Rat von Kollegen, die mit 'korrupten' Datenbanken hier Erfahrungen haben.

Problem ist, ich wollte im ersten Schritt erst einmal ein halbwegs brauchbares Backup der DB mit Boardmitteln durch das Windows Server Backup einrichten.
Bei der Durchführung prüft das Tool die Exchange DB auf Konsistenz, was leider fehlschlägt und somit kein brauchbares/verlässliches Backup erstellt.

Die Logdateien sagen ganz klar aus, dass einige Transaction-Logs fehlen.
Diese sind leider "nicht mehr da". Die wurden per Hand gelöscht, weil die Festplatte vollgelaufen war.

So, meine Frage ist. Wie kann ich auf sicherem Weg die Exchange-DB dazu zwingen, wieder Konsistent zu sein?
So das die Prüfung vor dem Backup erfolgreich verläuft.

Ich bin bei der Suche auf die Option "ESEUTIL /P" gestoßen.
Ist das der richtige Weg bei fehlenden Logs?

Danke & Gruß,
Daniel
Mitglied: HubertN
18.07.2011 um 16:28 Uhr
Moin

Kannst du die Bereitstellung der Datenbank aufheben ?
Bitte warten ..
Mitglied: GuentherH
18.07.2011 um 18:50 Uhr
Hallo.

- Stelle die Transaktionslogs um auf Umlaufprotokollierung
- führe ein Backup durch - wird, muss fehlerfrei durchlaufen - wenn nein, dann hast du ein DB Problem, sonst nicht
- lösche die nicht mehr benötigiten Transaktionslogs
- stelle wieder auf Standardprotokollierung um

Lasse bevor du dies Änderungs durchgeführt hast, die Finger von den Zusatztool.

LG Günther
Bitte warten ..
Mitglied: Flashy
19.07.2011 um 09:38 Uhr
Bisher konnte ich die Bereitstellung aufheben, Dienste neustarten und auch die DB neu mounten.
Da schien bisher alles sauber.

Danke Günther, genau auf so einen Tipp habe ich erst einmal gehofft!
Das werde ich am Wochenende in Ruhe ausprobieren.

Gruß,
Daniel
Bitte warten ..
Mitglied: Flashy
24.07.2011 um 12:51 Uhr
perfekt !

Danke, das hat geholfen!
Habe die Umlaufprotokolierung aktiviert, die Bereitstellung aufgehoben und wieder aktiviert. Danach waren automatisch alle allten Logs gelöscht.

Backup erfolgreich durchgelaufen und danach die Umlaufprotokolierung wieder deaktiviert.
Bitte warten ..
Mitglied: GuentherH
24.07.2011 um 13:27 Uhr
Hallo.

Fein, dass es geklappt hat, und danke für die Rückmeldung

LG Günther
Bitte warten ..
Neuester Wissensbeitrag
Ähnliche Inhalte
Exchange Server
Exchange 2010 Akzeptierte Domäne löschen (4)

Frage von Rob1982 zum Thema Exchange Server ...

Exchange Server
gelöst Exchange 2010 Berechtigungen wiederherstellen (21)

Frage von semperf1delis zum Thema Exchange Server ...

Heiß diskutierte Inhalte
Windows Userverwaltung
Ausgeschiedene Mitarbeiter im Unternehmen - was tun mit den AD Konten? (32)

Frage von patz223 zum Thema Windows Userverwaltung ...

LAN, WAN, Wireless
FritzBox, zwei Server, verschiedene Netze (21)

Frage von DavidGl zum Thema LAN, WAN, Wireless ...

Viren und Trojaner
Aufgepasst: Neue Ransomware Goldeneye verbreitet sich rasant (20)

Link von Penny.Cilin zum Thema Viren und Trojaner ...

Windows Netzwerk
Windows 10 RDP geht nicht (18)

Frage von Fiasko zum Thema Windows Netzwerk ...