Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Exchange 2010 Datenbank nach Rücksicherung auf Hyper-V Server nicht mehr bereitstellbar

Frage Microsoft Exchange Server

Mitglied: anaxagoras83

anaxagoras83 (Level 1) - Jetzt verbinden

23.04.2013 um 14:34 Uhr, 3756 Aufrufe, 3 Kommentare, 1 Danke

Datenbank eines frisch zurückgesicherten Exchange 2010 auf Server 2008 R2 - Enterprise stellt die Private Primäre Postfach Datenbank nicht mehr bereit. Reparaturversuche nach Recherche schlagen fehl.

Hallo alle zusammen,

nach einem sehr langen Wochenende und einigen neuen grauen Haaren, trete ich vor dieses Board mit der Bitte um Rat:
Bisher wurden die eingetzten virtuellen Maschinen mittels VMWARE ESXi bereitgestellt, diese wurden am vergangenen Wochenende per Hand mittels Windows Backup auf einen frisch installierten Windows Server 2012 - Standard mit installierter HyperV-Rolle migriert.

Die Wiederherstellung (mittels Server 2008 R2 Installationsdatenträger und Windows Sicherung von UNC-Pfad)funktioniert außer dem Server 2 (Fileserver) ohne Beanstandung. Dieses Problem wurde aber gelößt und die betroffene VHD-Datei wieder bootbar gemacht. Alle Server laufen nun wieder - nur die Exchange-Datenbank kann nicht bereitgestellt werden

Auf einem Blick

Setup vorher:
VMWARE ESXi - Server mit vier installierten virtuellen Windows Server 2008 R2 - Enterprise Servern
- Server 1: DC
- Server 2: Fileserver
- Server 3: Exchange-Server
- Server 4: Terminalserver

Setup nachher:
Hyper-V auf 2012 Standard
- Server 1: DC
- Server 2: Fileserver
- Server 3: Exchange-Server <-- Server mit Datenbankproblem
- Server 4: Terminalserver

Bisher durchgeführte Tätigkeiten
- Wiederherstellung der virtuellen Maschine mittles Windows Backup auf leere Maschine in Hyper-V
- Nach mehrmaligem Neustart und anpassen der Netzwerkeinstellungen auf feste IP sind Maschinen wieder ansprechbar.
- Alle anderen Dienste: AD, FS, Terminalserver, Printserver, etc. funktionieren anstandslos
- Versuch mit der Datenbank zu verbinden via Outlook - Mapi Fehler - Exchange nicht erreichbar
- Überprüfung der grafischen Exchange-Verwaltungskonsole
- Fehlermeldung: "Bereitstellung der Datenbank aufgehoben"
- Manuelle Bereitstellung der Datenbank nicht möglich
- Neustart des virtuellen Servers - Fehler weiterhin vorhanden
- Überprüfung der Serverdienste und des Windows-Eventlogs
- Exchange-Transportprotokolldienst ist nicht gestartet
- Manuelles Starten des Dienstes
- Erneuter Versuch - Fehler
- Recherche im Internet nach Umschreibung des Problems
- Reparatur der Datenbank notwendig
- Verschieben der Datenbank mittels /Configure-only command in c:\Exchange_datenbanken\
- Aufschalten auf Exchange-Server und öffnen der Exchange-Verwaltungsshell - OK
- cd \Exchange_Datenbanken\
- eseutil.exe /mh '.\Mailbox Database 1696148457.edb'
- DUMP:

DATABASE HEADER:
Checksum Information:
Expected Checksum: 0x03ae56c9
Actual Checksum: 0x03ae56c9

Fields:
File Type: Database
Checksum: 0x3ae56c9
Format ulMagic: 0x89abcdef
Engine ulMagic: 0x89abcdef
Format ulVersion: 0x620,17
Engine ulVersion: 0x620,17
Created ulVersion: 0x620,17
DB Signature: Create time:01/22/2011 22:04:16 Rand:1439114 Computer:
cbDbPage: 32768
dbtime: 58545871 (0x37d56cf)
State: Dirty Shutdown
Log Required: 43403-43403 (0xa98b-0xa98b)
Log Committed: 0-43404 (0x0-0xa98c)
Log Recovering: 0 (0x0)
GenMax Creation: 04/17/2013 20:02:03
Shadowed: Yes
Last Objid: 15447
Scrub Dbtime: 0 (0x0)
Scrub Date: 00/00/1900 00:00:00
Repair Count: 0
Repair Date: 00/00/1900 00:00:00
Old Repair Count: 0
Last Consistent: (0xA833,D0,187) 04/11/2013 18:08:07
Last Attach: (0xA835,9,86) 04/11/2013 18:10:31
Last Detach: (0x0,0,0) 00/00/1900 00:00:00
Dbid: 1
Log Signature: Create time:01/22/2011 22:04:16 Rand:1463482 Computer:
OS Version: (6.1.7601 SP 1 NLS 60101.60101)

Previous Full Backup:
Log Gen: 43342-43343 (0xa94e-0xa94f) - OSSnapshot
Mark: (0xA950,8,16)
Mark: 04/16/2013 21:01:03

Previous Incremental Backup:
Log Gen: 0-0 (0x0-0x0)
Mark: (0x0,0,0)
Mark: 00/00/1900 00:00:00

Previous Copy Backup:
Log Gen: 0-0 (0x0-0x0)
Mark: (0x0,0,0)
Mark: 00/00/1900 00:00:00

Previous Differential Backup:
Log Gen: 0-0 (0x0-0x0)
Mark: (0x0,0,0)
Mark: 00/00/1900 00:00:00

Current Full Backup:
Log Gen: 0-0 (0x0-0x0)
Mark: (0x0,0,0)
Mark: 00/00/1900 00:00:00

Current Shadow copy backup:
Log Gen: 0-0 (0x0-0x0)
Mark: (0x0,0,0)
Mark: 00/00/1900 00:00:00

- Wichtig: "State: Dirty Shutdown "
- Kopie aller Dateien und Ordner in Datenbankverzeichnis Sicherungspfad
- Durchführen von: eseutil /r "E00" /l . /d .
- Fehlermeldung:

Performing soft recovery...

Operation terminated with error -546 (JET_errLogSectorSizeMismatch, the log file sector size does not match the current
volume's sector size) after 0.141 seconds.

- Erneute Kopie der Datensicherung Recherche und versuche den Befehlt mit voller Pfadangabe, mit oder ohne Anführungszeichen - kein Erfolg
- Mit vollem Bewusstsein eines möglichen Datenverlustes Durchführung einer Hard-Recovery
- Hard-Recovery: eseutil /p <Datenbank>
- Erfolgreich durchgeführt.
- Defragmentierung der Datenbank und verschieben der LOG-Files "E000000XXXXXX" in Sicherungsverzeichnis
- Defragmentierung eseutil /d
- Erneutes esetutil.exe /mh - clean state - jedoch Datenbank weiterhin nicht bereitstellbar
- Neustart des Servers - starten des Dienstes
- Versuch der Bereitstellung der Datenbank - weiterhin Fehlermeldung

Microsoft Exchange Fehler
Die Datenbank 'Mailbox Database 1696148457' konnte nicht bereitgestellt werden.

Mailbox Database 1696148457
Fehler
Fehler:
Die angegebene Datenbank konnte nicht bereitgestellt werden. Angegebene Datenbank: Mailbox Database 1696148457; Fehlercode: Fehler bei Active Manager-Vorgang: Fehler Fehler bei der Datenbankaktion: Fehler bei Vorgang mit folgender Meldung: MapiExceptionCallFailed: Unable to mount database. (hr=0x80004005, ec=-546)
. [Datenbank: Mailbox Database 1696148457, Server: XXX.XXX.local].

Fehler bei Active Manager-Vorgang: Fehler Fehler bei der Datenbankaktion: Fehler bei Vorgang mit folgender Meldung: MapiExceptionCallFailed: Unable to mount database. (hr=0x80004005, ec=-546)
. [Datenbank: Mailbox Database 1696148457, Server: XXXXXX.XXX.local]

Fehler bei Active Manager-Vorgang: Fehler Fehler bei Vorgang mit folgender Meldung: MapiExceptionCallFailed: Unable to mount database. (hr=0x80004005, ec=-546)
[Server: XXXXX.XXX.local]

MapiExceptionCallFailed: Unable to mount database. (hr=0x80004005, ec=-546)

OK
- Rücksicherung der Datenbank aus letzter Datensicherung
- Erneuter Versuch gleiche Fehler wie oben beschrieben
- Durchführen der o.g. Punkte
- Leider weiterhin kein Erfolg.

Momentan fehlt mir der Hebel mit dem ich ansetzen könnte... Produzierte Fehlermeldungen
Die Datenbank ist mit den von mir gefundenen und vorhandenen Mitteln nicht wiederherstellbar.

Ich bin dankbar für jeden Hinweis, einer Lösung oder der Aussage - dass ich nicht weiter zu suchen brauche.

Beste Grüße und danke für die eingesetzte Zeit.

Anaxagoras83
Mitglied: Dani
23.04.2013, aktualisiert um 15:40 Uhr
Moin Anaxagoras83,
doofe Frage: Als du Images mit Windows Backup erstellt hast, hast du davor die Exchangedienste alle beendet? Wenn nicht hat die DB noch etwas gesschrieben während der Sicherung.

Log Required: 43403-43403 (0xa98b-0xa98b)
Log Committed: 0-43404 (0x0-0xa98c)
Die Logsfiles sind noch vorhanden vom Exchange?

Hast du die DB wieder an ihren Ursprungsort kopiert? Denn ich habe ob lesen das du diese am Anfang verschoben hast.

Hard-Recovery: eseutil /p <Datenbank>
Hast du die Ausgabe noch?


Grüße,
Dani

P.S. http://www.windowspro.de/tool/microsoft-virtual-machine-converter-vms-v ...
Bitte warten ..
Mitglied: filippg
23.04.2013, aktualisiert um 23:51 Uhr
Hallo,

die Fehlermeldung kenne ich zwar nicht, aber sie klingt doch sehr aufschlussreich:
the log file sector size does not match the current volume's sector size

Übersetzt: Jeder Datenträger hat ein Dateisystem, in diesem ist der Datenträger in kleinstmögliche Blöcke (Sektoren) unterteilt. Und deren Größe war früher anders als jetzt, was Exchange stört. Im allgemeinen ist die Sektorgröße aus Anwendungssicht ziemlich egal (da kümmert sich das OS drum), aber nachdem Exchange ziemlich IO-Optimiert ist, scheint man hier auch auf das Alignment der Sektoren geachtet zu haben.

Möglichkeiten könnten sein: a) formatiere das Log-Volume neu und gebe die richtige Sektorengröße an (aber frage mich nicht, wie du die herausfindets) b) schmeiße die Log-Dateien weg, dann wird Exchange meckern, dass ihm Logdateien fehlen, aber zum Thema "Wiederherstellung einer DB ohne zugehörige Logfiles" findest du sicher was im Internet. Natürlich kann das mit Datenverlust verbunden sein.

Gruß

Filipp

Edit: hat mich jetzt schon interessiert, weil ich es wie gesagt nicht kannte.
Das Thema ist aber nicht ganz unbekannt, es tritt wohl vor allem im Rahmen von Replikation (DAG) zwischen unterschiedlich aufgesetzten Clustern auf (jetzt wissen wir auch warum es heißt: "Zwei Knoten eines Clusters sollten stets identisch sein"). http://blogs.technet.com/b/timmcmic/archive/2013/04/23/exchange-2010-da ... beschäftigt sich damit ganz eingehend. Demnach sollte eseutil /ml auch eine Aussage zur Sektorgröße machen -hoffentlich nicht nur zur vorliegenden, sondern auch zur erwarteten.
Beim Überfliegen von http://technet.microsoft.com/en-us/library/ee832792%28v=exchg.141%29.as ... scheint es übrigens so zu sein als kämen nur 512-Byte oder, wenn der Server nach SP1 aufgesetzt wurde auch 512e (was immer das genau sein möge), als mögliche Sektorgrößen in Frage...
Bitte warten ..
Mitglied: filippg
26.04.2013 um 13:36 Uhr
Hallo,

das MS Exchange Team hat die Woche den zum Thema passenden, sehr ausführlichen Artikel veröffentlicht: http://blogs.technet.com/b/exchange/archive/2013/04/24/exchange-2010-da ...
(da ist auch erklärt, was 512e-Disks sind - wieder was gelernt).
Aber nachdem der TO ncihts mehr von sich hat hören lassen scheint das Problem ja gelöst (Danke für die Rückmeldung).

Gruß

Filipp
Bitte warten ..
Neuester Wissensbeitrag
Humor (lol)

Linkliste für Adventskalender

(3)

Information von nikoatit zum Thema Humor (lol) ...

Ähnliche Inhalte
Windows Server
Exchange 2010 Keine Verbindung zum LDAP-Server (7)

Frage von westberliner zum Thema Windows Server ...

Exchange Server
gelöst Exchange 2010 PublicFolder Replication auf zweiten Exchange Server abschalten (2)

Frage von fragenumfragen zum Thema Exchange Server ...

Heiß diskutierte Inhalte
Windows Server
DHCP Server switchen (25)

Frage von M.Marz zum Thema Windows Server ...

SAN, NAS, DAS
gelöst HP-Proliant Microserver Betriebssystem (14)

Frage von Yannosch zum Thema SAN, NAS, DAS ...

Grafikkarten & Monitore
Win 10 Grafikkarte Crash von Software? (13)

Frage von Marabunta zum Thema Grafikkarten & Monitore ...

Windows 7
Verteillösung für IT-Raum benötigt (12)

Frage von TheM-Man zum Thema Windows 7 ...