Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Exchange 2010 - eMails externe Empfänger (außerhalb AD) gehen nicht raus (DNS query failed)

Frage Microsoft Exchange Server

Mitglied: toxictype

toxictype (Level 1) - Jetzt verbinden

13.02.2015 um 09:43 Uhr, 1213 Aufrufe, 7 Kommentare, 1 Danke

Guten Morgen allerseits,

wir haben einen Exchange 2010, der die "externe Windows SBS-Domäne" firma1.de unter "Akzeptierte Domäne" als "Interne Relaydomäne" eingetragen hat.
firma1.de ist wird nur teilweise vom Exchange verwaltet, d.h. ein Teil der eMail-Adressen xxx@firma1.de ist im Exchange eingetragen, aber der Großteil liegt auf einem externen Webserver.

Der Exchange versendet interne eMails (vom AD ins AD) und externe eMails (vom AD an ext. Web- bzw. Mailserver). Das Problem ist, dass eMails an Adressen mit derselben Domain (Suffix firma1.de) nicht verschickt werden, wenn diese nicht im AD eingetragen sind. Entsprechende Nachrichten sammeln sich mit dem Fehler "451 4.4.0 DNS query failed" in der Warteschlange.

Das Häkchen "Nachrichten blockieren, die an..." unter "Hub-Transport" -> "Antispam" -> "Empfängerfilterung" ist draussen, also deaktiviert.
Den Tipp, firma1.de als "externe Relaydomäne" zu verwenden schlug fehl, da Exchange dies nicht zulässt.
Die Sendeconnectoren sollten funktionieren, da andere eMails auch raus gehen.
nslookup ergibt Folgendes:

nslookup firma1.de
Server: UnKnown
Address: <IPv6-Adresse>

Nicht autorisierende Antwort:
Name: firma1.de
Address: <korrekte ext. IP des Webservers von firma1.de>


Ich hoffe, ich kann noch mal auf eure Hilfe zählen.

Vielen Dank & Gruß,
tox




Mitglied: BirdyB
13.02.2015 um 10:22 Uhr
Hi,

Hast du einen Sendeconnector mit Bereichsdefinition für "firma1.de" angelegt? Dann könntest du dort mal den zweiten Mailserver als Smarthost eintragen und es erneut probieren!
Kannst du uns bitte auch noch einen nslookup der MX-Records schicken? nslookup -q=mx firma1.de

Beste Grüße!


Berthold
Bitte warten ..
Mitglied: toxictype
13.02.2015 um 12:52 Uhr
Hallo Berthold,

neben dem vom System erstellten Sendeconnector habe ich einen für "firma1.de" angelegt.
Dieser hat als SMTP-Adressraum *.firma1.de und eMails werden (bzw. sollen) über den Smarthost firma1.de weitergeleitet.
Für den Smarthost habe ich auf dem externen Webserver eigens eine Adresse mit Standardauthentifizierung angelegt, mit der versendet werden soll (pseudosbs@firma1.de).

nslookup der mx-Records für firma1.de sehen so aus:
Server: UnKnown
Address: <IPv6-Adresse>

Nicht autorisierende Antwort:
firma1.de MX preference = 10, mail exchanger = <korrekte ext. IP des Webservers von firma1.de>.firma1.de
firma1.de MX preference = 20, mail exchanger = <korrekte ext. IP des SBS (feste IP vom Provider)>.firma1.de

Ich habe zwei MX eingerichtet, da eMails weiterhin an Empfänger gehen sollen, die nicht auf dem SBS eingetragen sind und diese
weiterhin mit POP3 bzw. IMAP abgerufen werden sollen.

Danke & Gruß,
tox
Bitte warten ..
Mitglied: toxictype
13.02.2015, aktualisiert um 13:10 Uhr
Kann es sein, dass etwas mit den DNS-Einstellungen des ext. Webservers nicht passt!?
Das Ergebnis der MX-Abfrage mit der IP und im Anschluss die Domain sieht doch komsich aus...
Bitte warten ..
Mitglied: goscho
13.02.2015 um 13:12 Uhr
Hallo tox,

bist du beim Einrichten des gemeinsamen Adressraumes nach dieser Anleitung aus dem MS-Technet vorgegangen?

Dann sollte es eigentlich klapptn.
Bitte warten ..
Mitglied: toxictype
13.02.2015 um 13:34 Uhr
Hallo Goscho,

die Seite habe ich mir auch schon zu Gemüte geführt.
Ich habe allerdings <lokale Domäne abc>.local als "Autorisierend" gewählt, da die Adressen von firma1.de halt nicht nur auf dem SBS zu finden sind.
firma1.de hat die Eigenschaft "Internes Relay".

Danke & Gruß,
tox

P.S.: Muss bei den Sendeconnectoren auf der Registerkarte "Allgemein" zwingend ein FQDN angegeben werden?
Bitte warten ..
Mitglied: toxictype
13.02.2015, aktualisiert um 14:42 Uhr
Es scheint, als sei der Fehler gefunden...
Zumindest ist der erste Schwung eMails raus und ich hoffe, dass es auch so bleibt.

Ich habe beim Provider angerufen und nochmals um Prüfung der MX- und A-Records gebeten.
Nach den obligatorischen Antworten, wie "Ist alles ok!", etc. funktionierte es dann nach ca. 30 min.

Mal abwarten...
Bitte warten ..
Mitglied: 120615
19.02.2015 um 03:04 Uhr
Hallo,

Schalten Sie den EDNS0 Funktion auf Windows-basierten DNS-Servern. Um dies zu tun, nehmen Sie die folgenden Maßnahmen:


              Öffnen Sie die Eingabeaufforderung mit auf Als Administrator ausführen,

     Geben Sie den folgenden Befehl ein, und drücken Sie die Eingabetaste:

dnscmd / config / enableednsprobes 0

              Tat das gleiche auf allen Domänencontrollern.

              Gewählte die Nachricht zu wiederholen oder Neustart Transport feste mein Problem.

_________________________________________________________________
Ursache:
Dieses Problem tritt aufgrund der Erweiterungsmechanismen für DNS (EDNS0) Funktionen, die in Windows Server DNS unterstützt wird.
EDNS0 ermöglicht größere UDP (User Datagram Protocol) Paketgrößen. Jedoch können einige Firewall-Programme nicht erlauben, UDP-Pakete, die größer als 512 Bytes sind. Daher können diese DNS-Pakete von der Firewall blockiert werden ..

Danke Freund
Bitte warten ..
Ähnliche Inhalte
Exchange Server
gelöst Probleme mit Exchange 2010 und externem Relay (2)

Frage von mgcluebeck zum Thema Exchange Server ...

Exchange Server
Falscher Anzeigename bei Email-Empfang von Kontakten (8)

Frage von user080155 zum Thema Exchange Server ...

Exchange Server
gelöst Email in Exchange an 2ten Empfänger senden (18)

Frage von MultiStorm zum Thema Exchange Server ...

Exchange Server
gelöst Exchange 2016 spezifische externe adresse erhält keine Mail (6)

Frage von theoberlin zum Thema Exchange Server ...

Neue Wissensbeiträge
Viren und Trojaner

Ransomware or Wiper? RedBoot Encrypts Files but also Modifies Partition Table

Information von BassFishFox zum Thema Viren und Trojaner ...

Notebook & Zubehör

WOL bei HP Notebooks

(6)

Erfahrungsbericht von Henere zum Thema Notebook & Zubehör ...

LAN, WAN, Wireless

Neue Cisco Catalyst-Serie 9000

Information von Kuemmel zum Thema LAN, WAN, Wireless ...

Heiß diskutierte Inhalte
Windows 10
Netzwerkkarte schaltet sich erst nach dem Logon ein (23)

Frage von DerWoWusste zum Thema Windows 10 ...

Windows Server
Seit IP Umstellung DC DNS Fehler (18)

Frage von Yaimael zum Thema Windows Server ...

Netzwerke
Mobile Einwahl IPSec VPN von iPhone iPad T-Mobile zur Pfsense (16)

Frage von Spitzbube zum Thema Netzwerke ...

Weiterbildung
gelöst Fest angestellter Admin oder Systemhaus Admin mit Kundenbetreuung? (15)

Frage von Voiper zum Thema Weiterbildung ...