Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Exchange 2010 Fehlermeldung bei Aufruf der öffentlichen Ordner-Verwaltungskonsole

Frage Microsoft Exchange Server

Mitglied: manuel1985

manuel1985 (Level 2) - Jetzt verbinden

02.10.2012 um 11:11 Uhr, 3217 Aufrufe, 11 Kommentare

Hi,
ich stecke gerade in einer Migration von SBS 2003 zu Server 2008 R2 und Exchnage 2010.
Alles ist migriert, allerdings zicken seit Tagen die öffentlichen Ordner.

Folgende Fehlermeldung erhalte ich, wenn ich die öO in der Exchange Verwaltungsshell abfragen will:

[PS] C:\Windows\system32>Get-PublicFolder
Die Benennung "Get-PublicFolder" wurde nicht als Name eines Cmdlet, einer Funktion, einer Skriptdatei oder eines ausfüh
rbaren Programms erkannt. Überprüfen Sie die Schreibweise des Namens, oder ob der Pfad korrekt ist (sofern enthalten),
und wiederholen Sie den Vorgang.
Bei Zeile:1 Zeichen:17

Get-PublicFolder <<<<

+ CategoryInfo : ObjectNotFound: (Get-PublicFolder:String) [], CommandNotFoundException
+ FullyQualifiedErrorId : CommandNotFoundException


Wenn ich die öO via öffentliche Ordner-Verwaltungskonsole abfragen will, bekomme ich folgende Meldung:
"Die Benennung "get-publicfolder" wurde nicht als Name eines Cmdlet, einer Funktion, einer Scriptdatei oder eines ausführbaren Programms erkannt. Überprüfen Sie die Schreibweise des Namens, oder ob der Pfad korrekt ist (sofern enthalten), und wiederholen Sie den Vorgang."

Ich habe bereits alle Exchnage-Dienst einmal neugestartet, alle Ex-Konsolen geschlossen und neu geöffnet, aber der Fehler geht nicht weg.

Hat jemand eine Idee?
Mitglied: Luie86
02.10.2012 um 11:15 Uhr
Hi,

du bist dir ganz sicher, dass du auch wirklich die Ex-ManagementShell genommen hast?

Gruß Daniel
Bitte warten ..
Mitglied: manuel1985
02.10.2012 um 11:28 Uhr
Ja. Die ist standardmäßig offen, durch die Migration ;)
Bitte warten ..
Mitglied: 7Gizmo7
02.10.2012 um 12:34 Uhr
Welche Berechtigungen hast du den ?
Public Folder Management ?
Bitte warten ..
Mitglied: manuel1985
02.10.2012 um 12:40 Uhr
Habe volle Administratoren-Rechte.
Bin als "Administrator" mit Domänen-, Schema- und Organisations-Admin-Rechten unterwegs.
Bitte warten ..
Mitglied: Luie86
02.10.2012 um 13:06 Uhr
Hast du es mal mit der "Windows Powershell Modules" Verknüpfung / Shell probiert?
Dort werden (soweit ich weiß) alle Module geladen, sollte also funzen.
Bitte warten ..
Mitglied: manuel1985
02.10.2012 um 13:58 Uhr
@ Luie: Wie soll das funktionieren?

@ Gizmo: Funktioniert.
Bitte warten ..
Mitglied: Luie86
02.10.2012 um 14:10 Uhr
Ich habe im Startmenü (aufm Exchange-Server) diese Verknüpfung.

Ansonsten führ einfach mal den Befehl aus:
01.
%SystemRoot%\system32\WindowsPowerShell\v1.0\powershell.exe -NoExit -ImportSystemModules
Bitte warten ..
Mitglied: manuel1985
02.10.2012 um 14:16 Uhr
PS C:\Windows\system32\WindowsPowerShell\v1.0> Get-PublicFolder

Name Parent Path
-----------
IPM_SUBTREE


Das scheint zu funktionieren. Zumindest kein Fehler, aber die öffentlichen System- und Standardordner sind nicht da.
Also Standard-Ordner müsste eh leer sein, aber in den Systemordner sollte was sein
Bitte warten ..
Mitglied: manuel1985
02.10.2012, aktualisiert um 14:42 Uhr
Mir fällt grad auf, dass ich in der Exchange-Management-Shell Befehle per Tab nicht mehr erweitern kann.
Falls das bei der problemlösung hilft!?
Würde später den Mailserver nochmal komplett neustarten, in der Hoffnung, dass es dann wieder funktioniert.

Edit: Reboot hat keine Abhilfe gebracht.
Edit2: Ich kann mittlerweile nach dem Reboot wieder "taben", allergings scheint es den Befehl -PublicFolder nicht zu geben. Dieser taucht in der Liste nicht auf
Bitte warten ..
Mitglied: manuel1985
08.10.2012 um 15:17 Uhr
Hat denn keiner ne Idee dazu?
(Sch*** 30 Zeichen!)
Bitte warten ..
Ähnliche Inhalte
Exchange Server
Exchange 2010 zu 2013 Migration öffentliche Ordner (2)

Frage von cptkrabbe zum Thema Exchange Server ...

Exchange Server
gelöst Exchange 2010 - Öffentliche Ordner - Kontakte (11)

Frage von 0ber0n zum Thema Exchange Server ...

Exchange Server
Exchange 2016 - Öffentliche Ordner und Postfachumzug (5)

Frage von diemilz zum Thema Exchange Server ...

Exchange Server
Exchange 2010 (SBS) Öffentlicher Ordner DB zu viel zu groß (11)

Frage von krake79 zum Thema Exchange Server ...

Neue Wissensbeiträge
Firewall

PfSense OpenVPN beschleunigen

Tipp von Dobby zum Thema Firewall ...

Utilities

CCleaner 5.33 mit Malware infiziert

(25)

Information von SeaStorm zum Thema Utilities ...

Windows Server

Exchange Server 2016 Probleme auf Server 2016 mit iOS 11 Mailapp

Information von Oneplus zum Thema Windows Server ...

Internet

Pirate Bay lässt heimlich Krypto-Miner auf Nutzer-PCs laufen

(5)

Information von BassFishFox zum Thema Internet ...

Heiß diskutierte Inhalte
Utilities
CCleaner 5.33 mit Malware infiziert (25)

Information von SeaStorm zum Thema Utilities ...

Festplatten, SSD, Raid
gelöst Problem mit DELL 815R Server und Windows Bluescreen (24)

Frage von Leo-le zum Thema Festplatten, SSD, Raid ...

JavaScript
gelöst Kopierschutz auf Webseite (13)

Frage von honeybee zum Thema JavaScript ...

Windows Server
Änderung Subnetz an AD Standort (13)

Frage von hansdampf zum Thema Windows Server ...