Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Exchange 2010 Sicherheitszertifikat Namensgebung

Frage Microsoft Exchange Server

Mitglied: flojud

flojud (Level 1) - Jetzt verbinden

09.05.2011, aktualisiert 15:38 Uhr, 15971 Aufrufe, 7 Kommentare

Wir haben in einem zu betreuenden Unternhemen 4x Windows Server 2008 R2 mit einen Exchange Server 2010 und haben dabei ein Zertifikatsproblem mit der Namensgebung unseres Servers und der externen Domäne.

Da über eine SSL Verbindung sauber gesynct werden soll haben wir auf den externen Domänen Namen ein Zertifikat erstellen lassen:

mail.meine-domäne.de

Dieses Zertifikat wurde dann von uns hinterlegt.
Nun ist in der Exchange-Verwaltungskonsole in der Serverkonfiguration folgende Zertifikatssituation zu sehen:

Selbstsigniertes Zertifikat - "Microsoft Exchange" - IMAP, POP, SMTP - CN=server-exchange
Nicht Selbstsigniertes Zertifikat - "mail.meine-domäne.de" - IIS - CN=mail.meine-domäne.de, ...

Es funktioniert der OWA und der Sync mit den Handys sauber nach der Zertifikatseinbindung.
Lediglich beim Start von Outlook erhalten alle User einen Sicherheitshinweis.

Outlook möchte das Zertifikat der externen Domäne verwenden, welches natürlich nicht zu unserem Server/Verbindungsnamen passt.

35c0bd83b2038dfeab45087572351ff9 - Klicke auf das Bild, um es zu vergrößern

An welcher Stelle ist nun was zu korigieren?

Vielen Dank im Voraus für Eure Tipps/Hilfe.
Mitglied: ollembyssan
09.05.2011 um 17:31 Uhr
Hallo,

Stichwort "Autodiscover".

Set-AutodiscoverVirtualDirectory -Identity 'autodiscover (default Web site)' -ExternalUrl 'http://www.contoso.com'"
Set-AutodiscoverVirtualDirectory -Identity 'autodiscover (default Web site)' -InternalUrl 'http://www.contoso.local'"

Oder aber per SRV:
http://stephan-mey.de/?p=705
http://stephan-mey.de/?p=815

Gruß
Stephan
Bitte warten ..
Mitglied: flojud
11.05.2011 um 13:15 Uhr
Hallo Stephan,

ich habe die besagten AutodiscoverVirtualDirectory Befehle in der Exchange Management Console ausgeführt mit den Werten der:
die Erreichbarkeit habe ich geprüft, Funktion war i.O..

Wenn ich nun die Autokonfiguration im Outlook teste sehe ich:
Autodiscover to https://server-exchange.meine-domaene.local/Autodiscover/Autodiscover.xm ... starting
GetLastError = 12175; httpStatus=0,
GetLastError = 0; httpStatsus = 200.
Autodiscover to https://server-exchange.meine-domaene.local/Autodiscover/Autodiscover.xm ... succeeded
und der Sicherheitshinweis erscheint immernoch, da noch auf das "falsche" Zertifikat verwiesen wird.

Der Error 12175 besagt wieder:
ERROR_WINHTTP_SECURE_FAILURE
12175
One or more errors were found in the Secure Sockets Layer (SSL) certificate sent by the server. To determine what type of error was encountered, check for a
WINHTTP_CALLBACK_STATUS_SECURE_FAILURE notification in a status callback function. For more information, see WINHTTP_STATUS_CALLBACK.




Des weiteren habe ich den SRV Eintrag im DNS geprüft.
Hier habe ich in den Forward-Lookupzonen die Zonen:
1. meine-domäne.de
- Host (A) Eintrag mit "mail" auf die IP des des server-exchange
- _tcp Eintrag _autodiscover auf mail.meine-domäne.de
2. meine-domäne.local
- _tcp Eitnrag _autodiscover auf server-exchange.meine-domäne.local

Grüße und besten Dank im Voraus!

Florian
Bitte warten ..
Mitglied: flojud
16.05.2011 um 08:50 Uhr
Hat mir denn keiner mehr einen guten Rat?!
Bitte warten ..
Mitglied: flojud
16.05.2011 um 13:02 Uhr
Ich habe das Problem soeben selber gelöst bekommen, dabei war noch folgendes zu tun.

Ich habe nun das Autodiscover so eingerichtet, dass er sowohl intern als auch extern über die externe Domäne zugreift.
Zuvor habe ich ja in meinem DNS-Server den Autodiscover Wert gesetzt, so dass dieser auch erreichbar/auflösbar ist.

Nun ist in der Exchange Management Shell folgende Befehle ausgeführt.

set-ClientAccessService -AutodiscoverServiceInternalUri https://mail.meine-domaene.de/Autodiscover/Autodiscover.xml
set-WebServicesVirtualDirectory -identity "SERVER-EXCHANGE\EWS (Default Web Site)" -internalurl https://mail.meine-domaene.de/ews/exchange.asmx
set-OABVirtualDirectory -identity "SERVER-EXCHANGE\OAB (Default Web Site)" -internalurl https://mail.meine-domaene.de/OAB

Wichtig ist nun noch, dass man im IIS-Manager unter seinem Server / Anwendungspools, den Pool MSExchangeAutodiscoverAppPool neustartet, dies geht über "Wiederverwenden"

Nun geht meine Outlook Exchange Verbindung/ Autodiscover komplett über meinen externen Domänen Namen und es tritt kein Zertifikatsproblem mehr auf!
Bitte warten ..
Mitglied: M3ltdown
08.04.2012 um 09:30 Uhr
Danke an flojud! Genau das hat mir noch gefehlt.


Allerdings war die erste Zeile bei mir:

C:\Windows\system32>Set-ClientAccessServer -identity "ABG-EX04" -AutodiscoverServiceInternalUri https://mail.MEINEDOMAENE.at/Autodiscover/Autodiscover.xml
Bitte warten ..
Mitglied: foehny
25.04.2012 um 12:51 Uhr
Hallo Zusammen,

ich versuche gerade auf einem SBS-2011 das Problem nach Eurer Anleitung zu lösen, habe aber das Prolbem, dass "set-ClientAccessService" in der Management Shell nicht als Befehl erkannt wird. Hat jemand eine Idee woran das liegen könnte?

Gruß

Sven
Bitte warten ..
Mitglied: M3ltdown
25.04.2012 um 12:58 Uhr
Hallo Sven,

siehe meinen vorigen Post!
Bitte warten ..
Neuester Wissensbeitrag
Windows 10

Powershell 5 BSOD

(8)

Tipp von agowa338 zum Thema Windows 10 ...

Ähnliche Inhalte
Exchange Server
gelöst Exchange 2010 - Anonymes relay für einzelnen Client?? (14)

Frage von eastfrisian zum Thema Exchange Server ...

Exchange Server
Exchange 2010 Akzeptierte Domäne löschen (4)

Frage von Rob1982 zum Thema Exchange Server ...

Exchange Server
gelöst Exchange 2010 Berechtigungen wiederherstellen (21)

Frage von semperf1delis zum Thema Exchange Server ...

Heiß diskutierte Inhalte
Microsoft
Ordner mit LW-Buchstaben versehen und benennen (21)

Frage von Xaero1982 zum Thema Microsoft ...

Netzwerkmanagement
gelöst Anregungen, kleiner Betrieb, IT-Umgebung (18)

Frage von Unwichtig zum Thema Netzwerkmanagement ...

Windows Update
Treiberinstallation durch Windows Update läßt sich nicht verhindern (17)

Frage von liquidbase zum Thema Windows Update ...