Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Exchange 2010 Unable to relay per SMTP

Frage Microsoft Exchange Server

Mitglied: OOOmorpheusOOO

OOOmorpheusOOO (Level 1) - Jetzt verbinden

02.02.2012 um 14:15 Uhr, 22002 Aufrufe, 24 Kommentare, 1 Danke

Hallo Admins und Exchange Freunde

Ich habe einen Exchange 2010 Server eingerichtet OutlookAnywhere geht auch. Da es leider Menschen gibt, für die Thunderbird lebensnotwendig ist muss das ganze auch damit funktionieren.

Ich kann das Konto (POP und SMTP) problemlos einrichten und an interne User Mails verschicken (Mails können empfangen werden). Sobald eine Mail an externe Empfänger versendet wird kommt folgender Fehler:

Serverfehler: "550 5.7.1 Unable to relay"

Wenn ich testweise die Domain des externen Empfängers als akzeptierte Domain hinzufüge geht das auch. Ich kann doch jetzt aber nicht die Millionen Domains dort eintragen...

Hat noch jemand eine Idee, was ich da machen kann?

Bei dem Exchange Server handelt es sich um einen SBS 2011, Mails werden z.Zt. noch per POP3-Connector abgeholt.

Mit freundlichen Grüßen

OOOmorpheusOOO
Mitglied: Chonta
02.02.2012 um 14:30 Uhr
Hallo,

wieviele SMTP-Server sind im Thunderbird eingetragen? (bei mehreren richtig zugewiesen?)
Wenn die Mail an die gleiche Mailadresse über das Webmail/Outlook(2003/2007/2010) gesendet wird geht es?
Was sagt die Statusverfolgung vom Mailserver?

Gruß

Chonta
Bitte warten ..
Mitglied: OOOmorpheusOOO
02.02.2012 um 14:46 Uhr
Hallo Chonta,

ich habe das mit Outlook 2010 getestet (POP-SMTP).
Die Mail scheint gar nicht raus zu gehen, da die unzustellbarkeit sofort da ist und ich die Mail auch auf dem Server nicht finde.

Gruß
OmO
Bitte warten ..
Mitglied: Chonta
02.02.2012 um 15:24 Uhr
Hallo,

und über Mapi?
Wenn über Webmail die mail verschickt wird, dann versendet der Mailserver direkt. Wenn das geht ist der Client falsch eingerichtet in Bezug auf den SMTP-server.
Wichtig wäre das was der Exchange sagt, beim 2003er gab es die Nachrichtenstatuskonsole, mit der man die Nachrichten proma verfolgen konnte und sehen konnte wo es haberte.
Kann dein Exchange überhaupt mals nach draußen versenden?
Habt ihr eine Feste IP? Benutzt ihr einen Relayserver (Smarthost)? (bei letzsterem hat der Exchange evtl. eine falsche Autentifizierung und darf über den Relayserver nichts senden)

Wie sind die Einstellungen des virtuellen SMTP-Servers?

Gruß

Chonta
Bitte warten ..
Mitglied: filippg
02.02.2012 um 21:23 Uhr
Hallo,

ich würde vorschlagen, einfach nach "Exchange 2010 Unable to relay" zu suchen. Dazu findet sich so viel im Internet (und auch vernünftiges), das müssen wir dir jetzt wirklich nicht nochmal vorkauen.
Allerdings verstehe ich nicht, warum du Outlook an Exchange mit POP3 und SMTP verwendest - aber okay.

Gruß

Filipp
Bitte warten ..
Mitglied: OOOmorpheusOOO
02.02.2012 um 22:01 Uhr
Hallo Chonta,

ja der Exchange kann nach aussen verschicken. Wenn ich Outlook per Outlook anywhere anbinde gehen die Mails ja auch raus, nur wenn ich den POP und SMTP nehme wills einfach nicht (an externe - an internet User gehts wunderbar und empfangen kann ich auch alles).

Wir nutzen einen Smarthost zum Versand (über exchange nach extern gehts ja auch, nur warum so nicht?

Mich wundert ja im Moment nur, wenn ich eine Mail an ich@du.com schicken möchte und ich du.com als akzeptierte Domäne eintrage gehen die Mails raus.

der Sendeconnector hat folgende Einstellungen:

Max. Message Size 10240; Adressraum smtp (Typ) * (Adresse) 1 (Kosten); E-Mail über folgende Smarthosts leiten: unser Anbieter der Rest ist Standard (geht ja auch über Exchange)

LG
OmO
Bitte warten ..
Mitglied: OOOmorpheusOOO
02.02.2012 um 22:02 Uhr
ich würde vorschlagen, einfach nach "Exchange 2010 Unable to relay" zu suchen. Dazu findet sich so viel im Internet
(und auch vernünftiges), das müssen wir dir jetzt wirklich nicht nochmal vorkauen.
Allerdings verstehe ich nicht, warum du Outlook an Exchange mit POP3 und SMTP verwendest - aber okay.

Danke ich bin ja nach Tagen des Suchens und Ausprobierens hier gelandet...

LG
OmO
Bitte warten ..
Mitglied: filippg
03.02.2012 um 00:52 Uhr
Hallo,

Danke ich bin ja nach Tagen des Suchens und Ausprobierens hier gelandet...
Na, was hast du denn schon gefunden, und was ausprobiert?

Dein Receive connector nimmt die Mails von deinem Client an externe Empfänger nicht an. Das ist erstmal auch Absicht, Exchange nimmt nur Mails an Domains an, die es als Accepted Domain hinterlegt hat. Und es gibt zwei Abhilfen:
1. man kann den Client am Connector authentifizieren (SMTP-Auth). Dazu müssen auf dem Connector bei "Permission Groups" die "Exchange Users" zugelassen sein (einen solchen Connector legt Ex2010 afaik bei der Installation per default auf Port 587 an. Diesen zu verwenden ist eine bessere Idee, als den auf Port 25 anzupassen.
2. Man kann den Connector so einstellen, dass er auch unauthentifiziert den Versand nach extern ermöglicht. Der passende cmdlet-Aufruf dazu lässt sich z.B. mit o.g. Suchbegriff im dritten Hit finden: Get-ReceiveConnector RelayConnector | Add-ADPermission -User “NT AUTHORITY\ANONYMOUS LOGON” -ExtendedRights “ms-Exch-SMTP-Accept-Any-Recipient”. Wen man das macht muss man aber aufpassen, dass der Connector nur aus dem internen Netz erreichbar ist, nicht aus dem Internet. Sonst hat man ein Open Relay gebaut und bekommt ein Spam-Problem.

Gruß

Filipp
Bitte warten ..
Mitglied: OOOmorpheusOOO
06.02.2012 um 13:49 Uhr
Es geht noch weiter...

Wenn ich weiter probiere, Mails zu versenden bekomme ich ja diese Antwort:

Ihre Nachricht hat einige oder alle Empfänger nicht erreicht.

Betreff: test3
Gesendet am: 06.02.2012 13:41

Folgende(r) Empfänger kann/können nicht erreicht werden:

Adresse@E-Mail.tld am 06.02.2012 13:41
Serverfehler: "550 5.7.1 Unable to relay"'


Wenn ich eine solche Mail ein Paar Tage später öffne sieht es so aus:

Ihre Nachricht

An: Adresse@E-Mail.tld
Betreff: test2
Gesendet: 06.02.2012 13:40


Wo ist der ganze Rest geblieben?

Mich wundert ja einfach nur, warum ich Mails nach extern verschicken kann, wenn ich am Exchange-Server angemeldet bin und sobald ich über das POP3/SMTP-Konto gehe gehts nicht und ich bekomme diesen Fehler. Zu Testzwecken habe ich auch schon ein offenes Relay gebaut - ging auch nicht.

Mit den Empfangsconnectoren im Exchange hab eich jede Menge herumgeschraubt - alles ohne Erfolg. Warum geht denn das, wenn ich die akzeptierte Domain dort hinzu füge?
Wenn ich mich nicht ganz Irre, sollte das doch sofort funktionieren oder?

Wenn ich mit Outlook komme und meine Zugangsdaten eingetragen habe bin ich ja auch kein annonymer User mehr, sondern ein Exchange User...

LG
OmO
Bitte warten ..
Mitglied: mspano
11.07.2013 um 20:20 Uhr
Hallo,
ich weiß, der Eintrag ist bereits lange her, aber hast Du denn eine Lösung gefunden?
Ich habe haargenau das gleiche Porblem.
Über Mapi und OWA funktioniert alles (empfangen, senden an intern, senden an extern).
Verbinde ich mich von einem externen client über pop3 und will an extern versenden (an intern funktioniert es auch), kommt " 550 5.7.1 Unable to relay".

Ich habe POP3 aktiviert, im Client Empfangsconnector im Exchange die Exchange Authentifizierung eingestellt, am versendenden Client entsprechend den Port 587 mit eigener Authentifizierung konfiguriert....

Ich habe keine Ahnung, was noch fehlt.

Muss denn der IIS resettet werden? Vielleicht die virtual Directories irgendwie angepasst werden?

Bitte helft mir, ich brauche diese Funktion.
Gruß MSP
Bitte warten ..
Mitglied: OOOmorpheusOOO
11.07.2013, aktualisiert um 20:40 Uhr
Hi msp,

leider habe ich keine Lösung gefunden - ach ja eine Lösung gab es... Ich habe die User überzeugt Thunderbird zu entsorgen und auf Outlook umzusteigen.

Über Outlook Anywhere läuft ja alles super.

Leider kann ich dir keine andere Antwort geben.

LG

OmO
Bitte warten ..
Mitglied: mspano
11.07.2013 um 21:33 Uhr
Zitat von OOOmorpheusOOO:
Hi msp,

leider habe ich keine Lösung gefunden - ach ja eine Lösung gab es... Ich habe die User überzeugt Thunderbird zu
entsorgen und auf Outlook umzusteigen.

Über Outlook Anywhere läuft ja alles super.

Leider kann ich dir keine andere Antwort geben.

LG

OmO

Hi OmO,

das kann doch nicht sein. Hat denn keiner eine Ahnung, wie ich den Exchange dazu bringen kann eine SMTP Authentifizierung von extern zu fressen?
Wir haben einen externen Webshop, der signierte Mails an verschiedene Kunde schickt. Über unseren alten Exchange 2007 hat das Problemlos funktioniert: Einfach einen Benutzer im AD angelegt (sogar ohne angehängte Mailbox), der dann mit der Mailadresse einer Verteilergruppe gesendet hat. Antworten gingen dann schön an alle Mitglieder der Verteilergruppe und ich musste noch nicht einmal eine CAL dafür verbraten.
Weder das, noch ein vollwertiger Exchange Accouont mit Mailbox kann über eine POP3 Anbindung Mails verschicken. Nach intern geht, abrufen geht auch nur an externe Mailadressen funktioniert einfach nicht...

Ich glaube, ich geh mal an Microsoft...

Danke trotzdem für die schnelle Antwort.

Gruß,
MSP
Bitte warten ..
Mitglied: OOOmorpheusOOO
11.07.2013 um 21:55 Uhr
Falls du eine Lösung hast, bin ich sehr dran interessiert!
Viel Erfolg!
Lg
OmO
Bitte warten ..
Mitglied: Chonta
11.07.2013 um 23:02 Uhr
Hallo,

die Ports für die Dienste sind auch in Serverfirewall und Router freigegeben?
Man kann z.B. Benutzern auch Verweigern Dienste wie IMAP POP oder dergleichen zu verwenden.

Funktioniert ein IMAP/SMTP Zugriff im interneen Netz des Servers?

Wenn der Server generell Mails versenden und empfangen kann, ist SMTP auf dem Server im Prinzip auch in Ordnung.

Und zum verbinden mit SMTP von außerhalb wird auch die Feste IP vom Internetanschluss benutzt?


Gruß

Chonta
Bitte warten ..
Mitglied: mspano
12.07.2013 um 06:26 Uhr
Hallo Chonta.

Wie schon gesagt, die Funktion an sich ist gegeben. Ich kann über Pop empfangen und interne Mails (also die mit den bekannten und zugelassenen domains) über smtp versenden.
Ich kann nur nicht an extrerne domains senden. Es klingt alles nach einer Berechtigungsgeschichte im Empfangsconnector. Da habe ich aber bereits alle Vaianten getestet. Ich kann einfach keine Mails an externe Maildomänen verschicken, wenn ich an einem externen Client mit Pop3 verbunden bin.

Gruß. MSP
Bitte warten ..
Mitglied: Chonta
12.07.2013 um 07:38 Uhr
Hallo,

http://social.technet.microsoft.com/Forums/en-US/1a84a06a-f1c8-40b4-ace ...

"and finally check the "Allow all computers witch successfully authenticate to relay, regardless of the list above" checkbox. "

Evtl hilft das weiter.

Gruß

Chonta
Bitte warten ..
Mitglied: mspano
12.07.2013, aktualisiert um 12:07 Uhr
Hallo Chonta,

danke für den Tipp. Dort geht es aber in erster Linie um Exchange 2003. Wo habe ich die Möglichkeit, diese Einstellung am Exchange 2010 zu setzen?
Ein Tipp, den ich da noch rausziehen konnte, der aber leider nicht funktioniert hat, war das Abschalten der TLS am Empfangsconnector. Aber... wie geagt - leider ohne Erfolg.

Bin mal gespannt, was Microsoft sagt.
Als Übergangslösung nutzen wir nun den SMTP von unserem Provider - nicht sooooo elegant und man muss eben an zwei Stellen administrieren, aber ... es geht.

Gruß,
MSP
Bitte warten ..
Mitglied: mspano
15.07.2013 um 16:21 Uhr
Hallo,

das Problem mit der externen Anmeldung am SMTP und das Versenden darüber an externe Adressen konnte gelöst werden.

Das Problem, dass der AutoRply an externe Adressen nicht funktioniert (nur an interne), besteht weiterhin (ich dachte fälschlicherweise, die Ursache sei die gleiche.

Lösung zum Versenden an externe Adressen über externe Verbindung zum Exchange:

- Im Exchange Web Service (EWS) Virtual Directory war die public URL nicht hinterlegt.

- in der Exchange Management Shell mit "Get-webservicesvirtualdirectory | fl identity,internalurl,externalurl" anzeigen lassen und falls eine der beiden URLs fehlt,

- mit "Set-WebServicesVirtualDirectory -Identity "EWS (default web site)" -ExternalUrl https .externeURL.com/EWS -BasicAuthentication $true -InternalUrl https:interneURL.local/EWS" die entsprechenden URLs einsetzen.

Jetzt müsste mein lieber Exchange nur noch AutoRplys an externe E-Mail Adressen verschicken und nicht nur an interne und ich wäre glücklich %-)

Irgendwelche Ideen?

Gruß,
MSP
Bitte warten ..
Mitglied: filippg
16.07.2013 um 00:36 Uhr
Hallo,

- Im Exchange Web Service (EWS) Virtual Directory war die public URL nicht hinterlegt.
Okay... ich lasse mich zu der Aussage hinreissen: ich bin mir zu 93% sicher, dass das nicht die Ursache war, sondern nur ein Zufall, dass es jetzt "zeitgleich" wegging (vielleicht mal Services durchgestartet?). EWS und Konnektorberechtigungen sind eigentlich ziemlich weit von einander entfernt.

Jetzt müsste mein lieber Exchange nur noch AutoRplys an externe E-Mail Adressen verschicken und nicht nur an interne und ich
wäre glücklich %-)
Da lautet das Zauberwort "Remotdomain" http://technet.microsoft.com/de-de/library/aa996309%28v=exchg.141%29.as ...

Gruß

Filipp
Bitte warten ..
Mitglied: mspano
16.07.2013 um 09:08 Uhr
Hi Filipp,

Danke für Dein Statement. Wie auch immer, nachdem ich die externe URL im EWS eingetragen hatte, funktionierte es - auch ohne einen Neustart der Dienste.

Zum Thema "AutoReply":
Im Technet Artikel steht lediglich, wie die Remotedaomains eingerichtet werden und was die einzelnen Einstellungen bedeuten. Ich habe die Standardeinstellungen in der "Default" plus "Allow automatic replies" und "Allow automatic forward" konfiguriert.
Was kann ich denn dort sonst noch machen?

Weiteres googlen bringt mich auf den Trichter, ggf. die AutoKonfig Einstellungen zu prüfen. Kann das evtl. damit zu tun haben? Prinzipiell funktioniert die AutoKonfig sowohl intern als auch extern an Mapi Clients hervorragend... Wenn das Deiner Meinung nach sein könnte - kannst Du mir einen Tipp geben, wo ich ansetzen könnte?

Schon Mal vielen Dank im Voraus.
MSP
Bitte warten ..
Mitglied: mspano
16.07.2013 um 14:13 Uhr
Wir haben eine Lösung für beide Probleme.
Alle Vermutungen von oben sind obsolot

- Es lag einfach daran, dass wir über einen SMTP Smarthost unseres MailDomain Providers verschikt haben. Autoreply sendet ohne Absenderadressen, was beim Provider schlichtweg gebounced wurde.
- Wir verschicken jetzt direkt ins Internet, nachdem Reverse Lookup sauber gesetzt wurde.

Danke an alle und viele Grüße,
MSP
Bitte warten ..
Mitglied: OOOmorpheusOOO
26.07.2013 um 12:02 Uhr
Hallo MSP,

also zusammenfassend kann man sagen, dass die Anbindung von Outlook an Exchange per pop-Konto funktioniert und der Exchange die aus Outlook gesendeten Mails (smtp-server=Exchange-Server) auch an die Empfänger außerhalb der Domäne versendet?

LG
OmO
Bitte warten ..
Mitglied: mspano
05.09.2013 um 13:53 Uhr
Zitat von OOOmorpheusOOO:
Hallo MSP,

also zusammenfassend kann man sagen, dass die Anbindung von Outlook an Exchange per pop-Konto funktioniert und der Exchange die
aus Outlook gesendeten Mails (smtp-server=Exchange-Server) auch an die Empfänger außerhalb der Domäne versendet?

LG
OmO

Ja. Alles wieder schön.

PS: Sorry, für die verspätete Rückmeldung - kann ich hier irgendwie eine Mailbenachrichtigung einstellen, wenn es neue Posts zu bevorzugten Themen, oder meinen eigenen Einträgen gibt?
Bitte warten ..
Mitglied: OOOmorpheusOOO
09.09.2013 um 09:24 Uhr
Hallo MSP,

ja die Einstellungen kann man so machen Einstellungen - Benachrichtigungen.

Ich frage jetzt nochmal ganz dumm, wie schickst du denn die Mails direkt ohne SMTP vom Provider?

LG
OmO
Bitte warten ..
Mitglied: mspano
09.09.2013 um 11:10 Uhr
Zitat von OOOmorpheusOOO:
Hallo MSP,

ja die Einstellungen kann man so machen Einstellungen - Benachrichtigungen.

Ich frage jetzt nochmal ganz dumm, wie schickst du denn die Mails direkt ohne SMTP vom Provider?

LG
OmO

Hi OmO,

Exchange 2010 Management Console - Organization Configuration - Hub Transport - Send Connectors - Properties

Dort nicht über einen smart host verschicken, sondern "Use omain name system (DNS) "MX" records..." verwenden, dann gehen die Mails direkt ins Internet und werden über die öffentlichen DNS Server zu Ihren Empfängern weitergeleitet.

Man muss nur darauf achten, dass man den reverse lookup DNS (PTR record) seiner IP Adresse entsprechend setzt. Das kann beim Provider, der Dir die public IPs zur Verfügung stellt entweder beantragt, oder (wie bei uns) online angepasst werden. Wird hier kein eindeutiger Mail Server name wie z.B. "MX.meinedomain.com" zugewiesen, wird es nicht lange dauern, bis die IP Deines Exchange auf einer Blacklist erscheint.
Bitte warten ..
Neuester Wissensbeitrag
Internet

Unbemerkt - Telekom Netzumschaltung! - BNG - Broadband Network Gateway

(3)

Erfahrungsbericht von ashnod zum Thema Internet ...

Ähnliche Inhalte
Exchange Server
Exchange 2010 SMTP-Connector - zusätzliches Relay (6)

Frage von FA-jka zum Thema Exchange Server ...

Exchange Server
Exchange 2010 Akzeptierte Domäne löschen (4)

Frage von Rob1982 zum Thema Exchange Server ...

Exchange Server
gelöst Exchange 2010 Berechtigungen wiederherstellen (21)

Frage von semperf1delis zum Thema Exchange Server ...

Heiß diskutierte Inhalte
Windows Server
Outlook Verbindungsversuch mit Exchange (15)

Frage von xbast1x zum Thema Windows Server ...

Grafikkarten & Monitore
Tonprobleme bei Fernseher mit angeschlossenem Laptop über HDMI (11)

Frage von Y3shix zum Thema Grafikkarten & Monitore ...

Microsoft Office
Keine Updates für Office 2016 (11)

Frage von Motte990 zum Thema Microsoft Office ...