Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Exchange 2013: Benutzerobjekt aus AD-Subdomain gelöscht, Postfach immer noch vorhanden, wird nicht als getrennt angezeigt und kann nicht gelöscht werden

Frage Microsoft Exchange Server

Mitglied: robob

robob (Level 1) - Jetzt verbinden

03.10.2013 um 16:56 Uhr, 3028 Aufrufe, 2 Kommentare

Hallo,

ich stehe gerade vor dem Problem, dass aus einer Subdomain, die abgeschafft werden soll, ein Benutzerobjekt gelöscht wurde (zu dieser Zeit gab es wohl auch Tombstone-Probleme in dieser Subdomain und es war auch nur noch 1 DC vorhanden).
Der Benutzer wurde in einer anderen Subdomain neu angelegt aber das Problem ist, dass das mit dem Benutzerobjekt aus der "alten" Subdomain ein Exchange-Postfach angelegt war und sich dieses nicht mehr löschen lässt (Meldung, dass das entsprechende Benutzerobjekt nicht mehr in der AD vorhanden ist) und auch nicht als getrenntes Postfach angezeigt wird und somit auch die ursprüngliche E-Mail-Adresse noch belegt ist, die dann eigentlich für das angelgte Benutzerobjekt in der "neuen" Domäne weiterverwendet werden soll.
Das bestehende Postfach lässt sich auch nicht mit dem Benutzerobjekt in der "neuen" Domäne verbinden, da es noch mit dem nicht mehr vorhandenen Benutzerobjekt der "alten" Domäne verbunden ist.
Habe auch bereits "Update-StoreMailboxState" in der Exchange-PowerShell auf die entsprechende Postfach-GUID angewendet aber auch danach erscheint das Postfach nicht als getrenntes Postfach.

Szenario:
2x Exchange Server 2013 Standard CU1 auf Windows Server 2012 Datacenter in einer AD-Gesamtstruktur, DAG
Die Benutzer sind alle in Subdomains (für die verschiedenen Standorte des Unternehmens)

Kurzfassung:
- Benutzerobjekt in Subdomain A gelöscht, da Replikationsprobleme mit der Subdomain (auch nur noch 1 DC für diese Subodmain vorhanden) und nur noch dieser Benutzer aktiv in dieser Domain vorhanden war
- Benutzerobjekt in Subdomain B neu angelegt
- Postfach des "alten" Benutzers aus Subdomain A lässt sich nicht löschen, da AD-Benutzerobjekt nicht gefunden wird und erscheint auch nicht als getrenntes Postfach, ist also immer noch vorhanden
- Ursprüngliche Mailadresse die für das Benutzerobjekt in Subdomain B weiterverwendet werden soll ist somit "blockiert"

Hat jemand von Euch eine Idee wie ich dieses "alte" Postfach löschen kann, ohne dass das ursprüngliche AD-Benutzerobjekt vorhanden sein muss?
Ist mir natürlich klar, dass der Benutzer in der AD nicht hätte gelöscht werden dürfen, wenn es Replikationsprobleme gibt.
Aber eigentlich ging ich davon aus, dass ein Postfach, bei dem das Benutzerobjekt nicht mehr vorhanden ist, von Exchange automatisch als getrenntes Postfach angesehen wird.
Das ganze läuft jetzt schon seit 2 Woche so aber alle meine Versuche/Test brachten keine Lösung.

Besten Dank schon mal für Eure Bemühungen/Ratschläge!

Grüße,
Robob.
Mitglied: ticuta1
04.10.2013 um 10:03 Uhr
Hallo alle optionen ausproobiert??

Remove-Mailbox -Identity contoso\john

Remove-Mailbox -Identity contoso\john -Permanent $true

$Temp = Get-Mailbox | Where {$_.DisplayName -eq 'John Rodman'}
Remove-Mailbox -Database Server01\Database01 -StoreMailboxIdentity $Temp.MailboxGuid


und

http://technet.microsoft.com/de-DE/library/ff923253%28v=exchg.150%29.as ...

LG, ticuta1
Bitte warten ..
Mitglied: robob
04.10.2013 um 14:57 Uhr
Hallo Ticuta1,

besten Dank für Deine Tipps.

Die Optionen hatte ich alle bereits ausgeführt aber sie werden alle nicht ausgeführt, es erscheint immer der Hinweis, dass das entsprechende Benutzerobjekt in der AD nicht gefunden wird (was ja stimmt) und dann wird der Vorgang leider auch nicht weiter ausgeführt.

Das cmdlet "Remove-LinkedUser" hört sich "gut" an aber irgendwie ist dies wohl unter Exchange standardmässig nicht verwendbar, zumindest wird es nicht gefunden, wenn ich es in der "Exchange Management Shell" eingebe und im Technet-Artikel steht auch "Dieses Cmdlet wird nur Microsoft-intern verwendet.".

Hat jemand eine Idee wie man an diese Commandlet kommt bzw. wie man es vielleicht doch unter Exchange 2013 ausführen kann?

Gruß,
Robob.
Bitte warten ..
Ähnliche Inhalte
Exchange Server
Exchange 2013 inconsistenter öffentliches Postfach

Frage von thomas-99 zum Thema Exchange Server ...

Exchange Server
Postfach von Exchange 2013 Cu7 auf Exchange 2016 verschieben (3)

Frage von rainergugus zum Thema Exchange Server ...

Exchange Server
OWA mit Exchange 2013 und abweichendem Gateway funktioniert nicht (9)

Frage von EDeVau zum Thema Exchange Server ...

E-Mail
gelöst Exchange 2013 Authentifizierung (11)

Frage von fundave3 zum Thema E-Mail ...

Neue Wissensbeiträge
Windows 10

Windows 8.x oder 10 Lizenz-Key aus dem ROM auslesen mit Linux

(6)

Tipp von Lochkartenstanzer zum Thema Windows 10 ...

Tipps & Tricks

Wie Hackt man sich am besten in ein Computernetzwerk ein

(39)

Erfahrungsbericht von Herbrich19 zum Thema Tipps & Tricks ...

Heiß diskutierte Inhalte
Windows 10
gelöst Windows 10 Home "Netzlaufwerk nicht bereit" (19)

Frage von Oggy01 zum Thema Windows 10 ...

SAN, NAS, DAS
+100tb Storagelösung (13)

Frage von Data-Fabi zum Thema SAN, NAS, DAS ...

LAN, WAN, Wireless
Cisco W-Lan Controller als Applicance oder Software (11)

Frage von Herbrich19 zum Thema LAN, WAN, Wireless ...

DNS
gelöst Komplette TLD Überschreiben bzw eigene Definieren (10)

Frage von Herbrich19 zum Thema DNS ...