Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Exchange 2013 CU5 fehlgeschlagen (Probleme mit Bindings und IPRanges ?)

Frage Microsoft Exchange Server

Mitglied: minimalwerk

minimalwerk (Level 1) - Jetzt verbinden

21.06.2014 um 14:06 Uhr, 4651 Aufrufe, 4 Kommentare

Hallo liebe Community,

vielleicht kann hier einer helfen. Wir haben Exchange 2013 auf einem Server 2008R2 (aktuellster Updatestand) mit dem POPConnector von Servolutions laufen. Momentan sind nur 2 Postfächer verbunden da wir den Exchange erstmal testen wollten. Weitere Mitarbeiter holen ihre Mail noch per POP beim Provider ab. Bis zum SP3 lief der Exchange einwandfrei. Heute früh haben wir nun das CU5 eingespielt welches mitten drin abbrach. Folgende Fehlermeldung liegt vor:

[06.21.2014 11:06:57.0072] [1] [ERROR] The following error was generated when "$error.Clear();  
          $connectors = Get-ReceiveConnector -Server $RoleFqdnOrName; 
          foreach($connector in $connectors) { if($connector.MaxLocalHopCount -gt 1) { Set-ReceiveConnector -Identity $connector.Identity -MaxLocalHopCount 5 } }; 
        " was run: "Microsoft.Exchange.Management.SystemConfigurationTasks.ReceiveConnectorRoleConflictException: Die von Ihnen angegebenen Werte für die Parameter "Bindings" und "RemoteIPRanges" stehen im Konflikt mit den Einstellungen für den Empfangsconnector "SERVER2\Pullution". Empfangsconnectors, die auf einem einzigen Server verschiedenen Transportrollen zugewiesen sind, müssen an eindeutigen, lokalen IP-Adressen und Portbindungen lauschen. 
   bei Microsoft.Exchange.Configuration.Tasks.Task.WriteError(Exception exception, ErrorCategory category, Object target, Boolean reThrow, String helpUrl) 
   bei Microsoft.Exchange.Configuration.Tasks.Task.WriteError(Exception exception, ErrorCategory category, Object target) 
   bei Microsoft.Exchange.Management.SystemConfigurationTasks.SetReceiveConnector.InternalValidate() 
   bei Microsoft.Exchange.Configuration.Tasks.Task.<ProcessRecord>b__b() 
   bei Microsoft.Exchange.Configuration.Tasks.Task.InvokeRetryableFunc(String funcName, Action func, Boolean terminatePipelineIfFailed)". 
[06.21.2014 11:06:57.0072] [1] [ERROR] The values that you specified for the Bindings and RemoteIPRanges parameters conflict with the settings on Receive connector "SERVER2\Pullution". Receive connectors assigned to different Transport roles on a single server must listen on unique local IP address & port bindings. 
[06.21.2014 11:06:57.0072] [1] 1.  ErrorRecord: Die von Ihnen angegebenen Werte für die Parameter "Bindings" und "RemoteIPRanges" stehen im Konflikt mit den Einstellungen für den Empfangsconnector "SERVER2\Default Frontend SERVER2". Empfangsconnectors, die auf einem einzigen Server verschiedenen Transportrollen zugewiesen sind, müssen an eindeutigen, lokalen IP-Adressen und Portbindungen lauschen. 
[06.21.2014 11:06:57.0072] [1] 1.  ErrorRecord: Microsoft.Exchange.Management.SystemConfigurationTasks.ReceiveConnectorRoleConflictException: Die von Ihnen angegebenen Werte für die Parameter "Bindings" und "RemoteIPRanges" stehen im Konflikt mit den Einstellungen für den Empfangsconnector "SERVER2\Default Frontend SERVER2". Empfangsconnectors, die auf einem einzigen Server verschiedenen Transportrollen zugewiesen sind, müssen an eindeutigen, lokalen IP-Adressen und Portbindungen lauschen. 
   bei Microsoft.Exchange.Configuration.Tasks.Task.WriteError(Exception exception, ErrorCategory category, Object target, Boolean reThrow, String helpUrl) 
   bei Microsoft.Exchange.Configuration.Tasks.Task.WriteError(Exception exception, ErrorCategory category, Object target) 
   bei Microsoft.Exchange.Management.SystemConfigurationTasks.SetReceiveConnector.InternalValidate() 
   bei Microsoft.Exchange.Configuration.Tasks.Task.<ProcessRecord>b__b() 
   bei Microsoft.Exchange.Configuration.Tasks.Task.InvokeRetryableFunc(String funcName, Action func, Boolean terminatePipelineIfFailed) 
[06.21.2014 11:06:57.0073] [1] [ERROR] The following error was generated when "$error.Clear();  
          $connectors = Get-ReceiveConnector -Server $RoleFqdnOrName; 
          foreach($connector in $connectors) { if($connector.MaxLocalHopCount -gt 1) { Set-ReceiveConnector -Identity $connector.Identity -MaxLocalHopCount 5 } }; 
        " was run: "Microsoft.Exchange.Management.SystemConfigurationTasks.ReceiveConnectorRoleConflictException: Die von Ihnen angegebenen Werte für die Parameter "Bindings" und "RemoteIPRanges" stehen im Konflikt mit den Einstellungen für den Empfangsconnector "SERVER2\Default Frontend SERVER2". Empfangsconnectors, die auf einem einzigen Server verschiedenen Transportrollen zugewiesen sind, müssen an eindeutigen, lokalen IP-Adressen und Portbindungen lauschen. 
   bei Microsoft.Exchange.Configuration.Tasks.Task.WriteError(Exception exception, ErrorCategory category, Object target, Boolean reThrow, String helpUrl) 
   bei Microsoft.Exchange.Configuration.Tasks.Task.WriteError(Exception exception, ErrorCategory category, Object target) 
   bei Microsoft.Exchange.Management.SystemConfigurationTasks.SetReceiveConnector.InternalValidate() 
   bei Microsoft.Exchange.Configuration.Tasks.Task.<ProcessRecord>b__b() 
   bei Microsoft.Exchange.Configuration.Tasks.Task.InvokeRetryableFunc(String funcName, Action func, Boolean terminatePipelineIfFailed)". 
[06.21.2014 11:06:57.0073] [1] [ERROR] The values that you specified for the Bindings and RemoteIPRanges parameters conflict with the settings on Receive connector "SERVER2\Default Frontend SERVER2". Receive connectors assigned to different Transport roles on a single server must listen on unique local IP address & port bindings. 
[06.21.2014 11:06:57.0073] [1] [ERROR-REFERENCE] Id=TransportCommonComponent___79d82f60693f413588aa8c3a58e90b41 Component=EXCHANGE14:\Current\Release\Shared\Datacenter\Setup 
[06.21.2014 11:06:57.0085] [1] Setup is stopping now because of one or more critical errors. 
[06.21.2014 11:06:57.0086] [1] Finished executing component tasks. 
[06.21.2014 11:06:57.0167] [1] Ending processing Install-BridgeheadRole 
[06.21.2014 11:23:15.0770] [0] CurrentResult setupbase.maincore:396: 0 
[06.21.2014 11:23:15.0771] [0] End of Setup
Google lieferte mir folgende Seite die uns erstmal den Fehler erklärte:

http://social.technet.microsoft.com/Forums/de-DE/a3cd92c6-e6c2-4abb-a47 ...
und den
http://technet.microsoft.com/de-de/library/aa996395(v=exchg.150).aspx

Die Fehlerbehebung dann hier:

http://mike-graham.co.uk/blog/2013/08/16/exchange-2013-on-premises-rece ...

soweit so gut. Problem jetzt nur, dass die Exchange Powershell nicht mehr funktioniert.

New-PSSession : [server2.gral.local] Beim Verbinden mit dem Remoteserver "server2.gral.local" ist folgender Fehler 
aufgetreten: Der WinRM-Client kann die Anforderung nicht verarbeiten. Der Inhaltstyp der HTTP-Antwort vom Zielcomputer kann nicht ermittelt werden. Der Inhaltstyp fehlt oder ist ungültig. Weitere Informationen finden Sie im Hilfethema "about_Remote_Troubleshooting". 
In Zeile:1 Zeichen:1 
+ New-PSSession -ConnectionURI "$connectionUri" -ConfigurationName Microsoft.Excha ... 
+ ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ 
+ CategoryInfo          : OpenError: (System.Manageme....RemoteRunspace:RemoteRunspace) [New-PSSession], PSRemotin 
   gTransportException 
+ FullyQualifiedErrorId : -2144108297,PSSessionOpenFailed
folgende Seite zur fehlerbehebung aufgerufen:

http://social.technet.microsoft.com/Forums/de-DE/bc843147-e60a-46c4-b00 ...

Dies hilft uns jedoch nicht weiter. Wir haben nirgends eine gleiche Installation auf die wir zurück greifen können. Ich habe testweise die webconfig vom Tag zuvor aus unserem Backup wiederhergestellt. Fehler immer noch identisch. Kann uns hier jemand helfen?
Bzw. ist es eher ratsam bei den zwei Postfächern einfach den Exchange zu Deinstallieren (geht das überhaupt bei einer abgebrochenen Installation) und diesen dann nochmals sauber zu konfigurieren?

LG, Frank
Mitglied: Pjordorf
21.06.2014 um 14:39 Uhr
Hallo,

Zitat von minimalwerk:
ErrorRecord: Die von Ihnen angegebenen Werte für die Parameter "Bindings" und "RemoteIPRanges" stehen im Konflikt mit den Einstellungen für den Empfangsconnector "SERVER2\Default Frontend SERVER2". Empfangsconnectors, die auf einem einzigen Server verschiedenen Transportrollen zugewiesen sind, müssen an eindeutigen, lokalen IP-Adressen und Portbindungen lauschen.  
> 
Und? Wie ist dein Exchange eingerichtet? Welches IP's, Ports und Connectoren verwendest du wie und wo und wie sind diese Konfiguriert?

Dies hilft uns jedoch nicht weiter.
Warum hilft es dir nicht weiter? Fehlermeldung? Hinweise?

Kann uns hier jemand helfen?
Datensicherung deines AD sowie vom Exchange Server ohne des CU5 liegt vor?

Bzw. ist es eher ratsam bei den zwei Postfächern einfach den Exchange zu Deinstallieren
Dir ist schon klar das ein Exchange sich nicht so einfach mal eben löschen lässt vor allem wenn dort Fehler vorliegen, oder? Der ist tief im AD eingetragen und verwurzelt.

(geht das überhaupt bei einer abgebrochenen Installation)
Irgendwie von dein Server 2008R2 den Exchange runter zu kriegen ist nicht das Kunststück. Dein AD sauber zu bekommen damit eben eine NEU Installation vorgenommen werden kann schon eher. ADSIEdit ist dein Freund.

und diesen dann nochmals sauber zu konfigurieren?
Nur wenn dein AD UND der Server 2008R2 wirklich sauber sind. Den Server 2008R2 notfalls neu aufsetzen. Das AD notfalls händisch bereinigen. Sicherungen vorhanden?

Als Anfang mal:
http://blog.dargel.at/2012/11/20/complete-remove-exchange-2013-using-ad ...
http://social.technet.microsoft.com/forums/exchange/en-US/245e9288-c2c6 ...
http://windowsitpro.com/exchange-server/how-uninstall-stubborn-exchange ...
http://www.msexchange.org/articles-tutorials/exchange-server-2003/migra ...
http://www.wackytechtips.com/force-removal-of-exchange-server-remove-ex ...

Gruß,
Peter
Bitte warten ..
Mitglied: minimalwerk
21.06.2014 um 14:48 Uhr
Zitat von Pjordorf:
Und? Wie ist dein Exchange eingerichtet? Welches IP's, Ports und Connectoren verwendest du wie und wo und wie sind diese
Konfiguriert?

naja, anscheinend Fehlerhaft^^.. protokolliert wurde dies nicht :/

> Dies hilft uns jedoch nicht weiter.
Warum hilft es dir nicht weiter? Fehlermeldung? Hinweise?

wie gesagt, ohne die Powershell öffnen zu können kann ich ja gar nix abfragen bzw. ändern.

> Kann uns hier jemand helfen?
Datensicherung deines AD sowie vom Exchange Server ohne des CU5 liegt vor?

Es liegt eine aktuelle Datensicherung vom Vorabend vor. Erzeugt mit der Windows Server Sicherung (Volbackup inkl. Systemstatur und BareMetal).

Danke für die ganzen Hinweise bzgl. dem Entfernen. Aber so tief ist mein Wissen dann doch nicht. Dann komme ich wohl mit dem Backup besser zurecht

LG
Bitte warten ..
Mitglied: minimalwerk
23.06.2014 um 13:24 Uhr
backup mit Stand SP1 ist eingespielt und es funktioniert wieder alles.
Nun habe ich den Port für den POPcon auf 26 gestellt und das CU5 nochmals versucht zu installieren und siehe da es klappt auch mit dem Update. Sprich das Microsoft Update verträgt sich nicht mit Dritthersteller Software....

Nichts desto trotz habe ich immer noch den selben powershell fehler und werde dafür mal einen Neuen fred im korrekten bereich eröffnen.

LG
Bitte warten ..
Mitglied: Pjordorf
23.06.2014 um 15:01 Uhr
Hallo,

Zitat von minimalwerk:
backup mit Stand SP1 ist eingespielt und es funktioniert wieder alles.
OK, super.

Nun habe ich den Port für den POPcon auf 26 gestellt
Was um alles in der Welt machst du da und was willst du erreichen? E-Mail und Port 26? Wie Krank ist bei dir der Exchange eingestellt? Weisst du wirklich was du da tust bzw. dort anstellst? (Ungefähr so als wenn du mit einen 15 kg Vorschlaghammer eine PKW Verbundglasscheibe einpassen willst und anstelle die Scheibe einzukleben diese mit 10 Zoll Nägel festtackern willst)

Gruß,
Peter
Bitte warten ..
Neuester Wissensbeitrag
Windows 10

Powershell 5 BSOD

(1)

Tipp von agowa338 zum Thema Windows 10 ...

Ähnliche Inhalte
Exchange Server
Exchange 2013 Aktivierung (4)

Frage von Mazenauer zum Thema Exchange Server ...

Exchange Server
Problem mit POP3-Abruf eines Exchange-2013-Postfachs

Frage von YotYot zum Thema Exchange Server ...

Exchange Server
gelöst Exchange 2013 lässt sich nicht Updaten (9)

Frage von onkel87 zum Thema Exchange Server ...

Heiß diskutierte Inhalte
LAN, WAN, Wireless
gelöst Server erkennt Client nicht wenn er ausserhalb des DHCP Pools liegt (28)

Frage von Mar-west zum Thema LAN, WAN, Wireless ...

Outlook & Mail
Outlook 2010 findet ost datei nicht (18)

Frage von Floh21 zum Thema Outlook & Mail ...

Windows Server
Server 2008R2 startet nicht mehr (Bad Patch 0xa) (18)

Frage von Haures zum Thema Windows Server ...