Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Exchange 2013 - Mails ausgehend funktionieren nicht immer

Frage Microsoft Exchange Server

Mitglied: Forseti2003

Forseti2003 (Level 1) - Jetzt verbinden

01.08.2014, aktualisiert 17:53 Uhr, 3022 Aufrufe, 9 Kommentare

Hallo,

hab da zur Mittagszeit eine "kleine" Nuss zu knacken. Mein Exchange Server 2013 CU5 will seit ca. 2-3 Tagen nicht mehr ordnungsgemäß Mails versenden.
Intern und eingehend erhalten wir alle Mails ganz normal. Sobald wir aber ausgehend senden, besteht nur eine 50% Chance darauf, das die Mails ankommen.

In einigen Fällen erhalte ich einen Zustellungsbericht der behauptet es würde verzögert zugestellt worden sein, Prüfung ergibt aber, die sind nicht angekommen.
Auch einen Bericht über nicht zugestellte erhalte ich - meist erst 3 Tage später, was dann sehr ärgerlich ist.

Fehlercode anbei:
Diagnostic code = MaximumTimeExpired; Reason code = TransferFailed; Status code = 447
< #4.4.7 smtp;550 4.4.7 QUEUE.Expired; message expired>


Wenn ich MXToolBox teste erhalte ich folgende Hinweise:

Connecting to 21x.xx.xx.x71

220 MailEx01.domain.com Microsoft ESMTP MAIL Service ready at Thu, 31 Jul 2014 11:01:36 +0200 [728 ms]
EHLO MXTB-PWS3.mxtoolbox.com
250-MailEx01.domain.com Hello [21x.xx.xx.x71]
250-SIZE 26214400
250-PIPELINING
250-DSN
250-ENHANCEDSTATUSCODES
250-STARTTLS
250-AUTH NTLM
250-8BITMIME
250-BINARYMIME
250 CHUNKING [742 ms]
MAIL FROM: <supertool@mxtoolbox.com>
250 2.1.0 Sender OK [735 ms]
RCPT TO: <test@example.com>
550 5.7.1 Unable to relay [5737 ms]

MXTB-PWS3v2 10015ms

Angeblich soll das Reverse DNS fehlgeschlagen sein - wobei Banner mit Mailservernamen übereinstimmt.

Hat hierzu jemand eine Idee, was das auslösen kann?

Grüße
Forseti
Mitglied: Zangetsu
01.08.2014 um 12:15 Uhr
Hi Forseti,

Reverse-DNS ist nicht gleich EHLO/HELO + Mailservername. Kannst du deine öffentliche IP auflösen?

Gruß Zangetsu
Bitte warten ..
Mitglied: Chonta
01.08.2014 um 12:29 Uhr
Hallo,

wieviele Exchangeserver isnd im Einsatz?
Ging es schonmal?
Updates gefahren?
Wenn mehrere Server im Einsatz sind wieviele CAS Postfachserver gibt es?
Wenn Du dich von draußen auf deinen Exchange per SMTP verbindest, und an eine Domäne eine Mailzustellen willst, dann sollte die auch abgewiesen werden.
>MAIL FROM: <supertool@mxtoolbox.com>
Dein Absender ok
>250 2.1.0 Sender OK [735 ms]
>Absender akzeptiert
>RCPT TO: <test@example.com>
Wird keine Domäne sein die für die Dein Exchangserver zustädig ist
>550 5.7.1 Unable to relay [5737 ms]
Zustellung abgwwiesen, richtig so, sonst open Relay. (Willst Du nicht)

Die Frage ist, wie sachaut das gleiche aus dem Internen Netz aus?
Spätestens wenn der Absender sich autentifiziert hat sollte die Mail zugestellt werden.

Gruß

Chonta
Bitte warten ..
Mitglied: Forseti2003
01.08.2014 um 12:51 Uhr
Zitat von Zangetsu:

Hi Forseti,

Reverse-DNS ist nicht gleich EHLO/HELO + Mailservername. Kannst du deine öffentliche IP auflösen?

Gruß Zangetsu

Ja, das geht. Wenn ich aus einem externen Netz einfach mal einen Ping starte, erhalte ich als Rückmeldung mailex01.domain.com [21.xx.xxx.xx1].
Der nslookup auf die Adresse läuft auch sauber durch.
Bitte warten ..
Mitglied: Forseti2003
01.08.2014 um 12:56 Uhr
Zitat von Chonta:

Hallo,

wieviele Exchangeserver isnd im Einsatz?
Aktuell insgesamt 2 - der zweite läuft ohne Probleme (soll aber durch den anderen abgelöst werden)
Ging es schonmal?
Ja, ich würde behaupten bis Anfang diese Woche, erst ab da treten die Probleme auf.
Updates gefahren?

Wenn mehrere Server im Einsatz sind wieviele CAS Postfachserver gibt es?
Da beide Server als "standalone" vorgesehen sind, sind auch 2 CAS aktuell im Einsatz. Sobald ich die Postfächer vom alten auf den neuen migriere, leiden die neuen Postfächer unter dem Problem.

Wenn Du dich von draußen auf deinen Exchange per SMTP verbindest, und an eine Domäne eine Mailzustellen willst, dann
sollte die auch abgewiesen werden.
>MAIL FROM: <supertool@mxtoolbox.com>
Dein Absender ok
>250 2.1.0 Sender OK [735 ms]
>Absender akzeptiert
>RCPT TO: <test@example.com>
Wird keine Domäne sein die für die Dein Exchangserver zustädig ist
>550 5.7.1 Unable to relay [5737 ms]
Zustellung abgwwiesen, richtig so, sonst open Relay. (Willst Du nicht)

Die Frage ist, wie sachaut das gleiche aus dem Internen Netz aus?
Spätestens wenn der Absender sich autentifiziert hat sollte die Mail zugestellt werden.

Gruß

Chonta

Das ist richtig, Open-Relay wollen wir nicht und das klappt soweit auch, wenn man den Test von MXtoolbox durchsieht.
Intern ist es kurios, die Mails zwischen den Exchange-Servern kommen prompt und sauber an.
Die Anwender sind mit Outlook 2010 am Exchange verbunden, insofern sollte der Absender immer authentifiziert sein. Versuche über OWA bringen das selbe Ergebnis.
Bitte warten ..
Mitglied: Chonta
01.08.2014 um 13:08 Uhr
Du hast 2 Exchange 2013 im Einsatz und einer davon oll abgestellt werden?

Ich vermute mal die Senteeinstellungen sind irgendwie durcheinander.
Du must mal die Mails verfolgen. Versucht der problem Exchange über den anderen zu versenden und der macht kein Relay? Oder versucht der selber zu versenden aber kann die Mails nicht auflösen?


Gruß

Chonta
Bitte warten ..
Mitglied: SlainteMhath
LÖSUNG 01.08.2014, aktualisiert um 17:53 Uhr
Moin,
Ja, das geht. Wenn ich aus einem externen Netz einfach mal einen Ping starte, erhalte ich als Rückmeldung mailex01.domain.com [21.xx.xxx.xx1].
Der nslookup auf die Adresse läuft auch sauber durch.

Es geht um REVERSE DNS, also ob zu deine IP Adresse zu dem Hostnamen aufgelöst werden kann.

lg,
Slainte
Bitte warten ..
Mitglied: Forseti2003
01.08.2014 um 13:11 Uhr
Zitat von Chonta:

Du hast 2 Exchange 2013 im Einsatz und einer davon oll abgestellt werden?

Nicht ganz, einer ist 2013 und einer ist 2007 - der 2007er soll abgestellt werden. Hätte ich aktuell das Problem mit den Mails nicht, würden jetzt am WE alle Postfächer migriert werden und der alte EX ausgemustert.

Ich vermute mal die Senteeinstellungen sind irgendwie durcheinander.
Du must mal die Mails verfolgen. Versucht der problem Exchange über den anderen zu versenden und der macht kein Relay? Oder
versucht der selber zu versenden aber kann die Mails nicht auflösen?

Hm, guter Ansatz, prüf ich mal nach.
Bitte warten ..
Mitglied: Chonta
01.08.2014 um 14:03 Uhr
Hallo,

sag doch gleich das du mitten in einer Migration von 2007 auf 2013 stehst.
Mich würden mal die unzustellbarkeitsberichte interessieren.

Wie versendet ihr die Mails? Selber über Eure feste IP oder über einen Smarthost? (Fehlt evtl dem 2013)
Evtl findest Du hier noch Ansätze.
http://www.frankysweb.de/migration-von-exchange-2010-zu-exchange-2013-b ...

Gruß

Chonta
Bitte warten ..
Mitglied: Forseti2003
01.08.2014 um 17:53 Uhr
Zitat von Chonta:

Hallo,

sag doch gleich das du mitten in einer Migration von 2007 auf 2013 stehst.

Sorry, war an der Stelle für mich aktuell nebensächlich, da ja der neue Server die letzten 2 Monate im Test ohne Probleme lief.
Erst als wir die Postfächer migrierten, konnten Live-User das Problem feststellen, da es ja nicht permanent auftritt, aber überwiegend bei den selben Mailempfängern. Bin daher nicht davon ausgegangen, das hier die Migration quer schlägt.


Mich würden mal die unzustellbarkeitsberichte interessieren.

Wie versendet ihr die Mails? Selber über Eure feste IP oder über einen Smarthost? (Fehlt evtl dem 2013)
Evtl findest Du hier noch Ansätze.
http://www.frankysweb.de/migration-von-exchange-2010-zu-exchange-2013-b ...

Gruß

Chonta

Aber ich glaub der Fehler ist nun gelöst. Auf Deine Fragen:
Ja, wir senden mittels fester IP-Adresse über unseren eigenen Server. Aber genau hier lag der Hund begraben.

Wir haben unserem Domainhoster die IP-Adresse mitgeteilt, diese wurde auch hinterlegt. Wenn unser Server also nun Mails versendet hat, meldete er sich mit dem normalen Netz an und gab seine Kennung durch. Wenn nun der Mailempfänger seine Prüfung anfragte, landete er zwar im ersten Schritt noch beim Domainhoster und dessen Nameserver, der dann an die feste IP weiterleitete, doch der ISP hatte einen PTR bei sich vergessen und so war im Netz vom ISP nicht bekannt, das er an das Netz durchstellen sollte.

Der ISP hat den PTR nun nachgetragen und seitdem erhalte ich keinen Reverse DNS-Fehler mehr bei der MXtoolbox.

Schätzungsweise kamen damit nämlich einige Server nicht klar und gingen von einem Spambot aus und haben die Mails unbeantwortet gelöscht. Server mit niedriger Sicherheit haben die Mails empfangen.

Fazit: Nicht nur der Domainhoster muss einen PTR setzen, sondern auch der ISP - da wir einen neuen ISP seit diesem Jahr erst einsetzen und mit dem alten das Problemlos geklappt hat, sind wir da erst jetzt richtig drüber gestolpert.

Somit Danke bei allen für die Mithilfe, die uns auf die Spur gebracht hat.

Grüße

Forseti
Bitte warten ..
Ähnliche Inhalte
Debian
Exchange Server mit einem ausgehenden Mail-Gateway
Frage von spcvltDebian1 Kommentar

Hallo zusammen, ich bin recht neu im Thema Mailserver und bräuchte daher etwas Unterstützung im Thema Exchange und Smarthost/Relay. ...

Exchange Server
Exchange 2013 Verwaltungsshell und Konsole funktionieren nicht
Frage von dawe78Exchange Server

Guten Morgen, Ich habe Exchange 2013 auf einem komplett neuen Server 2012 R2 meiner Organisation hinzugefügt. Die Organisation besteht ...

Exchange Server
Exchange 2013, Keine Mails auf dem Mobilgerät
gelöst Frage von kansiii85Exchange Server6 Kommentare

Moin Moin, ich beschäfte mich derzeit in einer VM-Testumgebung mit Exchange2013. Derzeit gibt es 3VMs im gleichen Netz, einen ...

Exchange Server
Exchangeserver - Ausgehende mails konvertieren
gelöst Frage von E2K2014Exchange Server5 Kommentare

Hallo zusammen, ich habe ein kleines Problem mit unserem Exchangeserver: Wenn unser Ticketsystem eine Mail verschickt, wird die mit ...

Neue Wissensbeiträge
Erkennung und -Abwehr

Necur-Botnet soll Erpressungstrojaner Scarab massenhaft verbreiten

Information von BassFishFox vor 10 StundenErkennung und -Abwehr

12,5 Millionen Spam-Mails aus einem Bot-Netz mit 6 Millionen Computern? Eigentlich eine schwache Leistung. Die Erpresser setzen dabei auf ...

Microsoft

Nadeldrucker-Problem unter Windows - Microsoft liefert Updates

Information von BassFishFox vor 10 StundenMicrosoft

Hat ja nicht lange gedauert. Nachdem die November-Updates für Windows 7, 8.1 und 10 zahlreiche Nadeldrucker lahmgelegt hatten, stellt ...

Linux

Limux-Ende in München: Wie ein Linux Projekt unter Ausschluss der Öffentlichkeit zerstört wurde

Information von Frank vor 18 StundenLinux14 Kommentare

Mein persönlicher Kommentar zum Thema "Limux-Ende". Die SPD-Politikerin Anne Hübner hat die Richtung von München ganz klar definiert: "Wir ...

Batch & Shell

Open Object Rexx: Eine mittlerweile fast vergessene Skriptsprache aus dem Mainframebereich

Information von Penny.Cilin vor 1 TagBatch & Shell9 Kommentare

Ich kann mich noch sehr gut an diese Skriptsprache erinnern und nutze diese auch heute ab und an noch. ...

Heiß diskutierte Inhalte
Windows Server
Kann man im KMS nachschauen , wieviele Clients den Key in Anspruch genommen haben
gelöst Frage von rainergugusWindows Server15 Kommentare

Hallo, wir haben einen KMS Windows 10 Key. Dieser ist ja W7 kompatibel. Aber unser Windows 7 Pool registriert ...

Linux
Limux-Ende in München: Wie ein Linux Projekt unter Ausschluss der Öffentlichkeit zerstört wurde
Information von FrankLinux14 Kommentare

Mein persönlicher Kommentar zum Thema "Limux-Ende". Die SPD-Politikerin Anne Hübner hat die Richtung von München ganz klar definiert: "Wir ...

Router & Routing
Zwei Netzwerke erstellen
Frage von bunteblumeRouter & Routing14 Kommentare

Hallo Zusammen, Ich möchte gerne ein backup von einem bestimmten Folder welcher auf dem Server regelmässig synchronisiert wird auf ...

Off Topic
Fachkräftemangel in Deutschland? - Talentschmiede schreibt alle 2 Tage die gleichen Stellen aus
Frage von Penny.CilinOff Topic12 Kommentare

Hallo, haben wir in Deutschland Fachkräftemangel? Die Talentschmiede schreibt gefühlt alle zwei Tage dieselben Stellen aus. Und das schon ...