Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Exchange autodiscover

Frage Microsoft Exchange Server

Mitglied: Stops

Stops (Level 1) - Jetzt verbinden

18.11.2010 um 18:46 Uhr, 7897 Aufrufe, 1 Kommentar, 1 Danke

Hei Ihr,

ich möchte Autodiscover auch vom Internet für SmartPhones zu Verfügung stellen.
Exchange läuft auf einem SBS2008.
Hierfür habe ich mir ein UCC-Zertifikat mit folgenden Namen erstellen lassen.

SAN:
mailserver
mailserver.contoso.de
mailserver.contoso.local
autodiscover.contoso.de

Desweiteren habe ich bei meinem Provider eine Subdomain erstellt: autodiscover.contoso.de
Dessen DNS-Eintrag habe ich auf die feste IP des ExchangeServers (SBS2008) verweisen lassen.

Das Zertifikat funktioniert mit OWA und ActiveSync.
Autodiscover funktioniert intern mittels SCP im AD
Autodiscover funktioniert nicht von EXTERN

Wie funktioniert autodiscover:
1. Zuerst wird mittels SCP im AD nach https://autodiscover.contoso.local/autodis ... gesucht
Geht vom Internet logischerweise nicht - (intern findet er den SCP im AD)

2. Danach versucht er mittels DNS einen SRV-Eintrag zu finden der auf https://autodiscover.contoso.de/autodiscov ... verweist
Damit er Ihn finden kann habe ich zusätzlich eine Primäre DNS-Zone (contoso.de) auf dem SBS2008 mit einem SRV Eintrag (_autodiscover._tcp.contoso.de auf mailserver.contoso.local) erstellt.

Autodiscover erneut getestet:
Nun müsste er ihn doch finden - aber leider funktioniert autodiscover vom Internet immer noch nicht!! Also habe ich die DNS-Zone contoso.de vom SBS wieder gelöscht....


Auf der Website "www.testexchangeconnectivity.com" habe ich es mit folgendem Ergebniss testen lassen:


Es wird versucht, die mögliche AutoErmittlungs-URL https://autodiscover.contoso.de/AutoDiscov ... zu testen.
Fehler beim Testen dieser potenziellen AutoErmittlungs-URL.
Testschritte
Es wird versucht, den Hostnamen autodiscover.contoso.de im DNS aufzulösen.
Der Hostname wurde erfolgreich aufgelöst.
Weitere Details
Zurückgegebene IP-Adressen: 1.2.3.4
Es wird getestet, ob TCP-Port 443 auf Host autodiscover.contoso.de überwacht wird/geöffnet ist.
Der Port wurde erfolgreich geöffnet.
Die Gültigkeit des SSL-Zertifikats wird überprüft.
Das Zertifikat hat alle Überprüfungsanforderungen bestanden.
Testschritte
Der Zertifikatsname wird überprüft.
Zertifikatsnamen erfolgreich überprüft.
Weitere Details
Hostname autodiscover.contoso.de wurde im Eintrag für den alternativen Antragstellernamen des Zertifikats gefunden.

Zertifikatsvertrauensstellung wird überprüft.
Das Zertifikat wird als vertrauenswürdig angesehen, und in der Kette sind alle Zertifikate vorhanden.
Weitere Details
Die Zertifikatskette wurde bis zu einem vertrauenswürdigen Stamm überprüft. Stamm = CN=Entrust.net Secure Server Certification Authority, OU=(c) 1999 Entrust.net Limited, OU=www.entrust.net/CPS incorp. by ref. (limits liab.), O=Entrust.net, C=US.

Das Datum des Zertifikats wird getestet, um zu bestätigen, dass das Zertifikat gültig ist.
Datenüberprüfung bestanden. Das Zertifikat ist nicht abgelaufen.
Weitere Details
Das Zertifikat ist gültig. NotBefore = 11/18/2010 12:00:00 AM, NotAfter = 2/16/2012 11:59:59 PM



Die IIS-Konfiguration Wird im Hinblick auf die Clientzertifikatsauthentifizierung überprüft.
Keine Clientzertifikatsauthentifizierung erkannt.
Weitere Details
Clientzertifikate für Akzeptieren/Anfordern nicht konfiguriert.

Es wird versucht, dem AutoErmittlungsdienst eine POST-Anforderung zu senden, damit er URLs ggf. automatisch erkennen kann.
Beim Senden der POST-Anforderungen für die AutoErmittlung konnten keine AutoErmittlungseinstellungen abgerufen werden.
Testschritte
ExRCA versucht, eine XML-Antwort des AutoErmittlungsdiensts von URL https://autodiscover.contoso.de/AutoDiscov ... für Benutzer mustermann@contoso.de abzurufen.
Von ExRCA konnte keine XML-Antwort von der AutoErmittlung abgerufen werden.
Weitere Details
Webausnahme aufgrund des Empfangs der Antwort 'HTTP 401 - Unauthorized' von Unknown.



Es wird versucht, mit der HTTP-Umleitungsmethode eine Verbindung zum AutoErmittlungsdienst herzustellen.
Fehler beim Verbindungsversuch zur AutoErmittlung mit der HTTP-Umleitungsmethode.
Testschritte
Es wird versucht, den Hostnamen autodiscover.contoso.de im DNS aufzulösen.
Der Hostname wurde erfolgreich aufgelöst.
Weitere Details
Zurückgegebene IP-Adressen: 5.6.7.8
Es wird getestet, ob TCP-Port 80 auf Host autodiscover.contoso.de überwacht wird/geöffnet ist.
Der Port wurde erfolgreich geöffnet.
AutoErmittlung von Host contoso.de wird von ExRCA für HTTP-Umleitung zum AutoErmittlungsdienst überprüft.
Von ExRCA konnte keine HTTP-Umleitungsantwort für die AutoErmittlung abgerufen werden.
Weitere Details
Webausnahme aufgrund des Empfangs der Antwort 'HTTP 404 - NotFound' von IIS7.



Es wird versucht, mit der DNS-SRV-Umleitungsmethode eine Verbindung zum AutoErmittlungsdienst herzustellen.
Mit der DNS-SRV-Umleitungsmethode konnte keine Verbindung von ExRCA zum AutoErmittlungsdienst hergestellt werden.
Testschritte
Es wird versucht, den SRV-Datensatz _autodiscover._tcp.contoso.de im DNS zu finden.
Der SRV-Datensatz für die AutoErmittlung wurde nicht in DNS gefunden.

Jetzt noch 2 Dinge:

1.
Bei diesem Test habe ich den Benutzername "UPN" also als E-Mailadresse angegeben.
Gebe ich domaene benutzername an - scheint der Test wie folgt erfolgreich zu sein.

Es wird versucht, dem AutoErmittlungsdienst eine POST-Anforderung zu senden, damit er URLs ggf. automatisch erkennen kann.
ExRCA hat AutoErmittlung-Einstellungen erfolgreich durch Senden von AutoErmittlung-POST-Daten abgerufen.
Testschritte
ExRCA versucht, eine XML-Antwort des AutoErmittlungsdiensts von URL https://autodiscover.contoso.de/AutoDiscov ... für Benutzer mustermann@contoso.de abzurufen.
Die XML-Antwort der AutoErmittlung wurde erfolgreich abgerufen.


Wieso???? Wie kann ich das umstellen, damit auch UPN akzeptiert wird??? (Das wäre für die Smartphones wichtig, da die nur die E-Mailadresse und Passwort wollen!)

2.
Wieso findet er https://autodiscover.contoso.de/AutoDiscov ... obwohl ich die DNS-Zone auf dem lokalen SBS gar nicht mehr existiert!!! (Hab jch ja wieder gelöscht)

---
Sobald ich auf dem SBS2008 eine primäre DSN-Zone contoso.de mit dem autodiscover SRV Eintrag anlege erscheint INTERN bei den Outlookclients:
Konfigurieren von mustermann@contoso.de-Servereinstellungen für diese Website
https://mailserver.contoso.local/autodiscover/autodiscover.xml
Das Konto wurde für die Einstellungen auf diese Website umgeleitet. Sie sollten nur Einstellungen aus Quellen zusallen, die Sie kennen und denen Sie vertrauen.
Liegt es daran, das das Zertifikat "autodiscover.contoso.local" nicht beinhaltet???
Sollte ich diesen Namen noch in das Zertifikat mit eintragen lassen??
Vielen Dank für eure Hilfe
Mitglied: filippg
19.11.2010 um 22:07 Uhr
Hallo,

Bei diesem Test habe ich den Benutzername "UPN" also als E-Mailadresse angegeben.
Gebe ich domaene benutzername an - scheint der Test wie folgt erfolgreich zu sein.
nur um hier sicher zu gehen: Dass UPN und EMail-Adresse nicht das selbe (sondern nur oft das gleiche) sind, und sich durchaus unterscheiden können, ist dir bewusst? Sprich: du hast sicher den korrekten UPN verwendet?

Gruß

Filipp
Bitte warten ..
Ähnliche Inhalte
Exchange Server
Exchange 2010 AutoDiscover lokal
gelöst Frage von chb1982Exchange Server16 Kommentare

Hallo zusammen, ich habe ein Problem in einer Umgebung um Exchange 2010 und damit verbunden Ladehämmungen was das Verständnis ...

Exchange Server
Exchange 2016 Autodiscover für iPhone
Frage von anak1mExchange Server6 Kommentare

Hallo zusammen, hat jemand eine Idee woran es liegen könnte dass sich die iPhones nicht selbst konfigurieren? Wir setzen ...

Exchange Server
Autodiscover bei Exchange 2016
gelöst Frage von slanskyExchange Server1 Kommentar

Hallo, ich habe folgende Umgebung: DAG mit 6 Servern (Exchange 2016) in 3 Standorten (je 2) Eintrag in .de ...

Exchange Server
Exchange 2013 Autodiscover sehr langsam
Frage von smeclntExchange Server5 Kommentare

Hallo zusammen, nach Jahren mit den SBS 03/08/11 muss ich mich nun mit einem "richtigen" Exchange anfreunden. OS Server2012/R2, ...

Neue Wissensbeiträge
Apple

IOS 11.2.1 stopft HomeKit-Remote-Lücke

Tipp von BassFishFox vor 1 TagApple

Das Update für iPhone, iPad und Apple TV soll die Fernsteuerung von Smart-Home-Geräten wieder in vollem Umfang ermöglichen. Apple ...

Windows 10

Windows 10 v1709 EN murkst bei den Regionseinstellungen

Tipp von DerWoWusste vor 1 TagWindows 10

Dieser kurze Tipp richtet sich an den kleinen Personenkreis, der Win10 v1709 EN-US frisch installiert und dabei die englische ...

Webbrowser

Kein Ton bei Firefox Quantum über RDP

Tipp von Moddry vor 1 TagWebbrowser

Hallo Kollegen! Hatte das Problem, dass der neue Firefox bei mir auf der Kiste keinen Ton hat, wenn ich ...

Internet

EU-DSGVO: WHOIS soll weniger Informationen liefern

Information von sabines vor 1 TagInternet4 Kommentare

Wegen der europäische Datenschutzgrundverordnung stehen die Prozesse um die Registrierung von Domains auf dem Prüfstand. Sollte die Forderungen umgesetzt ...

Heiß diskutierte Inhalte
Hardware
Kein Bild mit nur einer bestimmten Grafikkarten - Mainboard Konfiguration
gelöst Frage von bestelittHardware18 Kommentare

Hallo zusammen, ich hatte schon einmal eine ähnliche Frage gestellt. Damals hatte ich genau das gleiche Problem. Allerdings lies ...

Windows Server
RODC kann nicht aus Domäne entfernt werden
Frage von NilsvLehnWindows Server18 Kommentare

HAllo, ich arbeite in einem Universitätsnetzwerk mit 3 Standorten. Die Standorte haben alle ein ESXi Cluster und auf diesen ...

Netzwerkmanagement
Mehrere Netzwerkadapter in einem PC zu einem Switch zusammenfügen
Frage von prodriveNetzwerkmanagement16 Kommentare

Hallo zusammen Vorweg, ich konnte schon einige IT-Probleme mit Hilfe dieses Forums lösen. Wirklich klasse hier! Doch für das ...

Hardware
Links klick bei Maus funktioniert nicht
gelöst Frage von Pablu23Hardware16 Kommentare

Hallo erstmal. Ich habe ein Problem mit meiner relativ alten maus jedoch denke ich nicht das es an der ...