Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Exchange mit DynDNS

Frage Microsoft Exchange Server

Mitglied: iceman5

iceman5 (Level 1) - Jetzt verbinden

01.03.2006, aktualisiert 02.03.2006, 6256 Aufrufe, 19 Kommentare

Langsam wirds fad....quäle mich seit Tagen mit dem Empfangen von Mails über meinen Exchange Server.... aber .....keine Chance....

Also erstmal zum System:

Ich habe hier einen Windows Server 2003 enterprise SP1, mit Exchange 2003 SP2

Hab das ganze System soweit ganz gut aufgesetzt (denk ich mal bzw. hoffe ich) Auch der Exchange server läuft über meinen dyndns Host. Aber dabei funktioniert NUR das SENDEN von Mails! Kein Empfang ist da möglich. Ich hab auch in einem Forum gelesen, das die Möglichkeit besteht, über Telnet auf den Exchange zuzugreifen. Vom LAN gehts, vom WAN keine chance...
Somit kam ich zu dem Schluss dass da mein Router nicht mitspielt, aber der Port 25 wird an den Server weitergeleitet....

wo könnte da noch der Fehler liegen? Hat jemand einen heißen Tipp?? Bin da echt langsam am Verzweifeln...
Mitglied: christians
01.03.2006 um 22:31 Uhr
Wenn Du vom WAN aus nicht per 'telnet $server 25' auf den Exchange kommst, wird entweder der Router blockieren oder die Firewall auf dem Server oder beide.

Noch was Grundsätzliches zum Thema:
Was ist wenn Deine IP wechselt/Dein Server nicht erreichbar ist? Im besten Fall wird die Zustellung verzögert/abgebrochen, im schlechtesten Fall bekommt ein Dritter Deine Mails.

Und denk auch dran einen MX Eintrag zu machen.
Bitte warten ..
Mitglied: Dani
01.03.2006 um 23:00 Uhr
Hi,
warum das Senden nicht geht ist mir klar. Und zwar musst du eine feste offizelle IP besitzen. Dann geht das ganze auch.

Gruß
Dani
Bitte warten ..
Mitglied: christians
01.03.2006 um 23:04 Uhr
Senden geht doch. Empfangen geht bei 'iceman5' nicht.

Und was soll das mit einer festen IP zu tun haben?
Bitte warten ..
Mitglied: Dani
01.03.2006 um 23:09 Uhr
Abend,
schitt....verlesen. Soll passieren....

Gruß
Dani
Bitte warten ..
Mitglied: iceman5
01.03.2006 um 23:23 Uhr
Also erstmal danek für die Antworten!

Das Problem mit dem Offline sein des Servers ist nicht unbedingt ein Problem für mich da ich das nicht unbedingt ernsthaft betreiben will, sonder quasi als Testsystem nutzen möchte.... Ich habe meine mail Adressen und mag die auch behalten! Aber ich brauch Exchange Administration momentan beruflich...

Also wie bereits erwähnt, senden funktioniert, MX ist bei DYNDNS eingetragen - wird bei nslookup auch angegebn, dieser zeiget aber natürlich wieder auf meinen dyndns host (Host: beispiel.mine.nu und der MX: beispiel.mine.nu) so auch im Router ist der Port 25 auf den Server weitergeleitet (TCP UND UDP) ABER ich habe keine MX einträge in meinem DNS Server gesetzt, weil ich ganz ehrlich gesagt keine ahnung habe was wohin gehört!

Danke im Vorraus

lg Ice
Bitte warten ..
Mitglied: christians
01.03.2006 um 23:31 Uhr
Ich vermute es liegt an der Firewall des Router oder des Server selbst.

Stell den Server doch zum testen mal in die DMZ (lösche dann alle Portfreigaben/weiterletungen, nicht jeder Router macht den Mix von Forwarding und DMZ mit.)

Ich gehe davon aus, Du testes wirklich von aussen, also nicht aus dem LAN mit der dyndns-Adresse.
Was passiert bei 'telnet beispiel.mine.nu 25'
Bitte warten ..
Mitglied: iceman5
01.03.2006 um 23:52 Uhr
Jap Teste wirklich vom WAN (Laptop mit UMTS Karte, WLAN deaktiviert)

So Server ist im DMZ und alle Port weiterleitungen auf den Server sind gelöscht.

Also wenn ich die Telnet Verbindung starte, selber stand wie vorher, die eingabeaufforderung nimmt den Befehl an, löscht das eingabefenster und der Courser blinkt demotiviert herum....aber keine Begrüßung vom Server... Genausowenig aber eine Meldung das keine Verbindung hergestellt werden kann....
Bitte warten ..
Mitglied: docsam
01.03.2006 um 23:53 Uhr
man kann auch mit dynamischer IP versenden, das Problem ist, das viele Server einen dann oft für nen Spammer halten.
Bitte warten ..
Mitglied: christians
02.03.2006 um 00:06 Uhr
Aber anpingen geht?

Wenn Du willst kannst Du mir mal die Adresse geben (PM).
Bitte warten ..
Mitglied: flabs
02.03.2006 um 00:07 Uhr
hey

es funktioniert doch alles ohne probs ist zwar nicht ganz rfc konform aber es geht.

dsl bei 1&1 mit dynip , .de domain auch bei 1&1

router port 25 freigeschaltet und dyndns client im router aktiviert

im EXC2k3 bei smtp connector neuen connector eingetragen zum auth senden smtp.1und1.de mit email eingetragen so fungiert 1&1 smtp server als relay server so landen die versendeten emails nicht im spam folder des empfängers

im 1&1 controlcenter bei Domains bei der entsprechenden in den DNS einstellungen

eigener MX Eintrag dort dann den im router eingetragenen dyndns namen eintragen
backup MX auf 1und1 mailserver zeigen lassen

wichtig dabei ist nur das port 25 in beide richtungen offen ist...

mache doch mal ein portscan z.b. unter heise de
Bitte warten ..
Mitglied: iceman5
02.03.2006 um 00:14 Uhr
einfach meinen host anpingen? Natürlich geht das, ich kann auch VPN, FTP und HTTP Verbindungen herstellen...
Bitte warten ..
Mitglied: christians
02.03.2006 um 00:16 Uhr
Ok, eine Idee noch: blockiert Dein Provider eventuell Port 25?

Teste mal mit einem anderen Port, zB 80
Denk dran, die IP muss im Router und im Server angepasst werden Ich spreche aus Erfahrung.
Bitte warten ..
Mitglied: iceman5
02.03.2006 um 00:17 Uhr
Naja und das ganze jetzt noch auf eine "gratis" Lösung (wenns sein muss auch ohne Backup -> Nochmal, bin nicht auf den Mail Server angewiesen, sondern es geht hier rein um den lern effekt....) wie heißts so schön "Kein Meister ist vom Himmel gefalln" (Hört sich im dialekt eindeutig besser an...
Bitte warten ..
Mitglied: iceman5
02.03.2006 um 00:18 Uhr
Was meinst du jetzt mit "Im Router und im Server"?
Bitte warten ..
Mitglied: christians
02.03.2006 um 00:23 Uhr
Du musst den Exchange an Port 80 lauschen lassen (Server) und die Portweiterleitung (am Router) auch auf Port 80 ändern.

ODER: Mach einfach ein mapping am Router von Port 80 auf Port 25.
Bitte warten ..
Mitglied: iceman5
02.03.2006 um 00:25 Uhr
also auf Port 80 kann ich zwar keine Verbindung in dem Sinn herstelln, aber es kommt wenigstens irgendeine Rückmeldung - und zwar die Standard WWW Seite vom Win2k3 Server (In Bearbeitung oder was da steht) als HTML Code, dann wird die Verbindung beendet...


Schon mal ein Vortschritt...ich bin durch den Router im Server (kurz) gewesen...
Bitte warten ..
Mitglied: iceman5
02.03.2006 um 00:27 Uhr
Noch ist der Server im DMZ!

(Danke zwischenzeitlich mal für die Hilfe spät des nächtens )
Bitte warten ..
Mitglied: christians
02.03.2006 um 00:27 Uhr
Ich glaub jetzt reden wir aneinander vorbei.

Du musst den Webserver natürlich ausschalten, es geht ja nur ein Service an einem Port.
Es geht eigentlich nur darum, einen anderen Port als 25 zu nehmen, weil der durch Deinen Provider gesperrt sein könnte.

Bist Du denn sicher, das am Server selbst keine Firewall läuft bzw dort nicht schon Port 25 blockiert wird?
Bitte warten ..
Mitglied: iceman5
02.03.2006 um 00:32 Uhr
Nein, reden nicht aneinander vorbei, hab den letzten eintrag erst zuspät gelesen!

Hab jetzt im IIS die Standard Websites angehalten.

Im Exchange System Manager hab ich im virtuell SMTP Connector auf Port 80 gestellt

Der Server ist immer noch im DMZ
Bitte warten ..
Neuester Wissensbeitrag
CPU, RAM, Mainboards

Angetestet: PC Engines APU 3a2 im Rack-Gehäuse

(1)

Erfahrungsbericht von ashnod zum Thema CPU, RAM, Mainboards ...

Ähnliche Inhalte
Exchange Server
Exchange Server und Outlook Anywhere über DYNDNS (8)

Frage von Guyver zum Thema Exchange Server ...

Exchange Server
gelöst SBS2011 - im Exchange mobile Geräte löschen (4)

Frage von MiSt zum Thema Exchange Server ...

Exchange Server
Inhalt von Postfächern in Exchange löschen (9)

Frage von m.reeger zum Thema Exchange Server ...

Heiß diskutierte Inhalte
DSL, VDSL
DSL-Signal bewerten (13)

Frage von SarekHL zum Thema DSL, VDSL ...

Switche und Hubs
Trunk für 2xCisco Switch. Wo liegt der Fehler? (13)

Frage von JayyyH zum Thema Switche und Hubs ...

Windows Server
Mailserver auf Windows Server 2012 (9)

Frage von StefanT81 zum Thema Windows Server ...

Backup
Clients als Server missbrauchen? (9)

Frage von 1410640014 zum Thema Backup ...