Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Exchange empfang auf externer domain

Frage Microsoft Exchange Server

Mitglied: haihappen18

haihappen18 (Level 1) - Jetzt verbinden

14.02.2010 um 16:58 Uhr, 10555 Aufrufe, 6 Kommentare

Mails werden empfangen an local.domain.de, nicht jedoch an domain.de

Hallo!
Nach vielem Lesen und guten Tipss aus diesem Board und von MSXFAQ habe ich es doch noch geschafft, exchange zu installieren.
Kurz zum System:
-domain.de registriert auf die feste IP meines Internetanschlusses
-modem-router-switch-server (server testweise als exposed-host, um alle forwardingprobleme ausschließen zu können)
-Server 2003 r2 standard x64, als DC promoted auf local.domain.de
-Exchange 2007 x64

Emails werden korrekt empfangen an "user@local.domain.de", emails können von "user" gesendet werden und (dank Einstellung im Konto von "User") mit dem Absender "user@domain.de" angezeigt. Eine Antwort an "user@domain.de" endet jedoch mit der Fehlermeldung #5.1.1 smtp;550 5.1.1 <user@domain.de>: Recipient address rejected: User unknown in local recipient table quittiert.

Was ich schon probiert habe/ was schon eingestellt ist:
-Organisationskonfiguraion/Hub-Transport/Akzeptierte Domänen: domain.de
- Email-Adressrichtlinien: domain.de ist eingetragen (vlt nicht korrekt? habe wenig infos hierfür gefunden, vlt hat jmd einen Tipp!)
-Serverkonfiguration/Hub-Transport/Empfangsconnectors: Empfänger "Extern" hinzugefügt mit "domain.de"
-Empfängerkonfiguration/Postfach/User/Emailadressen: Unter SMTP ist "user@local.domain.de" sowie "user@domain.de"(als Standard) eingetragen.

Meine Befürchtung ist ja, dass ich den DC-Promo nicht mit "local.domain.de" hätte konfigurieren sollen, sonder einfach auf "domain.de"...

Ich hoffe das handelt sich jetzt nur einen gaaaanz dummen Fehler von mir, aufgrund geschlossener Uni-Bibliothek konnte ich jetzt keine einschlägige Literatur besorgen ;)

Mit freundlichen Grüßen Jan
Mitglied: GuentherH
14.02.2010 um 20:40 Uhr
Hallo.

Meine Befürchtung ist ja, dass ich den DC-Promo nicht mit "local.domain.de" hätte konfigurieren sollen

Das ist mit Sicherheit nicht das Problem, der Exchange regelt den korrekten Domain Namen über die Empfängerrichtlinien

endet jedoch mit der Fehlermeldung #5.1.1 smtp;550 5.1.1 <user@domain.de>: Recipient address rejected: User unknown in local recipient table quittiert.

Von wem kommt diese Fehlermeldung? Sicher nicht von Exchange, oder?

Poste doch einmal wie die Mails versendet werden. Über Relay Host oder über DNS.

LG Günther
Bitte warten ..
Mitglied: haihappen18
14.02.2010 um 21:33 Uhr
Hallo Günther

Puh, nicht der DC ;)

Leider kann ich mit Relay Host bzw DNS nicht allzuviel anfangen. Also der Server ist natürlich auch DNS und korrekt kofiguriert, aber inwiefern das mit Exchange zu tun hat, bzw was ich bei exchange dafür konfiurieren muss, weiß ich leider nicht. Ich bin echt seehr neu in der Materie
Eine gerade testweise verschickte nachricht von "administrator@domain.de" an "user@domain.de" kommt korrekt an, jedoch kann ich den Maildetails entnehmen, dass diese nur intern (was ja soweit auch nicht falsch ist) weitergeleitet wurde:
Received: from server.local.domain.de ([192.168.178.100]) by server.local.domain.de ([192.168.178.100]) with mapi (daten natürlich angepasst)

Wenn ich von meinem alice-email-account jedoch eine nachricht an "user@domain.de" schicke, bekomme ich sofort eine Unzustellbarkeitsmail zurück:

Ihre Nachricht hat keine oder nicht alle Empfänger erreicht.

Betreff: testnachricht
Gesendet: 14.02.2010 21:19

Folgende(r) Empfänger konnte(n) nicht erreicht werden:

user@domain.de am 14.02.2010 21:19
Das E-Mail-Konto ist in der Organisation, an die diese Nachricht gesendet wurde, nicht vorhanden. Überprüfen Sie die E-Mail-Adresse, oder setzen Sie sich direkt mit dem Empfänger in Verbindung, um die richtige E-Mail-Adresse herauszufinden.
<smtp-out03.alice-dsl.net #5.1.1 smtp;550 5.1.1 <user@domain.de>: Recipient address rejected: User unknown in local recipient table>

Ich glaube wirklich langsam, mir fehlt eine grundlegende Einstellung. Ist das vlt. dieser Relay Host?

Falls weitere informationen gewünscht sind, bitte sagen wo ich diese angaben entnehmen kann

Mit freundlichen Grüßen Jan


P.s.: Nachtrag!

gerade mal versucht mich im OWA mit den möglichen "Kandidaten" einzuloggen: Möglich mit "user" und "user@local.domain.de" jedoch auch nicht wie die mails mit "user@domain.de"
Bitte warten ..
Mitglied: filippg
15.02.2010 um 01:30 Uhr
Hallo,

hat denn der Nutzer die eMail-Adresse user@domain.de? Ansonsten wird er für die auch keine Mails empfangen können. Füge sie mal in der Exchange Management Console manuell hinzu (und setze sie auch gleich als primäre). Sollte es das gewesen sein, kann man im nächsten Schritt mal wegen der Adress-Richtlinien schauen. Wenn er sie hat und es trotzdem nicht funktioniert.. hm.. dann soltest du nochmal sicherstellen, dass der MX-Eintrag im DNS auch auf deinen Server zeigt (cmd -> nslookup -> set type=mx -> dein Domainnamen. Bzw besser von extern testen, da dein lokales DNS durchaus vom "offiziellen" abweichen kann, z.B. http://www.heise.de/netze/tools/dns-abfrage und dort MX auswählen).

Die Anmeldung am OWA erfolgt übrigens nicht mit der EMail-Adresse, sondern mit dem User Principal Name, den man allerdings so einstellen kann, dass er wie die EMail-Adresse aussieht. Siehe Active Directory Users & Computers, Reiter Account.

Gruß

Filipp
Bitte warten ..
Mitglied: haihappen18
15.02.2010 um 02:03 Uhr
Zitat von filippg:
>dann soltest du nochmal sicherstellen, dass der MX-Eintrag im DNS auch auf deinen Server zeigt

Hui, ich glaub du hast voll ins Schwarze getroffen. Ich habe tatsächlich keinen mx-Eintrag für meine Domain. Lokal bringt mir der nslookup ne Zeitüberschreitung, per heise bekomme ich folgendes raus:
Typ Daten
MX name: domain.de
exchange: mx00.udag.de
preference: 10
ttl: 14400
MX name: domain.de
exchange: mx01.udag.de
preference: 20
ttl: 14400
(sagt mir jetzt persönlich nicht so viel, außer dass dort wahrscheinlich nicht *.udag.de (wahrscheinlich der united-domains-mx?!) sondern etwas mit meiner domain stehen sollte)

Im Interface bei United-Domains kann ich folgendes einstellen:
Eigene MX-Server (FQDN) verwenden:
Priorität 10:
Priorität 20:
Muss dort nun "local.domain.de" oder "domain.de" eingetragen werden? Und dies an beiden Stellen? ich habe ja nur den einen exchange und nur die eine externe ip, also gehe ich mal davon aus, das beides gleich lauten wird ;)

Die Anmeldung am OWA erfolgt übrigens nicht mit der EMail-Adresse, sondern mit dem User Principal Name, den man allerdings so
einstellen kann, dass er wie die EMail-Adresse aussieht. Siehe Active Directory Users & Computers, Reiter Account.

Naja, bei dem Reiter "Konto" (sorry, hab mir ausversehen die deutsche Version gezogen :D ) kann ich unter Benutzeranmeldename ja den "user" angeben, daneben ist das Drop-downfeld was mir nur "local.domain.de" anbietet. Oder sollte tatsächlich das Konto "user@domain.de" heißen? Also quasi vollqualifiziert lokal dann "user@domain.de@local.domain.de"?
Ich glaube echt, du versüßt mir noch die Tage durch den mx-Eintrag

Vielen Dank schonmal

Grüße, Jan

P.s.: Mal wieder Nachtrag: nach erneutem lokalem NSLOOKUP spuckt er mir dieselben mx-Einträge wie heise.de aus, also alles im Grünen
Bitte warten ..
Mitglied: filippg
15.02.2010 um 20:52 Uhr
Hallo,

Muss dort nun "local.domain.de" oder "domain.de" eingetragen werden? Und dies an beiden Stellen? ich habe ja
nur den einen exchange und nur die eine externe ip, also gehe ich mal davon aus, das beides gleich lauten wird ;)
Da muss ein Hostname eingetragen werden, der im Internet aufgelöst werden kann. I.A. ist das keiner mit "local" im Domain-Teil. Also z.B. mail.domain.de. Dann musst du halt einen entsprechenden A-Record im DNS anlegen. Wenn du auch Mails von dem Server versenden willst brauchst du auch einen korrekten Reverse-DNS-Eintrag. Nicht unvorteilhaft ist es auch, wenn sich dein Server beim SMTP-Greeting dann auch mit diesem Namen meldet. Und wenn du das zweite Feld nicht leer lassen kannst, dann trage ihn halt zweimal ein.

Naja, bei dem Reiter "Konto" (sorry, hab mir ausversehen die deutsche Version gezogen :D ) kann ich unter
Benutzeranmeldename ja den "user" angeben, daneben ist das Drop-downfeld was mir nur "local.domain.de"
anbietet.
Mögliche UPN-Suffixe sind per default die AD-Domain-Namen des Forests. Man kann aber auch beliebige weitere hinzufügen, siehe http://support.microsoft.com/?scid=kb%3Ben-us%3B243629&x=12&y=1 ...

Gruß

Filipp
Bitte warten ..
Mitglied: haihappen18
15.02.2010 um 21:34 Uhr
Filipp, du bist super

Alles gelöst, habe einfach als mx-Eintrag "domain.de" eingetragen, damit funktioniert alles. Ich gehe nicht davon aus, dass daraus weitere Probleme resultieren könnten?

("mail.domain.de" wie auch "local.domain.de" wird beides auf die zu "domain.de" gehörige IP aufgelöst (von extern), habe aber nichts weiteres eingetragen, also auch keine Alias(e))
Ob das so korrekt ist, weiß ich ehrlichgesagt nicht genau.

Der Tipp mit den UPN-Suffixen hat perfekt geklappt

Mich wundert nur, warum der Mailempfang auf "User@local.domain.de" von extern ohne mx-Eintrag geklappt hat. Aber dafür werde ich wohl noch viel zu lesen haben

Over and Out, vielen Dank nochmal

Grüße Jan
Bitte warten ..
Neuester Wissensbeitrag
CPU, RAM, Mainboards

Angetestet: PC Engines APU 3a2 im Rack-Gehäuse

Erfahrungsbericht von ashnod zum Thema CPU, RAM, Mainboards ...

Heiß diskutierte Inhalte
Grafikkarten & Monitore
Win 10 Grafikkarte Crash von Software? (13)

Frage von Marabunta zum Thema Grafikkarten & Monitore ...

DSL, VDSL
DSL-Signal bewerten (10)

Frage von SarekHL zum Thema DSL, VDSL ...

Windows Server
Mailserver auf Windows Server 2012 (8)

Frage von StefanT81 zum Thema Windows Server ...

Backup
Clients als Server missbrauchen? (8)

Frage von 1410640014 zum Thema Backup ...