Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Exchange Server 2010 - Private Store Einbindung aufgehoben - kann auch nicht mehr eingebunden werden

Frage Microsoft Exchange Server

Mitglied: gironimo84

gironimo84 (Level 1) - Jetzt verbinden

25.09.2012 um 17:30 Uhr, 6605 Aufrufe, 3 Kommentare

Hallo,

ein Kunde von uns hat einen produktiv Server auf dem ein Exchange Server 2010 läuft.
Leider ist unser Exchange Spezialist auf Urlaub und nicht erreichbar, das ganze ist aber sehr dringend.

Bei dem Server ist der Private Store aus irgendeinem Grund nicht mehr eingebunden, somit kommen keine E-Mails mehr rein oder raus. In der Exchange Verwaltungskonsole bringt der Versuch die Datenbank einzubinden nur folgende Fehlermeldung:


Microsoft Exchange Fehler
Die Datenbank 'Mailbox Database' konnte nicht eingebunden werden.

Mailbox Database
Fehler
Fehler:
Die angegebene Datenbank konnte nicht eingebunden werden. Angegebene Datenbank: Mailbox Database; Fehlercode: An Active Manager operation failed. Error: Fehler bei der Datenbankaktion: Fehler bei Vorgang mit folgender Meldung: MapiExceptionCallFailed: Unable to mount database. (hr=0x80004005, ec=-530)
.. [Database: Mailbox Database, Server: xxx.xxx.local].

Fehler bei Active Manager-Vorgang: Fehler bei der Datenbankaktion: Fehler bei Vorgang mit folgender Meldung: MapiExceptionCallFailed: Unable to mount database. (hr=0x80004005, ec=-530)
.. [Datenbank: Mailbox Database, Server: xxx.xxx.local]

Fehler bei Active Manager-Vorgang: Fehler bei Vorgang mit folgender Meldung: MapiExceptionCallFailed: Unable to mount database. (hr=0x80004005, ec=-530)
. [Server: xxx.xxx.local]

MapiExceptionCallFailed: Unable to mount database. (hr=0x80004005, ec=-530)





OK
Ich hab dann versucht mit "eseutil /mh" auszulesen wie der Status der Datenbank ist, da hab ich aber nur folgende Fehlermeldung bekommen:

Extensible Storage Engine Utilities for Microsoft(R) Exchange Server
Version 14.01
Copyright (C) Microsoft Corporation. All Rights Reserved.

Initiating FILE DUMP mode...
Error: Access to source database '.\Mailbox Database.edb' failed with Jet error -1032.

Operation terminated with error -1032 (JET_errFileAccessDenied, Cannot access file, the file is locked or in use) after 0.0 seconds.
Daraufhin habe ich versucht alle möglichen Exchange Dienste zu beenden, hat aber nichts geholfen. Ich hab daraufhin den Ordner mit dem Mail Store und den Logfiles wegkopiert. Dort funktionierte dann auch das eseutil und brachte folgende Meldung:


Extensible Storage Engine Utilities for Microsoft(R) Exchange Server
Version 14.01
Copyright (C) Microsoft Corporation. All Rights Reserved.

Initiating FILE DUMP mode...
Database: c:\Mailbox Database\Mailbox Database.edb


DATABASE HEADER:
Checksum Information:
Expected Checksum: 0x1778e4d2
Actual Checksum: 0x1778e4d2

Fields:
File Type: Database
Checksum: 0x1778e4d2
Format ulMagic: 0x89abcdef
Engine ulMagic: 0x89abcdef
Format ulVersion: 0x620,17
Engine ulVersion: 0x620,17
Created ulVersion: 0x620,17
DB Signature: Create time:06/13/2012 20:41:25 Rand:4177899 Computer:
cbDbPage: 32768
dbtime: 7824454 (0x776446)
State: Dirty Shutdown
Log Required: 29278-29278 (0x725e-0x725e)
Log Committed: 0-29279 (0x0-0x725f)
Log Recovering: 29278 (0x725e)
GenMax Creation: 09/22/2012 17:59:02
Shadowed: Yes
Last Objid: 1571
Scrub Dbtime: 0 (0x0)
Scrub Date: 00/00/1900 00:00:00
Repair Count: 0
Repair Date: 00/00/1900 00:00:00
Old Repair Count: 0
Last Consistent: (0x5063,8,1F) 06/28/2012 08:33:47
Last Attach: (0x5064,9,86) 06/28/2012 08:33:53
Last Detach: (0x0,0,0) 00/00/1900 00:00:00
Dbid: 1
Log Signature: Create time:06/13/2012 20:41:16 Rand:4190063 Computer:
OS Version: (6.1.7600 SP 0 NLS ffffffff.ffffffff)

Previous Full Backup:
Log Gen: 0-0 (0x0-0x0)
Mark: (0x0,0,0)
Mark: 00/00/1900 00:00:00

Previous Incremental Backup:
Log Gen: 0-0 (0x0-0x0)
Mark: (0x0,0,0)
Mark: 00/00/1900 00:00:00

Previous Copy Backup:
Log Gen: 0-0 (0x0-0x0)
Mark: (0x0,0,0)
Mark: 00/00/1900 00:00:00

Previous Differential Backup:
Log Gen: 0-0 (0x0-0x0)
Mark: (0x0,0,0)
Mark: 00/00/1900 00:00:00

Current Full Backup:
Log Gen: 0-0 (0x0-0x0)
Mark: (0x0,0,0)
Mark: 00/00/1900 00:00:00

Current Shadow copy backup:
Log Gen: 0-0 (0x0-0x0)
Mark: (0x0,0,0)
Mark: 00/00/1900 00:00:00

cpgUpgrade55Format: 0
cpgUpgradeFreePages: 0
cpgUpgradeSpaceMapPages: 0

ECC Fix Success Count: none
Old ECC Fix Success Count: none
ECC Fix Error Count: none
Old ECC Fix Error Count: none
Bad Checksum Error Count: none
Old bad Checksum Error Count: none

Last checksum finish Date: 00/00/1900 00:00:00
Current checksum start Date: 00/00/1900 00:00:00
Current checksum page: 0


Operation completed successfully in 0.47 seconds.

Ich hab dann versucht "eseutil /r "E00" /l "c:\Mailbox Database" /d "c:\Mailbox Database" auszuführen, dabei habe ich folgende Fehlermeldung bekommen:

Extensible Storage Engine Utilities for Microsoft(R) Exchange Server
Version 14.01
Copyright (C) Microsoft Corporation. All Rights Reserved.

Initiating RECOVERY mode...
Logfile base name: E00
Log files: c:\Mailbox Database
System files: <current directory>
Database Directory: c:\Mailbox Database

Performing soft recovery...
Restore Status (% complete)

0 10 20 30 40 50 60 70 80 90 100
|----|----|----|----|----|----|----|----|----|----|
X



Operation terminated with error -1032 (JET_errFileAccessDenied, Cannot access file, the file is locked or in use) after 20.187 seconds.
Ich weis leider nicht weiter. Was könnte ich noch schauen?


Mitglied: gironimo84
26.09.2012 um 00:13 Uhr
Hallo,

mittlerweile konnte ich das Acronis Backup und das Trend Micro Antivirus als Fehlerquelle ausschliessen. (Möglichkeit bestand, dass sie die edb sperren).

Im Eventlog hab ich folgende Fehlermeldung:

Fehler beim Cmdlet. Cmdlet Mount-Database, Parameter {Identity=Mailbox Database}.
und:

'25.09.2012 23:52:46': Bei der Kopie der Datenbank 'Mailbox Database' ist auf diesem Server beim Einbinden ein Fehler aufgetreten. Überprüfen Sie das Ereignisprotokoll auf dem Server für 'ExchangeStoreDb'- oder 'MSExchangeRepl'-Ereignisse, um weitere Informationen zu erhalten. Der Einbindungsvorgang wird später automatisch erneut ausgeführt.
und:

25.09.2012 23:52:46: Für die Kopie der Datenbank 'Mailbox Database' auf diesem Server scheint ein Konfigurationsfehler vorzuliegen Das Problem ist möglicherweise auf einen Speicherfehler zurückzuführen. Überprüfen Sie das Ereignisprotokoll auf dem Server hinsichtlich anderer Speicher- und "ExchangeStoreDb"-Ereignisse, um detailliertere Informationen zu dem Fehler zu erhalten. Die Dienstwiederherstellung wurde mithilfe eines Failovers auf eine andere Kopie versucht. Der Failover konnte den Dienst nicht wiederherstellen. Fehler Es ist nur eine Kopie der Postfachdatenbank (Mailbox Database)
vorhanden. Es ist keine automatische Wiederherstellung verfügbar.
lg. Gergely
Bitte warten ..
Mitglied: gironimo84
26.09.2012 um 14:34 Uhr
Hallo,

so ich bin etwas weitergekommen:

ich hatte gestern fälschlicherweise angenommen, wenn der Private Store nicht eingebunden ist, dass ich den "Microsoft Exchange-Informationsspeicher" Dienst nicht beenden muss. Nachdem ich das heute gemacht habe, konnte ich auch gleich Ergebnisse mit eseutil erzielen.

So wie es ausschaut hat meine edb einen "Dirty Shutdown":

Extensible Storage Engine Utilities for Microsoft(R) Exchange Server
Version 14.01
Copyright (C) Microsoft Corporation. All Rights Reserved.

Initiating FILE DUMP mode...
Database: .\Mailbox Database.edb


DATABASE HEADER:
Checksum Information:
Expected Checksum: 0x1778e4d2
Actual Checksum: 0x1778e4d2

Fields:
File Type: Database
Checksum: 0x1778e4d2
Format ulMagic: 0x89abcdef
Engine ulMagic: 0x89abcdef
Format ulVersion: 0x620,17
Engine ulVersion: 0x620,17
Created ulVersion: 0x620,17
DB Signature: Create time:06/13/2012 20:41:25 Rand:4177899 Computer:
cbDbPage: 32768
dbtime: 7824454 (0x776446)
State: Dirty Shutdown
Log Required: 29278-29278 (0x725e-0x725e)
Log Committed: 0-29279 (0x0-0x725f)
Log Recovering: 29278 (0x725e)
GenMax Creation: 09/22/2012 17:59:02
Shadowed: Yes
Last Objid: 1571
Scrub Dbtime: 0 (0x0)
Scrub Date: 00/00/1900 00:00:00
Repair Count: 0
Repair Date: 00/00/1900 00:00:00
Old Repair Count: 0
Last Consistent: (0x5063,8,1F) 06/28/2012 08:33:47
Last Attach: (0x5064,9,86) 06/28/2012 08:33:53
Last Detach: (0x0,0,0) 00/00/1900 00:00:00
Dbid: 1
Log Signature: Create time:06/13/2012 20:41:16 Rand:4190063 Computer:
OS Version: (6.1.7600 SP 0 NLS ffffffff.ffffffff)

Previous Full Backup:
Log Gen: 0-0 (0x0-0x0)
Mark: (0x0,0,0)
Mark: 00/00/1900 00:00:00

Previous Incremental Backup:
Log Gen: 0-0 (0x0-0x0)
Mark: (0x0,0,0)
Mark: 00/00/1900 00:00:00

Previous Copy Backup:
Log Gen: 0-0 (0x0-0x0)
Mark: (0x0,0,0)
Mark: 00/00/1900 00:00:00

Previous Differential Backup:
Log Gen: 0-0 (0x0-0x0)
Mark: (0x0,0,0)
Mark: 00/00/1900 00:00:00

Current Full Backup:
Log Gen: 0-0 (0x0-0x0)
Mark: (0x0,0,0)
Mark: 00/00/1900 00:00:00

Current Shadow copy backup:
Log Gen: 0-0 (0x0-0x0)
Mark: (0x0,0,0)
Mark: 00/00/1900 00:00:00

cpgUpgrade55Format: 0
cpgUpgradeFreePages: 0
cpgUpgradeSpaceMapPages: 0

ECC Fix Success Count: none
Old ECC Fix Success Count: none
ECC Fix Error Count: none
Old ECC Fix Error Count: none
Bad Checksum Error Count: none
Old bad Checksum Error Count: none

Last checksum finish Date: 00/00/1900 00:00:00
Current checksum start Date: 00/00/1900 00:00:00
Current checksum page: 0


Operation completed successfully in 0.16 seconds.
Daraufhin habe ich die Integrität der edb überprüft:

Extensible Storage Engine Utilities for Microsoft(R) Exchange Server
Version 14.01
Copyright (C) Microsoft Corporation. All Rights Reserved.

Initiating INTEGRITY mode...
Database: .\Mailbox Database.edb
Temp. Database: TEMPINTEG12572.EDB


Checking database integrity.



The database is not up-to-date. This operation may find that

this database is corrupt because data from the log files has

yet to be placed in the database.


To ensure the database is up-to-date please use the 'Recovery' operation.






Operation terminated with error -550 (JET_errDatabaseDirtyShutdown, Database was not shutdown cleanly. Recovery must first be run to properly complete database operations for the previous shutdown.) after 401.47 seconds.

Leider mit einer Fehlermeldung.
Dannach habe ich die Konsitenz der Datenbank überprüft, mit folgendem Ergebniss:

Extensible Storage Engine Utilities for Microsoft(R) Exchange Server
Version 14.01
Copyright (C) Microsoft Corporation. All Rights Reserved.

Initiating CHECKSUM mode...
Database: .\Mailbox Database.edb
Temp. Database: TEMPCHKSUM10228.EDB


File: .\Mailbox Database.edb



Checksum Status (% complete)



0 10 20 30 40 50 60 70 80 90 100

|----|----|----|----|----|----|----|----|----|----|

...................................................





598274 pages seen

0 bad checksums

0 correctable checksums

7153 uninitialized pages

0 wrong page numbers

0x1279aeb highest dbtime (pgno 0x295)



299137 reads performed

18696 MB read

233 seconds taken

80 MB/second

238800558 milliseconds used

798 milliseconds per read

133053 milliseconds for the slowest read

0 milliseconds for the fastest read





Operation completed successfully in 233.689 seconds.


Da er mit dem eseutil /mh Befehl geschrieben hat, dass er die 725E.log benötigt, habe ich noch die Integrität der E00.log und E000000725E.log überprüft. Mit positivem Ergebniss.
Dannach wollte ich ein Soft - Recovery ausführen, dieser brach leider mit einem Fehler ab:

Extensible Storage Engine Utilities for Microsoft(R) Exchange Server
Version 14.01
Copyright (C) Microsoft Corporation. All Rights Reserved.

Initiating RECOVERY mode...
Logfile base name: E00
Log files: c:\Program Files\Microsoft\Exchange Server\V14\Mailbox\Mailbox Database
System files: <current directory>
Database Directory: C:\Program Files\Microsoft\Exchange Server\V14\Mailbox\Mailbox Database

Performing soft recovery...
Restore Status (% complete)

0 10 20 30 40 50 60 70 80 90 100
|----|----|----|----|----|----|----|----|----|----|
............X



Operation terminated with error -530 (JET_errBadLogSignature, Bad signature for a log file) after 0.546 seconds.

Im Ereignissprotokoll habe ich gesehen, dass er ein Problem mit dem E000000725F.log hat, ich hab deren Integrität überprüft, diese war aber ok. Da er aber nur das log 725E braucht habe ich testweise die 725F wegkopiert. und dannach nocheinmal das Soft Recovery durchgeführt, diesmal mit Erfolg.

Extensible Storage Engine Utilities for Microsoft(R) Exchange Server
Version 14.01
Copyright (C) Microsoft Corporation. All Rights Reserved.

Initiating RECOVERY mode...
Logfile base name: E00
Log files: c:\Program Files\Microsoft\Exchange Server\V14\Mailbox\Mailbox Database
System files: <current directory>
Database Directory: C:\Program Files\Microsoft\Exchange Server\V14\Mailbox\Mailbox Database

Performing soft recovery...
Restore Status (% complete)

0 10 20 30 40 50 60 70 80 90 100
|----|----|----|----|----|----|----|----|----|----|
...................................................



Operation completed successfully in 5.444 seconds.

Auch eseutil /mh war danach mit einem Clean Shutdown gekennzeichnet:

Extensible Storage Engine Utilities for Microsoft(R) Exchange Server
Version 14.01
Copyright (C) Microsoft Corporation. All Rights Reserved.

Initiating FILE DUMP mode...
Database: .\Mailbox Database.edb


DATABASE HEADER:
Checksum Information:
Expected Checksum: 0x1a206ad4
Actual Checksum: 0x1a206ad4

Fields:
File Type: Database
Checksum: 0x1a206ad4
Format ulMagic: 0x89abcdef
Engine ulMagic: 0x89abcdef
Format ulVersion: 0x620,17
Engine ulVersion: 0x620,17
Created ulVersion: 0x620,17
DB Signature: Create time:06/13/2012 20:41:25 Rand:4177899 Computer:
cbDbPage: 32768
dbtime: 19374908 (0x127a33c)
State: Clean Shutdown
Log Required: 0-0 (0x0-0x0)
Log Committed: 0-0 (0x0-0x0)
Log Recovering: 0 (0x0)
GenMax Creation: 00/00/1900 00:00:00
Shadowed: Yes
Last Objid: 1779
Scrub Dbtime: 0 (0x0)
Scrub Date: 00/00/1900 00:00:00
Repair Count: 0
Repair Date: 00/00/1900 00:00:00
Old Repair Count: 0
Last Consistent: (0x7260,C,1F) 09/26/2012 14:01:10
Last Attach: (0x7260,A,140) 09/26/2012 14:01:10
Last Detach: (0x7260,C,1F) 09/26/2012 14:01:10
Dbid: 1
Log Signature: Create time:06/13/2012 20:41:16 Rand:4190063 Computer:
OS Version: (6.1.7600 SP 0 NLS ffffffff.ffffffff)

Previous Full Backup:
Log Gen: 0-0 (0x0-0x0)
Mark: (0x0,0,0)
Mark: 00/00/1900 00:00:00

Previous Incremental Backup:
Log Gen: 0-0 (0x0-0x0)
Mark: (0x0,0,0)
Mark: 00/00/1900 00:00:00

Previous Copy Backup:
Log Gen: 0-0 (0x0-0x0)
Mark: (0x0,0,0)
Mark: 00/00/1900 00:00:00

Previous Differential Backup:
Log Gen: 0-0 (0x0-0x0)
Mark: (0x0,0,0)
Mark: 00/00/1900 00:00:00

Current Full Backup:
Log Gen: 0-0 (0x0-0x0)
Mark: (0x0,0,0)
Mark: 00/00/1900 00:00:00

Current Shadow copy backup:
Log Gen: 0-0 (0x0-0x0)
Mark: (0x0,0,0)
Mark: 00/00/1900 00:00:00

cpgUpgrade55Format: 0
cpgUpgradeFreePages: 0
cpgUpgradeSpaceMapPages: 0

ECC Fix Success Count: none
Old ECC Fix Success Count: none
ECC Fix Error Count: none
Old ECC Fix Error Count: none
Bad Checksum Error Count: none
Old bad Checksum Error Count: none

Last checksum finish Date: 00/00/1900 00:00:00
Current checksum start Date: 00/00/1900 00:00:00
Current checksum page: 0


Operation completed successfully in 0.47 seconds.
Aktuell mache ich gerade einen eseutil /d (Offline Defragmentieren) Und warte auf das Ergebniss, hoffendlich funktioniert es jetzt.

lg.
Bitte warten ..
Mitglied: gironimo84
26.09.2012 um 15:35 Uhr
OK, jetzt funktionierts wieder.

Ganz wichtig ist zum Abschluss der Reparaturarbeiten ein eseutil /d (Offline Defragmentieren), durchzuführen.
Beim ersten Versuch hab ich das nicht gemacht, weshalb ich sofort wieder mit einem Dirty Shutdown belohnt wurde, als ich die edb in der Verwaltungskonsole bereitstellen wollte.

Hab das ganze wieder von vorne machen können.

Aber die eseutil Werkzeuge sind Gold Wert bei einem edb Chrash. Viel geholfen hat mir auch dieses Tutorial:

http://www.mikepfeiffer.net/2010/04/getting-an-exchange-database-into-a ...

Und ein Exchange Server 2010 Kompendium.

Leider habe ich hier nicht viel Rückmeldung bekommen, aber ich hoffe meine Erfahrungen können hier jemand anderem weiterhelfen.

Lg. Gergely
Bitte warten ..
Neuester Wissensbeitrag
Internet

Unbemerkt - Telekom Netzumschaltung! - BNG - Broadband Network Gateway

(3)

Erfahrungsbericht von ashnod zum Thema Internet ...

Heiß diskutierte Inhalte
Windows Server
Outlook Verbindungsversuch mit Exchange (15)

Frage von xbast1x zum Thema Windows Server ...

Grafikkarten & Monitore
Tonprobleme bei Fernseher mit angeschlossenem Laptop über HDMI (11)

Frage von Y3shix zum Thema Grafikkarten & Monitore ...

Microsoft Office
Keine Updates für Office 2016 (11)

Frage von Motte990 zum Thema Microsoft Office ...