Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Exchange SMTP Mail FROM in Telnet

Frage Microsoft Exchange Server

Mitglied: Goofie

Goofie (Level 1) - Jetzt verbinden

23.03.2008, aktualisiert 25.03.2008, 7500 Aufrufe, 4 Kommentare

Das versenden von Mails via Telnet und Exchange funktioniert nur, wenn bei MAIL FROM: <myname@domain.com> verwendet wird. MAIL FROM: myname <myname@domain.com> funktioniert nicht!

Hi,

ich versuche verzweifelt rauszubekommen, warum mein Exchange per Telnet einfach nur E-Mails mit Absender-Mail-Adresse verschickt und ich keinen Absendername anfügen kann.

Wenn ich per Telnet auf den Server verbinde und
MAIL FROM: <myname@domain.com>
ausführe, dann funktioniert alles.
Will ich jedoch einen Absendername hinzufügen (MAIL FROM: myname <myname@domain.com>)
und nicht nur eine Absender-Mail-Adresse, dann meckert Exchange: 501 5.5.4 Invalid arguments.

Per Outlook Express kann ich jedoch auch einen beliebitgen Absendernamen eingeben und die Mails kommen korrekt an.

Wahrscheinlich ist die Eingabe-form falsch... kann mir jemand helfen???

Gruß

Ben
Mitglied: filippg
23.03.2008 um 17:13 Uhr
Hallo,

beim Mailversand per SMTP taucht der Absender zweimal auf: einmal im "MAIL FROM:"-SMTP-Befehl, und einmal im Message-Header. Der Message-Header wird im "DATA"-Teil übertragen. Der Mailserver wertet diese Header gar nicht aus (gut, zum Spamschutz wird das mittlerweile schon gemacht, ist eigentlich aber nicht vorgesehen). Und die Angabe des Absendernamens kann nur in den Message-Headern im DATA-Teil gemacht werden, nicht im MAIL FROM-Befehl.

Gruß

Filipp
Bitte warten ..
Mitglied: Goofie
24.03.2008 um 14:54 Uhr
@filippg: Danke für den Hinweis...
Ich versuche allerdings per PHP mit dem mail()-Befehl eine E-Mail zu versenden.
wie ich bereits erläutert habe, funktioniert dies nur, wenn ich als absender eine e-mail-adresse festlege...

mit:
$headers.="From: \"$fromname\" <$from>\r\n";
wird keine E-Mail versandt... ich bin hier etwas fündig geworden, aber der bugfix zeigt keine wirkung:

The fix is in Microsoft Article ID 291828 ( http://support.microsoft.com/?id=291828 ). Even though the "bug" workaround is for IIS 6.0 on Exchange 2003 communicating with a UNIX server, THIS SOLVES THE PROBLEM. Just skip down to the last section for Exchange 2003 and follow the instructions to modify the IIS 6 MetaBase with the MetaBase Explorer found in the IIS 6 Resource Kit.
Bitte warten ..
Mitglied: filippg
24.03.2008 um 15:33 Uhr
Hallo,

von PHP hattest du leider kein Wort geschrieben.
Und der Patch den du verlinkt hast bezieht sich auf einen komplett anderen Fehler.

Gruß

Filipp
Bitte warten ..
Mitglied: Goofie
25.03.2008 um 13:07 Uhr
Habs hinbekommen...

das Problem lag an folgendem: die in der PHP.ini kein Absender angegeben war, hat die Mail-funktion als Absender die im Header angegebene Adresse verwendet und zwar mit Absendername <E-Mail-adresse>, was Exchange aber so nicht annimmt.

Meine neue Mail-Funktion in PHP ändert also erst die Absenderadresse in der PHP.ini, im Header kann dann trotzdem Absendername <E-Mail-Adresse> verwendet werden.
Bitte warten ..
Neuester Wissensbeitrag
Ähnliche Inhalte
Exchange Server
gelöst Exchange Server Mail senden (5)

Frage von MorrowToon zum Thema Exchange Server ...

Outlook & Mail
gelöst Exchange 2016 Mail Disclaimer (3)

Frage von JensDND zum Thema Outlook & Mail ...

Exchange Server
Exchange nicht alle mails kommen rein 550 smtp (2)

Frage von windows10 zum Thema Exchange Server ...

Heiß diskutierte Inhalte
Windows Userverwaltung
Ausgeschiedene Mitarbeiter im Unternehmen - was tun mit den AD Konten? (33)

Frage von patz223 zum Thema Windows Userverwaltung ...

LAN, WAN, Wireless
FritzBox, zwei Server, verschiedene Netze (21)

Frage von DavidGl zum Thema LAN, WAN, Wireless ...

Viren und Trojaner
Aufgepasst: Neue Ransomware Goldeneye verbreitet sich rasant (20)

Link von Penny.Cilin zum Thema Viren und Trojaner ...