Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Exchange SP2 Installation auf SBS2003 bricht mit Fehler ab

Frage Microsoft Exchange Server

Mitglied: ahoffm14

ahoffm14 (Level 1) - Jetzt verbinden

08.01.2007, aktualisiert 09.01.2008, 6352 Aufrufe, 9 Kommentare

Die Installation des SP2 für Exchange bricht auf einem SBS2003 SP1 ab

Die Installation des Exchange SP2 bricht mit folgendem Logeintrag ab.

[21:12:03] Interpretation der Datei 'r:\install\windows 2003 server\exchange server updates\e3sp2deu\setup\i386\exchange\smtp_update.ins' wird gestartet -- ID:31258 --
[21:12:03] Zeile <CreateProcessSafe:.;unlodctr TURFLIST;180000> wird interpretiert. -- ID:31259 --
[21:12:03] Process created ... waiting (180000)
[21:12:03] Ignoring exit code 00000000
[21:12:03] Zeile <OpenMachineKey:SYSTEM\CurrentControlSet\Services> wird interpretiert. -- ID:31259 --
[21:12:03] Zeile <CreateKey:TURFLIST\Performance> wird interpretiert. -- ID:31259 --
[21:12:03] Zeile <CloseKey:> wird interpretiert. -- ID:31259 --
[21:12:03] Zeile <OpenMachineKey:SYSTEM\CurrentControlSet\Services\TURFLIST\Performance> wird interpretiert. -- ID:31259 --
[21:12:03] Zeile <ReplaceString:Close;TURFLISTClose> wird interpretiert. -- ID:31259 --
[21:12:03] Zeile <ReplaceString:Collect;TURFLISTCollect> wird interpretiert. -- ID:31259 --
[21:12:03] Zeile <ReplaceString:Library;C:\Programme\Exchsrvr\bin\exprfdll.dll> wird interpretiert. -- ID:31259 --
[21:12:03] Zeile <ReplaceString:Open;TURFLISTOpen> wird interpretiert. -- ID:31259 --
[21:12:03] Zeile <CloseKey:> wird interpretiert. -- ID:31259 --
[21:12:03] Zeile <CreateProcess:C:\Programme\Exchsrvr\bin;lodctr turfctrs.ini;180000> wird interpretiert. -- ID:31259 --
[21:12:03] Process created ... waiting (180000)
[21:12:05] Process has exited with 00000000
[21:12:05] Zeile <CreateProcess:C:\Programme\Exchsrvr\bin;regsvr32 /u /s e2kdsn.dll;180000> wird interpretiert. -- ID:31259 --
[21:12:05] Process created ... waiting (180000)
[21:12:08] Process has exited with 00000000
[21:12:08] Zeile <CreateProcess:C:\Programme\Exchsrvr\bin;regsvr32 /s e2kdsn.dll;180000> wird interpretiert. -- ID:31259 --
[21:12:08] Process created ... waiting (180000)
[21:12:08] Process has exited with 0x000005
[21:12:08] Fehler bei Befehl

regsvr32 /s e2kdsn.dll.

Fehlercode 5 (Zugriff verweigert) -- ID:31136 -- ScCreateProcess (f:\tisp2\admin\src\libs\exsetup\hiddenw1.cxx:1821)
Error code 0XC103798A (31114): Fehler bei einer internen Komponente.
[21:12:08] CInsParser::ScProcessLine (f:\tisp2\admin\src\libs\exsetup\hiddenw1.cxx:1225)
Error code 0XC103798A (31114): Fehler bei einer internen Komponente.
[21:12:08] Die Datei 'r:\install\windows 2003 server\exchange server updates\e3sp2deu\setup\i386\exchange\smtp_update.ins' wird bei oder nahe bei Zeile 29 (CreateProcess:C:\Programme\Exchsrvr\bin;regsvr32 /s e2kdsn.dll;180000) verarbeitet. -- ID:31111 -- CInsParser::ScProcessLine (f:\tisp2\admin\src\libs\exsetup\hiddenw1.cxx:492)
Error code 0XC103798A (31114): Fehler bei einer internen Komponente.
[21:12:08] Registry file name: 'r:\install\windows 2003 server\exchange server updates\e3sp2deu\setup\i386\exchange\smtp_update.ins' CRegistryManager::ScProcessFile (f:\tisp2\admin\src\udog\setupbase\tools\regmgr.cxx:125)
Error code 0XC103798A (31114): Fehler bei einer internen Komponente.
[21:12:08] Filename = 'r:\install\windows 2003 server\exchange server updates\e3sp2deu\setup\i386\exchange\smtp_update' CBaseAtom::ScRunRegistryFile (f:\tisp2\admin\src\udog\setupbase\basecomp\baseatom.cxx:1745)
Error code 0XC103798A (31114): Fehler bei einer internen Komponente.
[21:12:08] Leaving CBaseAtom(SMTP-Dienst)::ScRunRegistryFile
[21:12:08] SMTP-Dienst CBaseAtom(%s)::ScServicePackUpdate (f:\tisp2\admin\src\udog\setupbase\basecomp\baseatom.cxx:1376)
Error code 0XC103798A (31114): Fehler bei einer internen Komponente.
[21:12:08] Leaving CBaseAtom(SMTP-Dienst)::ScServicePackUpdate
[21:12:08] mode = 'Aktualisieren' (61957) CBaseAtom::ScSetup (f:\tisp2\admin\src\udog\setupbase\basecomp\baseatom.cxx:847)
Error code 0XC103798A (31114): Fehler bei einer internen Komponente.

Danach hilft nur noch ein Restore um die Kiste wieder ans Laufen zu bringen.
Mitglied: Kosh
11.01.2007 um 07:53 Uhr
hast du einen virenscanner am server installiert?
ich meine einen file-scanner. nicht einen speziell für exchange der die mailboxen scannt.

falls ja, deinstalliere ihn und versuch dann das SP2 aufzuspielen.
Bitte warten ..
Mitglied: ahoffm14
11.01.2007 um 08:28 Uhr
Hallo Kosh,

ich hab Antivir für Windows Server 2003 installiert ... aber im Moment noch ohne das Exchange Modul... das sollte nach dem Update auf SP2 istalliert werden.

reicht es Antivir zu deaktivieren oder muss es deinstalliert werden ?
Bitte warten ..
Mitglied: Kosh
11.01.2007 um 08:31 Uhr
ich würde es sicherheitshalber deinstallieren.

bei sicherheitsbedenken könntest du den server in diesem zeitraum vom internet trennen.
Bitte warten ..
Mitglied: ahoffm14
11.01.2007 um 08:53 Uhr
alles klar. Ich werde mich morgen dransetzen und melde mich dann.

Vorab schon mal vielen Dank
Bitte warten ..
Mitglied: ahoffm14
12.01.2007 um 22:01 Uhr
war leider nichts

Antivir deinstalliert, Server rebootet, SP2 Installation gestartet... Abbruch an der gleichen Stelle.

Hast du sonst noch ne Idee ?? Ich brauch dringend den Spamfilter von SP2... sonst ersticke ich noch in der Flut
Bitte warten ..
Mitglied: Kosh
15.01.2007 um 07:46 Uhr
hmm. da scheint ein programm die "e2kdsn.dll" zu blockieren.

lade dir den processexplorer,
http://www.microsoft.com/technet/sysinternals/ProcessesAndThreads/Proce ...

und suche nach der applikation welche diese dll im gebrauch hat.
dann die applikation stoppen oder deinstallieren, und dann sollte es klappen.

hast du dir das service pack runtergeladen?
möglich wäre auch das die datei fehlerhaft ist. lade dir das SP2 erneut runter.
Bitte warten ..
Mitglied: ahoffm14
15.01.2007 um 20:48 Uhr
Hallo Kosh,

der Prozess Explorer ist ja ein Hammer !!!! aber leider hilft auch er nicht weiter. Als Administrator eingeloggt zeigt der Explorer KEINE Applikation an, die die e2kdsn.dll benutzt/blockiert.

Auch ein erneuter Download des SP2 hat mich nicht weitergebracht
Bitte warten ..
Mitglied: Kosh
16.01.2007 um 07:21 Uhr
ich hätt hier noch nen link.
bezieht sich zwar auf eine andere dll, aber selber fehler:

http://support.microsoft.com/kb/838176/en-us
Bitte warten ..
Mitglied: itsurfer4711
09.01.2008 um 05:23 Uhr
habe den fehler ebenso bekommen
versuche diesen ansatz:
http://support.microsoft.com/kb/940439/
zeigt auf, wo fehler sein könnten
Bitte warten ..
Ähnliche Inhalte
Exchange Server
Exchange 2013 Installation am anderen Standort vorbereiten (3)

Frage von BlackRain zum Thema Exchange Server ...

Webbrowser
gelöst Internet Explorer muss vor der Installation aktualisiert werden - fehler (3)

Frage von Flosbrain zum Thema Webbrowser ...

Exchange Server
gelöst Exchange 2016 Installation und die Domain Funktionsebene (1)

Frage von RobertMC zum Thema Exchange Server ...

Exchange Server
gelöst Fehler bei Installation von Exchange 2013 (3)

Frage von ingoue zum Thema Exchange Server ...

Neue Wissensbeiträge
Batch & Shell

Batch - ein paar Basics die man kennen sollte

Tipp von Pedant zum Thema Batch & Shell ...

Microsoft

Restrictor: Profi-Schutz für jedes Window

(6)

Tipp von AlFalcone zum Thema Microsoft ...

Batch & Shell

Batch zum Zurücksetzen eines lokalen Profils

Tipp von Mr.Error zum Thema Batch & Shell ...

Heiß diskutierte Inhalte
Windows Server
Benutzer lässt sich nur an einem Clientcomputer anmelden (11)

Frage von Ammann zum Thema Windows Server ...

Hosting & Housing
gelöst Webserver bei WIX, aber DNS Server wo anders (9)

Frage von laster zum Thema Hosting & Housing ...

Hyper-V
Virtualisierung eines Servers (7)

Frage von Lornsti zum Thema Hyper-V ...