Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Exchange-Verwaltungshell - kann keine command-lets ausführen

Frage Microsoft Exchange Server

Mitglied: Lasher

Lasher (Level 1) - Jetzt verbinden

14.09.2009 um 14:27 Uhr, 9936 Aufrufe, 8 Kommentare

Hallo,

da das selbst signierte Zertifikat des Exchange Server in wenigen Tagen abläuft, wollte ich es erneuern. Mit Erstaunen musste ich jedoch feststellen, dass ich schon den Befehl "get-exchangecertificate" nicht ausführen konnte. Es hat auch eine Weile gedauert, bis ich die Fehlermeldung, welche die Shell ausspuckt, entdeckte.

Ausnahme beim Festlegen von "ViewEntireForest": "Fehler bei Active Directory-Vorgang auf XCH-RTS.RTS-GMBH.INTERN. Die angegebenen Anmeldeinformationen für den Vorgang DOMAIN\Administrator' auf Bind sind ungültig. Fehlercode: 0x31." Bei C:\Program Files\Microsoft\Exchange Server\bin\Exchange.ps1:19 Zeichen:32 + $global:AdminSessionADSettings.V <<<< iewEntireForest = $false

Wenn ich den Befehl "get-exchangecertificate" ausführe erhalte ich folgende Fehlermeldung

Get-ExchangeCertificate : Dieser Vorgang kann nur lokal auf einem Microsoft Exchange-Server ausgeführt werden, auf dem eine der Serverfunktionen 'Edge-Transport', 'Hub-Transport', 'ClientAccess' oder 'UnifiedMessaging' installiert ist. Melden Sie sich lokal bei einem Microsoft Exchange-Server an, auf dem eine dieser unterstützten Serverfunktionen installiert ist, und führen Sie den Vorgang erneut aus.
Bei Zeile:1 Zeichen:23
get-exchangecertificate <<<<


Zudem wird mir im Ereignisprotokoll folgender Fehler angezeigt:

Microsoft Exchange konnte ein Zertifikat nicht finden, das den Domänennamen "XCH-SERVER.DOMAIN.INTERN" im persönlichen Informationsspeicher auf dem lokalen Computer enthält. Daher kann die STARTTLS-SMTP-Aktionsart für den Connector "Default XCH-SERVER" mit einem FQDN-Parameter von "XCH-SERVER.DOMAIN.INTERN" nicht unterstützt werden. Überprüfen Sie die Connectorkonfiguration sowie die installierten Zertifikate, damit sichergestellt wird, dass ein Zertifikat mit einem Domänennamen für jeden Connector-FQDN vorhanden ist. Wenn das Zertifikat vorhanden ist, führen Sie "Enable-ExchangeCertificate -Services SMTP" aus, damit sichergestellt ist, dass der Microsoft Exchange-Transportdienst auf den Zertifikatschlüssel zugreifen kann.

Die Outlook-Clients können sich mit dem Exchange Server verbinden und es kann auf alle Funktionen des Exchange-Servers zugegriffen werden.




Frieden und ein langes Leben.
Mitglied: El-Larso
14.09.2009 um 14:39 Uhr
Hallo,

führst du denn den Befehl auf einem der genannten Server aus oder auf deinem Rechner, wo bestimmt nicht einer der genannten Rollen (Hub-Transport, UMS, Edge-Transport oder Clientaccess) installiert ist?

Gruß
Bitte warten ..
Mitglied: Lasher
14.09.2009 um 18:38 Uhr
Hallo El-Larso,

die Befehle werden auf dem Exchange Server ausgeführt.



Frieden und ein langes Leben.
Bitte warten ..
Mitglied: Lasher
15.09.2009 um 08:39 Uhr
Hallo,

wie von Geisterhand hat sich das Problem scheinbar von selbst gelöst.
Habe heute früh die Shell gestartet (die Hoffnung stirbt zuletzt) und siehe da keine Fehlermeldung. Auch der "get-exchangecertificate" Befehl (und alle anderen) funktioniert wie gewohnt.



Frieden und ein langes Leben.
Bitte warten ..
Mitglied: El-Larso
15.09.2009 um 11:14 Uhr
Hi...

nichts geisterhand... ich habe ja nicht umsonst in diesen Thread gepostet :p

;)

Gruß
Bitte warten ..
Mitglied: Lasher
15.09.2009 um 19:07 Uhr
... dann gilt Dir mein Dank und ich werde in Zukunft nur an Dich denken, wenn mal wieder ein unerklärliches Phänomen auftaucht...



Frieden und ein langes Leben.
Bitte warten ..
Mitglied: yimmii
28.03.2012 um 14:29 Uhr
Guten Tag

Entschuldigen Sie das erneute Starten des 2009 Threads. Bei uns geht's leider nicht wieder von alleine...


Bei unserem Server ( Win 2008 mit Exchange 2007) sind die Zertifikate seit kurzem abgelaufen.
Mit einem einfach Internet Manual wollte ich die Internen Zertifikate erneuern.

http://christian-weihs.de/index.php/kategorie-als-blog/93-zertifikat-fu ...

Nur nach dem Kopieren und exportieren des Bestehenden Zertifikats kommt beim Exchange Verwaltungsshell eine ähnliche / gleiche Meldung wie der Thread Starter:
Diese wird auf dem Server mit ausführen als Administrator gestartet.

Ausgeführter Befehl:
Get-ExchangeCertificate -DomainName remote.x.local| New-ExchangeCertificate -GenerateRequest -Path c:\remote.x.local –FriendlyName „Exchange Cert 2012“

Fehlermeldung im Shell:
Ausnahme beim Festlegen von "ViewEntireForest": "Der Active Directory-Server XY.X.local ist nicht verfügbar. Fehlermeldung Lokaler Fehler.
Die Shell Startet danach wie gewohnt nur schlagen die meisten Befehle fehl wie z.B. "get-exchangecertificate".

Der Exchange funktioniert immer noch wie gewohnt und zeigt außer der Zertifikat Meldung keine Fehler.
Das ärgerliche ist das wir Mitte letztes Jahr auf Office 365 Umgestiegen sind und den Lokalen Exchange Server nicht mehr benötigen, das ganze per Web abgleichen.
Und einzig die Meldung mit dem Zertifikat beim Starten von Outlook erscheint was auf die Dauer ärgerlich ist.


Vielen Dank und Freundliche Grüsse aus der Schweiz
Bitte warten ..
Mitglied: Hefezopf
02.08.2012 um 10:33 Uhr
Hallo,

kann mir bitte jemand weiterhelfen?

Betreibe ebenfalls Exchange 2007 auf Win2008 Server und das selbst angelegte Certificate ist bereits abgelaufen.
Leider kann ich es aber nicht - wie an unzäligen Stellen im Web beschrieben - über die Exchange Powershell verlängern.

Bei Starten der Exchange Powershell erhalte ich bereits die Fehlermeldung:

Ausnahme beim Festlegen von "ViewEntireForest": "In der Domäne xy konnte kein Domänencontroller gefunden werden."
Bei C:\Program Files\Ex2007\bin\Exchange.ps1:19 Zeichen:32
'+ $global:AdminSessionADSettings.V <<<< iewEntireForest = $false

Egal welchen Befehl ich dann zum ExchangeCertificate versuche (z.B. get-exchangecertificate),
ich erhalte immer folgende Fehlermeldung:

Get-ExchangeCertificate : Dieser Vorgang kann nur lokal auf einem Microsoft Exchange-Server ausgeführt werden, auf dem eine der Serverfunktionen 'Edge-Transport', 'Hub-Transport', 'ClientAccess' oder 'UnifiedMessaging' installiert ist. Melden Sie sich lokal bei einem Microsoft Exchange-Server an, auf dem eine dieser unterstützten Serverfunktionen installiert ist, und führen Sie den Vorgang erneut aus.
Bei Zeile:1 Zeichen:23
get-exchangecertificate <<<<

Habe bereits mehrere Neustarts sowohl des Exchange-Servers als auch des Domaincontrollers durchgeführt.
Der Domaincontroller ist vom Exchange-Server aus sowohl über Ping als auch über den Explorer zu erreichen.
Starten der Powershell und ausführen des oben genannten Befehls habe ich sowohl mit der Domainanmeldung als auch mit der lokalen Anmeldung versucht.
Die Serverfunktionen 'Hub-Transport' und 'ClientAccess' sind laut Exchange Server Setup installiert.

In der Anwendungs-Ereignisanzeige erhalte ich ca. alle 15 Minuten folgende Einträge:
- Warnung 12015 "Ein internes Transportzertifikat ist abgelaufen. Fingerabdruck: XYZ......." und
- 2 x Fehler 12014 "Mocrosoft Exchange konnte ein Zertifikat nicht finden, das den Domänennamen "ExchangeServer.Domain" im persönlichen Informationsspeicher auf dem lokalen Computer enthält. Daher kann die STARTTLS-SMTP-Aktionsart für den Connector "XYZ" mit einem FQDN-Parameter von "ExchangeServer.Domain" nicht unterstützt werden. Überprüfen Sie die Connectorkonfiguration sowie die installierten Zertifikate, damit sichergestellt wird, dass ein Zertifikat mit einem Domänennamen für jeden Connector-FQDN vorhanden ist. Wenn das Zertifikat vorhanden ist, führen Sie "Enable-ExchangeCertificate-Services SMTP" aus, damit sichergestellt ist, dass der Microsoft Exchange-Transportdienst auf den Zertifikatschlüssel zugrifen kann.

Weiß jemand noch einen Rat für mich?

Vielen Dank
Bitte warten ..
Mitglied: yimmii
16.08.2012 um 16:03 Uhr
Hallo Hefezopf

Die Lösung für das Problem war bei unserem Server einfach in der SBS Verwaltung, unter Netzwerkübersicht nach Problemen suchen.

Dieses hat angezeigt das das Zertifikat abgelaufen ist und erneuert werden muss.
Bei Auswahl der Fehlerhilfe repariert sich dieses dann von selber...

(habe den genauen Ablauf leider nicht mehr ganz im kopf aber ungefähr so konnten wir es lösen)


Gruss yimmii
Bitte warten ..
Ähnliche Inhalte
Batch & Shell
Wmic command per Batch ausführen
gelöst Frage von Chaser21aBatch & Shell2 Kommentare

Hallo Community, Ich möchte gerne per Batchdatei bei mehreren Rechnern über den cmd command: Die installierten Windows Updates von ...

Exchange Server
CMD-let Exchange Postfach reparieren
gelöst Frage von TakakamiExchange Server3 Kommentare

Hallo Zusammen, ich bin leider ratlos beim SBS2011 Exchange 2010 SP3 Ich habe ein defektes Exchange Postfach und möchte ...

PHP
PHP Script Probleme beim Ausführen von ShellExec Commands
Frage von MaxPainPHP1 Kommentar

Guten Abend zusammen, bezüglich PHP-Scripting habe ich derzeitig ein Problem. Ich möchte gerne auf meinem Raspberry Pi 3 ein ...

Webbrowser
Lets encrypt und Android
gelöst Frage von HenereWebbrowser4 Kommentare

Hallo zusammen, ich habe jetzt erfolgreich einige Webseiten auf https umgestellt. Der Aufruf vom PC, egal ob FF, IE ...

Neue Wissensbeiträge
Windows 10

Autsch: Microsoft bündelt Windows 10 mit unsicherer Passwort-Manager-App

Tipp von kgborn vor 23 StundenWindows 102 Kommentare

Unter Microsofts Windows 10 haben Endbenutzer keine Kontrolle mehr, was Microsoft an Apps auf dem Betriebssystem installiert (die Windows ...

Sicherheits-Tools

Achtung: Sicherheitslücke im FortiClient VPN-Client

Tipp von kgborn vor 1 TagSicherheits-Tools

Ich weiß nicht, wie häufig die NextGeneration Endpoint Protection-Lösung von Fortinet in deutschen Unternehmen eingesetzt wird. An dieser Stelle ...

Internet

USA: Die FCC schaff die Netzneutralität ab

Information von Frank vor 1 TagInternet3 Kommentare

Jetzt beschädigt US-Präsident Donald Trump auch noch das Internet. Der neu eingesetzte FCC-Chef Ajit Pai ist bekannter Gegner einer ...

DSL, VDSL

ALL-BM200VDSL2V - Neues VDSL-Modem mit Vectoring von Allnet

Information von Lochkartenstanzer vor 1 TagDSL, VDSL2 Kommentare

Moin, Falls jemand eine Alternative zu dem draytek sucht: Gruß lks

Heiß diskutierte Inhalte
Windows Server
GPO nur für bestimmte Computer
Frage von Leo-leWindows Server13 Kommentare

Hallo Forum, gern würde ich ein Robocopy script per Bat an eine GPO hängen. Wichtig wäre aber dort der ...

Windows Server
KMS Facts for Client configuration
Frage von winlinWindows Server13 Kommentare

Hey Leute, wir haben in unserem Netz nun einen neuen KMS Server. Haben Bestands-VMs die noch nicht aktiviert sind. ...

Windows Tools
Software-Tool zum Entfernen von bösartigem Windows
Frage von emeriksWindows Tools11 Kommentare

Hi, siehe Betreff hat das jemals irgendjemand schonmal sinnvoll eingesetzt? (MRT) E.

Router & Routing
OpenWRT bzw. L.E.D.E auf Buffalo WZR-HP-AG300H - update
gelöst Frage von EpigeneseRouter & Routing11 Kommentare

Guten Tag, ich habe auf einem Buffalo WZR-HP-AG300H die alternative Firmware vom L.E.D.E Projekt geflasht. Ich bin es von ...