Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Exchange und Website auf unterschiedlichen Servern - DNS- bzw. Weiterleitungsproblem

Frage Internet Hosting & Housing

Mitglied: PhobosX

PhobosX (Level 1) - Jetzt verbinden

06.05.2013, aktualisiert 08.05.2013, 3271 Aufrufe, 12 Kommentare

Hallo zusammen.
Wir haben hier eine etwas kniffelige Konstellation.

Wir haben bei KabelBW eine feste externe IP Adresse. z.B. 123.234.123.234
Wir hosten hier selbst einen Microsoft Exchange 2013 Server. (per NAT Port 25 -> LAN) Also ankommende Mails an 123.234.123.234 gehen per NAT auf 192.168.1.222

123.234.123.234 hat einen DNS Eintrag (ebenfalls bei Host-Europe) beispiel1.de

Zusätzlich haben wir noch eine Internetseite (aber eben eine andere Domain als die Domain für die Mailadressen), welche aber bei Host Europe gehostet wird. www.beispiel2.de

Also folgendes Beispiel: Peter.Silie@beispiel1.de wird an 123.234.123.234 gesendet.

Unsere Website lautet http://www.beispiel2.de



Nun möchten wir, dass unsere Domain für die Mails auch auf die Website zeigt.

Also sollen ...
http://www.beispiel1.de
und
http://www.beispiel2.de
beide auf die bei Host Europe gehostet Website zeigen. Die Mails bzw. der Mailserver sollen aber natürlich weiterhin unter beispiel1.de erreichbar sein.


Wie mache ich das nun?

Muss ich da selbst eine Weiterleitung auf dem Webserver (IIS) einrichten? Oder muss ich das bei Host Europe einrichten?


VG
Mitglied: wiesi200
06.05.2013 um 13:13 Uhr
Hallo,

jetzt mal von dem ganzen OWA Zeug abgesehen.

Der Mailserver hat nicht's mit der Webseite zu tun.

für den Mailserver musst du im DNS einen MX Record setzten.
Für die Webseite ist's der A Record
Bitte warten ..
Mitglied: PhobosX
06.05.2013 um 13:17 Uhr
Ja OWA soll ich ja genau so noch funktionieren. Also Outlook Anywhere.

Ich bin da leider etwas überfragt bei dem Thema Webhosting.
Bitte warten ..
Mitglied: wiesi200
06.05.2013 um 13:24 Uhr
Also du brauchst für die Domain Beispiel1.de und Beispiel2.de jeweils einen A Record der auf deinen (entsprechenden) Webserver zeigt, kann auch der gleiche sein.

Dann brauchst du für die Domains die E-Mail können sollten einen MX Eintrag der auf deinen Mailserver Zeigt.

Dann musst du noch einen Host bzw. eine Subdomain anlegen die lautet OWA.Beispiel1.de oder wie du willst.
Und dann braucht die entsprechend einen A Record auf deinen Mailserver.

Eigentlich ist das sogar eine relativ einfache Konstellation.
Bitte warten ..
Mitglied: PhobosX
06.05.2013, aktualisiert um 13:39 Uhr
Also ich habe hier die Settings:
3ba3b70e35492bf0980d90a6f72defb4 - Klicke auf das Bild, um es zu vergrößern

Du meinst also einfach den A-Record von www.beispiel1.de auf beispiel2 zeigen lassen?

Das geht aber nicht, weil Host Europe ja mehrere Site unter einer IP Adresse hostet. Ich kann also nicht einfach die IP dort eintragen.


Das mit der Subdomain habe ich jetzt leider so nicht verstanden.

Momentan lässt sich owa über https://beispiel1.de/owa aufrufen.


Danke und Grüße!
Bitte warten ..
Mitglied: wiesi200
06.05.2013 um 13:52 Uhr
Zitat von PhobosX:
Also ich habe hier die Settings:
3ba3b70e35492bf0980d90a6f72defb4 - Klicke auf das Bild, um es zu vergrößern

Du meinst also einfach den A-Record von www.beispiel1.de auf beispiel2 zeigen lassen?
Nö, das nicht

Das geht aber nicht, weil Host Europe ja mehrere Site unter einer IP Adresse hostet. Ich kann also nicht einfach die IP dort
eintragen.
Genau


Das mit der Subdomain habe ich jetzt leider so nicht verstanden.
Ganz unten bei dem Punkt neu anlegen.

Momentan lässt sich owa über https://beispiel1.de/owa aufrufen.

1+2 Einträge zeigen auf die IP des Webservers.
3+4 spielen jetzt da keine Rolle aber eher auf den Webserver.
5+6 auf die IP von deinem KabelBW Anschluss
7+8 Interessiert jetzt nicht.
9+10 Wieder auf die IP des Webservers.

Jetzt kommst du auf den OWA per https://mail.beispiel1.de/owa

Jetzt kannst du wenn du lustig bist noch einen neuen Host setzten, eben da wo neu anlegen steht.
z.b. owa oder wie immer du willst.
Und den leitest du auch auf deine KabelBW IP
Dann kannst du unter https://owa.beispiel1.de/owa den OWA aufrufen.
Das brauchst z.b. auch wenn du Autodiscover verwenden willst.

Gut jetzt kannst du noch, wenn du willst einen Reverse Proxy einbauen, bringt dir auch Sicherheit.
Dadurch könntest du steuern das wenn du http://owa.beispiel1.de oder https://owa.beispiel1.de eingibst du auch auf den OWA kommst.
Bitte warten ..
Mitglied: PhobosX
07.05.2013, aktualisiert 08.05.2013
Danke dir für die Antwort.


Also es hat gereicht, die beiden A-Records .beispiel1.de und www.beispiel1.de auf die IP des Webservers zu setzen.
Zusätzlich musste ich noch eine Weiterleitung bei der Domainzuordnung konfigurieren.


Momentan funktioniert noch alles, die Weiterleitung ist ebenfalls schon aktiv.

Ich hoffe jetzt nur, dass es auch so bleibt


Vielen Dank nochmal!


EDIT:

Also es funktioniert nun doch nicht. Bzw: Die Weiterleitung funktioniert nun, aber Outlook Webaccess funktioniert nun nicht mehr.

Es liegt an dem A-Record .beispiel1.de bzw. http://beispiel1.de

Der zeigt ja nun auf die Website. Aber das geht nicht, weil man den Eintrag für OWA/Outlook Anywhere braucht.

Was nun? Gibt es noch eine andere Möglichkeit?


Ich habe jetzt wie von dir vorgeschlagen einen neuen A-Record owa.beispiel1.de angelegt, der auf die IP Adresse des Exchange zeigt.

Nun kann ich auf dem Handy wieder Mails empfangen, wenn ich halt als Server owa.beispiel1.de eintrage.

Aber Outlook Anywhere funktioniert nicht und das ist Grundvoraussetzung.


Wie kann ich das nun auch noch umstellen?

Ich schätze ich muss hier den externen Hostnamen owa.beispiel1.de eingeben. Trau mich aber nicht so recht, nicht dass es dann Komplikationen wegen des Zertifikats (StartSSL) gibt.

073347ae831816e84b8847292cdc538b - Klicke auf das Bild, um es zu vergrößern

VG
Bitte warten ..
Mitglied: wiesi200
08.05.2013, aktualisiert um 11:44 Uhr
Hallo,

Outlook Anywhere kommt bei mir erst die nächsten Monate bei der Umstellung auf Exchange 2012.
Aber grundsätzlich hast du da recht. Umstellung aber dann passt das Zertifikat nicht mehr und du brauchst ein neues.

Gut du kannst schon http://www.domain.de auf deinen Webserver zeigen lassen und http://domain.de auf deinen Exchange.
Find ich aber eher ungut.

Das andere währe noch ein Reverse Proxy da könntest du dann schon sagen leite alle https anfragen an https://owa.domain.de weiter. Da wird's dann aber schon ne große Spielerei.
Bitte warten ..
Mitglied: PhobosX
08.05.2013, aktualisiert um 13:29 Uhr
Hi.
Also ich habe nun ein A-Record auf .beispiel.de & www.beispiel1.de auf den Webserver.

Dann habe ich gemäß deinem Vorschlag einen A-Record .owa.beispiel1.de, welcher auf den Exhchange zeigt.

Auf den Handys der MA funktioniert das nun, wenn ich beim Server .owa vorne dran stelle.


Wir arbeiten mit Outlook 2010. Damit klappt es leider (noch) nicht. Dann habe ich bei mir zum Testen auf Office 2013 upgegraded und siehe da, damit funktioniert es.


Woran liegt das? Was macht Outlook 2013 anders als 2010?

Oder muss man im Outlook 2010 etwas umstellen, damit es vlt. auch funktioniert?



Also wie man sieht, ist es doch etwas knifflig


EDIT:

Also über https://www.testexchangeconnectivity.com habe ich mal die AutoErmittlungsfunktion durchgeführt.

Das klappt schon deswegen nicht, weil er auf den A-Record. .beispiel1.de anfrägt. Und das scheitert, da dieser ja auf den Webserver zeigt.
Bitte warten ..
Mitglied: wiesi200
08.05.2013 um 13:50 Uhr
Ja eigentlich hat sich da schon was geändert da das Mapi Protokoll langsam durch Outlook Anywhere ersetzt und somit zum Standard wird.

http://technet.microsoft.com/de-de/library/cc179036(v=office.14).aspx

Hast du die Outlook Anywhere Adresse im Exchange schon geändert? Des sonst zeigt ja die Autoermittlung auf den Falsch Eintrag?
Zudem brauchst du extern für die AutoErmittlung ja auch noch den Eintrag autodiscover.domain.de

Ach knifflig ist's eigentlich nicht. Da es meiner Meinung nach wirklich die Standard konfig für ne Domain darstellt mit der vermutlich 90% der Firmen fahren.
Bitte warten ..
Mitglied: PhobosX
08.05.2013 um 14:30 Uhr
Okay, aber wenigstens für mich knifflig

Also ich habe beim Exchange folgendes Eingetragen:

277d4159e447a15a7701e00e82627326 - Klicke auf das Bild, um es zu vergrößern

Beim Domainhoster folgendes:

209b8b7d619b9e40c3069a1002b21857 - Klicke auf das Bild, um es zu vergrößern


Das Problem ist eben noch, dass ich Outlook Anywhere nicht übers Internet konfigurieren kann.

Heißt ich kann Outlook nicht neu einrichten, weil er bei der Autoermittlung immer auf .beispiel1.de und nicht auf owa.beispiel1.de schaut.
Bitte warten ..
Mitglied: wiesi200
08.05.2013 um 15:03 Uhr
Das währ für dich noch Lektüre zum durchlesen.

http://www.msxfaq.de/e2007/autodiscover.htm
Bitte warten ..
Mitglied: PhobosX
17.05.2013, aktualisiert um 11:14 Uhr
Also ich bin bei dem Thema noch nicht weiter, weil wir noch ein anderes (akuteres) Problem haben.


Aber dann nochmal zum Thema:

Ich untersuche grad die Konfig mit https://www.testexchangeconnectivity.com

Es kommt beim Remote Connectivity Analyzer zu folgender Meldung:

Nachricht: The request failed. The remote name could not be resolved: 'paris.beispiel1.de'

extern ist der Server ja über beispiel1.de zu erreichen.

Intern heißt der Server "Paris".

Macht es Sinn einen A-Record (extern) auf paris.beispiel1.de zu setzen?

Das wäre ja dann sowohl intern als auch extern derselbe Name.

3f5598509637fb18c62ad8567fa9bc65 - Klicke auf das Bild, um es zu vergrößern


Ich habe dann halt auch intern das Problem, dass bei der Namensauflösung dann die externe und nicht die interne IP Adresse ermittelt wird.
Bitte warten ..
Neuester Wissensbeitrag
Windows 10

Powershell 5 BSOD

(3)

Tipp von agowa338 zum Thema Windows 10 ...

Ähnliche Inhalte
Exchange Server
Exchange 365. Kein Reverse DNS möglich? (24)

Frage von MyApps2GO.de zum Thema Exchange Server ...

DNS
DNS Einstellungen für lokale Website ohne WWW (4)

Frage von Goimi zum Thema DNS ...

Exchange Server
gelöst Exchange 2010 einstellen eines externen DNS Namens beim versenden nach extern (3)

Frage von ThePinky777 zum Thema Exchange Server ...

Windows Server
gelöst Unter SBS2011 DNS, DHCP-Server deaktivieren, IMAP-Connecter für Exchange 2013 (8)

Frage von maniacmacpain zum Thema Windows Server ...

Heiß diskutierte Inhalte
LAN, WAN, Wireless
gelöst Server erkennt Client nicht wenn er ausserhalb des DHCP Pools liegt (28)

Frage von Mar-west zum Thema LAN, WAN, Wireless ...

Outlook & Mail
Outlook 2010 findet ost datei nicht (18)

Frage von Floh21 zum Thema Outlook & Mail ...

Windows Server
Server 2008R2 startet nicht mehr (Bad Patch 0xa) (18)

Frage von Haures zum Thema Windows Server ...