Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Exchange-Zugriff über WLAN und 3G

Frage Microsoft Exchange Server

Mitglied: E--404

E--404 (Level 1) - Jetzt verbinden

27.06.2012 um 15:37 Uhr, 7038 Aufrufe, 18 Kommentare

Wir haben seid kurzem einen Exchange2010 Server und Windows Server 2008 im Einsatz.
Funktioniert auch soweit ganz gut, Problem ist nur folgendes:
Wenn man z.B. ein iPad im Gebäude über WLAN nutzen möchte und außerhalb über 3G dann kann Ich im WLAN kein Konto auf dem iPad erstellen oder synchronisieren. Über 3G alles kein Problem.
Mein Fehler schein also die Namensauflösung zu sein.
Nur wo muss ich die anpassen damit es passt?
Wir haben als domain: firma.local
Die Emailadressen auf: mail.firma.de

Bei Google fand ich Ratschläge wie "Tragen Sie einen FQDN im DNS ein." Der klebt aber immer sein ".firma.local" an meinen Eintrag und lässt sich anschließend nicht mehr ändern. Und auf mail.firma.de.firma.local reagiert logischerweise das iPad nicht.

Was habe ich Falsch gemacht?
Mitglied: Onitnarat
27.06.2012 um 15:44 Uhr
Dann musst Du eine neue Zone im DNS anlegen, die "firma.de" heißt und dort die Einträge anlegen:

mail.firma.de -> interne IP des Exchange
www.firma.de -> externe IP Euerer Homepage bzw. des Webservers
???.firma.de -> weitere Subdomänen die ihr habt
Bitte warten ..
Mitglied: E--404
27.06.2012 um 16:00 Uhr
Schon mal vielen Dank für den Tip. Vom PC aus funktioniert das schon ganz gut. Nur das iPad zickt noch rum.
Bitte warten ..
Mitglied: Onitnarat
27.06.2012 um 16:07 Uhr
Definiere "zickt noch rum"...welchen DNS-Server hat das iPad (vom DHCP oder einen anderen)? Zickt es im WLAN oder über Mobilfunk?
Bitte warten ..
Mitglied: E--404
27.06.2012, aktualisiert um 16:17 Uhr
Vom PC aus passt alles.
Also Ping auf den Host (mail.firma.de)geht auf die richtige interne IP. allerdings auch erst nach /flushdns.
Ich denke das das iPad etwas ähnliches braucht.
Das WLAN Lease passt (interner DNS, lokale IP, grundsätzlich dazu in der Lage online zu gehen), hat er alles brav so wie sich das gehört vom DHCP genommen.
Möchte aber im moment weder auf die OWA-Seite, noch ein neues Exchange-Konto verifizieren...

Nachtrag: über 3G läuft alles bisher wie es soll, nur WLAN will nicht.
Bitte warten ..
Mitglied: Onitnarat
27.06.2012 um 16:27 Uhr
Okay, das riecht tatsächlich nach einem nötigen /flushdns fürs iPad, aber hier bin ich total überfragt wie man das anstellen soll.
Neustart?
WLAN ignorieren und neu einrichten?
Bitte warten ..
Mitglied: E--404
27.06.2012 um 16:31 Uhr
Da stoßen die "tollen" Apple-Lösungen leider schnell an Grenzen...
Neustart hab ich schon. Werde als nächstes mal die Netzwerkeinstellungen zurück setzen... Bin gespannt ob das dann läuft.
Bitte warten ..
Mitglied: Onitnarat
27.06.2012 um 16:36 Uhr
Zitat von E--404:
Da stoßen die "tollen" Apple-Lösungen leider schnell an Grenzen...

Och, da gibts doch sicher ne App für...es gibt für fast alles eine App! ;)
Bitte warten ..
Mitglied: E--404
27.06.2012 um 17:44 Uhr
Ein Arbeitskollege meinte mal:
"Mist, kein Klopapier mehr! Zum Glück habe ich dafür eine App."

iPad hat auch nach zurück setzen der Netzwerkeinstellungen keine Lust lokale "Webseiten" (->OWA) anzusprechen.
Dementsprechend hat auch die Mail-App bzw iOS keine Lust ein exchange-Konto über WLAN einzurichten.

Es gibt so Kleinigkeiten, da verzweifelt man einfach an iOS. Schon mal versucht von einem iPad zu drucken? :D
Bitte warten ..
Mitglied: Alchemy
27.06.2012, aktualisiert um 19:39 Uhr
Hallo

das hat mit dem iPad nichts zu tun. Dein Problem ist rein Netzwerkseitig.

Als Grundlage hat eure Firewall eine Weiterleitung des port 443 an euren Exchangeserver. Das ist notwendig damit sich iPad und iPhone verbinden können.

Nun richtest auf dem iPad ein Exchangekonto ein. Dort musst du den Servernamen angeben. Dies ist in den meisten Fällen die Externe IP, weil es am einfachsten ist. Jetzt bist du im W-LAN und quasi hinter der Firewall. Das heist, du kommst nicht mehr von außen und das iPad versucht vergeblich über "externe IP" seinen Server zu finden. Das bedeutet... so funktioniert das erstmal nicht.

Die Lösung lautet: Du richtest eine Subdom. ein, zB mail.firma.de. Diese wird bei eurem Provider registriert und zeigt auf deine externe IP Adresse. Über diese Dom. richtest du dein iPad ein. Wenn du außerhalb des Netzwerkes unterwegs bist, funktioniert alles sauber. Im Netzwerk wird aktuell diese Dom. mit der externen IP aufgelöst. Nun kommt der "Hack". Du legst in deinem DNS eine neue Primäre Zone mit mail.firma.de an und darunter einen Host, welchen du leer lässt. Als IP vergibst du die interne IP deines Exchange. Das hat zur Folge, das wenn du innerhalb deines Netzwerkes auf mail.firma.de anfragst, du auf dem Exchange auf Port 443 rauskommst und dein iPad hat wieder eine Verbindung

Mit freundlichen Grüßen

EDIT: Wenn der Text zu lang ist... Die Lösung ist die Primäre Zone mit mail.firma.de im DNS anzulegen und darunter einen leeren Host mit der IP des Exchange anzulegen.
Bitte warten ..
Mitglied: Pjordorf
27.06.2012 um 22:01 Uhr
Hallo,

Zitat von E--404:
Wenn man z.B. ein iPad im Gebäude über WLAN nutzen möchte und außerhalb über 3G dann kann Ich im WLAN
Das Problem hat es schon vor ein paar Tagen hier mal wieder gegeben. Siehe http://www.administrator.de/contentid/186388#comment-759910. Die Lösung ist an deinem Router zu suchen. Kann der Hairpin NAT? Ja, dann richtig einrichten. Nein? Dann SplitDNS betreiben oder einen anderen Router der es kann. Wie das Problem zustande kommt kannst du hier schön sehen. http://wiki.mikrotik.com/wiki/Hairpin_NAT
This is called - among other terms - hair pin NAT because the traffic flow has clients enter the router through the same interface it leaves through, which when drawn looks like a hair pin.
http://tools.ietf.org/html/rfc4787#section-6
http://www.techrepublic.com/article/configure-a-split-dns-system-on-win ...

Gruß,
Peter
Bitte warten ..
Mitglied: Onitnarat
28.06.2012 um 09:14 Uhr
Zitat von Alchemy:
Hallo

das hat mit dem iPad nichts zu tun. Dein Problem ist rein Netzwerkseitig.

Als Grundlage hat eure Firewall eine Weiterleitung des port 443 an euren Exchangeserver. Das ist notwendig damit sich iPad und
iPhone verbinden können.

Nun richtest auf dem iPad ein Exchangekonto ein. Dort musst du den Servernamen angeben. Dies ist in den meisten Fällen die
Externe IP, weil es am einfachsten ist. Jetzt bist du im W-LAN und quasi hinter der Firewall. Das heist, du kommst nicht mehr von
außen und das iPad versucht vergeblich über "externe IP" seinen Server zu finden. Das bedeutet... so
funktioniert das erstmal nicht.

Die Lösung lautet: Du richtest eine Subdom. ein, zB mail.firma.de. Diese wird bei eurem Provider registriert und zeigt auf
deine externe IP Adresse. Über diese Dom. richtest du dein iPad ein. Wenn du außerhalb des Netzwerkes unterwegs bist,
funktioniert alles sauber. Im Netzwerk wird aktuell diese Dom. mit der externen IP aufgelöst. Nun kommt der "Hack".
Du legst in deinem DNS eine neue Primäre Zone mit mail.firma.de an und darunter einen Host, welchen du leer lässt. Als
IP vergibst du die interne IP deines Exchange. Das hat zur Folge, das wenn du innerhalb deines Netzwerkes auf mail.firma.de
anfragst, du auf dem Exchange auf Port 443 rauskommst und dein iPad hat wieder eine Verbindung

Mit freundlichen Grüßen

EDIT: Wenn der Text zu lang ist... Die Lösung ist die Primäre Zone mit mail.firma.de im DNS anzulegen und darunter einen
leeren Host mit der IP des Exchange anzulegen.

Nichts anderes steht in meiner ersten Antwort, aber sei es drum...
Bitte warten ..
Mitglied: E--404
28.06.2012, aktualisiert um 10:04 Uhr
Vielen Dank für die ausführliche Antwort.
Aber Onitnarat hat schon Recht, steht alles schon in seiner Antwort. Und (leider etwas) zwischen den Zeilen steht der andere Teil deiner Antwort in meiner Frage. Habe ja geschrieben das Zugriff über 3G funktioniert, bedeutet also das unsere Cisco ASA 5510 bereits so eingerichtet ist, das von Aussen auf den OWA zugegriffen werden kann.

Und um mal etwas Benzin in das ewige "Apple-Feuer" zu gießen:
Mit meinem Blackberry geht es sowohl im WLAN als auch über 3G. :D
Liegt aber an der Blackberry-Technik. Da wird der Server eh über den BIS-Server meines Providers bzw RIM extern abgefragt und die Mails aufs Gerät geschoben.
Bitte warten ..
Mitglied: Onitnarat
28.06.2012 um 10:15 Uhr
Hi,
wenn ich Peters Vorschlag mit dem SplitDNS richtig verstehe, haben wir das ja eingerichtet mit der zweiten DNS-Zone? Ich denke, dass Du eine Weiterleitung auf die ISP-DNS-Server sowieso drin hast?

Was passiert denn auf dem iPad wenn Du die OWA-Seite im Safari ansurfst?
Das Problem wird sein zu erkennen, sollte es funktionieren, ob das jetzt SplitDNS oder Hairpinning-NAT ist...Du bräuchtest nslookup auf dem iPad...
Bitte warten ..
Mitglied: E--404
28.06.2012 um 10:23 Uhr
Vielen Dank an Pjordorf.

Hair Pinning NAT scheint meine Lösung zu sein.
Werde mal meinen Cisco-Fachmann anrufen.
Hoffe das löst mein Problem.
Bitte warten ..
Mitglied: E--404
28.06.2012 um 10:29 Uhr
Zitat von Onitnarat:
Hi,
wenn ich Peters Vorschlag mit dem SplitDNS richtig verstehe, haben wir das ja eingerichtet mit der zweiten DNS-Zone? Ich denke,
dass Du eine Weiterleitung auf die ISP-DNS-Server sowieso drin hast?

Was passiert denn auf dem iPad wenn Du die OWA-Seite im Safari ansurfst?
Das Problem wird sein zu erkennen, sollte es funktionieren, ob das jetzt SplitDNS oder Hairpinning-NAT ist...Du bräuchtest
nslookup auf dem iPad...

Auf den OWA kam ich nur über die interne IP, nicht über den Host-Namen oder ähnliches.
Das Blackberry Playbook kann solche spielereien wie traceroute, ping und nslookup sogar (von haus aus ohne extra App). Irgendwann wird Apple auch soetwas "neu erfinden und damit die Welt verändern". :D

Ich werde mal abwarten was mein Cisco-Mensch sagt...
Bitte warten ..
Mitglied: Alchemy
28.06.2012 um 11:34 Uhr
Servus,

natürlich stand das alles schon einmal oben in dem Text. Aber ich kann ja die Fähigkeiten des TO nicht einschätzen. Deshalb die "Ideotensichere Anleitung".

Meine Erfahrung: Wenn du Hufgetrappel hörst, denk an Pferde, nicht an Zebras.

Die Konfiguration läuft in so vielen Netzen. Einer meiner betreuten User hat zB auch nur einen neuen Host in seiner internen Zone angelegt und sich gewundert, warum es nicht geht. Die PCs reagieren dann meist noch richtig, weil sie in der internen Domäne sind.

Den BB kannst du aus deiner Rechnug auch rausnehmen, da er (üblicherweise) eine ganz andere Technologie nutzt.

Wenn du über die interne IP auf die OWA kommst, dann hast du ein reines DNS Problem. Lad dir eine kostenlose PING App und Ping doch einfach mal in die Gegend. Was kommt bei mail.firma.de, was bei dem internen Namen des Exchange? Was sagt dein DHCP? Taucht das iPad auf? Was passiert wenn du deine Netzwerkparameter fest vergibst?

Mit freundlichen Grüßen
Bitte warten ..
Mitglied: Pjordorf
28.06.2012 um 17:06 Uhr
Hallo,

Zitat von E--404:
Hair Pinning NAT scheint meine Lösung zu sein.
Das wird es sein. Split DNS ist aber auch eine Lösung sofern das mit den Zonen auch klappt.

Werde mal meinen Cisco-Fachmann anrufen.
Dann gebe ihm sofort die Cisco Quellen mit an. http://www.cisco.com/web/about/ac123/ac147/archived_issues/ipj_7-3/anat ... und https://supportforums.cisco.com/thread/1003238

Gruß,
Peter
Bitte warten ..
Mitglied: SDohle
02.07.2012 um 09:26 Uhr
Moin
wir hatten das gleiche Prob

Der Fehler war der Proxy

Der PC hatte keine Probleme, weil dort in den Einstellungen via wpad.dat ausnahmen waren, die will das Iphone aber nicht nehmen.

Das IPhone will mit den Einstellungen beim Browser auch die Mails abrufen.

Hieß mail.server.de liess sich anpingen, Mails und Browsen via 3G möglich,

Mails nicht, Browsen ja via WLAN
den Proxy aus den Einstellungen entfernt, Mails geht, Browsen nicht.

Unsere Lösung,
wir haben unseren Proxy entsprechend verändert, das er Fragen von Intern auf mail.server.de an den Exchange routet.

Gruss
S. Dohle
Bitte warten ..
Neuester Wissensbeitrag
CPU, RAM, Mainboards

Angetestet: PC Engines APU 3a2 im Rack-Gehäuse

Erfahrungsbericht von ashnod zum Thema CPU, RAM, Mainboards ...

Heiß diskutierte Inhalte
Grafikkarten & Monitore
Win 10 Grafikkarte Crash von Software? (13)

Frage von Marabunta zum Thema Grafikkarten & Monitore ...

Windows Server
Mailserver auf Windows Server 2012 (8)

Frage von StefanT81 zum Thema Windows Server ...

DSL, VDSL
DSL-Signal bewerten (8)

Frage von SarekHL zum Thema DSL, VDSL ...

Backup
Clients als Server missbrauchen? (8)

Frage von 1410640014 zum Thema Backup ...