Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Exchangeserver 2010 - Der komplette Webbereich ist defekt.

Frage Microsoft Exchange Server

Mitglied: ANPAS1

ANPAS1 (Level 1) - Jetzt verbinden

06.03.2013, aktualisiert 17:15 Uhr, 2938 Aufrufe, 5 Kommentare

Hallo liebe IT Kollegen!

Wir haben ein kleines Netzwerk mit einem SBS2011 Standard-Server übernommen.
Das Hauptproblem war oder ist der darauf liegende Exchange 2010, bzw. der komplette Webbereich des Exchanges.
Von OWA bis ActiveSync funktioniert nichts. Wenigstens haben wir den Exchange2010 soweit wieder beleben können, dass jeder User wieder auf sein Outlook zugreifen kann. Die Zweigstellen funktionieren auch soweit wieder mit Outlook.

Mögliche Ursache:
Was wir herausfinden konnten ist, dass der vorige Betreuer offensichtlich eine Datenordnerrücksicherung vorgenommen haben muss - (einfach alles drüber gebügelt)
Ich komme darauf, da z.B. in den Owa-Verzeichnissen verschiedene Dateien und Konfigs mit "Kopie von" bezeichnet sind.
Und wenn man nun den Owa-Link öffnet, kommt folgende Ausgabe:

01.
Serverfehler in der Anwendung /owa. 
02.
Die Datei oder Assembly "2012-10-01 23-01 Kopie von Microsoft.Exchange.Clients.Owa" oder eine Abhängigkeit davon wurde nicht gefunden. Die gefundene Manifestdefinition der Assembly stimmt nicht mit dem Assemblyverweis überein. (Ausnahme von HRESULT: 0x80131040) 
03.
Beschreibung: Unbehandelte Ausnahme beim Ausführen der aktuellen Webanforderung. Überprüfen Sie die Stapelüberwachung, um weitere Informationen über diesen Fehler anzuzeigen und festzustellen, wo der Fehler im Code verursacht wurde. 
04.
 
05.
Ausnahmedetails: System.IO.FileLoadException: Die Datei oder Assembly "2012-10-01 23-01 Kopie von Microsoft.Exchange.Clients.Owa" oder eine Abhängigkeit davon wurde nicht gefunden. Die gefundene Manifestdefinition der Assembly stimmt nicht mit dem Assemblyverweis überein. (Ausnahme von HRESULT: 0x80131040) 
06.
 
07.
Quellfehler: 
08.
 
09.
Beim Ausführen der aktuellen Webanforderung wurde einen unbehandelte Ausnahme generiert. Informationen über den Ursprung und die Position der Ausnahme können mit der Ausnahmestapelüberwachung angezeigt werden. 
10.
 
11.
Überwachung beim Laden der Assembly: Mit folgenden Informationen kann bestimmt werden, warum die Assembly 2012-10-01 23-01 Kopie von Microsoft.Exchange.Clients.Owa nicht geladen werden konnte. 
12.
 
13.
 
14.
WRN: Protokollierung der Assemblybindung ist AUS. 
15.
Sie können die Protokollierung der Assemblybindungsfehler aktivieren, indem Sie den Registrierungswert [HKLM\Software\Microsoft\Fusion!EnableLog] (DWORD) auf 1 festlegen. 
16.
Hinweis: Die Protokollierung der Assemblybindungsfehler führt zu einer gewissen Leistungseinbuße. 
17.
Sie können dieses Feature deaktivieren, indem Sie den Registrierungswert [HKLM\Software\Microsoft\Fusion!EnableLog] entfernen. 
18.
 
19.
 
20.
Stapelüberwachung: 
21.
 
22.
 
23.
[FileLoadException: Die Datei oder Assembly "2012-10-01 23-01 Kopie von Microsoft.Exchange.Clients.Owa" oder eine Abhängigkeit davon wurde nicht gefunden. Die gefundene Manifestdefinition der Assembly stimmt nicht mit dem Assemblyverweis überein. (Ausnahme von HRESULT: 0x80131040)] 
24.
   System.Reflection.Assembly._nLoad(AssemblyName fileName, String codeBase, Evidence assemblySecurity, Assembly locationHint, StackCrawlMark& stackMark, Boolean throwOnFileNotFound, Boolean forIntrospection) +0 
25.
   System.Reflection.Assembly.InternalLoad(AssemblyName assemblyRef, Evidence assemblySecurity, StackCrawlMark& stackMark, Boolean forIntrospection) +416 
26.
   System.Reflection.Assembly.InternalLoad(String assemblyString, Evidence assemblySecurity, StackCrawlMark& stackMark, Boolean forIntrospection) +166 
27.
   System.Reflection.Assembly.Load(String assemblyString) +35 
28.
   System.Web.Configuration.CompilationSection.LoadAssemblyHelper(String assemblyName, Boolean starDirective) +190 
29.
 
30.
[ConfigurationErrorsException: Die Datei oder Assembly "2012-10-01 23-01 Kopie von Microsoft.Exchange.Clients.Owa" oder eine Abhängigkeit davon wurde nicht gefunden. Die gefundene Manifestdefinition der Assembly stimmt nicht mit dem Assemblyverweis überein. (Ausnahme von HRESULT: 0x80131040)] 
31.
   System.Web.Configuration.CompilationSection.LoadAssemblyHelper(String assemblyName, Boolean starDirective) +11241896 
32.
   System.Web.Configuration.CompilationSection.LoadAllAssembliesFromAppDomainBinDirectory() +388 
33.
   System.Web.Configuration.CompilationSection.LoadAssembly(AssemblyInfo ai) +232 
34.
   System.Web.Configuration.AssemblyInfo.get_AssemblyInternal() +48 
35.
   System.Web.Compilation.BuildManager.GetReferencedAssemblies(CompilationSection compConfig) +210 
36.
   System.Web.Compilation.BuildProvidersCompiler..ctor(VirtualPath configPath, Boolean supportLocalization, String outputAssemblyName) +76 
37.
   System.Web.Compilation.ApplicationBuildProvider.GetGlobalAsaxBuildResult(Boolean isPrecompiledApp) +283 
38.
   System.Web.Compilation.BuildManager.CompileGlobalAsax() +50 
39.
   System.Web.Compilation.BuildManager.EnsureTopLevelFilesCompiled() +676 
40.
 
41.
[HttpException (0x80004005): Die Datei oder Assembly "2012-10-01 23-01 Kopie von Microsoft.Exchange.Clients.Owa" oder eine Abhängigkeit davon wurde nicht gefunden. Die gefundene Manifestdefinition der Assembly stimmt nicht mit dem Assemblyverweis überein. (Ausnahme von HRESULT: 0x80131040)] 
42.
   System.Web.Compilation.BuildManager.ReportTopLevelCompilationException() +76 
43.
   System.Web.Compilation.BuildManager.EnsureTopLevelFilesCompiled() +1012 
44.
   System.Web.Hosting.HostingEnvironment.Initialize(ApplicationManager appManager, IApplicationHost appHost, IConfigMapPathFactory configMapPathFactory, HostingEnvironmentParameters hostingParameters) +1025 
45.
 
46.
[HttpException (0x80004005): Die Datei oder Assembly "2012-10-01 23-01 Kopie von Microsoft.Exchange.Clients.Owa" oder eine Abhängigkeit davon wurde nicht gefunden. Die gefundene Manifestdefinition der Assembly stimmt nicht mit dem Assemblyverweis überein. (Ausnahme von HRESULT: 0x80131040)] 
47.
   System.Web.HttpRuntime.FirstRequestInit(HttpContext context) +11335894 
48.
   System.Web.HttpRuntime.EnsureFirstRequestInit(HttpContext context) +88 
49.
   System.Web.HttpRuntime.ProcessRequestNotificationPrivate(IIS7WorkerRequest wr, HttpContext context) +4355316
Nun habe ich hoffentlich die korrekte Ordnerstruktur mit Hilfe von "Virtuelle Verzeichnisse zurücksetzen" wieder hergestellt. Leider muss ich noch etwas übersehen haben, denn offensichtlich greift der IIS noch auf Dateien zu, die er nicht nehmen soll. Hat jemand von Euch eine Idee, wie ich dem System wieder beibringen kann auf seine Standarddateien zuzugreifen? Hier gibt es offensichtlich Umleitungsfehler?

Falls noch Fragen Eurerseits bestehen, bitte löchern.

Vielen Dank vorab!!!

Mit freundlichen Grüßen
ANPAS1
Mitglied: Dani
06.03.2013 um 20:06 Uhr
Moin,
den Technetartikel gelesen / durchgearbeitet?!

Was sagt die Ereignisanzeige? Da müssten ein paar rote Events auftauchen.


Grüße,
Dani
Bitte warten ..
Mitglied: ANPAS1
06.03.2013 um 21:09 Uhr
Hallo Dani,

vielen Dank für den Hinweis auf Technet, danach habe alles abgearbeitet.
Wie in dem oberen Log beschrieben will der IIS noch immer auf die alten Dateien "Kopie von..." zugreifen.
Hier nochmal ein LOG wenn versucht wird sich mit Active sync zu verbinden:
01.
Event code: 3008 
02.
Event message: Es ist ein Konfigurationsfehler aufgetreten. 
03.
Event time: 06.03.2013 20:54:06 
04.
Event time (UTC): 06.03.2013 19:54:06 
05.
Event ID: f89483f1cba648b4b7cab736a30cab18 
06.
Event sequence: 1 
07.
Event occurrence: 1 
08.
Event detail code: 0 
09.
 
10.
Application information: 
11.
Application domain: /LM/W3SVC/1/ROOT/Microsoft-Server-ActiveSync-7-130070732464619666 
12.
Trust level: Full 
13.
Application Virtual Path: /Microsoft-Server-ActiveSync 
14.
Application Path: C:\Program Files\Microsoft\Exchange Server\V14\ClientAccess\sync\ 
15.
Machine name: KNSERVER 
16.
 
17.
Process information: 
18.
Process ID: 10556 
19.
Process name: w3wp.exe 
20.
Account name: NT-AUTORITÄT\SYSTEM 
21.
 
22.
Exception information: 
23.
Exception type: HttpException 
24.
Exception message: Die Datei oder Assembly "2012-10-01 23-01 Kopie von Microsoft.Exchange.AirSyncHandler" oder eine Abhängigkeit davon wurde nicht gefunden. Die gefundene Manifestdefinition der Assembly stimmt nicht mit dem Assemblyverweis überein. (Ausnahme von HRESULT: 0x80131040) 
25.
 
26.
Request information: 
27.
Request URL: https://192.168.1.253:443/Microsoft-Server-ActiveSync/default.eas 
28.
Request path: /Microsoft-Server-ActiveSync/default.eas 
29.
User host address: 192.168.1.253 
30.
User: 
31.
Is authenticated: False 
32.
Authentication Type: 
33.
Thread account name: NT-AUTORITÄT\SYSTEM 
34.
 
35.
Thread information: 
36.
Thread ID: 1 
37.
Thread account name: NT-AUTORITÄT\SYSTEM 
38.
Is impersonating: False 
39.
Stack trace: bei System.Web.Compilation.BuildManager.ReportTopLevelCompilationException() 
40.
bei System.Web.Compilation.BuildManager.EnsureTopLevelFilesCompiled() 
41.
bei System.Web.Hosting.HostingEnvironment.Initialize(ApplicationManager appManager, IApplicationHost appHost, IConfigMapPathFactory configMapPathFactory, HostingEnvironmentParameters hostingParameters) 
42.
 
43.
 
44.
Custom event details:
Hier nochmal über OWA:
01.
Event code: 3008  
02.
Event message: Es ist ein Konfigurationsfehler aufgetreten.  
03.
Event time: 06.03.2013 21:04:44  
04.
Event time (UTC): 06.03.2013 20:04:44  
05.
Event ID: cd06cbd7005245c9b27ea982a3c7c21b  
06.
Event sequence: 1  
07.
Event occurrence: 1  
08.
Event detail code: 0  
09.
  
10.
Application information:  
11.
    Application domain: /LM/W3SVC/1/ROOT/owa-8-130070738839402211  
12.
    Trust level: Full  
13.
    Application Virtual Path: /owa  
14.
    Application Path: C:\Program Files\Microsoft\Exchange Server\V14\ClientAccess\Owa\  
15.
    Machine name: KNSERVER  
16.
  
17.
Process information:  
18.
    Process ID: 12244  
19.
    Process name: w3wp.exe  
20.
    Account name: NT-AUTORITÄT\SYSTEM  
21.
  
22.
Exception information:  
23.
    Exception type: HttpException  
24.
    Exception message: Die Datei oder Assembly "2012-10-01 23-01 Kopie von Microsoft.Exchange.Clients.Owa" oder eine Abhängigkeit davon wurde nicht gefunden. Die gefundene Manifestdefinition der Assembly stimmt nicht mit dem Assemblyverweis überein. (Ausnahme von HRESULT: 0x80131040)  
25.
  
26.
Request information:  
27.
    Request URL: https://192.168.1.253:443/owa/  
28.
    Request path: /owa/  
29.
    User host address: 192.168.1.253  
30.
    User:   
31.
    Is authenticated: False  
32.
    Authentication Type:   
33.
    Thread account name: NT-AUTORITÄT\SYSTEM  
34.
  
35.
Thread information:  
36.
    Thread ID: 9  
37.
    Thread account name: NT-AUTORITÄT\SYSTEM  
38.
    Is impersonating: False  
39.
    Stack trace:    bei System.Web.Compilation.BuildManager.ReportTopLevelCompilationException() 
40.
   bei System.Web.Compilation.BuildManager.EnsureTopLevelFilesCompiled() 
41.
   bei System.Web.Hosting.HostingEnvironment.Initialize(ApplicationManager appManager, IApplicationHost appHost, IConfigMapPathFactory configMapPathFactory, HostingEnvironmentParameters hostingParameters) 
42.
  
43.
  
44.
Custom event details: 
Mit freundlichen Grüßen
Bitte warten ..
Mitglied: Dani
06.03.2013 um 21:54 Uhr
Sieht auf jeden Fall nicht gut aus. Ich habe allerdings mit SBS und Exchange keinerlei Erfahrungen, daher ist diese Anleitung nicht zielführend.

Ich Microsoft Forum hab ich noch was gefunden.


Grüße,
Dani
Bitte warten ..
Mitglied: ANPAS1
06.03.2013 um 23:34 Uhr
Besteht die Möglichkeit, dass vieleicht ASP.net defekt ist? Dass darin noch irgendwo ein Verweis auf die alten Dateien vorhanden ist? Oder ein alter Temp-Cache?
Bitte warten ..
Mitglied: napperman
07.03.2013, aktualisiert um 08:50 Uhr
Moin!
Nach einem Fullbackup würde ich nochmal ausprobieren, das virtuelle Verzeichnis zurückzusetzen.
EMC -> Server-Konfig -> Clientaccess -> Server auswählen -> RMT -> "Virtuelles Verzeichnis zurücksetzen...".
Danach auf OWA und den Assistenten durchlaufen lassen.


Nachtrag:
Sorry, habe den Link oben nicht gesehen....
Bitte warten ..
Neuester Wissensbeitrag
Humor (lol)

Linkliste für Adventskalender

(3)

Information von nikoatit zum Thema Humor (lol) ...

Ähnliche Inhalte
Exchange Server
gelöst Exchange 2010 Berechtigungen wiederherstellen (20)

Frage von semperf1delis zum Thema Exchange Server ...

Exchange Server
gelöst Exchange 2010 Activesync Problem bei IOS 10.1.1 und Wildcard SSL Zertifikat (2)

Frage von hasel123 zum Thema Exchange Server ...

Exchange Server
Exchange 2010 Problem (6)

Frage von Peacer zum Thema Exchange Server ...

Heiß diskutierte Inhalte
Router & Routing
gelöst Ipv4 mieten (22)

Frage von homermg zum Thema Router & Routing ...

Windows Server
DHCP Server switchen (20)

Frage von M.Marz zum Thema Windows Server ...

Exchange Server
gelöst Exchange 2010 Berechtigungen wiederherstellen (20)

Frage von semperf1delis zum Thema Exchange Server ...

Hardware
gelöst Negative Erfahrungen LAN-Karten (19)

Frage von MegaGiga zum Thema Hardware ...