Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Explorer.exe mit Startparametern funktioniert nicht

Frage Microsoft Windows 7

Mitglied: mfernau

mfernau (Level 1) - Jetzt verbinden

02.08.2013, aktualisiert 17.01.2014, 5654 Aufrufe, 6 Kommentare, 1 Danke

Hallo!

Bei einer recht kleinen Auswahl an Kunden habe ich das Phänomen, dass sich der Explorer nicht öffnet wenn man einen beliebigen Startparameter an den Aufruf hängt. Bisher betrifft es ausschließlich Windows 7 Arbeitsstationen.

Funktioniert:
$> explorer
$> explorer.exe
$> %windir%\explorer

Funktioniert alles nicht:
$> explorer.exe c:\
$> explorer.exe /root,c:\
$> explorer.exe /n, /e, c:\
$> explorer.exe foo bar
$> explorer.exe wurstbrot

Das ist insofern blöd, weil wir in unserer Anwendung eben diese Funktionalität nutzen um den Explorer für einen bestimmten vordefinierten Pfad öffnen zu lassen.
Ich hab überhaupt keine Idee was diese Aufrufe blockieren könnte und Fehlermeldungen gibt es natürlich überhaupt keine.
Testen kann ich den Senf auch nicht, weil es natürlich in jeder mir zur Verfügung stehenden Windows 7 Instanz (sei es 'echt', als auch virtuell) einfach alle Varianten funktionieren.

Hat hier vielleicht jemand eine Idee?

Beste Grüße
Martin
Mitglied: 112778
02.08.2013 um 19:14 Uhr
Hi,

Zitat von mfernau:
Hat hier vielleicht jemand eine Idee?

Den Start der Konsole hast du schon mal "Als Administrator ausführen" lassen, desgleichen den "Ausführen"-Dialog?
Das .exe kannst du übrigens weglassen.

Gruß
Bitte warten ..
Mitglied: mfernau
03.08.2013 um 15:27 Uhr
Hallo!

Nein, als Administrator habe ich das noch nicht explizit ausführen lassen. Das wäre auch nicht hilfreich wenn es nur so ginge. Der User muss doch einen Windows-Explorer benutzen können...? In 99% aller mir bekannten Installationen funktioniert es auf diese Weise.
Ich tippe auf irgend ein quer schießendes Programm was den Start verhindert. Irgend welche "plugins" oder dergleichen. Nur fehlt mir hier ein Ansatz wie ich so was herausfinden könnte, oder wie ich das gar testen kann.

Gerade überlege ich das mal mit dem Prozess Monitor (http://technet.microsoft.com/en-us/sysinternals/bb896645) zu analysieren. Das ding is nur ziemlich unübersichtlich..

Das .exe kann man zwar weg lassen, aber sollte eine Datei mit demselben Namen als .com in einem Verzeichnis existieren, würde zuerst diese ausgeführt. Letztlich war es für mich nur die Sicherheit, das korrekte Programm ausführen zu wollen

Schöne Grüße
Martin
Bitte warten ..
Mitglied: 112778
04.08.2013, aktualisiert um 00:08 Uhr
Hallo,

das stimmt schon, was du geschrieben hast, nicht nur als .com, sondern auch als .cmd oder .bat. *gg* Möglich wäre ja auch, dass jemand (der die entsprechende Zugriffsberechtigung besitzt) eine Explorer.exe geschrieben hat, die im Windows-Verzeichnis liegt und den "echten" Explorer nur startet, wenn keine Parameter übergeben wurden. ;)
Das ist zwar vielleicht etwas weit hergeholt, aber immerhin möglich.
Du kannst ja in der Konsole mal ein
01.
 dir /a \Explorer*.* /s /b 
absetzen, um herauszufinden, wo sich überall eine Datei mit diesem Namen findet.

Mit dem Prozessexplorer Direktlink kannst du einfacher feststellen, auf welchem Pfad und mit welchem Parameter der Start erfolgt, du musst dir nur in den Spalteneinstellungen die Befehlszeile anzeigen lassen.

Gruß
Bitte warten ..
Mitglied: Stephan-Joe
LÖSUNG 16.01.2014, aktualisiert 17.01.2014
Bitte warten ..
Mitglied: mfernau
16.01.2014 um 19:37 Uhr
Interessant!
Ich konnte das Szenario zwar nur durch löschen von "Eigene Dateien" erzwingen, aber tatsächlich ergab sich hierdurch das von mir dargestellte Problem.
Besten Dank für den Hinweis!
Bitte warten ..
Mitglied: mfernau
17.01.2014 um 12:19 Uhr
Hab es heute beim Kunden verifizieren und beheben können. Erste Sahne!
Zwar war bei meinem Kunden der Ordner für "Eigene Dateien" vorhanden, aber das Prinzip war mir ja einleuchtend. In der Registry gibt es folgenden Eintrag:
HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\Shell Folders\Personal

verweist dieser auf einen nicht existierenden Ordner, kommt es exakt zu dem beschriebenen Fehler. Trägt man hier einen validen Pfad ein, funktioniert alles wieder.

Grüße
Martin
Bitte warten ..
Ähnliche Inhalte
Windows 7
Windows Prozess explorer.exe funktioniert nicht mehr
gelöst Frage von Syber07Windows 76 Kommentare

Hallo, ich habe folgendes Problem: der Prozess "explorer.exe" funktioniert nicht mehr. Sobald ich mich einlogge erscheint nur ein schwarzer ...

Windows 7
Programm mit startparametern mit sc installieren
Frage von Mit.ohne.AhnungWindows 77 Kommentare

Hallo zusammen, ich habe folgendes Problem ich möchte eine com port abhören Momentan ist es so gelöst das dies ...

Windows 7
Explorer.exe - starten des Servers fehlgeschlagen
gelöst Frage von DeathNoteWindows 711 Kommentare

Hi. Ich habe einen Win7 Client, bei dem ich den Explorer nicht mehr starten kann. Es kommt o.a. Fehlermeldung. ...

Windows 7
Explorer.exe: Scnittstelle nicht unterstützt
Frage von itze80Windows 74 Kommentare

Hallo liebe Admins, ich habe hier ein Problem auf einem Terminal Server. Seit gestern können normale Nutzer keine Ordner ...

Neue Wissensbeiträge
Apple

IOS 11.2.1 stopft HomeKit-Remote-Lücke

Tipp von BassFishFox vor 6 StundenApple

Das Update für iPhone, iPad und Apple TV soll die Fernsteuerung von Smart-Home-Geräten wieder in vollem Umfang ermöglichen. Apple ...

Windows 10

Windows 10 v1709 EN murkst bei den Regionseinstellungen

Tipp von DerWoWusste vor 11 StundenWindows 10

Dieser kurze Tipp richtet sich an den kleinen Personenkreis, der Win10 v1709 EN-US frisch installiert und dabei die englische ...

Webbrowser

Kein Ton bei Firefox Quantum über RDP

Tipp von Moddry vor 11 StundenWebbrowser

Hallo Kollegen! Hatte das Problem, dass der neue Firefox bei mir auf der Kiste keinen Ton hat, wenn ich ...

Internet

EU-DSGVO: WHOIS soll weniger Informationen liefern

Information von sabines vor 23 StundenInternet4 Kommentare

Wegen der europäische Datenschutzgrundverordnung stehen die Prozesse um die Registrierung von Domains auf dem Prüfstand. Sollte die Forderungen umgesetzt ...

Heiß diskutierte Inhalte
LAN, WAN, Wireless
Von rj11 auf rj45
Frage von jensgebkenLAN, WAN, Wireless19 Kommentare

Hallo Gemeinschaft, könnt ihr mir vielleicht bei der anfertigung eines Kabels helfen - habe ein rj 11 stecker und ...

Netzwerkmanagement
Firefox Profieles im Roaming
gelöst Frage von Hendrik2586Netzwerkmanagement17 Kommentare

Hallo liebe Leute. :) Ich hab da ein kleines Problem, welches anscheinend nicht unbekannt ist. Wir nutzen hier in ...

LAN, WAN, Wireless
Häufig Probleme beim Anmelden in WLAN
Frage von mabue88LAN, WAN, Wireless15 Kommentare

Hallo zusammen, in einem Netzwerk gibt es relativ häufig (1-2 mal pro Woche) Probleme mit der WLAN-Verbindung. Zunächst mal ...

Windows Server
Remotesteuerung der Sitzung (Kennung XX) fehlgeschlagen
gelöst Frage von Stefan91Windows Server14 Kommentare

Hallo Zusammen, seit kurzem bekomme ich oben genannte Fehlermeldung, wenn ich versuche eine Remotesitzung über den Taskmanager fernzusteuern (Rechtsklick ...