Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Externe Links auf Homepage auf eigenem Webserver funktionieren nicht.

Frage Microsoft Windows Server

Mitglied: Peacer

Peacer (Level 1) - Jetzt verbinden

12.01.2010 um 18:51 Uhr, 3745 Aufrufe, 4 Kommentare

Hallo,


habe einen eigenen Webserver (Microsoft Windows Server 2003 mit IIS) mit 2 HPs


auf der HP welche zuerst drauf war funktionieren externe links zu anderen seiten wie myspace.com einwandfrei.

Jetzt hab ich per HTTP Hostheader eine 2. Site auf dem Server laufen.

Problem:

die zweite HP enthält auch links zu zb. myspace.com doch anstatt die verlinkte site zu öffnen wird folgender link angezeigt:


www.homepage2.de/www.myspace.com

Es scheint als ob entweder der Server zu jedem link die mainpage mitsendet bzw den eigentlich externen link als teil der zweiten Homepage ansieht.

Ich hoffe mir kann jemand helfen, denn meiner meinung nach liegt es nicht am quelltext der 2.HP sondern an einer server einstellung (wahrscheinlich im IIS) aber wo?


Vielen Dank

greetingz Peacer
Mitglied: bbyszio
12.01.2010 um 19:50 Uhr
Hallo Peacer,
ich kenne dieses Phänomen, wenn der Link nicht vollständig, also ohne "http://" angegeben wird. Kontrollier das mal bei dir. Ansonsten kann ich zu evtl. IIS-Einstellungen leider nichts sagen.

Gruß
Bodo
Bitte warten ..
Mitglied: Peacer
12.01.2010 um 20:33 Uhr
HA! ich weiss worans lag ... der Programmierer hat die Links ohne http:// angegeben

Deswegen funktionierte es nicht.


Problem gelöst!
Bitte warten ..
Mitglied: dog
13.01.2010 um 10:32 Uhr
Phänomen, haha der war gut

Das ist kein "Phänomen", das ist die Spezifikation.
Alle Links ohne führendes http:// sind vom Browser als relativ zur aktuellen Seite zu betrachten.
Bitte warten ..
Mitglied: bbyszio
13.01.2010 um 11:00 Uhr
Das ist mir schon klar.;) Hatte nur gerade meine Wort-Goldwaage nicht zur Hand.;)

Nen schönen Tag noch,
Bodo
Bitte warten ..
Neuester Wissensbeitrag
Windows 10

Powershell 5 BSOD

(8)

Tipp von agowa338 zum Thema Windows 10 ...

Ähnliche Inhalte
Groupware
Newsletter Mails vom Webserver oder Mailserver versenden? (10)

Frage von Lakatusch zum Thema Groupware ...

Exchange Server
gelöst SBS2011 Owa und Activesync funktionieren nach V2V Umzug nicht mehr (2)

Frage von Anulu1 zum Thema Exchange Server ...

Sicherheits-Tools
Tor hinter (eigenem) Proxy (12)

Frage von mrserious73 zum Thema Sicherheits-Tools ...

Heiß diskutierte Inhalte
Microsoft
Ordner mit LW-Buchstaben versehen und benennen (19)

Frage von Xaero1982 zum Thema Microsoft ...

Outlook & Mail
gelöst Outlook 2010 findet ost datei nicht (19)

Frage von Floh21 zum Thema Outlook & Mail ...

Windows Server
Server 2008R2 startet nicht mehr (Bad Patch 0xa) (18)

Frage von Haures zum Thema Windows Server ...

Netzwerkmanagement
gelöst Anregungen, kleiner Betrieb, IT-Umgebung (18)

Frage von Unwichtig zum Thema Netzwerkmanagement ...