Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Externer Zugriff über VPN - Telefonie mit Fritzbox funktionert nicht - kein Ton (Synology, OpenVPN)

Frage Netzwerke Voice over IP

Mitglied: Pretre

Pretre (Level 1) - Jetzt verbinden

03.04.2014, aktualisiert 14:56 Uhr, 10126 Aufrufe, 3 Kommentare

Hallo zusammen,
ich hätte mal wieder ein Problem, ich hoffe man kann mir hier helfen

Folgendes Szenario:

- Fritzbox 7390 (IP 192.168.11.1) DnyDNS eingerichtet
Telefoniegerät ist eingerichtet
- Synology DS213+ (IP 192.168.11.26)
OpenVPN-Server, Dynamische IP 10.8.0.0

- Android-Phone
mit OpenVPN-Client, Verbindung steht (IP 10.8.0.6)
Zoiper SIP-Client, Verbindung zu Fritzbox steht auch


Das Problem ist, ich kann zwar wählen und der Anruf wird auch aufgebaut, aber es ist kein Ton zu hören.
Wenn ich nun in der Fritzbox in den Detailinformation für die Sprachübertragung nachschaue, steht bei dem getätigten Telefonat bei der Gegenstelle, also ein Android-Phone, die IP 10.8.0.6.

Nutze ich integrierte VPN-Funktion der Fritzbox, funktioniert die Telefonie ohne Probleme von extern.

Ich vermute das es irgendwas mit der IP-Bereich von OpenVPN zu tun hat. Kann mir da jemand auf die Sprünge helfen umd das Problem zu lösen?

Ich hoffe ich hab nix vergessen und es ist verständlich wie ich es geschieben habe, falls ihr noch Info´s brauch einfach melden

Vielen Dank.

Mit freundlichen Grüßen Pretre
Mitglied: aqui
LÖSUNG 03.04.2014, aktualisiert um 14:56 Uhr
Du betreibst das OpenVPN Gateway hinter einem NAT Router (Fritzbox). Alle deine Endgeräte im Netz haben aber die Fritzbox als Default Gateway nicht aber der VPN Client.
Die Fritzbox weiss also ohne eine statische Route nicht WO sich dein 10.8.0.0er VPN Netz befindet. Folglich kann auch die Voice RTP Session nicht direkt zwischen den Endgeräten aufgebaut werden weil die FB nicht weiss das sie das 10er Netz über deinen OVPN Gateway erreichen muss.
Sie routet Pakete ohne statische Route fürs VPN dann ins Internet wo sie im Nirwana verschwinden mit dem Ergebnis...kein Ton ! Müsstest du auch sehen wenn du vom VPN Client versuchst andere Clients im 192.168.11.0er LAN zu pingen, was ohne diese statische Route fehlschlägt. Logisch...wenn man nachdenkt.
Das hiesige OVPN Tutorial http://www.administrator.de/contentid/123285 beschreibt annähernd dein Szenario im Kapitel "...hinter NAT Router" nur das das bei dir eben nur mit einem Port gemacht ist statt mit 2 wie im Tutorial.
Fazit um das Problem schnell zu lösen:
Trage ein zusätzliche statische IP Route in deiner Fritzbox ein ala:
Zielnetz: 10.8.0.0, Maske: 255.255.255.0, Gateway: 192.168.11.26 (Achtung: Geht davon aus das dein 10er VPN Netz eine 24 Bit Maske hat !!)
Fertig. Das sollte dein Problem sofort lösen.
Bitte warten ..
Mitglied: Pretre
03.04.2014 um 14:56 Uhr
Zitat von aqui:

Trage ein zusätzliche statische IP Route in deiner Fritzbox ein ala:
Zielnetz: 10.8.0.0, Maske: 255.255.255.0, Gateway: 192.168.11.26 (Achtung: Geht davon aus das dein 10er VPN Netz eine 24 Bit
Maske hat !!)

Hallo Aqui,
Vielen Dank für deine, wie schon so oft, schnelle kompetente Hilfe - Es funktioniert.

DANKE!

Mit freundlichen Grüßen
Pretre
Bitte warten ..
Mitglied: aqui
03.04.2014 um 20:30 Uhr
Hört sich gut an....
Ist auch ein Wink das o.a. Tutoral mal in der NAT Rubrik um dieses "one armed" VPN Szenario zu erweitern
Bitte warten ..
Neuester Wissensbeitrag
Windows 10

Powershell 5 BSOD

(1)

Tipp von agowa338 zum Thema Windows 10 ...

Ähnliche Inhalte
Netzwerkprotokolle
gelöst VPN-Verbindung von Fritzbox 7490 auf Synology NAS am anderen Anschluss (5)

Frage von ExkoSven zum Thema Netzwerkprotokolle ...

Router & Routing
Externer Zugriff auf NAS mit Glasfasermodem + Fritzbox (1)

Frage von sadi191 zum Thema Router & Routing ...

Google Android
Pixel kann kein VPN zur Fritzbox herstellen! Finger weg von Google Pixel! (5)

Frage von MyApps2GO.de zum Thema Google Android ...

Router & Routing
gelöst VPN-Server (Fritzbox) hinter Zyxel 5501 betreiben (7)

Frage von basti76nie zum Thema Router & Routing ...

Heiß diskutierte Inhalte
LAN, WAN, Wireless
gelöst Server erkennt Client nicht wenn er ausserhalb des DHCP Pools liegt (28)

Frage von Mar-west zum Thema LAN, WAN, Wireless ...

Outlook & Mail
Outlook 2010 findet ost datei nicht (18)

Frage von Floh21 zum Thema Outlook & Mail ...

Windows Server
Server 2008R2 startet nicht mehr (Bad Patch 0xa) (18)

Frage von Haures zum Thema Windows Server ...