Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Falsche ausgabe von Umlauten unter MySQL

Frage Entwicklung Datenbanken

Mitglied: AskFabrice

AskFabrice (Level 1) - Jetzt verbinden

23.02.2011 um 16:26 Uhr, 10641 Aufrufe, 12 Kommentare

Hallo zusammen.
Ich habe das Problem, dass ich in meiner Datenbank, wenn ich Inhalte per INSERT statement einfüge, Umlaute komisch angezeigt werden. z.B. ä = ä oder ü = ü.

Ich habe auf meinem Server XAMPP installiert und eine MySQL datenbank eingerichtet. Ich manage sie mit PHPmyadmin.
Wenn ich nun Daten aus einem XML file einfüge klappt das zwar ganz gut aber alle Umlaute werden falsch dargestellt, ä = ä oder ü = ü.
Zuerst waren es in den Feldern mit umlauten komplett nur zahlen ich habe aber dann die kollation geändert und dann hatte ich obiges Problem.
Ich habe schon ziemlich jedes Charset ausprobiert und ausgiebig bei Google recherchiert.
Kann mir jemand helfen?

Freundlich Grüsse
AskFabrice
Mitglied: 48507
23.02.2011 um 17:31 Uhr
Die Daten scheinen als cp1251 zu kommen und werden als UTF-8/Unicode gespeichert. Stell doch mal die Codierung deiner XML-Datei um.
Bitte warten ..
Mitglied: dog
23.02.2011 um 19:07 Uhr
Du musst durchgängig den korrekten Zeichensatz benutzen.

Zuerst muss auf der phpmyadmin-Startseite das Verbindungscharset auf UTF-8 stehen.
Dann sollte das Datenbankcharset auf UT8 stehen.
Genauso das Tabellencharset.
Und das Feldcharset muss auch auf utf8_general_ci stehen.

Dann muss die XML-Datei als UTF-8 deklariert sein und auch wirklich UTF-8 enthalten und das muss beim Import auch ausgewählt sein.

So wird da auch was draus.
Bitte warten ..
Mitglied: AskFabrice
24.02.2011 um 16:54 Uhr
Vielen dank werd ich mal ausprobieren, vor allem das mit der xml-datei tönt erfolgsversprechend.

Ich werde mich wieder melden.
Bitte warten ..
Mitglied: AskFabrice
01.03.2011 um 11:51 Uhr
Also ich habe das jetzt ausprobiert hat leider nicht geklappt.
Als ich jedoch in mein ausgabeskript:
header("Content-type: text/html; charset=utf-8");
Eingefügt habe ist alles korrekt dargestellt worden. In der Datenbank selbst wurden die Umlaute imernoch inkorrekt datgestellt.
Ich habe es auch in meinem einfügeskript versucht jedoch ohne erfolg.

Habt ihr noch andere Ideen?

Vielen Dank
Bitte warten ..
Mitglied: 48507
01.03.2011 um 12:01 Uhr
In der Datenbank heißt in phpmyadmin - was nichts anderes ist als eine Sammlung von Scripten. Wie sieht es in SQL aus?
Bitte warten ..
Mitglied: AskFabrice
01.03.2011 um 12:04 Uhr
Ja das heisst in PHPmyadmin. Guter Punkt. Wie meinst du das? Bin noch nicht so erfahren, wo kann ich das nachschauen?
Bitte warten ..
Mitglied: 48507
01.03.2011 um 12:36 Uhr
X:\xampplite\mysql\bin>mysql --user =root --password =pw datenbankname
select * from tabellenname;


Wenn z.B. aus ü ein ³ wird, ist alles richtig (hier spielt noch die Codierung in der Eingabeaufforderung eine Rolle...)
Bitte warten ..
Mitglied: AskFabrice
01.03.2011 um 14:24 Uhr
Wenn ich den Befehl durchführe werden die Umlaute falsch dargestellt (ä so oder ähnlich). Liegt es also an der Datenbank (also dem Zeichensatz)?
Bitte warten ..
Mitglied: 48507
01.03.2011 um 14:43 Uhr
Also ich habe mir mal mein phpmyadmin (3.3.9.2) angeschaut:

phpmyadmin eingestellt auf utf8_general_ci
Datenbank: utf8_general_ci

Alles Ok.

Wie importierst du die Daten? Per Import oder copy&paste? Wenn per Import, muss in der XML oder beim Import selbst die Codierung angegeben werden (?)
Bitte warten ..
Mitglied: AskFabrice
01.03.2011 um 15:19 Uhr
Hallo

Die einstellungen sind bei mir identisch.
Ich imortiere sie mit einem PHP skript aus einer XML Datei mitels Insert statement. In der XML ist sie Angegeben.
Weisst du wie ich die Codierung beim Import angeben kann?
Bitte warten ..
Mitglied: AskFabrice
01.03.2011 um 15:55 Uhr
Vielen Vielen Vielen Dank!!!!!!!

Der erste Link verbarg die Lösung. Ich musste beim einfügen noch "set names 'utf8'" einfügen und siehe da alles i.O.

noch einmal Vielen Dank
Top
Bitte warten ..
Neuester Wissensbeitrag
Off Topic

"Ich habe nichts zu verbergen"

(2)

Erfahrungsbericht von FA-jka zum Thema Off Topic ...

Ähnliche Inhalte
Verschlüsselung & Zertifikate
Zugriff auf mySQL-DB mit ODBC und SSL (2)

Frage von Titan24 zum Thema Verschlüsselung & Zertifikate ...

Cluster
Brauche hilfe beim einrichten von Galera Cluster for MySQL

Frage von akadawa zum Thema Cluster ...

Datenbanken
MySQL - Mehrere Instanzen

Frage von ForgottenRealm zum Thema Datenbanken ...

Heiß diskutierte Inhalte
Linux Netzwerk
gelöst DHCP vergibt keine Adressen (31)

Frage von Maik82 zum Thema Linux Netzwerk ...

Exchange Server
gelöst Bestehende eMails autoamatisch weiterleiten (22)

Frage von metal-shot zum Thema Exchange Server ...

Apache Server
gelöst Lets Encrypt SSL mit Apache2 (20)

Frage von banane31 zum Thema Apache Server ...

Switche und Hubs
LAG zwischen SG300-Switches macht Probleme. Wer weiß Rat? (19)

Frage von White-Rabbit2 zum Thema Switche und Hubs ...