Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Falsche ausgabe von Umlauten unter MySQL

Frage Entwicklung Datenbanken

Mitglied: AskFabrice

AskFabrice (Level 1) - Jetzt verbinden

23.02.2011 um 16:26 Uhr, 10967 Aufrufe, 12 Kommentare

Hallo zusammen.
Ich habe das Problem, dass ich in meiner Datenbank, wenn ich Inhalte per INSERT statement einfüge, Umlaute komisch angezeigt werden. z.B. ä = ä oder ü = ü.

Ich habe auf meinem Server XAMPP installiert und eine MySQL datenbank eingerichtet. Ich manage sie mit PHPmyadmin.
Wenn ich nun Daten aus einem XML file einfüge klappt das zwar ganz gut aber alle Umlaute werden falsch dargestellt, ä = ä oder ü = ü.
Zuerst waren es in den Feldern mit umlauten komplett nur zahlen ich habe aber dann die kollation geändert und dann hatte ich obiges Problem.
Ich habe schon ziemlich jedes Charset ausprobiert und ausgiebig bei Google recherchiert.
Kann mir jemand helfen?

Freundlich Grüsse
AskFabrice
Mitglied: 48507
23.02.2011 um 17:31 Uhr
Die Daten scheinen als cp1251 zu kommen und werden als UTF-8/Unicode gespeichert. Stell doch mal die Codierung deiner XML-Datei um.
Bitte warten ..
Mitglied: dog
23.02.2011 um 19:07 Uhr
Du musst durchgängig den korrekten Zeichensatz benutzen.

Zuerst muss auf der phpmyadmin-Startseite das Verbindungscharset auf UTF-8 stehen.
Dann sollte das Datenbankcharset auf UT8 stehen.
Genauso das Tabellencharset.
Und das Feldcharset muss auch auf utf8_general_ci stehen.

Dann muss die XML-Datei als UTF-8 deklariert sein und auch wirklich UTF-8 enthalten und das muss beim Import auch ausgewählt sein.

So wird da auch was draus.
Bitte warten ..
Mitglied: AskFabrice
24.02.2011 um 16:54 Uhr
Vielen dank werd ich mal ausprobieren, vor allem das mit der xml-datei tönt erfolgsversprechend.

Ich werde mich wieder melden.
Bitte warten ..
Mitglied: AskFabrice
01.03.2011 um 11:51 Uhr
Also ich habe das jetzt ausprobiert hat leider nicht geklappt.
Als ich jedoch in mein ausgabeskript:
header("Content-type: text/html; charset=utf-8");
Eingefügt habe ist alles korrekt dargestellt worden. In der Datenbank selbst wurden die Umlaute imernoch inkorrekt datgestellt.
Ich habe es auch in meinem einfügeskript versucht jedoch ohne erfolg.

Habt ihr noch andere Ideen?

Vielen Dank
Bitte warten ..
Mitglied: 48507
01.03.2011 um 12:01 Uhr
In der Datenbank heißt in phpmyadmin - was nichts anderes ist als eine Sammlung von Scripten. Wie sieht es in SQL aus?
Bitte warten ..
Mitglied: AskFabrice
01.03.2011 um 12:04 Uhr
Ja das heisst in PHPmyadmin. Guter Punkt. Wie meinst du das? Bin noch nicht so erfahren, wo kann ich das nachschauen?
Bitte warten ..
Mitglied: 48507
01.03.2011 um 12:36 Uhr
X:\xampplite\mysql\bin>mysql --user =root --password =pw datenbankname
select * from tabellenname;


Wenn z.B. aus ü ein ³ wird, ist alles richtig (hier spielt noch die Codierung in der Eingabeaufforderung eine Rolle...)
Bitte warten ..
Mitglied: AskFabrice
01.03.2011 um 14:24 Uhr
Wenn ich den Befehl durchführe werden die Umlaute falsch dargestellt (ä so oder ähnlich). Liegt es also an der Datenbank (also dem Zeichensatz)?
Bitte warten ..
Mitglied: 48507
01.03.2011 um 14:43 Uhr
Also ich habe mir mal mein phpmyadmin (3.3.9.2) angeschaut:

phpmyadmin eingestellt auf utf8_general_ci
Datenbank: utf8_general_ci

Alles Ok.

Wie importierst du die Daten? Per Import oder copy&paste? Wenn per Import, muss in der XML oder beim Import selbst die Codierung angegeben werden (?)
Bitte warten ..
Mitglied: AskFabrice
01.03.2011 um 15:19 Uhr
Hallo

Die einstellungen sind bei mir identisch.
Ich imortiere sie mit einem PHP skript aus einer XML Datei mitels Insert statement. In der XML ist sie Angegeben.
Weisst du wie ich die Codierung beim Import angeben kann?
Bitte warten ..
Mitglied: AskFabrice
01.03.2011 um 15:55 Uhr
Vielen Vielen Vielen Dank!!!!!!!

Der erste Link verbarg die Lösung. Ich musste beim einfügen noch "set names 'utf8'" einfügen und siehe da alles i.O.

noch einmal Vielen Dank
Top
Bitte warten ..
Ähnliche Inhalte
Datenbanken
MYSQL ausgabe
Frage von pcguyDatenbanken31 Kommentare

Hallo zusammen Ich versuche gerade einen DB inhalt gefiltert auszugeben. DB: id - parent_id - title - url - ...

PHP
PHP - MySQL-Ausgabe editieren
gelöst Frage von ThoomaasPHP19 Kommentare

Hallo alle zusammen! Ich bin gerade dabei ein Portal für meine Firma zu basteln. Hierbei sollen die User Protokolle ...

Batch & Shell
Falsche Umlaute beim auslesen einer .txt mit batch
gelöst Frage von pdiddoBatch & Shell2 Kommentare

Hi Leute, ich habe folgendes Problem: Ich möchte mit einer Batch Datei eine .txt Datei auslesen. Das ausgelesene wird ...

Exchange Server
Umlaute Autoresponder Exchange 2013 werden falsch dargestellt
Frage von AirportExchange Server

Hallo zusammen, nach einer mehrstufigen Migration Exchange 2003 auf 2010 und dann 2013 werden die Umlaute bei der Abwesenheitsbenachrichtigung ...

Neue Wissensbeiträge
Verschlüsselung & Zertifikate

19 Jahre alter Angriff auf TLS funktioniert immer noch

Information von BassFishFox vor 1 StundeVerschlüsselung & Zertifikate

Interessant zu lesen. Der Bleichenbacher-Angriff gilt unter Kryptographen als Klassiker, trotzdem funktioniert er oft noch. Wie wir herausgefunden haben, ...

Windows 10

Windows 10 Fall Creators Update - Neue Funktion Hyper-V Standardswitch kann ggf. Fehler bei Proxy Configs verursachen

Erfahrungsbericht von rzlbrnft vor 12 StundenWindows 102 Kommentare

Hallo Kollegen, Da wir die Gefahr lieben, haben wir bei einigen Usern nun mittlerweile das Creators Update drauf. Einige ...

Sicherheit

TLS-Zertifikat und privater Schlüssel von Microsofts Dynamics 365 geleakt

Information von Penny.Cilin vor 14 StundenSicherheit

Microsoft hat versehentlich das TLS-Zertifikat inklusive dem privaten Schlüssel seiner Business-Anwendung Dynamics 365 geleakt. TLS-Zertifikat und privater Schlüssel von ...

Viren und Trojaner

Deaktivierter Keylogger in HP Notebooks entdeckt

Information von bitcoin vor 1 TagViren und Trojaner3 Kommentare

Ein Grund mehr warum man Vorinstallationen der Hersteller immer blank bügeln sollte Der deaktivierte Keylogger findet sich im vorinstallierten ...

Heiß diskutierte Inhalte
Netzwerkmanagement
Firefox Profieles im Roaming
gelöst Frage von Hendrik2586Netzwerkmanagement17 Kommentare

Hallo liebe Leute. :) Ich hab da ein kleines Problem, welches anscheinend nicht unbekannt ist. Wir nutzen hier in ...

Netzwerkmanagement
NAS über zwei weitere Ethernet Anschlüsse verbinden
gelöst Frage von Sibelius001Netzwerkmanagement16 Kommentare

Sorry - ich bin hier wahrscheinlich als kompetter IT Trottel unterwegs. Aber eventuell kann mir jemand ganz einfach helfen: ...

LAN, WAN, Wireless
Häufig Probleme beim Anmelden in WLAN
Frage von mabue88LAN, WAN, Wireless15 Kommentare

Hallo zusammen, in einem Netzwerk gibt es relativ häufig (1-2 mal pro Woche) Probleme mit der WLAN-Verbindung. Zunächst mal ...

Netzwerkgrundlagen
Hi eine blöde frage. xD
Frage von 132954Netzwerkgrundlagen13 Kommentare

Also: Habe 2012 r2 essentials neuinstalliert, allerdings installiert diese version ja gleich diesen gangen AD kram mit, den hab ...