Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Falsches Tastaturlayout bei Remote-Verbindung

Frage Microsoft

Mitglied: marc-1303

marc-1303 (Level 2) - Jetzt verbinden

23.11.2011, aktualisiert 18:54 Uhr, 13837 Aufrufe, 3 Kommentare

Guten Tag

Seit einigen Tagen habe ich ein delikates Problem. Wenn ich von Zuhause aus über den IPSec-Tunnel auf meinen Server im Geschäft remote wird ein falsches Tastaturlayout zu Grunde gelegt.

Client zuhause: Win7 Pro SP1
Server: SBS 2011 Standard SP1

Ich bin mir im Mindesten nicht bewusst, dass ich diesbezüglich etwas geändert hätte. Ich finde in den Einstellungen zur Remoteverbindung keine Option, mit welcher ich dieses Verhalten beeinflussen könnte.

EDIT
Kleine Ergänzung, ich hab das eben noch mal kontrolliert: Sowohl auf dem Client wie auch auf dem Server (während der Remote-Verbindung) sind die richtigen Tastatur-Layouts eingestellt. In meinem Fall Deutsch (Schweiz). Trotzdem kann ich z.B. kein Slash schreiben. Oder wenn ich ein _ schreiben möchte erhalte ich stattdessen ein ?
EDIT ENDE

Jemand eine Ahnung?

Grüsse
Marc
Mitglied: nEmEsIs
23.11.2011 um 21:20 Uhr
Hi

Klingt für mich als würde deine Tastatur auf Englisch umgestellt werden. Hatte das Problem mit Win 7 auch mal.
Lösung:
Trag mal auf deinem Server mit regedit
[HKEY_LOCAL_MACHINE][SYSTEM][CurrentControlSet][Control][Keyboard Layout]

REG_DWORD "IgnoreRemoteKeyboardLayout=1"

ein.
Dann abmelden und neu anmelden. Sollte das Problem lösen.

MFG Nemesis

PS: Schau mal als erstes ob du vll. das englische Tastaturlayout auf deinem Windows 7 Client aktiviert hast bzw. in der Liste auftaucht. Lösch es einfach mal raus.
Bei mir hat aber das oben erst eine Lösung gebracht. Unter XP keine Probleme mit Win 7 schon.
Bitte warten ..
Mitglied: marc-1303
24.11.2011 um 10:44 Uhr
Zitat von nEmEsIs:
Hi

Hallo NEmEsis
Sorry, bin erst jetzt, nach einer längeren Sitzung dazu gekommen zum Testen.

Klingt für mich als würde deine Tastatur auf Englisch umgestellt werden. Hatte das Problem mit Win 7 auch mal.
Lösung:
Trag mal auf deinem Server mit regedit
[HKEY_LOCAL_MACHINE][SYSTEM][CurrentControlSet][Control][Keyboard Layout]

Ich habe den neuen Key eingetragen. explorer.exe abgeschossen und neu gestartet. Ab- und wieder angemeldet.
Jetzt habe ich immer noch dasselbe Verhalten. Keine Besserung.

REG_DWORD "IgnoreRemoteKeyboardLayout=1"

ein.
Dann abmelden und neu anmelden. Sollte das Problem lösen.

MFG Nemesis

PS: Schau mal als erstes ob du vll. das englische Tastaturlayout auf deinem Windows 7 Client aktiviert hast bzw. in der Liste
auftaucht. Lösch es einfach mal raus.
Bei mir hat aber das oben erst eine Lösung gebracht. Unter XP keine Probleme mit Win 7 schon.

Auf meinem Client habe ich nur ein Tastaturlayout installiert (Deutsch Schweiz). Also kein englisches Layout.
Könnte es auch an irgend einer Gruppenrichtlinien-Einstellung liegen?

Gruss
Marc
Bitte warten ..
Mitglied: marc-1303
24.11.2011 um 10:52 Uhr
Ich glaube, ich habe das Problem eben behoben.
Wie folgt:

Ich habe auf dem Server wieder das englische Tastaturlayout installiert und mir die Sprachenleiste in der Taskleiste angezeigen lassen.
Trotzdem das Deutsche (Schweiz) Tastaturlayout als Standard definiert ist zeigt die Sprachenleiste "EN".
Jetzt kann ich wenigestens bei Bedarf um "DE" umschalten.

Danke trotzdem für Deine Hilfe, NEmEsis
Bitte warten ..
Ähnliche Inhalte
LAN, WAN, Wireless
gelöst Anderes Tastaturlayout im WLAN-Passwort-Eingabefeld (2)

Frage von eraiser zum Thema LAN, WAN, Wireless ...

Voice over IP
gelöst VoIP - Was kann man alles falsch machen? (20)

Frage von MegaGiga zum Thema Voice over IP ...

Batch & Shell
gelöst Powershell Remote VPN einrichten (4)

Frage von Bugger zum Thema Batch & Shell ...

Neue Wissensbeiträge
Windows Update

Microsoft Update KB4034664 verursacht Probleme mit Multimonitor-Systemen

Tipp von beidermachtvongreyscull zum Thema Windows Update ...

Viren und Trojaner

CNC-Fräsen von MECANUMERIC werden (ggf.) mit Viren, Trojanern, Würmern ausgeliefert

(4)

Erfahrungsbericht von anteNope zum Thema Viren und Trojaner ...

Windows 10

Windows 10: Erste Anmeldung Animation deaktivieren

(3)

Anleitung von alemanne21 zum Thema Windows 10 ...

Heiß diskutierte Inhalte
Verschlüsselung & Zertifikate
SSL Zertifikat für HTTPS (33)

Frage von Hendrik2586 zum Thema Verschlüsselung & Zertifikate ...

Grafikkarten & Monitore
24" oder 27" mit Full HD oder doch mehr Auflösung? (21)

Frage von brutzler zum Thema Grafikkarten & Monitore ...

Router & Routing
gelöst Linksys wrt1200ac v2 mit dd-wrt: keine vlan-einstellungen im GUI (15)

Frage von Pixi123 zum Thema Router & Routing ...