Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

fehlende DNS Auflöungs WS2K3

Frage Microsoft Windows Server

Mitglied: Iceman1983DU

Iceman1983DU (Level 1) - Jetzt verbinden

01.04.2007, aktualisiert 02.04.2007, 3248 Aufrufe, 8 Kommentare

Hallo zusammen,

ich habe einen WS2k3 mit folgender Konfiguration

DC+ADS, DNS, DHCP, WINS, IIS , EX2k3, RRAS

Ich habe eine DSL Anbindung und diese per DynDNS von außen erreichbar gemacht.
Der Server hat 2 Netzwerkkarten (Internes Netz + DSL-Modem)

Im Windows Server wurde die Domäne mit dem gleichen Namen aufgebaut wie der DynDNS Name. Ich nenne sie mal

testdom.dyndns.org

Die generelle Namensauflösung des DNS funktioniert wunderbar. Wenn ich also "ping testsrv.testdom.dyndns.org" bzw "testsrv" eingebe erhalte ich die interne richtige IP des internes Netzes.

Wenn ich von einem Testrechner "ping testdom.dyndns.org" eingebe erhalte ich auch die interne IP des Netzes. Jedoch bekomme ich die Meldung das der Host "www.testdom.dyndns.org" nicht gefunden werden konnte.

"ping www.testdom.dyndns.org" liefert mir auf dem Server jedoch die externe IP des ISP.


Ich kann also intern nicht die Web Seiten des IIS testen, wenn ich www.testdom.dyndns.org eingebe.

Ich bitte um Hilfe.
Danke

Greetz Patrick
Mitglied: cykes
02.04.2007 um 06:53 Uhr
Hi,

dazu musst Du entsprechende Host(A) Eintrag in Deinem DNS Server einrichten, der www....
auch auflösen kann. Im Moment fühlt sich Dein DNS dafür nicht zuständig und leitet die
Auflösung an den DNS Deines Providers weiter.

Gruß

cykes
Bitte warten ..
Mitglied: Iceman1983DU
02.04.2007 um 10:35 Uhr
Hallo cykes,

danke für deinen Tip.

Aber einen TCP/IP Dienst "WWW" werde ich nicht als Host(A) Eintrag im DNS hinterlegen können.

Der DNS Server leitet die Anfrage "www.testdom.ath.cx" an einen anderen DNS weiter, wenn man die vom Server selbst aus startet. Deswegen auch die öffentliche IP. Die gleiche Anfrage von einem internen Rechner werden mit der Meldung "Host nicht gefunden" beantw.

Nur die Anfrage "testdom.ath.cx" wird sowohl vom Server aus als auch vom internen Rechner aus mit der privaten internen IP beantw.


Greetz Patrick.
Bitte warten ..
Mitglied: cykes
02.04.2007 um 10:45 Uhr
Hi,

ich meinte nicht den www-Dienst (bzw. besser eigentlich HTTP Dienst/Port), sondern den kompletten DNS Namen www.testdom.ath.cx, den musst Du zumindest lokal in Deinen DNS
eintragen oder alternativ in die lokale Hosts-Datei.

Gruß

cykes
Bitte warten ..
Mitglied: Iceman1983DU
02.04.2007 um 13:02 Uhr
Hi,

also wenn ich dich richtig verstehe, soll ich als Host(A) "www.testdom.ath.cx" eingetragen.

Das hat doch zur Folge, das der FQDN zu "www.testdom.ath.cx.testdom.ath.cx" wird.

Denn der DNS gehört zur DC+ADS "testdom.ath.cx"

Gruß Patrick
Bitte warten ..
Mitglied: cykes
02.04.2007 um 13:05 Uhr
Hi,

also wenn ich dich richtig verstehe, soll
ich als Host(A)
"www.testdom.ath.cx" eingetragen.

Genau das sollst Du tun

Das hat doch zur Folge, das der FQDN zu
"www.testdom.ath.cx.testdom.ath.cx"
wird.

Nein, der Host(A) ist nur ein Name eines Rechners, den der DNS in eine IP auflösen kann
und ein Server oder Client kann auch mehrere Host(A) Einträge haben.

Denn der DNS gehört zur DC+ADS
"testdom.ath.cx"

Das bleibt auch weiterhin so,d a Du nicht den Namen der Domäne änderst.
Bitte warten ..
Mitglied: Iceman1983DU
02.04.2007 um 19:07 Uhr
Hi,

ich hab deinen Vorschag ausprobiert. Daraufhin wurden bei mir die Ordner "cx", "ath", "testdom" und der Host(A) "www" angelegt. Der FQDN des Host(A) "www" war dann wie von mir behauptet "www.testdom.ath.cx.testdom.ath.cx."

Nichts desto trotz hat dies mein Problem nicht lösen können. Von einem Client aus, kann ich noch immer nicht die "www.testdom.ath.cx" Adresse pingen.

P.S. dies ist lediglich ein internes Problem. Von außen kann ich den Server anpingen.

Greetz Ice
Bitte warten ..
Mitglied: cykes
02.04.2007 um 19:27 Uhr
Ähm, ich glaub Du hast mich missverstanden, Du solltest in der Forward-Lookupzone unter dem Container Deiner Domäne testdom.ath.cx einen neuen Host(A) anlegen mit dem Namen "www"
- also nur "www" in das weisse Feld eintragen.
Hab das grad bei mir probiert, das funktioniert einwandfrei.
Bitte warten ..
Mitglied: Iceman1983DU
02.04.2007 um 21:19 Uhr
OK danke, dass hat funktioniert.
Es hat auch mit einem ALIAS funktioniert.


Grüße Ice
Bitte warten ..
Ähnliche Inhalte
Server-Hardware
Fehlende Treiber!
gelöst Frage von Hendrik2586Server-Hardware11 Kommentare

Frohes Neues wünsche ich euch allen! Mein Serverumzug hat super geklappt und ich bin gerade dabei den alten ein ...

Router & Routing
Fehlende Redundanz
gelöst Frage von aguilaRouter & Routing19 Kommentare

Hallo zusammen, Ich habe ein Standort, der über eine VPN Verbindung an die Zentrale angebunden ist. Das VPN zwischen ...

Windows Netzwerk
Fehlendes Netzwerkprotokoll
Frage von ThorgeonWindows Netzwerk1 Kommentar

Moin Moin, Folgendes Problem ich will meine Playstation 4 mittels Rechner über nen Surfstick laufen lassen, so weit so ...

Debian
NFS mit fehlenden Rechten
gelöst Frage von cra.CHDebian1 Kommentar

Hallo zusammen Ich habe zwei Debian-Rechner, welche via NFS miteinander "verbunden" sind. Auf dem Quell-Rechner habe ich drei Ordner, ...

Neue Wissensbeiträge
Batch & Shell

Open Object Rexx: Eine mittlerweile fast vergessene Skriptsprache aus dem Mainframebereich

Information von Penny.Cilin vor 12 StundenBatch & Shell8 Kommentare

Ich kann mich noch sehr gut an diese Skriptsprache erinnern und nutze diese auch heute ab und an noch. ...

Humor (lol)

"gimme gimme gimme": Automatischer Test stolpert über Easter Egg im man-Tool

Information von Penny.Cilin vor 14 StundenHumor (lol)6 Kommentare

Interessant, was man so alles als Easter Egg implementiert. Ist schon wieder Ostern? "gimme gimme gimme": Automatischer Test stolpert ...

MikroTik RouterOS

Mikrotik - Lets Encrypt Zertifikate mit MetaROUTER Instanz auf dem Router erzeugen

Anleitung von colinardo vor 1 TagMikroTik RouterOS8 Kommentare

Einleitung Folgende Anleitung ist aus der Lage heraus entstanden das ein Kunde auf seinem Mikrotik sein Hotspot Captive Portal ...

Sicherheit

Sicherheitslücke in HP-Druckern - Firmware-Updates stehen bereit

Information von BassFishFox vor 1 TagSicherheit1 Kommentar

Ein weiterer Grund, dass Drucker keinerlei Verbindung nach "auswaerts" haben sollen. Unter Verwendung spezieller Malware können Angreifer aus der ...

Heiß diskutierte Inhalte
Windows Server
RDP macht Server schneller???
Frage von JaniDJWindows Server17 Kommentare

Hallo Community, wir betrieben seit geraumer Zeit diverse virtuelle Maschinen und Server mit Windows Server 2012. Leider haben wir ...

Windows 10
Windows 10 dunkler Bildschirm nach Umfallen
Frage von AkcentWindows 1015 Kommentare

Hallo, habe hier einen Windows 10 Rechner der von einem User umgefallen wurde (Beine übers Knie, an den PC ...

Windows 10
Bitlocker nach Verschlüsselung nicht mehr aufrufbar!
gelöst Frage von alexlazaWindows 1013 Kommentare

Hallo, ich besitze ein HP ZBook 17 G4 mit einem Windows 10 Pro Betriebssystem. Bei diesem Problem handelt sich, ...

Batch & Shell
Neuste Datei via PowerShell kopieren
gelöst Frage von kaiuwe28Batch & Shell11 Kommentare

Hallo zusammen, ich hatte mir mit Hilfe der Suche im Forum einen kleinen Code von colinardo rausgesucht und versucht ...