Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Fehler beim Öffnen von Framebuffer Device

Frage Linux

Mitglied: refugee

refugee (Level 1) - Jetzt verbinden

14.09.2010, aktualisiert 15:04 Uhr, 3755 Aufrufe, 1 Kommentar

Hey hallo,
bräuchte Hilfe mit qemu unter Debian 5.0.5

Habe qemu installiert und versucht ein existierendes Image zu laden.

01.
qemu -m 256 -hda /path/image.img -boot c -full-screen -net nic,macaddr=xx:xx:xx:xx:xx:xx,vlan=x -net user,vlan=x -net nic,macaddr=xx:xx:xx:xx:xx:xx,vlan=x -net tap,vlan=x
Ich erhalte folgenden Fehler:

01.
02.
     =======================|  DirectFB 1.0.1  |======================= 
03.
          (c) 2001-2007  The DirectFB Organization (directfb.org) 
04.
          (c) 2000-2004  Convergence (integrated media) GmbH 
05.
        ------------------------------------------------------------ 
06.
 
07.
(*) DirectFB/Core: Single Application Core. (2008-08-18 12:36) 
08.
(!) Direct/Util: opening '/dev/fb0' and '/dev/fb/0' failed 
09.
    --> No such file or directory 
10.
(!) DirectFB/FBDev: Error opening framebuffer device! 
11.
(!) DirectFB/FBDev: Use 'fbdev' option or set FRAMEBUFFER environment variable. 
12.
(!) DirectFB/Core: Could not initialize 'system' core! 
13.
    --> Initialization error! 
14.
Could not initialize SDL - exiting
Damit bin ich ganz ehrlich etwas überfordert! Kenne mich mit qemu nicht wirklich aus...
DirectFB ist wohl FrameBuffer, aber warum die Devices nicht gefunden werden, weiß ich nicht

Hat jemand einen Rat/ eine Lösung für mein Problem?
Mitglied: refugee
15.09.2010 um 09:33 Uhr
Lösung: man muss bisschen in der /boot/grub/menu.lst herumwerken:

kernel /boot/vmlinuz-2.6.26-2-686 root=/dev/sda1 ro quiet
=>
kernel /boot/vmlinuz-2.6.26-2-686 root=/dev/sda1 vga=788 splash=silent ro quiet


und schon funktioniert die ganze Geschichte

(für alle die es interessiert: Die Zahl 788 steht für die Auflösung 800x600 mit 16Bit Farben. Dieser Wert ist einer Tabelle zu entnehmen, die man relativ leicht findet, wenn man danach googelt)
Bitte warten ..
Ähnliche Inhalte
Outlook & Mail
gelöst Fehler beim Öffnen von Anlagen im Öffentlichen Ordnern (1)

Frage von Sinzal zum Thema Outlook & Mail ...

Microsoft Office
Outlook 2016 Fehler Link einfügen

Frage von Florian86 zum Thema Microsoft Office ...

Neue Wissensbeiträge
Windows Server

Verschieben von Servergespeicherten Profilen an einen anderen Speicherort

Erfahrungsbericht von Enriqe zum Thema Windows Server ...

Windows 10

Plattformdienst für unbekannte Geräte (7023)

Tipp von KMUlife zum Thema Windows 10 ...

Administrator.de Feedback

Umgangsformen auf der Seite

(16)

Information von Frank zum Thema Administrator.de Feedback ...

Heiß diskutierte Inhalte
Windows Server
Windows Server Komplettspiegelung (16)

Frage von pdiddo zum Thema Windows Server ...

Batch & Shell
gelöst Dir tc Befehl unter Windows 10 macht Probleme (14)

Frage von sugram zum Thema Batch & Shell ...

Windows Server
Windows Server 2016 RDS Remoteapp Anzeigefehler (11)

Frage von qlnGenius zum Thema Windows Server ...